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Preface

About This Document

This User Guide is a resource written for all users of Lumension Endpoint Management and Security Suite: Patch
and Remediation. This document defines the concepts and procedures for installing, configuring, implementing,
and using Lumension Endpoint Management and Security Suite: Patch and Remediation 7.3 SP1.

Tip:  Lumension documentation is updated on a regular basis. To acquire the latest version of this or any other
published document, please refer to the Lumension Customer Portal (http://portal.lumension.com/).

Typographical Conventions

The following conventions are used throughout this documentation to help you identify various information
types.

Table 1: Typographical Conventions

Convention Usage

bold Buttons, menu items, window and screen objects.

bold italics Wizard names, window names, and page names.

italics New terms, options, and variables.

MONOSPACE UPPERCASE Keyboard keys.

BOLD UPPERCASE SQL Commands.

monospace File names, path names, programs, executables, command syntax, and
property names.

http://portal.lumension.com/
http://portal.lumension.com/
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Contacting Lumension

Arizona

8660 East Hartford Drive
Suite 300
Scottsdale, AZ 85255
United States of America

Phone: +1 888 725 7828
Phone: +1 480 970 1025
Fax: +1 480 970 6323

Ireland

Lumension Security Ireland Ltd.
Lyrr Building, Second Floor
Mervue Business & Technology
Park
Mervue, Galway
Ireland

Phone: +353 91 44 8980
Fax: +353 91 76 6722

Luxembourg

Lumension Security SA
Atrium Business Park
Z.A Bourmicht
23, rue du Puits Romain
L-8070 Bertrange
Luxembourg

Phone: +352 265 364 11
Fax: +352 265 364 12

Lumension Support

phone:
+1 480 970 1025 (USA)
+1 877 713 8600 (USA - legacy Sanctuary products)
+353 9142 2999 (EMEA)
+44 800 012 1869 (UK)
+61 (02) 8223 9810 (Australia)
+852 3071 4690 (Hong Kong)
+65 6622 1078 (Singapore)

submit a ticket:
Registered users can open a support ticket via the customer portal (http://support.lumension.com/).

Lumension customers without a support account should contact our support team (support@lumension.com) to
have an account created.

Note:  For additional contact information, please visit the Contact Lumension page at http://
www.lumension.com/contact-us.aspx.

http://support.lumension.com/
http://support.lumension.com/
mailto:support@lumension.com
mailto:support@lumension.com
http://www.lumension.com/contact-us.aspx
http://www.lumension.com/contact-us.aspx
http://www.lumension.com/contact-us.aspx
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Chapter

1
Lumension Patch and Remediation Overview

In this chapter:

• Installing Patch and Remediation on
the Lumension EMSS Server

• The Patch and Remediation Process

• Recommended Configuration

• Supported Endpoint Operating
Systems

• Agent Supported
Internationalizations and Locales

Lumension Patch and Remediation (Patch and Remediation) is
a Lumension Endpoint Management and Security Suite module
that audits and remediates software and system configuration
vulnerabilities within your network. It can also be used for network-
wide installation of content non-related to vulnerabilities, such as
software or service packs.

To accomplish this task, Patch and Remediation uses two main
components: The Endpoint Management and Security Suite Server and
the Endpoint Management and Security Suite Agent.

Patch and Remediation uses the Lumension EMSS Server to download
content and then deploys it throughout your network. Content includes
data that identifies vulnerabilities, patches that remediate them, and
various other types of software and service packs. Content is deployed
with assistance from the Lumension EMSS agent.

The agent scans its host endpoint via a Discover Applicable Updates
(DAU) task, which takes a system inventory of endpoint software,
hardware, and system configuration settings. The DAU results are sent
back to the server, which compares these results with a list of known
vulnerabilities. Based on these results and administrator input, the
server deploys content as needed.

Installing Patch and Remediation on the Lumension EMSS Server
Administrators can install Patch and Remediation as a module within the Lumension Endpoint Management and
Security Suite (Lumension EMSS) server.

Install Patch and Remediation using Lumension Installation Manager. For additional information, refer to
Lumension Endpoint Management and Security Suite: Wake on LAN User Guide (http://portal.lumension.com).

The Patch and Remediation Process
This chart lists the transactions that occur between the Lumension Endpoint Management and Security Suite
server and agent when patching and remediating endpoint vulnerabilities. Using Patch and Remediation module

http://portal.lumension.com
http://portal.lumension.com
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functions, Lumension Endpoint Management and Security Suite finds network endpoints, installs agents on
them, and then protects them.

Lumension EMSS) detects endpoints on a network with a discovery scan job. This job also
detects endpoint operating systems, address information, credential access levels, and agent
presence.

Based on the discovery scan job’s results, the Lumension EMSS administrator decides
which endpoints require the Lumension EMSS Agent. Agents are installed either manually
or with agent management jobs. Following initial installation of the Lumension EMSS, you
must then install the Patch Agent.

The agent scans the host endpoint and compiles information on its operating system,
software, hardware, and services via the Discover Applicable Updates (DAU) task.

The DAU results are sent back to Lumension EMSS, which compares the results with a list
of known vulnerabilities.

The administrator reviews the DAU task results, which can be viewed at any time from
Patch and Remediation’s Vulnerabilities page. If applicable, the agent performs another
DAU task to determine the endpoint’s patch status in relation to a vulnerability.

Patch and Remediation reviews agent detections. Based on this information, applicable
vulnerability patches (a type of content) are determined for each endpoint. If required,
Patch and Remediation downloads uncached content from the Global Subscription Server,
a central repository of content compiled by Lumension.

Once patch status is established, the Lumension EMSS administrator can deploy the
applicable content to each applicable endpoint on the network.
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After receiving content from the Lumension EMSS server, the agent installs the content on
the endpoint. The endpoint is now protected. Following this step, Patch and Remediation
verifies the level or protection on the endpoint by repeating step three.

Additionally, Patch and Remediation does more than just patch vulnerabilities. It allows you to manage network-
wide software installs, distribute custom deployments, and create Mandatory Baselines, which are sets of content
for which specified endpoints must be patched.

Recommended Configuration
Lumension recommends different system and bandwidth settings for your server and network based on the
number of endpoints in your network environment. As the number of managed endpoints in your network
increases, so do server and network requirements.

Recommended Server Configuration
For optimal performance, your Lumension Endpoint Management and Security Suite: Patch and Remediation
server should meet the defined hardware recommendations.

The following tables define the recommended server configuration when installing Lumension Patch and
Remediation on your server.

Note:  This table assumes you are installing on a physical (bare-metal) server. If you are installing in a virtual
environment, please refer to Lumension KnowledgeBase Article 258 (http://www.lumension.com/kb/258) for
additional guidance.

Table 2: Recommended Configuration

Node Count < 50 < 500 < 1,000 < 5,000 < 10,000

Operating System Windows
2008

Windows
2008 R2

Windows
2008 R2

Windows
2008 R2

Windows
2008 R2

Operating System Edition Standard Standard Standard Standard Standard

Operating System
Architecture

x86 x64 x64 x64 x64

Database Server SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

Database Server Edition Express Standard Standard Standard Standard

Software

Database Server Architecture x86 x64 x64 x64 x64

Hardware Core Architecture 2 2 4 8 16

http://www.lumension.com/kb/258
http://www.lumension.com/kb/258
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Node Count < 50 < 500 < 1,000 < 5,000 < 10,000

Core Speed (GHz) 2.0+ 2.0+ 2.0+ 2.0+ 2.0+

RAM (GB) 2 4 8 16 32

Network (LAN) 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s

Disk Array * RAID 1 RAID 1 Multiple
RAID

Multiple
RAID

Multiple
RAID

# Hard Drives 2 2 4 6 8

Drive Speed (RPM) 7200 7200 7200 10k 10k

Hard Drive Volume Breakdown

OS/Data * RAID 1
- 250GB

RAID 1
- 250GB

N/A N/A N/A

OS N/A N/A RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

Data * N/A N/A RAID 1 -
250GB (&
TempDB)

RAID 1
- 250GB

RAID 10
- 500GB

Temp DB N/A N/A N/A RAID 0
- 250GB

RAID 0
- 250GB

* Due to performance issues, do not use a RAID 5 configuration for the data drive.

Recommended Server Configuration (Components on Separate Servers)
When the Application Server and Database Server are installed on two physical servers, then each servers
recommended hardware requirements will increase according to the number of managed endpoints in your
network.

The following tables define the recommended server configuration when installing Lumension Patch and
Remediation on your server.

Note:  This table assumes you are installing on a physical (bare-metal) server. If you are installing in a virtual
environment, please refer to Lumension KnowledgeBase Article 258 (http://www.lumension.com/kb/258) for
additional guidance.

The following table lists the recommended configuration for the Application Server.

Table 3: Application Server Recommended Configuration

Node Count < 50 < 500 < 1000 < 5000 < 10,000

Software Operating System Windows
2008

Windows
2008 R2

Windows
2008 R2

Windows
2008 R2

Windows
2008 R2

http://www.lumension.com/kb/258
http://www.lumension.com/kb/258
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Node Count < 50 < 500 < 1000 < 5000 < 10,000

Operating System Edition Standard Standard Standard Standard Standard

Operating System
Architecture

x86 x64 x64 x64 x64

Core Architecture 2 2 4 8 16

Core Speed (GHz) 2.0+ 2.0+ 2.0+ 2.0+ 2.0+

RAM (GB) 2 4 8 8 16

Network (LAN) 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s

Disk Array RAID 1 RAID 1 RAID 1 RAID 1 RAID 1

# Hard Drives 2 2 2 2 2

Drive Speed (RPM) 7200 7200 7200 7200 7200

Hard Drive Volume Breakdown

Hardware

OS/Data RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

* Due to performance issues, do not use a RAID 5 configuration for the data drive.

The following table lists the recommended configuration for the Database Server.

Table 4: Database Server Recommended Configuration

Node Count < 50 < 500 < 1000 < 5000 < 10,000

Database Server SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

SQL
2008 R2

Database Server Edition Standard Standard Standard Standard Standard

Software

Database Server Architecture x86 x86 x64 x64 x64

Core Architecture 2 2 4 8 16

Core Speed (GHz) 2.0+ 2.0+ 2.0+ 2.0+ 2.0+

RAM (GB) 2 4 8 8 16

Network (Backplane) 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s 1 Gb/s

Disk Array RAID 1 RAID 1 Multiple
RAID

Multiple
RAID

Multiple
RAID

# Hard Drives 2 2 4 6 8

Hardware

Drive Speed (RPM) 7200 7200 7200 10k 10k
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Node Count < 50 < 500 < 1000 < 5000 < 10,000

Hard Drive Volume Breakdown

Database RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

RAID 1
- 250GB

RAID 10
- 500GB

Temp DB N/A N/A N/A RAID 0
- 250GB

RAID 0
- 250GB

* Due to performance issues, do not use a RAID 5 configuration for the data drive.

Note:  If you are managing more than 10,000 nodes, contact Lumension Support (http://support.lumension.com)
for a recommended configuration.

Recommended Agent Configuration
Lumension recommends configuring server-to-agent communication according to the number of managed
endpoints in your network.

After installing Lumension Endpoint Management and Security Suite Server and Agents, Lumension
recommends configuring agent settings according to your network size.

Lumension recommends the following settings for the Patch Agent. Agent settings are edited within the
Lumension Endpoint Management and Security Suite Web console.

Table 5: Application Settings: Options - Deployment Defaults

Node Count < 50 < 500 < 1,000 < 5,000 < 10,000

Communication Interval (min) 15 30 30 60 60

Concurrent Deployment Limit (CDL) -
Global

1000 1000 1000 2500 5000

CDL - Reboot 200 200 200 500 1000

CDL - DAU 500 500 500 500 1000

CDL - MB 200 200 200 400 800

Lumension recommends the following settings for the Lumension EMSS Agent.

Table 6: Application Settings: Agent Policy Sets - Lumension EMSS Agent Communication

Node Count < 50 < 500 < 1,000 < 5,000 < 10,000

Send interval (sec) 2 3 4 5 6

Receive interval (sec) 0 0 0 0 0

Timeout interval (hour) 12 12 12 12 12

http://support.lumension.com
http://support.lumension.com
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Node Count < 50 < 500 < 1,000 < 5,000 < 10,000

Heartbeat interval (min) 15 30 30 60 60

Note:  If you are managing more than 10,000 nodes, contact Lumension Support (http://support.lumension.com)
for a recommended configuration.

Recommended Server Configuration Information
Additional server configuration may be needed for physical memory limits, SQL Server system databases, and
storage practices.

• For additional information about the physical memory limits for Windows releases,
refer to Memory Limits for Windows Releases (http://msdn.microsoft.com/en-us/library/
aa366778(VS.85).aspx#physical_memory_limits_windows_server_2003).

• For additional information about moving SQL Server 2008 system databases, refer to Moving System
Databases (http://msdn.microsoft.com/en-us/library/ms345408(v=SQL.100).aspx).

• For additional information about Microsoft's top ten best practices for storage, refer to Storage Top Ten Best
Practices (http://technet.microsoft.com/en-us/library/cc966534.aspx).

Supported Endpoint Operating Systems
The Lumension EMSS Agent and all available endpoint modules can be installed on multiple operating systems.

The following table lists the Windows platforms on which the Lumension EMSS Agent 7.3 SP1 is supported.

Table 7: Supported Windows Operating Systems

Operating
System

Version Edition Data
Width

Proc.
Family

Software
Prerequisites

Agent Version

Microsoft
Windows 8

6.2 Windows 8

Windows 8 N

Professional(1)

Professional N

Enterprise

Enterprise N

32/64 bit Intel Microsoft .NET
Framework 4.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows 8.1(5)

6.2 Windows 8.1

Windows 8.1 N

Professional(1)

Professional N

Enterprise

Enterprise N

32/64 bit Intel Microsoft .NET
Framework 4.0+

Lumension
EMSS 7.3
SP1 Agent

http://support.lumension.com
http://support.lumension.com
http://msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx#physical_memory_limits_windows_server_2003
http://msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx#physical_memory_limits_windows_server_2003
http://msdn.microsoft.com/en-us/library/aa366778(VS.85).aspx#physical_memory_limits_windows_server_2003
http://msdn.microsoft.com/en-us/library/ms345408(v=SQL.100).aspx
http://msdn.microsoft.com/en-us/library/ms345408(v=SQL.100).aspx
http://msdn.microsoft.com/en-us/library/ms345408(v=SQL.100).aspx
http://technet.microsoft.com/en-us/library/cc966534.aspx
http://technet.microsoft.com/en-us/library/cc966534.aspx
http://technet.microsoft.com/en-us/library/cc966534.aspx
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Operating
System

Version Edition Data
Width

Proc.
Family

Software
Prerequisites

Agent Version

Microsoft
Windows Server
2012

6.2 Standard(2)

Datacenter(2)

Foundation

Essentials

64 bit Intel Microsoft .NET
Framework 4.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Server
2012 R2(5)

6.2 Standard(2)

Datacenter(2)

Foundation

Essentials

64 bit Intel Microsoft .NET
Framework 4.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Storage
Server 2012

6.2 Standard

Workgroup

64 bit Intel Microsoft .NET
Framework 4.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows 7

6.1 Professional

Professional N

Enterprise

Enterprise N

Ultimate

Ultimate N

32/64 bit Intel Microsoft .NET
Framework 3.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Server
2008 R2

6.1 Standard

Enterprise

Web

64 bit Intel Microsoft .NET
Framework 3.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Vista(3)

6.0 Business

Enterprise

Ultimate

32/64 bit Intel Microsoft .NET
Framework 3.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Server
2008

6.0 Web

Standard(4)

Enterprise(4)

32/64 bit Intel Microsoft .NET
Framework 3.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows Server
2003 SP1+

5.2 Web

Standard(4)

Enterprise(4)

R2

32/64 bit Intel Microsoft .NET
Framework 2.0+

Lumension
EMSS 7.3
SP1 Agent

Microsoft
Windows XP
SP2+

5.1 Professional 32/64 bit Intel N/A Lumension
EMSS 7.3
SP1 Agent
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Operating
System

Version Edition Data
Width

Proc.
Family

Software
Prerequisites

Agent Version

(1) This edition is also supported when Windows Media Center is installed.

(2) Server Core mode for this edition is supported.

(3) When installing the Device Control endpoint module on this operating system, SP1+ is required.

(4) When installing the Device Control endpoint module on these editions, SP2+ is required.

(5) When installing on these operating systems, the only endpoint module supported is Patch and Remediation.

Note:  The Software Prerequisites column applies only to Patch and Remediation and Security
Configuration Management endpoints. Agents without these modules do not require the software prerequisites.
Microsoft .NET Framework 4.0 is installed on Windows 8 and Server 2012 by default.

The following table lists the Mac, UNIX, and Linux operating systems on which the agent is supported. This
version of the agent can only be installed in environments that have Patch and Remediation installed.

Table 8: Supported Mac, UNIX, and Linux Operating Systems

Operating
System

Version Edition Data
Width

Proc.
Family

Software
Prerequisites

Agent Version

Mac OS X 10.5

10.4

10.3

All 32/64 bit PowerPC Sun Java
JRE 1.5.0+

Patch 7.0
Agent

Mac OS X 10.8(1)

10.7(1)

10.6

10.5

10.4

All 32/64 bit Intel Sun Java
JRE 1.5.0+

Patch 7.0306
Agent

HP-UX 11.31

11.23

11.11

All 64 bit PA-RISC Sun Java
JRE 1.5.0+

Patch 7.0
Agent

HP-UX 11.31 All 64 bit Itanium Sun Java
JRE 1.5.0+

Patch 7.0306
Agent

IBM AIX 7.1

6.1

All 32/64 bit PowerPC Sun Java
JRE 1.5.0+

Patch 7.0306
Agent

Novell SUSE
Linux

11

10

Server

Desktop

32/64 bit Intel Sun Java
JRE 1.5.0+
or IcedTea/
OpenJDK

Patch 7.0306
Agent
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Operating
System

Version Edition Data
Width

Proc.
Family

Software
Prerequisites

Agent Version

Red Hat
Enterprise Linux

6(1)

5

Server

Desktop

32/64 bit Intel Sun Java
JRE 1.5.0+
or IcedTea/
OpenJDK

Patch 7.0306
Agent

Oracle Solaris 11

10

All 32/64 bit SPARC/
Intel

Sun Java
JRE 1.5.0+

Patch 7.0306
Agent

Oracle Linux 6

5

Server 32/64 bit Intel Sun Java
JRE 1.5.0+
or IcedTea/
OpenJDK

Patch 7.0306
Agent

CentOS Linux 6

5

Server 32/64 bit Intel Sun Java
JRE 1.5.0+
or IcedTea/
OpenJDK

Patch 7.0306
Agent

(1) This operating system version is compatible with either Sun Java JRE 1.5.0+ or IcedTea/OpenJDK.

Agent Supported Internationalizations and Locales
The Lumension EMSS Agent is internationalized to operate in a variety of locales. However, the agent UI text is
not fully localized for some supported languages.
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The agent has been fully localized to operate in the following locales. Agent UI text is translated.

• en-au: English (Australia)
• en-bz: English (Belize)
• en-ca: English (Canada)
• en-in: English (India)
• en-ie: English (Ireland)
• en-jm: English (Jamaica)
• en-nz: English (New Zealand)
• en-ph: English (Philippines)
• en-sg: English (Singapore)
• en-za: English (South Africa)
• en-gb: English (United Kingdom)
• en-us: English (United States)
• es-es: Spanish (Spain)
• fr-fr: French (France)
• de-de: German (Germany)
• it-it: Italian (Italy)
• ja-jp: Japanese (Japan)
• nl-no: Dutch (Netherlands)
• pt-be: Portuguese (Brazil)
• ru-ru: Russian (Russia)
• sv-se: Swedish (Sweden)
• zh-cn / zh-chs: Chinese (China [Simplified])
• zh-tw / zh-cht: Chinese (Taiwan [Traditional])

The agent has been internationalized to operate in the following locales. However, the agent UI text has not been
translated. English text is displayed.

• da-da: Danish (Denmark)
• fi-fi: Finnish (Finland)
• ko-kr: Korean (Korea)
• no-no: Norwegian - Nynorsk (Norway)
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Chapter

2
Installing the Module

In this chapter:

• Explaining Module Subcomponents

• Installing the Patch and Remediation
Module Server Component

• Installing the Patch and Remediation
Module Endpoint Component

• Uninstalling the Patch and
Remediation Module Server
Component

Lumension Endpoint Management and Security Suite is a platform
that supports various modules, which are components that secure
endpoints in unique ways. Before you can begin using a module, you
must first install it.

Explaining Module Subcomponents
Lumension Endpoint Management and Security Suite is a platform for modules, which are add-ons that protect
your network using different methods. Each Lumension Endpoint Management and Security Suite module is
composed of two subcomponents: the server component and the endpoint component.

Server Component This subcomponent is installed on the Lumension Endpoint Management
and Security Suite server. The server component must be installed before
the endpoint component.

Endpoint Component This subcomponent is installed on endpoints hosting a Lumension Endpoint
Management and Security Suite Agent. Endpoint components can be
installed after the server component and agents are installed. Each installed
endpoint subcomponent consumes an agent license for the applicable
modules

Note:  Ideally all endpoint agents should be the same version as the Lumension EMSS server.

New releases of the server support all currently supported versions of the endpoint agent. Older agent versions,
however, are constrained to the features available when the agent was released and may not support new server
functionality.
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Installing the Patch and Remediation Module Server Component
To begin using the Patch and Remediation, you must first install the Patch and Remediation module server
component on your Lumension Endpoint Management and Security Suite server.

Prerequisites:

You must be licensed for Patch and Remediation.

Install the Patch and Remediation module server component using the Lumension Installation Manager.

Tip:  For additional information on using the Lumension Installation Manager, refer to the Lumension Endpoint
Management and Security Suite: Wake on LAN User Guide (http://portal.lumension.com).

1. Select Tools > Launch Installation Manager.

Step Result: Installation Manager opens to the New/Update Components tab.

2. Select the Patch and Remediation check box for your version number of Lumension Endpoint Management
and Security Suite.

3. Click Install.

Step Result: The Install/Update Components dialog opens.

4. Click Next to dismiss the Database backup recommended notification. Lumension recommends backing up
your database before installing a module.

5. Click Install.

Step Result: A dialog opens, notifying you that installing the module may cause logged in user to lost their
work.

6. Click OK.

Step Result: The installation begins.

7. Click Finish.

Tip:  Select the Launch Lumension EMSS check box to relaunch Lumension Endpoint Management and
Security Suite after clicking Finish.

Result: The Patch and Remediation module server component is installed. To begin using the module, reopen
Lumension Endpoint Management and Security Suite.

After Completing This Task:

Complete Installing the Patch and Remediation Module Endpoint Component on page 33.

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com
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Installing the Patch and Remediation Module Endpoint Component
To deploy content to Lumension Endpoint Management and Security Suite endpoints, the Patch and Remediation
module endpoint component must be installed on the endpoints.

Prerequisites:

• The Patch and Remediation module server component must be installed on the Lumension Endpoint
Management and Security Suite server.

• The Lumension EMSS Agent is installed on target endpoints.

Install the Patch and Remediation module endpoint component from the Endpoints page.

1. Select Manage > Endpoints.

Step Result: The Endpoints page opens to the All tab.

2. From the list, select the endpoints that you want to install the Patch and Remediation module endpoint
component on.

3. Click Manage Modules

Step Result: The Add/Remove Modules dialog opens.

4. Select the Patch check box for all endpoints you want to install the component on.

5. Click OK.

Result: The Add/Remove Modules dialog closes. The Patch and Remediation module endpoint component
begins installing, as denoted by LPR Installed column pending status. The install is completed when
the status changes to Yes. The Patch and Remediation module endpoint component is the Patch Agent.
For additional information, refer to Using the Patch Agent on page 485.

Uninstalling the Patch and Remediation Module Server Component
You can delete Patch and Remediation from Lumension Endpoint Management and Security Suite. When
uninstalling the module, both the server component and endpoint components are removed.

Uninstall Patch and Remediation from the Lumension Installation Manager.

1. Select Tools > Launch Installation Manager.

Step Result: The Lumension Installation Manager opens to the New/Update Components tab.

2. Select the Existing Components tab.

3. Select the Patch and Remediation check box.
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4. Click Uninstall.

Step Result: The Uninstall Components dialog opens.

5. Click Uninstall.

Step Result: A dialog opens, warning you that uninstalling the module may cause logged in users to lose
their work.

6. Click Yes.

Step Result: Removal of the module begins.

7. Click Finish.

Step Result:
Tip:  Select the Launch Lumension EMSS to relaunch Lumension Endpoint Management
and Security Suite after clicking finish.

Result: The module is uninstalled. When the server component is uninstalled, all endpoint components for the
modules are automatically uninstalled as well Relaunch Lumension Endpoint Management and Security
Suite to complete the uninstall.



- 35 -

Chapter

3
Getting Started with Patch and Remediation

In this chapter:

• Patch and Remediation at a Glance

• Help and support while you work

• The Lumension Patch and
Remediation Workflow

Patch and Remediation is a Lumension Endpoint Management and
Security Suite module that remotely installs patches and other software
on your managed network endpoints. To get started with Patch and
Remediation, you should install the module and then perform several
other tasks essential to its operation.

After performing these tasks, you will be able to deploy patches and
other content to endpoints in your network, thus remediating potential
exploits.

Following completion of these initial tasks, take some time to grow
accustomed to the Patch and Remediation. You will continue to
perform these tasks, plus many other. Lumension EMSS contains
many features and functions, and by learning the environment, you can
secure your network quickly and efficiently.

Patch and Remediation at a Glance
Patch and Remediation is a module you can use to install patches and other software on your network endpoints.

Benefits

• Identifies endpoint vulnerabilities and remediates them by installing content (such as software and patches).
• Scans agent-managed endpoints for an inventory of their hardware and software.
• Lets you deploy patches, software, and other types on content to endpoints.
• Lets you establish mandatory baselines, which are content standards applied to endpoint groups that monitor

endpoints to ensure defined content is always installed.
• Adds new Patch and Remediation-related reports, agent policies, default options, widgets, access rights, and

email notifications.
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Key Terms

Patch and Remediation A Lumension Endpoint Management and Security Suite module you can
use to apply hotfixes, patches, service packs, and other content to agent-
managed endpoints. Content is first deployed from the Lumension Endpoint
Management and Security Suite Server, and is then installed on endpoints
by the Lumension Endpoint Management and Security Suite Agent.

patch management The systematic deployment, installation, and auditing of applicable
hotfixes, patches, and service packs to operating systems and software
applications. This process must incorporate the organization or people
needed to administer the patches, the processes needed to ensure the proper
testing, the inventorying of existing patch levels, the identification of
needed patches, and the technology to deploy and apply the appropriate
patches.

vulnerability A weakness in a system that would allow an attacker to compromise
system confidentiality, integrity, or availability. Alternatively, it can
also be a breach from the original design, concept, or intended behavior
of a computer’s hardware or software that leaves the computer, or any
piece of it, in an exposed state. Malicious users can use this to force other
unintended actions to be performed. Vulnerabilities are often caused
by defects or bugs, though this is not always the case. Many times the
very configuration may result in unexpected exposures. Even out of date
documentation may be labeled as a vulnerability, as not informing a user
of how to perform actions in the preferred manner may result in systems
being widely exposed. This term applies to environments with the Patch
and Remediation module installed.

remediation Installing a countermeasure to reduce or neutralize the risks associated
with a vulnerability. This term applies to environments with the Patch and
Remediation module installed.

Discover Applicable Updates
(DAU)

A predefined system task that launches the Lumension Endpoint
Management and Security Suite agent on a client endpoint. The DAU runs
following subscription replication, five minutes after the application of a
patch, after a reboot and when an agent checks in after the ScanNow button
has been clicked in the Lumension Endpoint Management and Security
Suite server interface.

deployment The planned delivery of content to any or all nodes determined to be non-
compliant. Deployments are available in environments with the Patch and
Remediation module installed.
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content Any type of content that the Lumension Endpoint Management and
Security Suite server can deploy to agents. Types of content include
vulnerabilities, software, patches, hotfixes, and so on. Security content
items contain pre-requisites, fingerprints, and signatures (all of which
determine whether content is applicable to an endpoint) in addition to the
package that contains the software to be installed. Content is available in
environments with the Patch and Remediation module installed.

package A package contains all the actual patch software and executable code
for deployment. A package can run tasks or scripts, install software
applications, place files (or directories of files) in a specified location,
change the configuration of applications or services, or perform various
other tasks that can be done in an unattended manner. The majority of
packages contain the patches for vulnerabilities, defects, or bugs. This term
applies to environments with the Patch and Remediation module installed.

Mandatory Baseline The absolute minimum set of content or locally-created distribution
packages that must be installed on the group’s computer members. In terms
of content reports, a Mandatory Baseline will continually verify that the
content is actually installed, and, if it is not, it will deploy the necessary
distribution packages to bring the computer into compliance. This feature
is available in environments with the Patch and Remediation module
installed.

Help and support while you work
Interactive assistance, troubleshooting information, and technical support are provided to you at all stages of your
experience with the suite and its modules, directly from the user interface and external sources.

Context-Sensitive Help
The help system contained in the suite provides context-sensitive conceptual, procedural, and reference
information. Accessing the help differs according to context:

• From a page, select Help > Help Topics.
• From a dialog, click the Question Mark (?) icon.

The help browser opens as a separate window, which enables you to use the suite and view help simultaneously.

Embedded Help
Prompts, examples, tooltips, and infotips are embedded throughout the pages, dialogs, and wizards of the suite.

Hover over fields or the Information ( ) icon to reveal additional information or micro help.
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Customer Portal
Easy online access to all of Lumension's support resources is available at a single location called the Lumension
Customer Portal (http://portal.lumension.com). View a repository of the latest announcements, product
documentation (PDF), software and patch downloads, known issues, and answers to frequently asked questions.

Online Training
Acquire the knowledge and skills to fully utilize the entire Lumension product line at your own pace on the
Lumension Learning Web site (http://www.lumensionlearning.com). Taught by Lumension subject matter experts
using engaging multimedia, the lessons are delivered in a useful how-to format and cover all key features and
functions.

Knowledge Base
Quick problem resolution and 24 x 7 Web self-service is available to you by the Lumension KnowledgeBase
(http://www.lumension.com/kb/home.aspx).

Discussion Forums
The Lumension Forums (http://www.lumensionforums.com) is an online platform that enables you to swap
experiences and tips with other users, and also provides a medium for discussion among Lumension employees.

Customer Community
Engage with Lumension subject matter experts and other customers in the participative, collaborative
environment called Lumension Connect (http://www.lumension.com/Customers/Community.aspx). Through
discussion forums, rich media sharing, groups, and events, Lumension Connect facilitates dialog and the
exchange of ideas.

Contacting Support
If you have an active Lumension software maintenance contract, you can contact Lumension Support
(support@lumension.com) via email.

The Lumension Patch and Remediation Workflow
To use Lumension Patch and Remediation (Patch and Remediation), all Lumension Endpoint Management and
Security Suite components must be installed, along with the Patch and Remediation module. After installing all
necessary components, review this chart to understand the Patch and Remediation work flow.

Refer to the following flow chart to determine tasks when using the Patch and Remediation module within
Lumension EMSS.

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com
http://www.lumensionlearning.com
http://www.lumension.com/kb/home.aspx
http://www.lumension.com/kb/home.aspx
http://www.lumensionforums.com
http://www.lumension.com/Customers/Community.aspx
http://www.lumension.com/Customers/Community.aspx
mailto:support@lumension.com
mailto:support@lumension.com
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Install the Patch and Remediation module server component. This component is installed
after initial Lumension EMSS installation. For additional information, refer to Installing
the Patch and Remediation Module Server Component on page 40.

Note:  If you purchased a Patch and Remediation license during your initial Lumension
EMSS purchase, Patch and Remediation is installed during the initial Lumension EMSS
installation by default.

Install the Patch and Remediation module endpoint component on agents you want to
support Patch and Remediation functions. Each agent you install the endpoint component
on consumes a Patch and Remediation license. For additional information, refer to
Installing the Patch and Remediation Module Endpoint Component on page 41.

Create groups containing Patch and Remediation endpoints in preparation for deployment.
A group associates similar endpoints for the purpose of deploying content to multiple
endpoints. For additional information, refer to Creating New Groups on page 42.

Create new agent policy sets (or edit existing policy set for Patch and Remediation
functions) and apply them to Patch and Remediation groups. Agent policy sets are a
compilation of values that govern agent behavior. New settings for agent policy sets are
added after installing Patch and Remediation. For additional information, refer to Creating
Agent Policy Sets on page 43.

View network vulnerabilities and then deploy content, which are patches and other
software, to managed endpoints. First, view network vulnerabilities. Agents detect
vulnerabilities by scanning endpoints for signatures that indicate a vulnerabilities are
present. The, remediate vulnerabilities using a deployment, which triggers the agent to
download selected content from the Lumension EMSS Server. For additional information,
refer to Viewing and Remediating Vulnerabilities on page 44.

After initial vulnerabilities are remediated, you can define a Mandatory Baseline. This
baseline is a selection of user-defined content that must always be installed on all group
endpoints. If an endpoint falls out of compliance, the Mandatory Baseline ensures the
endpoint is patched back into compliance via automatic deployment. For additional
information, refer to Installing the Patch and Remediation Module Endpoint Component on
page 41.

Define default Patch and Remediation settings. New default settings are added to
Lumension Endpoint Management and Security Suite after Patch and Remediation is
installed. New settings include new access roles, email notifications, and deployment
options. For additional information, refer to the following topics:

• Defining Default Deployment Options on page 46
• Editing Email Notifications on page 46
• Editing Custom Roles on page 47
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Logging In to Lumension Endpoint Management and Security Suite
Get started with Lumension Endpoint Management and Security Suite by logging in to the Web console.

You can access this console from any endpoint in your network.

1. Open your Web browser.

2. In your browser’s address bar, type the Lumension EMSS URL (http[s]://ServerURL) and press ENTER.

Tip:  You can also use the server IP address.

Step Result: A dialog prompting you for credentials opens.

3. Type your user name in the User name field.

When logging in for the first time, type the user name of the Windows user account used to install Lumension
EMSS. You can use additional user names after adding new user profiles to Lumension EMSS. If logging in
using a domain account, type the name in the following format: DOMAIN\Username.

4. Type your password in the Password field.

5. Click OK.

After Completing This Task:

Continue to Installing the Patch and Remediation Module Server Component on page 40.

Installing the Patch and Remediation Module Server Component
After logging in to Lumension Endpoint Management and Security Suite, the first step in implementing Patch
and Remediation features and functions is to install the server module

Figure 1: Install Server Module

Install the server module using Installation Manager.

1. Select Tools > Launch Installation Manager.

Step Result: Installation Manager opens to the New/Update Components tab.

2. Select the Patch and Remediation check box for your version number of Lumension Endpoint Management
and Security Suite.

3. Click Install.

Step Result: The Install/Update Components dialog opens.
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4. Click Next to dismiss the Database backup recommended notification. Lumension recommends backing up
your database before installing a module.

5. Click Install.

Step Result: A dialog opens, notifying you that installing the module may cause logged in user to lost their
work.

6. Click OK.

Step Result: The installation begins.

7. Click Finish.

Tip:  Select the Launch Lumension EMSS check box to relaunch Lumension Endpoint Management and
Security Suite after clicking Finish.

Result: The Patch and Remediation server module is installed.

After Completing This Task:

Continue to Installing the Patch and Remediation Module Endpoint Component on page 41.

Installing the Patch and Remediation Module Endpoint Component
After installing the Patch and Remediation server module, you must install the Patch and Remediation endpoint
component (the patch agent) on your managed network endpoints.

Prerequisites:

Complete Installing the Patch and Remediation Module Server Component on page 40.

Figure 2: Install Endpoint Module

Install the endpoint component from the Endpoints page.

1. Select Manage > Endpoints.

Step Result: The Endpoints page opens to the All tab.

2. From the list, select the endpoints that you want to install the Patch and Remediation module endpoint
component on.

3. Click Manage Modules

Step Result: The Add/Remove Modules dialog opens.

4. Select the Patch check box for all endpoints you want to install the component on.
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5. Click OK.

Result: The Patch and Remediation endpoint module is installed on selected endpoints.

After Completing This Task:

Continue to Creating New Groups on page 42.

Creating New Groups
After installing the Patch and Remediation components, create a new group for your Patch and Remediation
endpoints. By placing your Patch and Remediation endpoints in a group (or multiple groups), you can manage
them collectively. For example, you deploy content to all Patch and Remediation with one deployment by using
groups.

Prerequisites:

Complete Installing the Patch and Remediation Module Endpoint Component on page 41.

Figure 3: Group Diagram

Create and configure groups from the Groups page.

1. From the navigation menu, select Manage > Groups.

2. From the Group Browser directory tree, select Custom Groups.

Groups are arranged within a directory tree structure. You can place your new group anywhere within the
custom group hierarchy.

Note:  The group you create is added as a child group to the group selected within the directory tree.

3. Create a group.

a) From the View list, select Group Membership.
b) Click Create.
c) In the Name field that displays, type a group name.
d) In the Description field that displays, type a description.
e) Click the Save icon.

4. Add endpoints to the group.

a) From the View list, select Endpoint Membership.
b) Click Manage.
c) Assign endpoints to the group.

For more detailed information, refer to Adding Endpoint Members on page 281.
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d) Click OK.

5. Define the group's settings.

Group settings contain additional group controls.

a) From the View list, select Settings.
b) Define the settings.

For more detailed information, refer to Editing Group Settings on page 335.
c) Click Save.

Result: The group is created.

After Completing This Task:

Continue to Creating Agent Policy Sets on page 43.

Creating Agent Policy Sets
After you create a group, create an agent policy to govern the group's endpoints' behavior. Agent policy sets can
control endpoint communications, hours or operations, and so on.

Prerequisites:

Complete Creating New Groups on page 42.

Figure 4: Install Server Module

Create agent policy sets using the Agent Policy Sets page, and then assign them to a group using the Groups
page.

1. Select Manage > Agent Policy Sets.

Step Result: The Agent Policy Sets page opens.

2. Click Create to create an agent policy set.

For additional information, refer to Creating an Agent Policy Set on page 347.

3. Select Manage > Groups.

Step Result: The Groups page opens.

4. From the View list, select Agent Policy Sets.

Step Result: The Agent Policy Sets view opens.

5. From the Group Browser directory tree, select the group you created.
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6. Click Assign to assign the agent policy set to your created group.

For additional information, refer to Assigning an Agent Policy Set to a Group on page 320.

Result: The agent policy set is created and assigned.

After Completing This Task:

Continue to Viewing and Remediating Vulnerabilities on page 44.

Viewing and Remediating Vulnerabilities
After installing the Patch and Remediation module server and endpoint components, your network endpoints
complete their first discover applicable updates task, which detect vulnerabilities. Following this task, you can
then view vulnerabilities in your network and then deploy patches and other content to resolve them.

Prerequisites:

Complete Creating Agent Policy Sets on page 43.

Figure 5: Viewing and Remediating Vulnerabilities

1. View dashboard widgets, vulnerabilities, and reports to identify vulnerabilities in your network.

Dashboard widgets and reports provide detailed graphs and statistics about the state of your network.
Reviewing this information provides insight about the actions required to secure your network. For additional
information, refer to the following documentation:

• To see an overview of how many vulnerabilities are in your network, view The Dashboard. View the
dashboard by click Home from the navigation menu.

• To view the vulnerabilities on a specific endpoint, view The Endpoint Details Page. View the Endpoint
Details page by selecting Manage > Endpoints and clicking an endpoint link.

• To view the specific vulnerabilities in your network, view The Content Pages List. To view this page,
select Manage > Vulnerabilities.

• To view a report of vulnerabilities in your network, view Generating a Report. To generate reports, select
Reports > All Reports, select a report, and click Generate Report.

2. Select Review > Vulnerabilities > All.

Step Result: The Content page opens to show vulnerabilities.

3. From the list, select the vulnerabilities you want to deploy.

Tip:  Use the page filters to find vulnerabilities applicable to your endpoints.
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4. Click Deploy to remediate vulnerabilities.

Remediate network vulnerabilities by deploying content that fix identified vulnerabilities. For additional
information, refer to Using the Deployment Wizard on page 229.

Result: The deployment is scheduled and will begin at the scheduled time. Completion time of the deployment
varies dependent on size.

After Completing This Task:

Continue to Adding Content to a Mandatory Baseline on page 45.

Adding Content to a Mandatory Baseline
Each group in Lumension Endpoint Management and Security Suite has a mandatory baseline, which is a
list of content that must be installed on the group's endpoints at all time. By default, this baseline is empty.
However, you can add patches, software, and other content to this baseline. After adding content to the baseline,
Lumension Endpoint Management and Security Suite continually checks groups endpoints for the content's
presence. If a group endpoint is found to not have content included in the mandatory baseline, Lumension
Endpoint Management and Security Suitet automatically deploys that content to the endpoint.

Prerequisites:

Complete .Editing Email Notifications on page 46.

Figure 6: Adding Content to Mandatory Baselines

Add content to a mandatory baseline from the Groups page.

1. Select Manage > Groups.

2. From the View list, select Mandatory Baseline.

3. From the Group Browser directory, select the group you created earlier.

4. Click Manage to add content.

For additional information, refer to Adding Content to Mandatory Baselines on page 295.

5. Click OK.

Result: Content is added to the group mandatory baseline.

After Completing This Task:

Continue to Defining Default Deployment Options on page 46.
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Defining Default Deployment Options
After you install Patch and Remediation, a Deployments tab is added to the Options page. Configure this tab to
define the default values for the Deployments Wizard.

Prerequisites:

Complete Adding Content to a Mandatory Baseline on page 45.

Figure 7: Define Default Deployment Options

Define default deployment options from the Options page.

1. Select Tools > Options.

2. Select the Deployments tab.

3. Define the default deployment options.

For additional information, refer to Configuring the Deployments Tab on page 135.

4. Click Save.

Result: The default deployment options are defined.

After Completing This Task:

Continue to Editing Email Notifications on page 46.

Editing Email Notifications
After installing Patch and Remediation, two new email notification types are added: New Vulnerabilities and
Deployment Failure. To use these new notifications, edit your defined email addresses or create new ones.

Prerequisites:

Complete Defining Default Deployment Options on page 46.

Figure 8: Edit Email Notifications

Edit email notifications from the Email Notifications page.
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1. Select Tools > Email Notification.

Step Result: The Email Notifications page opens.

2. For each defined email address, select one or both of the following new notification types.

Tip:  For more information on how to define a new address and email notifications, refer to Creating Email
Notification Addresses on page 113.

Notification Type Description

New Vulnerabilities Sends the defined address a notification email when new vulnerabilities
are available.

Deployment Failure Sends the defined address a notification email when a scheduled
deployment fails.

3. Click Save.

Result: The email addresses you edited are configured to receive the new email notifications.

After Completing This Task:

Continue to Editing Custom Roles on page 47.

Editing Custom Roles
After installing Patch and Remediation, new access rights are added for new features. To update custom roles for
these features, edit your roles.

Prerequisites:

Complete Editing Email Notifications on page 46.

Edit custom roles from the Users and Roles page.

1. Select Tools > Users and Roles.

2. Select the Roles tab.

3. From the page list, click the edit icon for the custom role to which you want to add access rights.

Step Result: The Edit Role dialog opens.

4. Select the Access Rights tab.

5. Define the new Patch and Remediation access rights.

Access Right Description

View LPR Widgets Access to select and view the Patch and Remediation Dashboard
widgets.
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Access Right Description

View Content Access the vulnerability and other content data.

Manage Content Enable and disable vulnerabilities and other content.

Export Content Export vulnerability and other content data list.

View Content Details Access the detailed information for vulnerabilities and other content.

View LPR Tab Access the Patch and Remediation tab.

Manage LPR Tab Install, uninstall, enable, and disable the Patch and Remediation
module.

ExportLPR Tab Export the Patch and Remediation tab endpoint list.

Scan Now Discover Applicable
Updates

Scan endpoints using the DAU Scan Now Dropdown button.

Reboot Endpoints Reboot endpoints using the Reboot Now button.

View Inventory View the endpoint inventory.

Export Inventory Export the endpoint inventory list.

Create Deployments Ability to create new deployments.

View My Deployments and
Tasks

Access the deployments and tasks that this user has created.

View All Deployments Access the deployments that all users have created.

Manage Deployments and
Tasks

Deploy, enable, disable, abort, and delete deployments and tasks that
the user has access to.

Export Deployments and Tasks Export the deployments and tasks in the list that this user has access to.

View Packages Access the package data.

Manage Packages Create, edit, and delete packages.

Export Packages Export the package data list.

Cache Packages Ability to download packages from the Global Subscription Server
onto the Lumension Endpoint Management and Security Suite server.

Manage LPR Email
Notifications

Create and edit Patch and Remediation notifications.

6. Click OK.

7. Click OK.
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Chapter

4
Using Lumension Endpoint Management and Security
Suite

In this chapter:

• Supported Browsers

• Common Functions within
Lumension Endpoint Management
and Security Suite

• The Home Page

Within Lumension Endpoint Management and Security Suite, you can
use a number of common functions to navigate and operate the system.
After you log in, Lumension Endpoint Management and Security Suite
opens to the Home page.

Lumension Endpoint Management and Security Suite performs the
following functions:

• Endpoint Detection
• Agent Installation
• Endpoint Management
• Endpoint Grouping
• Agent Policy Set Creation
• User and Role Creation and Management
• Server Module Management
• Report Generation

Lumension Endpoint Management and Security Suite consists of a
browser-based management console, which provides access to system
management, configuration, reporting, and deployment options.

Supported Browsers
Lumension Endpoint Management and Security Suite is managed using a Web browser. The Lumension
Endpoint Management and Security Suite Web console is supported by several Web browsers.
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The following list defines the Web browsers supported by Lumension Endpoint Management and Security Suite,
along with other software required to use all Lumension Endpoint Management and Security Suite functions.

• One of the following:  Microsoft Internet Explorer 8, Microsoft Internet Explorer 9, or Mozilla Firefox 17.x
Extended Support Release (ESR) version.

Note:  Due to the accelerated release cycle of the Mozilla Firefox RapidRelease version, support for for
Mozilla Firefox RapidRelease cannot be guaranteed.

• Internet Information Services (IIS) 6.0 or later.
• Microsoft Silverlight™

Logging In to Lumension Endpoint Management and Security Suite
Lumension Endpoint Management and Security Suite (Lumension EMSS) is an Internet application that
conforms to standard Web conventions. You can access the application's console from a Web browser. Log in to
the Lumension EMSS server to begin using product features.

Prerequisites:

Microsoft Internet Explorer 8, Microsoft Internet Explorer 9, or Mozilla Firefox 17.x Extended Support Release
(ESR) version. must be installed.

You can access the console from any endpoint within your network.

Note:  When accessing the Lumension EMSS console using a Web browser with high security settings enabled,
the following message may display:

Scripting must be enabled to display this application properly.

In this event, Lumension recommends adding the Lumension EMSS Web address as a trusted site in your
browser settings to view the Web console.

1. Open your Web browser.

2. In your browser’s address bar, type the Lumension EMSS URL (http[s]://ServerURL) and press ENTER.

Tip:  You can also use the server IP address.

Step Result: A dialog prompting you for credentials opens.

3. Type your user name in the User name field.

When logging in for the first time, type the user name of the Windows user account used to install Lumension
EMSS. You can use additional user names after adding new user profiles to Lumension EMSS. If logging in
using a domain account, type the name in the following format: DOMAIN\Username.

4. Type your password in the Password field.

5. Click OK.

Result: Lumension EMSS opens to the Home page.
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Logging Out of Lumension Endpoint Management and Security Suite
After you finish using Lumension Endpoint Management and Security Suite (Lumension EMSS), log out of the
system to ensure no unauthorized users access the console.

1. Browse to the navigation menu.

2. Click Log Out.

Figure 9: Log Out Link

Result: You are logged out of Lumension EMSS, and the Logout page displays.

Figure 10: Log Out Page

Common Functions within Lumension Endpoint Management and
Security Suite

Lumension Endpoint Management and Security Suite uses both standard Web browser conventions and functions
specific to itself. Familiarity with these common functions facilitate efficient product use.

From the navigation menu and system pages, you can access all features and functions your access rights
authorize. The topics that follow provide instructions on how to use common functions.
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Common Conventions
This application supports user interface conventions common to most Web applications.

Table 9: Common User Interface Conventions

Screen Feature Function

Entry Fields Type data into these fields, which allow the system to retrieve matching criteria or
to enter new information.

Drop-Down Menus Displays a list to select preconfigured values.

Command Buttons Perform specific actions when clicked.

Check Boxes A check box is selected or cleared to enable a feature, disable a feature, or initiate
function for a list item. Some lists also include a Select All check box that lets
you select all the available listed items on that page (and any remaining pages).

Radio Buttons Select the button to select an item.

Sort Data presented in tables can be sorted by ascending (default) or descending order
within a respective column by clicking on a (enabled) column header.

Mouseovers Additional information may be displayed by hovering your mouse pointer over an
item.

Auto Refresh Where present and when selected, the auto refresh function automatically
refreshes the page every 15 seconds.

Scrollbars Drag to see additional data that does not fit the window.

Tabs Click on the tab name to switch to different information related to the specific
page or dialog.

Bread Crumb Names the page you are currently viewing, that page's parent page (if applicable),
and the navigation menu item that opened the displayed page. If viewing a page
that is child of another page, you can view the parent page by clicking the bread
crumb, which also serves as a link, allowing you to retrace your steps.

Tip:  Most system pages support right-click.

Toolbars
Toolbars appear near the top of most Lumension Endpoint Management and Security Suite pages. These
toolbars contain menus and buttons that let you use product features specific to the displayed page.
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The menus and buttons displayed vary according to page. Additionally, user access rights determine which
buttons are available for use. Click the available buttons and menus to use them.

Figure 11: Toolbar

List Pages
Most Lumension Endpoint Management and Security Suite pages feature lists of selectable items. These items
represent a series of product features that can be edited using menus and buttons.

Figure 12: List Page

You can select individual list items. To select a list item:

• Select a check box.
• Click a list row.

You can select multiple list items. To select multiple list items:

• Select all list items by selecting the Select All check box.
• Select multiple, non-concurrent items by using CTRL+Click over list rows or check boxes.
• Select multiple, concurrent items by using SHIFT+Click over list rows or check boxes.

The Page Banner
A page banner displays on Lumension Endpoint Management and Security Suite pages that pertain to a specific
module component. Use this banner to identify the module that the page belongs to.

For example, pages pertaining to Lumension Patch and Remediation display a Patch and Remediation page
banner. Page banners are color coded by module.

Figure 13: Page Banner Example

The Options Menu
Toolbars feature an Options menu, whose function is to set page views, filter data, and enable clipboard copy.
Menu items vary based on the functions applicable to the selected page.
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The following functions can be found on the Options menu.

Table 10: Options Menu Items

Option Description

Show results on page load If enabled, automatically provides query results based on the default filters.
If disabled, you must define the available page filters and click Update
View to view query results. For more information, see Filters on page
54.

Save as default view Saves the current visual setting as the default view for the selected page
and the logged in user.

Clear default view Resets a saved default view to the system default view.

Note:  This option is only available on certain pages.

Show Group By Row Sorts list items into groups based on column headers. For more
information, see Group By on page 58.

Enable Copy to Clipboard Enables selected text to be copied to the clipboard and pasted into a text
editor.

Note:  Selecting this option disables other features, such as the right-click
context menu, or dragging to select multiple list items.

Note:  Some menu item titles change according to context. For example, if you select Show Group By Row to
view the Group By row, the menu item title changes to Hide Group By Row.

Filters
Filters appear on most list pages. You can use them to search pages for specific data.

Depending on which page you viewing, you can filter pages using one of the following features. Only one feature
appears per page.

• Filters
• Filter Row

Filters
Filters appear above page lists. They feature different fields, lists, and check boxes used for filtering. Filters vary
according to page.

Figure 14: Filters
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Additionally, you can save frequently used filter settings as your default view. To save your filter criteria, select
a list page and choose Options > Save as default view from the toolbar. The toolbar Options menu contains the
following options related to filtering.

Table 11: Filter Options

Option Function

Show results on page
load

Automatically retrieves and displays results when selected.

Save as default view Saves the active filter and sort criteria as the default view for the page.

The default view displays each time the page is accessed. You can change this setting
at any time.

Clear default view Resets a saved default view to the system default view.

Note:  Your default view remains applicable until you save a new default view or clear the default view, even
after browsing to a different page or logging out of Lumension Endpoint Management and Security Suite.

Filter Rows
Filter rows appear in the lists themselves. Rows feature a field for each column. Columns can be filtered using a
variety of data types. For example, you can use a Contains filter or a StartsWith filter.

Figure 15: Filter Row

These filter are not case sensitive. Additionally, date columns filter at the lowest level of granularity; higher
levels of granularity return no filter results.

Supported Wildcards
When searching for or filtering vulnerabilities, you can use wildcards to make search results more specific and
efficient.
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Wildcards can be used anywhere within the search string. The following table lists the supported operators and
wildcards in Lumension Endpoint Management and Security Suite. Type any wildcards that you intend to use in
the Name of CVE-ID field.

Table 12: Supported Wildcards

Wildcard Description Example

% Any string. The string can be empty or
contain any number of characters.

Typing Microsoft%Server in the Name
or CVE-ID field returns any vulnerability
with the words "Microsoft" and "Server" in
any part of the vulnerability's name, such
as:

• MS12-043 Security Update for
Microsoft Office SharePoint Server
2007 32-Bit Edition (KB2687497)

• The 2007 Microsoft Office Servers
Service Pack 3 (SP3), 32-bit Edition
(KB2526299)

_ (underscore) Wildcard placeholder for any single
character.

Typing _itrix or Citri_ in the Name or
CVE-ID field returns any vulnerabilities
with "Citrix" in the name.

[ ] Any single character within a specified
range ([a-f]) or set ([abcdef]).

Typing [m]ic in the Name or CVE-ID
field returns vulnerabilities with the string
"mic" anywhere in the name ("Microsoft"
and "Dynamic").

Typing 200[78] in the Name or CVE-
ID field returns vulnerabilities with 2007
or 2008 in any part of the vulnerability's
name.

[^] Any single character not within a specified
range ([^a-f]) or set ([^abcdef]).

Typing M[^i]cro in the Name or CVE-
ID field returns any vulnerability that does
not have "Micro" in the vulnerability's
name.

Using Filters
When list pages are overpopulated with items, use filters to search for specific list items. Use this feature to filter
list pages by criteria specific to the page.

Filters are available on most list pages.

1. Select a list page. For additional information, refer to List Pages on page 53.

2. Ensure filters are displayed.

If filters are not displayed, click Show Filters.
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3. Define filter criteria.

Note:  Available filters differ by page.

• In filter fields, type the desired criteria.
• From filter lists, select the desired list item.

4. If applicable, select the Include sub-groups check box.

Note:  This check box only appears on list pages related to groups.

5. Click Update View.

Step Result: The list is filtered according to the filter criteria.

6. [Optional] Save the filter criteria by selecting Options > Save as default view from the toolbar.

Using Filter Rows
Some list pages use filter rows rather than filters. Use these rows, which are the first row of applicable lists, to
filter column results. Filter column results to search for specific list items.

These rows appear on several list pages.

1. Select a page featuring the filter row.

2. Ensure the filter row is displayed.

If the filter row is not displayed, select Options > Show Filter Row from the toolbar.

3. Type criteria in the applicable filter row field.

4. Apply a filter type.

a) Click the applicable Filter icon.

Step Result: A menu opens.

b) Select a filter type.

The following table describes each filter type.

Table 13: Data Filtering Types

Type Description

NoFilter Removes previously applied filtering.

Contains Returns results that contain the value applied to the filter.

DoesNotContain Returns results that do not contain the value applied to the filter.

StartsWith Returns results that start with the value applied to the filter.

EndsWith Returns results that end with the value applied to the filter

EqualTo Returns results equal to the value applied to the filter.
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Type Description

NotEqualTo Returns results that are not equal to the value applied to the filter.

Greater Than Returns results that are greater than the value applied to the filter.

Less Than Returns results that are less than the value applied to the filter.

GreaterThanOrEqualTo Returns results that are greater than or equal to the value applied to the
filter.

LessThanOrEqualTo Returns results that are less than or equal to the value applied to the
filter.

Between Returns results that are between two values. Place a space between the
two values.

NotBetween Returns results that are not between two values. Place a space between
the values.

IsEmpty Returns results that are empty.

NotIsEmpty Returns results that are not empty.

IsNull Returns results that have no value.

NotIsNull Returns results that have a value.

Note:  Text filters are case sensitive. Date columns filter at the lowest level of granularity; higher levels
of granularity return no filter results. The availability of filtering options is dependent on the type of data
displayed in the column. For example, filtering options that can only apply to numeric data will not be
available in columns that contain text data or a mix of text and numeric data.

Result: The list column is filtered according to the criteria. If desired, repeat the process to filter additional
columns.

Group By
The Group By row lets you sort list items into groups based on column headers. Use this feature to see which
list items share similarities.

To use the Group By row, ensure Options > Show Group By Row is selected from the toolbar, and then drag a
column header into the row. You may drag multiple columns to the row, but you may only drag one column into
the row at a time.
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To ungroup the list, right-click on the row and select Cancel All Groupings. To hide the Group By row, select
Options > Hide Group By Row.

Figure 16: Group By Row

Expanding and Collapsing Structures
Certain structures in Lumension Endpoint Management and Security Suite are expandable and collapsible.
Expand structures to view additional available information or options. Collapse them to conserve screen space.

Click available Plus icons (+), Minus icons (-), and Rotating Chevron icons (>) to expand or collapse a
structure.

Figure 17: Expandable/Collapsable Structure Example

Advancing Through Pages
Lumension Endpoint Management and Security Suite creates pagination links to manage the overflow. Click
these links to advance through like items.
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The number of list items and the specific page you are viewing determines the number of pagination links.

Figure 18: Pagination Feature

Lumension Endpoint Management and Security Suite also features a Rows Per Page drop-down list. From this
list, you can select the number of items that populate a list.

Table 14: Pagination Feature Functions

Icon or Link Title Function

Final Page Link Advances to the final page of list items.

First Page Link Returns to the first page of list items.

Next Ten/Previous Ten
Pages Link

Displays the next ten or previous ten page links available. Fewer
page links will display if the remaining list items cannot populate
ten pages.

Pagination Links Advances or returns to the selected pagination link.

Each page also features a Rows Per Page Drop-Down List. This list modifies the number of list items displayed
on a single page (25, 50, 100, 200, 500).

Help
Lumension Endpoint Management and Security Suite contains context-sensitive HTML (.html) help. Help
provides product feature explanations, step-by-step procedures, and reference materials.

Accessing help differs according to context.

• From a page, select Help > Help Topics.
• From a dialog, click the Question Mark icon (?).

Accessing help displays information that is useful for your current context.

Exporting Data
On many system pages, you can export the listed data to a comma separated value file (.csv) available for
use outside of Lumension Endpoint Management and Security Suite. Use this exported data for management
purposes (reporting, noting trends, and so on).

You can export data from a variety of Lumension Endpoint Management and Security Suite pages.

Note:  These instructions are intended for Microsoft Internet Explorer users. If you are using Mozilla Firefox,
this procedure differs slightly.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses export functionality
and must be disabled to export data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.
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1. Select a list page (or dialog) where you can export information.

2. If necessary, populate the page by defining filter criteria and clicking Update View.

3. Click Export.

Step Result: The File Download dialog opens.

4. In the File Download dialog, select from one of the following options.

Option Description

Open Creates the file and opens it in your default (.csv) program.

Save Creates the file and saves it to a specified local folder. The file is
saved in a Microsoft Office Excel (.csv) format. The file is named
Export.csv, with the exported file containing data based on list data.

Cancel Cancels the export.

Note:  All data results will export, not just the selected results.

Figure 19: Exported Data

The Home Page
The entry point to Lumension Endpoint Management and Security Suite is the Home page. From this page you
can view the dashboard, which features draggable widgets that display information about Lumension Endpoint
Management and Security Suite and agent-managed endpoints.
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Some widgets display general information about the system, others provide links to documentation, and still
others summarize activity for Lumension Endpoint Management and Security Suite modules you are licensed
for.

Figure 20: The Home Page

The Lumension Endpoint Management and Security Suite Header
The product header contains links for information about various Lumension products. Clicking one of these links
opens a new window that pertains to the applicable product.

Figure 21: Header

The product header appears at the top of all Lumension Endpoint Management and Security Suite Web site
pages.

The Navigation Menu
This menu appears on all Lumension Endpoint Management and Security Suite pages. Use this menu to navigate
through the console.

This menu organizes product features based on functionality. When you select a menu item (or sub-menu item), a
new page, dialog, wizard, or window opens. You can access all features of the system from this menu (that your
access rights authorize).

Note:  The menu items available change based on the installed Lumension Endpoint Management and Security
Suite modules.

Figure 22: Navigation Menu
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The navigation menu contains the several menus, which are organized based on functionality.

Table 15: Navigation Menus

Menu Description

Home Opens the Home page. This link contains no menu items.

Discover Contains menu items related to running discovery scan jobs.

Review Contains menu items related to reviewing security content and discovery scan jobs.

Manage Contains menu items related to managing system features.

Reports Contains menu items related to creating reports.

Tools Contains menu items related to system administration.

Help Contains menu items related to help systems.

Tip:  When a menu item is selected, the navigation menu text is underlined to display its active state.

Most navigation menus contain items. The following table lists each menu item in the Discover menu and the
actions that occur when they are selected.

Table 16: Discover Menu Items

Menu Item Description

Assets... The Discover Assets dialog.

Assets and Install
Agents...

The Install Agents dialog.

Assets and Uninstall
Agents...

The Uninstall Agents dialog.

The following table lists each menu item in the Review menu and the actions that occur when they are selected.

Table 17: Review Menu Items

Menu Item Description

My Default View The All Content page with your saved filters.
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Menu Item Description

Vulnerabilities Opens a sub-menu. The sub-menu contains the following items:

All The Vulnerabilities page, filtered to show
only critical vulnerabilities.

Critical Vulnerabilities The Vulnerabilities page, filtered to show
only critical vulnerabilities that are not
superseded.

New Vulnerabilities The Vulnerabilities page, filtered to
show only critical but not superseded
vulnerabilities released in the last 30 days.

Top Vulnerabilities The Vulnerabilities page, filtered to
show only critical but not superseded
vulnerabilities sorted by the greatest number
of applicable endpoints that are not patched.

Software Opens a sub-menu. The sub-menu contains the following items:

All The Software page, filtered to show all
software.

Service Packs The Software page, filtered to show only
service packs.

Software Installers The Software page, filtered to show only
software installers.

Updates The Software page, filtered to show only
software updates.
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Menu Item Description

Other Opens a sub-menu. The sub-menu contains the following items:

All The Other page, filtered to show all non-
critical content.

Detection Only The Other page, filtered to display Detection
Only content.

Informational The Other page, filtered to display only
Information content.

Packages The Other page, filtered to display only
Packages content.

Policies The Other page, filtered to display only
Policies content.

Recommended The Other page, filtered to display only
Recommended content.

System Management The Other page, filtered to display only
System Management content.

Tasks The Other page, filtered to display only Task
content.

Virus Removal The Other page, filtered to display only
Virus Removal content.

Asset Discovery Job
Results

Opens the Job Results page, which is filtered to display discovery job results.

Agent Management Job
Results

Opens the Job Results page, which is filtered to display agent management job
results.

The following table lists each menu item in the Manage menu and the actions that occur when they are selected.

Table 18: Manage Menu Items

Menu Item Description

Endpoints Opens the Endpoints page.

Inventory Opens the Inventory page.

Groups Opens the Groups page.

Deployments Opens the Deployments and Tasks page.

Agent Policy Sets Opens the Agent Policy Sets page.
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The following table lists each menu item in the Reports menu and the actions that occur when they are selected.

Table 19: Reports Menu Items

Menu Item Description

All Reports Opens the All Reports page.

Configuration Opens the All Reports page with configuration reports expanded.

Deployments Opens the All Reports page with deployments reports expanded.

Inventory Opens the All Reports page with inventory reports expanded.

Management/Status Opens the All Reports page with management/status reports expanded.

Policy and Compliance Opens the All Reports page with policy and compliance reports expanded.

Power Management

(Power Management
only)

Opens the All Reports page with Power Management reports expanded.

Risks Opens the All Reports page with risks reports expanded.

Vulnerabilities Opens the All Reports page with vulnerabilities reports expanded.

The following table lists each menu item in the Tools menu and the actions that occur when they are selected.

Table 20: Tools Menu Items

Menu Item Description

Users and Roles Opens the Users and Roles page.

Change My Password... Opens the Change My Password dialog.

Download Agent
Installer...

Opens the Download Agent Installer dialog opens over the currently selected
page.

Power Management

(Power Management
only)

Opens the Power Management page.

Launch Installation
Manager...

Opens the Lumension Installation Manager in a new window.

Subscription Updates Opens the Subscription Updates page.

Email Notifications Opens the Email Notifications page.

Options Opens the Options page.
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The following table lists each menu item in the Help menu and the actions that occur when they are selected.

Table 21: Help Menu Items

Menu Item Description

Help Topics... Opens the Help page.

Help Forums... Opens the Lumension message boards.

Knowledge Base... Opens the Lumension knowledge base.

New Users Start Here... Opens the New Users Start Here page.

Technical Support Opens the Technical Support page.

Product Licensing Opens the Product Licensing page.

About... Opens the About dialog.

Note:  Any unavailable or absent menus, menu items, or sub-menu items are due to restricted access rights or
unavailable modules. Contact your network administrator if you require access to unavailable features.

The Dashboard
The dashboard displays widgets depicting the activity on your protected network. Located on the Home
page, the dashboard provides convenient information you can use to ensure your network protection is up to
standard. Additionally, you can customize the dashboard to display the widgets most applicable to your network
environment.

Widget graphs are generated based on the latest data and statistics available from endpoints, groups, module-
specific data, and so on.
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The following Dashboard widgets are available:

• The Agent Module Installation Status Widget on page 68
• The Agent Status Widget on page 69
• The Applicable Content Updates Widget on page 70
• The Discovery Scan Results: Agents Widget on page 72
• The Critical Patch Status by Endpoint Widget on page 71
• The Endpoints with Unresolved Updates Widget on page 73
• The Incomplete Deployments Widget on page 74
• The Last 5 Completed Scan Jobs Widget on page 75
• The Latest News Widget on page 76
• The Mandatory Baseline Compliance Widget on page 76
• The Next 5 Pending Scan Jobs Widget on page 77
• The Offline Patch Endpoints Widget on page 78
• The Patch Agent Module Status Widget on page 79
• The Scheduled Deployments Widget on page 80
• The Server Information Widget on page 81
• The Time Since Last DAU Scan Widget on page 83
• The Un-remediated Critical Vulnerabilities Widget on page 84

The Agent Module Installation Status Widget
This widget displays the installation and licensing stats of each agent module.

Figure 23: Agent Module Installation Status Widget
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A graph bar displays for each installed module. The following table describes the widget graph(s).

Table 22: Graph Bar Color Descriptions

Bar Color Description

Blue The number of managed endpoints with the applicable module pending installation
or uninstallation.

Green The number of managed endpoints with the applicable module installed.

Red The number of managed endpoints without the applicable module installed.

Tip:  Click the graph to open the Endpoints page All tab.

Note:  Endpoints with an agent version that does not support a module are not counted.

The Agent Status Widget
This widget displays all agents grouped by agent status.

Figure 24: The Agent Status Widget

The following table describes the fields in the Agent Status widget.

Table 23: Agent Status Widget Fields

Field Description

Online The number of agents that are online.
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Field Description

Offline The number of agents that are offline.

Note:  Offline status is determined by the amount of time since the agent last communicated
as determined on the Options page.

Disabled The number of agents that are disabled.

Total Agents The total number of agents in your environment.

Tip:  Clicking on the pie chart opens the Endpoints page All tab. The page is filtered to display all agents.

The Applicable Content Updates Widget
This widget displays applicable content updates grouped by content type. View this widget when determining
what content is applicable to endpoints in your network.

Figure 25: Applicable Content Updates Widget

The following table describes each graph bar.

Table 24: Applicable Content Updates Widget Graph Bars

Bar Description

Critical The number of critical content items that are applicable to the agent-managed endpoints
within your network.

Recommended The number of recommended content items that are applicable to the agent-managed
endpoints within your network.
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Bar Description

Optional The number of optional software, informational, and virus removal content items that are
applicable to the managed endpoints within your network.

Tip:  Clicking the Applicable Content Updates widget graph opens the Vulnerabilities, Software, or Other
page, which is filtered to display all applicable non-patched content.

The following table describes each widget field.

Table 25: Applicable Content Updates Widget Fields

Field Description

Applicable updates The total number of content items applicable to managed endpoints within your
network.

Endpoints The total number of managed endpoints with applicable updates within your
network.

The Critical Patch Status by Endpoint Widget
This widget depicts the patch status of all managed endpoints. Each bar indicates the number of managed
endpoints with applicable vulnerabilities within a given release date range.

Figure 26: Critical Patch Status By Endpoint Widget
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The following table describes the Critical Patch Status By Endpoint widget. Green bars indicate endpoints
that are patched for critical vulnerabilities, while red bars indicate endpoints that are not patched for critical
vulnerabilities.

Table 26: Critical Patch Status By Endpoint Fields

Graph Bar Description

<30 days The number of managed endpoints with applicable critical vulnerabilities fewer than 30 days
old.

30 - 120 days The number of managed endpoints with applicable critical vulnerabilities between 30 to 120
days old.

>120 days The number of managed endpoints with applicable critical vulnerabilities greater than 120
days old.

The following table describes the widget fields.

Table 27: Critical Patch Status By Endpoint Bars

Field Description

Endpoints The total number of managed endpoints with applicable critical vulnerabilities.

Critical
vulnerabilities

The total number of critical vulnerabilities applicable to your environment.

Tip:  Click the graph to open the Critical Vulnerabilities content page.

The Discovery Scan Results: Agents Widget
This widget displays the number endpoints capable of hosting agents (agent-compatible endpoint) discovered in
the latest discovery scan job. The endpoints discovered are classified in to two groups: endpoints with agents and
endpoints without agents.

Figure 27: Discovery Scan Results: Agents Widget
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The following table describes the Discovery Scan Results: Agents widget fields.

Table 28: Discovery Scan Results: Agents Widget Fields

Field Description

As of The name of the discovery scan job used to generate the widget graph and
statistics. This job is the job most recently run.

Endpoints with agents The number of agent-compatible endpoints discovered that have agents
installed.

Endpoints without agents The number of agent-compatible endpoints discovered that have no agents
installed.

Endpoints The total number of agent-compatible endpoints discovered.

Tip:  Clicking the Discovery Scan Results: Agents widget opens the Results page for the most recently run
discovery scan job.

The Endpoints with Unresolved Updates Widget
This widget displays all managed endpoints with unapplied applicable content updates, grouped by content type.
View this widget when discerning if a managed endpoint requires deployment.

An unresolved update is an occurrence of an endpoint that has not had an applicable content item installed.

Figure 28: Endpoints with Unresolved Updates Widget

The following table describes each graph bar.
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Bar Description

Critical The number of managed endpoints in your network that have unresolved critical
content updates.

Recommended The number of managed endpoints in your network that have unresolved recommended
content updates.

Optional The number of managed endpoints in your network that have unresolved software,
informational, and virus removal content updates.

Tip:  Clicking a widget graph bar opens the My Default View page, which is filtered to display all unapplied
applicable content.

The following table describes each widget field.

Field Description

Endpoints The number of managed endpoints with applicable updates within your network.

Applicable updates The total number of content items applicable to managed endpoints within your
network.

The Incomplete Deployments Widget
This widget displays all deployments with elapsed start dates and a status of not started or in progress.

Figure 29: Incomplete Deployments Widget
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The following table describes the Incomplete Deployments widget fields.

Table 29: Incomplete Deployment Widget Fields

Field Description

<25% The number of deployments that are less than 25 percent complete. This field includes
deployments that have not started.

25% - 49% The number of deployments that are 25 to 49 percent complete.

50% - 69% The number of deployments that are 50 to 69 percent complete.

70% - 79% The number of deployments that are 70 to 79 percent complete.

80% - 89% The number of deployments that are 80 to 89 percent complete.

>90% The number of deployments that are more than 90 percent complete.

Total The total number of deployments that have a status of in progress or not started with an
elapsed start time.

Total affected
endpoints

The total number of endpoints receiving pending or in-progress deployments.

The Last 5 Completed Scan Jobs Widget
This widget contains information about the last five completed scan jobs. Each job name is a link to the
associated Result page.

Figure 30: Last 5 Completed Scan Jobs Widget

The following table describes each column in the Last 5 Completed Jobs widget.

Table 30: Last 5 Completed Scan Jobs Widget Columns

Column Description

Name The job name. The name is a link to the associated Results page.

Completed Date The date and time the job completed on the server.

Status The status of the completed job.
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The Latest News Widget
This widget displays important announcements and other information regarding Lumension Endpoint
Management and Security Suite.

Click a Latest News link to view additional details about an announcement in a new window.

Figure 31: Latest News Widget

The Mandatory Baseline Compliance Widget
This widget displays the Mandatory Baseline status of all managed endpoints.

Figure 32: Mandatory Baseline Compliance Widget

The following table describes the Mandatory Baseline Compliance widget fields.

Table 31: Mandatory Baseline Compliance Widget Fields

Field Description

Compliant The number of agents with all Mandatory Baseline content installed.

In process The number of agents currently downloading Mandatory Baseline content.
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Field Description

No baseline The number of agents with no content assigned to their Mandatory Baseline(s).

Non compliant The number of agents that do not have all content in their Mandatory Baseline(s)
installed.

Total number of
endpoints

The total number of endpoints with an agent installed.

The Next 5 Pending Scan Jobs Widget
This widget displays information about the next five pending discovery scan jobs. Each job name is a link to the
Discovery Scan Jobs page Scheduled tab.

Figure 33: Next 5 Pending Scan Jobs Widget

The following table describes the Next 5 Pending Scan Jobs widget columns.

Table 32: Next 5 Pending Scan Jobs Widget Columns

Column Description

Name The job name. Each name is a link to the Discovery Scan Jobs page Scheduled tab.

Scheduled Time The date and time the job is scheduled to run on the server.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 78 -

The Offline Patch Endpoints Widget
This widget displays all offline patch endpoints. These agents are grouped by time ranges since they last checked
in.

Figure 34: The Offline Patch Endpoints Widget

The following table describes the fields in the Offline Patch Endpoints widget.

Table 33: Offline Agents Widget Fields

Field Description

< 48 hours The number of patch endpoints offline fewer than 48 hours.

48 - 72 hours The number of patch endpoints offline 48 to 72 hours.

> 72 The number of patch endpoints offline greater than 72 hours.

Total number of
offline agents

The total number of patch endpoints that are offline (since their last scheduled Discover
Applicable Updates task).

Tip:  Clicking the Offline Patch Endpoints widget pie chart opens the Endpoints page Patch and
Remediation tab, which is filtered to display offline patch agents.
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The Patch Agent Module Status Widget
This widget displays all agents with the Patch and Remediation modules installed, which are grouped by Patch
and Remediation status.

Figure 35: The Patch Agent Module Status Widget

The following table describes the fields in the Patch Agent Module Status widget.

Table 34: Patch Agent Module Status Widget Fields

Field Description

Working The number of Patch Agents that are working on a deployment task.

Idle The number of Patch Agents that are idle.

Disabled The number of Patch Agents that are disabled.

Sleeping The number of Patch Agents that are sleeping.

Offline The number of Patch Agents that are offline.

Disabled The number of Patch Agents that are disabled.

Agents with Patch and
Remediation module
installed.

The number of network endpoints with the Patch Agents installed.
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Field Description

Total Agents The total number of Patch Agents in your environment.

Tip:  Clicking on the pie chart opens the Endpoints page Patch and Remediation tab. The page filtered to
display all patch agents.

The Scheduled Deployments Widget
This widget displays endpoints that have not-yet installed applicable content. These endpoints are divided in to
two categories: endpoints with deployments scheduled and endpoints with deployments not scheduled. These
categories are further divided into three categories: endpoints with not-yet applied critical content, endpoints with
not-yet applied recommended content, and endpoints with not-yet applied optional content.

Figure 36: Schedule Deployments Widget

The following table describes the Scheduled Deployments widget graph bars. Orange graph bars indicate
endpoints that are not scheduled to receive applicable content, while blue graph bars indicate endpoints that are
scheduled to receive applicable content.

Table 35: Scheduled Deployments Widget Graph Bars

Graph Bar Description

Critical The number of managed endpoints scheduled or not scheduled to receive deployments
for critical content.

Recommended The number of managed endpoints scheduled or not scheduled to receive deployments
for recommended content.



Using Lumension Endpoint Management and Security Suite

- 81 -

Graph Bar Description

Optional The number of managed endpoints scheduled or not scheduled to receive deployments
for optional content.

Tip:  Clicking the Scheduled Deployments widget opens the Deployments and Tasks page, which is filtered
to display scheduled deployments.

The following table describes the Scheduled Deployments widget field.

Table 36: Scheduled Deployments Widget Field

Field Description

Endpoint with unresolved
updates

The total number of endpoints with unresolved updates.

The Server Information Widget
This widget lists your serial number, number of licenses available, number of licenses in use, and information
about current license usage and availability for Lumension Endpoint Management and Security Suite.

Figure 37: Server Information Widget

The following table describes the fields in the Server Information widget.

Table 37: Server Information Widget Fields

Field Name Description

Company The company Lumension Endpoint Management and Security Suite
(Lumension EMSS) is registered to as defined during installation.

Serial Number Lumension EMSS license number (serial number) assigned to your server.

License Replication The subscription status between Lumension EMSS and the Global
Subscription Server (GSS).
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Field Name Description

System Replication The system replication status between Lumension EMSS and the GSS.

Patch / Content Replication The replication status between Lumension EMSS and the GSS.

Package Replication The number of packages remaining for replication.

Auto-download New Critical
Packages

The indication of whether Lumension EMSS automatically downloads
packages for critical vulnerabilities. Clicking the link opens the
Subscription Service Configuration dialog.  For additional information
refer to Configuring the Service Tab on page 101.

The following table describes the Product Licenses table columns. A row appears for each purchased module.

Table 38: Product Licenses Table Columns

Column Description

Product Module The module for which you purchased licenses.

In Use The number of module licenses in use.

Pending The number of licenses pending use or pending removal. Licenses pending
removal become available upon removal completion.

Available The number of licenses available.

Note:  A license expiration notice displays if all available licenses are expired.
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The Time Since Last DAU Scan Widget
This widget displays all active agents (not including disabled or offline) grouped by the amount of time since
their last Discover Applicable Updates (DAU) task.

Figure 38: The Time Since Last Agent Scan Widget

The following table describes the fields in the Time Since Last Agent Scan widget.

Table 39: Time Since Last Agent Scan Widget Fields

Field Description

< 24 hours The number of agents that last performed a DAU task and checked in fewer than 24
hours ago.

24 - 47 hours The number of agents that last performed a DAU task and checked in 24 to 47 hours
ago.

48 - 72 hours The number of agents that last performed a DAU task and checked in 48 to 72 hours
ago.

> 72 hours The number of agents that performed a DAU task and last checked in greater than 72
hours ago.

Never checked in The number of agents that have registered yet have not completed a DAU task.

Total active agents The total number of active agents.

Tip:  Clicking the Time Since Last Agent Scan widget pie chart opens the Endpoints page, which is filtered
to display enabled devices.
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The Un-remediated Critical Vulnerabilities Widget
This widget displays the total number of unremediated critical vulnerabilities that are applicable to your
environment grouped by age.

Figure 39: Un-remediated Critical Vulnerabilities Widget

The following table describes the Un-remediated Critical Vulnerabilities widget graph bars.

Table 40: Un-remediated Critical Vulnerabilities Widget Graph

Graph Bar Description

<30 days The number of unremediated critical but not superseded vulnerabilities applicable to your
environment fewer than 30 days old.

30 - 120 days The number of unremediated critical but not superseded vulnerabilities applicable to your
environment that are 30 to 120 days old.

>120 days The number of unremediated critical but not superseded vulnerabilities applicable to your
environment greater than 120 days old.

Note:  Clicking the Unremediated Critical Vulnerabilities widget graph opens the Vulnerabilities page,
which is filtered to display critical but not superseded applicable vulnerabilities.

The following table describes the Un-remediated Critical Vulnerabilities widget fields.

Table 41: Un-remediated Critical Vulnerabilities Widget Fields

Field Description

Critical Vulnerabilities The number of critical but not superseded vulnerabilities applicable to your
environment.
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Field Description

Endpoints The number of managed endpoints with critical but not superseded applicable
vulnerabilities.

Dashboard Setting and Behavior Icons
Setting and behavior icons are UI controls used to manage the dashboard. Click these icons to maximize,
minimize, hide, and refresh the dashboard and widgets.

The following table describes each icon action.

Table 42: Widget Setting and Behavior Icons

Icon Action

Opens the Dashboard Settings dialog.

Opens the dashboard in print preview mode.

Collapses the associated widget.

Expands the associated collapsed widget.

Hides the associated widget.

Refreshes the associated widget (or the entire dashboard).

Note:  Not all widgets contain Refresh icons.

Previewing and Printing the Dashboard
When viewing the dashboard, you can reformat it for printing purposes. This print preview omits the Web site's
header and footer, reorganizing the dashboard to display only the selected widgets, making it ideal for printing.

View the print preview from the Home page.

1. Select Home from the navigation menu.

2. Click the Print icon.

Step Result: The dashboard print preview opens in a new Web browser window.

3. [Optional] Use your Web browser controls to print the dashboard.
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Editing the Dashboard
Lumension Endpoint Management and Security Suite lets you define how dashboard widgets are arranged and
prioritized. Edit the dashboard to display only the widgets that are most useful when managing your network
environment.

Edit the dashboard from the Dashboard Settings dialog.

1. From the navigation menu, select Home.

2. Click the Settings icon.

Step Result: The Dashboard Settings dialog opens.

Figure 40: Dashboard Settings Dialog

3. Choose which widgets you want to display on the dashboard.

• Select the check box associated with the applicable widget to display it.
• Clear the check box associated with the applicable widget to hide it.

4. Prioritize the widgets in the desired order.

• Click the applicable Increase Priority icon to increase a widget priority.
• Click the applicable Decrease Priority icon to decrease a widget priority.

Highly prioritized widgets appear in the dashboard upper-left corner, while lowly prioritized widgets appear
in the lower-right.

5. Display or hide widget descriptions.

• Click the Display Descriptions icon to display descriptions.
• Click the Hide Descriptions icon to hide description.
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6. Choose a widget layout.

• Click the Two Column icon to make widgets appear in two columns.
• Click the Three Column icon to make widgets appear in three columns.

7. Click OK.

The System Alert Pane
The System Alert pane is an expandable window that provides information about changing conditions on your
Lumension Endpoint Management and Security Suite server. The System Alert pane displays information about
required actions with links to related help topics to assist you with tasks.

The System Alert pane displays on the left side of the dashboard and shows the number of alerts that require your
attention. You can drag the right edge of the pane to resize the System Alert pane within the dashboard.

Figure 41: The System Alert Pane

The following functions can be found in the System Alert pane.

Table 43: Options Menu Items

Option Description

Pin

(icon)

Docks the System Alert pane open. Clicking this icon again will collapse
the System Alert pane.

Pagination Links Allows you to navigate between alerts. For more information, see
Advancing Through Pages on page 59.
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Option Description

Action Link Opens the appropriate application page, external Web page, or context-
sensitive help topic, depending on the action specified in the alert.

Don't show this again

(check box)

Collapses the System Alert pane. The alert shown in the System Alert pane
when this check box is selected will no longer be shown.

OK

(button)

Collapses the System Alert pane.

Note:  Dismissing a notification only dismisses the notification for the user you are currently logged in as. The
notification still displays for other users. Additionally, the system automatically dismisses alerts as you complete
their related actions, regardless of whether you manually dismiss those alert.

License Expiration
The Lumension Endpoint Management and Security Suite and its modules are licensed for a prepaid period.
When you purchase a module, you purchase a license for the module itself and the module function for a set
number of agents. After the license period expires, you must renew your licenses.
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The following table describes the different licensing expiration scenarios and the events that follow.

Note:  When a subscription expires, the applicable module history and configuration is retained so no work is
lost when the module is renewed.

Table 44: License Expiration Scenario and Events

Scenario Event(s)

Lumension EMSS Module
Expiration

• Functionality for all agent components for the module is partially
disabled (function disabled varies by module).

• Agent components for the module cannot be installed on agents that do
not already have the module installed.

• Module Installed statuses for affected endpoints change from Yes to
Expired on the Endpoints page.

• The Available license count for the module changes to 0 in the Server
Information widget.

Lumension EMSS Module
Agent Expiration

• Functionality for all agent components for the module (in the license
block) is partially disabled (functions disabled varies by module).

• The Patch and Remediation agent component continues to inventory
its host endpoint, but no longer enforces Patch and Remediation agent
policies or downloads deployments.

• Agent components for the module cannot be installed on agents that do
not already have the module installed.

• Module Installed statuses for affected endpoints change from
Installed to Expired on the Endpoints page.

• The Available license count for the module changes to 0 in the Server
Information widget.

To reactivate your licenses following renewal, select the Subscription Updates page and click Update Now. The
license verification process begins and connects to the Global Subscription Server, retrieving updated license
information. The page refreshes following update completion, and all previous module functionality is restored.

Note:  For more information about renewing or adding licenses, contact Lumension Sales Support
(sales@lumension.com).

mailto:sales@lumension.com
mailto:patchlink.sales@lumension.com
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Chapter

5
Configuring Default Behavior

In this chapter:

• The Subscription Updates Page

• Working with Subscription Updates

• The Email Notifications Page

• Working with Email Notifications

• The Options Page

• Working with Options

Use configuration options to define default behavior and administer
Lumension Endpoint Management and Security Suite. Configure and
manage the product using a variety of system Web pages.

The pages used to configure default behavior include:

• The Subscription Updates Page on page 91
• The Email Notifications Page on page 106
• The Options Page on page 116

The Subscription Updates Page
Periodically, the Lumension Endpoint Management and Security Suite (Lumension EMSS) server renews
license and system information via contact with the Global Subscription Server (GSS). If additional modules are
installed, subscription updates downloads additional, module-specific information. You can view or edit settings
related to this process from the Subscription Updates Page.

Figure 42: Subscription Updates Page

From this page, you can modify the subscription communication interval, initiate a replication, and configure the
subscription service. This page also displays the subscription service history, which lists previous replications.
These listings confirm successful communication between the Lumension EMSS server and the GSS.

Subscription updates retrieve the latest data for the following Lumension EMSS items:

Licenses Verifies the validity of your Lumension Endpoint Management and
Security Suite licenses.
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System Downloads new core system files, including operating system definitions
and agent upgrades.

Package Downloads the current packages based upon the patch content (or
packages) cached for deployment. If automatic critical package caching
is enabled, all critical packages are downloaded (Patch and Remediation
only).

Patch / Content Downloads the current patch content definitions according to: (Patch and
Remediation only)

• The subscription type and operating system subscriptions defined for
the account.

• The content languages selected within the Lumension EMSS console.
For additional information, refer to Configuring the Languages Tab on
page 104.

Patch / Components Downloads new Patch and Remediation module files (Patch and
Remediation only).

Viewing the Subscription Updates Page
Navigate to the Subscriptions Updates page to view the subscription update history or to edit subscription
settings.

You can access this page from the navigation menu.

1. Select Tools > Subscription Updates.

2. [Optional] Perform a task listed in Working with Subscription Updates on page 99.

Subscription Updates Page Toolbar
This toolbar controls the functions available from the Subscription Updates page. Click a toolbar button to
initiate subscription function.

The following table describes each button's function

Table 45: Subscription Updates Page Buttons

Button Function

Save Saves the edits made to the subscription updates. You must click the button
to implement your edits.

Update Now Replicates all license, system, and content changes since the last replication
with the Global Subscription Server (GSS). For additional information, refer
to Replicating on page 100.

Reset Resets the replication status. For additional information, refer to Resetting
the Replication Status on page 100.
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Button Function

Configure... Configures subscription communication settings between the Lumension
Endpoint Management and Security Suite server and the GSS. For additional
information, refer to The Subscription Service Configuration Dialog on page
95.

Launch Installation
Manager...

Opens the Lumension Installation Manager in a new window.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Subscription Service Information
These fields list information about the Global Subscription Server and its communication history with your
Lumension Endpoint Management and Security Suite (Lumension EMSS) server.

The following table describes the Subscription Service Information fields.

Table 46: Subscription Service Information

Field Description

Replication Host The name and port of the Global Subscription Server (GSS).

Replication Status The current replication status. Replication ensures that Lumension EMSS remains
current with the latest content, package, and license information.

Account ID Your account ID. The ID is passed to the GSS, which validates the update request.
The account ID is created by Lumension EMSS when it registers with the GSS.

Communication
Interval

(list)

The time Lumension EMSS connects to the GSS for replication. For additional
information, refer to Editing the Communication Interval on page 101.

Last Poll The date and time of the last successful contact with the GSS.

Note:  The Communication Interval field is the only field within Subscription Service Information that can
be edited. Click Save following Communication Interval edits to store your changes. Changes will take effect
following the next time the server communication with the Global Subscription Server.
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Subscription Service History
This table lists a record of subscription license replications and content replications. Additional details for each
replication are included.

The following reference describes the Subscription Service History table.

Table 47: Subscription Service History Table

Column Description

Type The type of replication task. The types include:

Licenses Verifies the validity of your Lumension Endpoint
Management and Security Suite licenses.

System Downloads new core system files, including operating
system definitions and agent upgrades.

Package Downloads the current packages based upon the
patch content (or packages) cached for deployment. If
automatic critical package caching is enabled, all critical
packages are downloaded (Patch and Remediation only).

Patch / Content Downloads the current patch content definitions
according to: (Patch and Remediation only)

• The subscription type and operating system
subscriptions defined for the account.

• The content languages selected within the Lumension
EMSS console. For additional information, refer to
Configuring the Languages Tab on page 104.

Patch / Components Downloads new Patch and Remediation module files
(Patch and Remediation only).

Status The status of the replication task. The statuses include:

Initializing Replication Replications are initializing.

Downloading Replications are downloading.

Completed Replications are complete.

Start Date The date and time the task started.

Stop Date The date and time the task completed.

Duration The duration of the task in minutes and seconds (2 minute[s], 0 seconds).

Successful The replication task completion status (True or False).
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The Subscription Service Configuration Dialog
This dialog is the interface used to configure subscription updates. Use this dialog to configure how your
Lumension Endpoint Management and Security Suite server contacts the Global Subscription Server.
Additionally, use this dialog to select the languages that content definitions are downloaded in.

The Subscription Service Configuration dialog contains the following tabs:

• The Service Tab on page 95
• The Languages Tab on page 98
• The Content Tab on page 99

Figure 43: Subscription Service Configuration Dialog

Viewing the Subscription Service Configuration Dialog
Navigate to this dialog to begin editing settings related to subscription services. Controls include proxy server
settings, system communication settings, and service restart. You can also select which languages you want
content for (Patch and Remediation only).

You can access this dialog from the Subscription Updates page.

1. Select Tools > Subscription Updates.

2. Click Configure.

Result: The Subscription Service Configuration dialog opens.

The Service Tab
Using this tab, you can customize communication settings between the Lumension Endpoint Management and
Security Suite (Lumension EMSS) server and the Global Subscription Server, as well as the log recorded during
transactions. Additionally, if your Lumension EMSS server uses a proxy server to access the Internet, you can
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define your proxy server information using this tab. Finally, you can use this tab to restart the subscription
service.

Figure 44: Service Tab

Status
The Status section lists whether the subscription service is running, as well as information about past and
pending communication with the Global Subscription Server (GSS). It also lets you restart the service. View this
section for useful information when troubleshooting communication issues between the Lumension Endpoint
Management and Security Suite server and the GSS.

The following table describes each Status field and control.

Table 48: Status Fields and Controls

Field or Control Description

Service Status

(Field)

The current status of the local subscription service’s communication with the GSS.

Last Checked

(Field)

The last date and time the local subscription service contacted the GSS.

Next Check

(Field)

The next scheduled date and time for the local subscription service to contact the GSS.

Restart

(Button)

Restarts the subscription service. For additional information, refer to Restarting the
Subscription Service on page 104.
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Package Caching
The Package Caching section lets you select whether Lumension Endpoint Management and Security Suite
automatically downloads the packages related to critical vulnerabilities. Caching packages makes them available
for immediate deployment. However, this option increases network traffic and decreases server disk space.

Table 49: Package Caching Option

Option Description

Automatically download
critical packages

(check box)

Indicates whether Lumension Endpoint Management and Security Suite
automatically downloads packages associated with critical vulnerabilities. For
additional information, refer to Configuring the Service Tab on page 101.

Proxy
When using a proxy for communication between the Lumension Endpoint Management and Security Suite
server and the Global Subscription Server, you must define the applicable proxy information within Lumension
Endpoint Management and Security Suite before communication can occur.

Define this proxy information from the Subscription Service Configuration dialog Service tab. The following
table describes each setting.

Table 50: Proxy Setting Descriptions

Setting Description

Address

(field)

The IP address or name of the proxy used for communication between Lumension
Endpoint Management and Security Suite Lumension EMSS) and the Global
Subscription Server (GSS).

Port

(field)

The proxy port used for communication between Lumension EMSS and the GSS.

Authenticated

(check box)

This check box enables the remaining fields when proxy authentication is required.

User Name

(field)

A user name that will authenticate with the proxy.

Password

(field)

The password associated with the user name.

Confirm Password

(field)

The password retyped.

Communication
When configuring subscription service communication, you can define multiple parameters regarding how your
Lumension Endpoint Management and Security Suite server communicates with the Global Subscription Server.
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Define communication options from the Subscription Service Configuration dialog Service tab. The following
table describes each communication option.

Table 51: Communication Option Descriptions

Option Description

Logging Level

(list)

Defines the level of detail in logs recorded during communication between the
Lumension Endpoint Management and Security Suite server and the Global
Subscription Server. The available values include:

Debug Logs errors, warnings, system actions, and
debugging information.

Note:  This logging level is the most
comprehensive logging level. It should only
be used for troubleshooting purposes due
to the large logging files it produces and
increased replication overhead it causes.

Information Logs errors, warnings, and system actions.

Warning Logs errors and warnings.

Error Logs only errors.

Enable Bandwidth
Throttling

(check box)

Limits the maximum data quantity during communication between the Lumension
Endpoint Management and Security Suite server and the Global Subscription
Server.

x Kbytes per second

(field)

Defines the maximum data quantity value when Enable Bandwidth Throttling is
selected (in Kbytes).

Retry Limit

(field)

The maximum number of times Lumension EMSS attempts to reestablish
communication with the GSS if the first attempt fails.

Retry Wait

(field)

The number of seconds between retries.

Connect Timeout

(field)

The number of seconds before a connection attempt is considered unsuccessful.

Command Timeout

(field)

The number of seconds of inactivity before a command is considered unsuccessful.

The Languages Tab
Lumension Endpoint Management and Security Suite offers content and content definitions in multiple
languages. From the Languages tab, you can define which languages that security content is offered in following
replication.
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Generally, you should only select the languages that suit your network environment.

Figure 45: Languages Tab

The Content Tab
Some content is downloaded directly from vendors' Web sites rather than the Global Subscription Server. To
download this content, your server must have access to applicable vendor Web sites. Thus, you must create
exceptions in your server's firewall for Lumension Endpoint Management and Security Suite (Lumension EMSS)
to access these sites. The Content tab lists whether Lumension EMSS can access these sites.

By downloading content directly from its source rather than from the Global Subscription Server, Lumension
EMSS expedites access to new content. Additionally, from the Content tab, you can export a list of external sites
that Lumension EMSS can access to download content.

Figure 46: Content Tab

Working with Subscription Updates
You can configure how the Lumension Endpoint Management and Security Suite server receives subscription
updates from the Global Subscription Server by using the Subscription Updates page.

• Replicating on page 100
• Resetting the Replication Status on page 100
• Editing the Communication Interval on page 101
• Configuring the Service Tab on page 101
• Restarting the Subscription Service on page 104
• Configuring the Languages Tab on page 104
• Exporting Content Data

• Exporting Subscription Update Data on page 105
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Replicating
Although the Lumension Endpoint Management and Security Suite regularly replicates with the Global
Subscription Server automatically, you can manually perform replication should you need updates before the
next scheduled automatic replication.

You can perform manual replications from the Subscriptions Updates page.

1. Select Tools > Subscription Updates.

2. Click Update Now.

Step Result: A notification dialog opens.

Note:  In network environments with the Lumension AntiVirus module installed, the
notification dialog contains selectable options (System and License Replication and Virus
Engine and Definition Update). In this scenario, select the desired options before proceeding
to the next step.

3. Acknowledge the replication by clicking OK.

Result: Replication begins immediately. All license and content changes since the last replication are retrieved
from the Global Subscription Server. This process may take several minutes, and no Discover
Applicable Update tasks will run during the process.

Resetting the Replication Status
Resetting the replication status forces the Lumension Endpoint Management and Security Suite server to re-
download (or update) the licenses, packages, and content.

Reset the replication status from the Subscription Updates page.

1. Select Tools > Subscription Updates.

2. Click Reset.

Step Result: The Reset Replication dialog opens.

3. Click Reset.

Step Result: The Reset Replication dialog opens.
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4. Select a replication option.

Select from the following options based upon the applicable context.

Note:  The options available in the Reset Replication dialog change based on whether the Auto-download
new critical packages option is selected. For additional information, refer to Package Caching on page
97.

Context Options

If the Auto-download new
critical packages option is
selected

Select from the following options:

• Cache metadata and critical packages for only new and changed
content.

• Cache metadata and critical packages for all historical content.

If the Auto-download new
critical packages option is
cleared

Select from the following options:

• Cache both metadata and critical packages.
• Only cache metadata.

5. Define when you want to begin replication.

Click the applicable button.

• To begin replication immediately, click Update Now.
• To being replication at the next scheduled interval, click Update Later.

Editing the Communication Interval
Edit the communication interval to control when the Lumension Endpoint Management and Security Suite server
downloads content and license data from the Global Subscription Server.

Edit the communication interval from the Subscription Updates page.

1. Select Tools > Subscription Updates.

Step Result: The Subscription Updates page opens.

2. Select a time from the Communication Interval list located in the Subscription Service Information area.

This list includes a value for every half-hour.

3. Click Save.

Result: The selected communication interval is saved. Your Lumension Endpoint Management and Security
Suite server will replicate with the Global Subscription Server at the selected time.

Configuring the Service Tab
Configuring the Service tab defines communication, proxy, and log settings pertaining to the Lumension
Endpoint Management and Security Suite server and Global Subscription Server communication.
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Configure the Service tab from the Subscription Service Configuration dialog. Access this dialog from the
Subscription Updates page.

1. Select Tools > Subscription Updates.

2. Click Configure.

Step Result: The Subscription Service Configuration dialog opens.

3. Ensure the Service tab is selected.

4. Define the Status options.

This section lists whether the subscription service is running and past and pending communication with the
GSS. It also allows you to restart the service.

a) View or select the Status options.

Table 52: Status Options

Option Description

Service Status The current status of the local subscription service's communication with the
Global Subscription Server (GSS).

Last Checked The last date and time the subscription service contacted the GSS.

Next Check The next scheduled date an time for the local subscription service to contact
the GSS.

Restart Restarts the subscription service. For additional information, refer to
Restarting the Subscription Service on page 104.

b) To automatically download packages associated with content items with a status of critical, select the
Auto-download new critical packages check box .

5. Define Proxy options.

These options define the proxy information used for communication between Lumension Endpoint
Management and Security Suite (Lumension EMSS and the Global Subscription Server (GSS.

a) Type the applicable information in the following fields.

Table 53: Proxy Options

Field Description

Address The IP address or name of the proxy used for communication between
Lumension EMSS and the GSS.

Port The proxy port used for communication between Lumension EMSS and the
GSS.
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b) If your network uses a proxy server for communication between Lumension EMSS and the GSS, select
the Authenticated check box and type the applicable information in the following fields.

Table 54: Proxy Options: Authenticated

Field Description

User Name A user name that will authenticate with the proxy.

Password The password associated with the user name.

Confirm Password The password retyped.

6. Define Communication options.

These options define parameters regarding how your Lumension EMSS server communicates with the GSS.

a) From the Logging Level select from the following options.

Table 55: Logging Level Options

Option Description

Debug Logs errors, warnings, system actions, and debugging information.

Note:  This logging level is the most comprehensive logging level. It should
only be used for troubleshooting purposes due to the large logging files it
produces and increased replication overhead it causes.

Information Logs errors, warnings, and system actions.

Warning Logs errors and warnings.

Error Log only errors.

b) To limit the maximum data quantity during communication between Lumension EMSS and the GSS,
select the Enable Bandwidth Throttling check box.

c) Type the maximum number of kilobytes permitted per second in the X Kbytes per second field.
d) [Optional] Edit the following fields.

Table 56: Communication Option Fields

Option Description

Retry Limit The maximum number of times Lumension EMSS attempts to reestablish
communication with the GSS if the first attempt fails.

Retry Wait The number of seconds between retries.

Connect Timeout The number of seconds before a connection attempt is considered
unsuccessful.
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Option Description

Command Timeout The number of seconds of inactivity before a command is considered
unsuccessful.

Note:  Under most network conditions, these fields do not require editing.

7. Apply option changes.

a) Click Apply.

Step Result: The Configuration Settings dialog opens confirming your changes have been saved.

b) Click OK.

Step Result: Closes the Configuration Settings dialog.

8. Click Save.

Step Result: The Subscription Service Configuration dialog closes.

Result: Your edits are saved. These edits will take effect the next time Lumension EMSS communicates with
the GSS.

Restarting the Subscription Service
If the subscription service is stopped or needs restarting, it can be restarted within the Lumension Endpoint
Management and Security Suite Web console.

You can restart the subscription service from the Subscription Service Configuration dialog Service tab.

1. Select Tools > Subscription Updates.

2. Click Configure.

Step Result: The Subscription Service Configuration dialog opens.

3. Ensure the Service tab is selected.

4. Click Restart.

5. Acknowledge the notification by clicking OK.

Result: The subscription service is restarted on the Lumension Endpoint Management and Security Suite
server.

Configuring the Languages Tab
Selecting language options will increase the offerings listed on content pages. For each language you select, a
content item will be available in that language. However, some content items may not exist in certain languages.
Selecting multiple languages will increase replication times. These options do not control user interface
language.
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Select language options from the Subscription Server Configuration dialog Languages tab. Access this dialog
from the Subscription Updates page.

1. Select Tools > Subscription Updates.

2. Click Configure.

Step Result: The Subscription Service Configuration dialog opens.

3. Select the Languages tab.

4. Select the check boxes associated with the languages you want content items to replicate in. Clear the check
boxes associated with the languages you want to omit.

Note:  Selecting multiple languages configures Lumension Endpoint Management and Security Suite to
replicate numerous versions of a content item, slowing subscription update times. Additionally, the English
check box cannot be cleared.

5. Save your edits.

Use one of the following methods.

Method Steps

If editing only the Languages
tab:

Click Save.

If editing other tabs: Click Apply.

Result: Your edits are saved. During the next subscription update, only content in the selected languages is
replicated.

Exporting Enhanced Content Data
While viewing the Content tab, you can export the listed content URLs to a comma separated value (.csv) file.

To export the listed URLs, select Tools > Subscription Updates and click Configure. Then select the Content
tab and click Export. For additional information refer to Exporting Data on page 60.

Exporting Subscription Update Data
You can export data displayed on the Subscription Updates page to a comma separated value (.csv) file for
reporting and analytical purposes.

Both Subscription Service Information and Subscription Service History are exported. To export this data,
select Tools > Subscription Updates and click the Export button. For additional information refer to Exporting
Data on page 60.
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The Email Notifications Page
You can configure Lumension Endpoint Management and Security Suite to send email notifications when certain
system events occur. Configure email notifications from the Email Notifications page. Configuring Lumension
Endpoint Management and Security Suite to send you email notifications alerts you to system features that
require administration.

You can configure email notification settings, define alert types, and set alert settings. Enter the email addresses
that you want to receive notifications, and then select the alert types that you want each email address to receive.
You can enter an unlimited number of email addresses. Also use this page to define alert thresholds, which are
data values that initiate email notifications.

Figure 47: Email Notifications Page

Viewing the Email Notifications Page
Navigate to Email Notification to define email addresses for notification alerts.

You can access this page at any time from the navigation menu.

1. Select Tools > Email Notifications.

2. View the email notifications.

Email Notification Page Buttons
These buttons let you use functions available on the Email Notification page.

The following table describes each button function.

Table 57: Email Notification Page Buttons

Button Function

Create... Creates a new email notification entry in Email Notifications. For additional information, refer to
Creating Email Notification Addresses on page 113.
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Button Function

Save Saves the changes made in Email Notifications. For additional information, refer to the following
topics:

• Creating Email Notification Addresses on page 113
• Editing Email Notification Addresses on page 114

Delete Deletes the selected entry from Email Notifications. For additional information, refer to Deleting
Email Notification Addresses on page 115.

Test Sends a test email message to the selected email address(es). For additional information, refer to
Testing Email Notifications on page 116.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

The Email Notifications Table
This table lists the email addresses that receive system alerts. You can also use this table to define a limitless
number of addresses. The alert types sent to each email address can be customized.

The following table describes Email Notifications.

Table 58: E-Mail Notification Table

Column Description

New Vulnerabilities

(Patch and Remediation only)

Alerts when a new content item becomes available for deployment.

New Agent Version Alerts when a new version of the Lumension Endpoint Management and
Security Suite (Lumension EMSS) agent becomes available for installation.

New Agent Registrations Alerts when an agent registers with Lumension EMSS.

Subscription Failure Alerts when any subscription task (download) fails.

Deployment Failure

(Patch and Remediation only)

Alerts when a deployment fails.

Low System Disk Space Alerts when the available system drive space on the Lumension EMSS
Server falls below the defined minimum.

Low Storage Disk Space Alerts when the available storage space on the drive where content is stored
falls below the defined minimum.
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Column Description

Low Available License Count Alerts when the number of licenses available to the Lumension EMSS falls
below the defined minimum.

Upcoming License Expiration Alerts when licenses will expire within the defined time frame.

License Expiration Alerts when a license expires.

Failed to Clean, Quarantine,
Delete Virus/Malware

(AntiVirus only)

Alerts when AntiVirus fails to clean, quarantine, or delete a detected virus or
malware.

Virus/Malware Detected

(AntiVirus only)

Alerts when a virus or malware has been detected on a network endpoint.

Antivirus Alert Summary

(AntiVirus only)

Alerts when an AntiVirus alert summary has been completed.

Notification Address Lists the email address that receives alert notifications. Lumension EMSS
does not validate the address.

Note:  Option check boxes only appear in Email notifications after you create an email notifications entry.

For additional information about creating email notifications, refer to Working with Email Notifications on page
111.

Alert Settings
Alert settings are user-defined values that trigger notification emails. These values are defined from the Alert
Settings options. Edit these values to suit your network environment. Settings are available for system disk
space, storage disk space, and license information.

The following table describes the Alert Settings options.

Table 59: Alert Settings Options

Option Definition

Outgoing Mail Server
(SMTP)

(Field)

The mail host used by Lumension Endpoint Management and Security Suite
(Lumension EMSS) for sending email messages.

Note:  The Outgoing Mail Server (SMTP) is not an alert value setting.
However, completion of this field with your network's valid SMTP server
is required for addresses listed in the Email Notifications table to receive
alerts.
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Option Definition

Low System Disk Space Defines the threshold that initiates email notifications due to low system disk
space. Define the following options:

Alert When Below x MB (field) Defines the level of system disk space
that Lumension EMSS must drop below
before an alert is generated (1-9,999
MBs [9.765 GB]).

Check Disk Every x Interval
(field and list)

Defines the interval between Low
System Disk Space threshold checks.
This interval is defined in minutes,
hours, or days (1-99).

Low Storage Disk Space Defines the threshold that initiates email notifications due to low storage disk
space. Define the following options:

Alert When Below x MB (field) Defines the level of storage disk space
that Lumension EMSS must drop below
before an alert is generated (1-9,999
MBs [9.765 GB]).

Check Disk Every x Interval
(field and list)

Defines the interval between Low
Storage Disk Space threshold checks.
This interval is defined in minutes,
hours, or days (1-99).

Low Available License Count Defines the threshold that initiates email notifications due to low available
license count. Define the following option:

Alert for any Module That Falls
Below x Licenses (field)

Defines the number of available
licenses that Lumension EMSS must
drop below before an alert is generated
(1-999).

While License Count Remains
Low, Send a Reminder E-mail
Every x Days (check box and
field)

Defines if an alert is sent and the
interval in days (1-99).
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Option Definition

Upcoming License Expiration Defines the threshold that initiates email notifications due to upcoming
license expiration. Define the following option:

Alert for any License That Will
Expire Within x Days (field)

Defines the number of days before
an alert is generated due to upcoming
license expiration (1-99).

While Licenses Aren't Renewed
After This Alert, Send a
Reminder E-mail Every x Days
(check box and field)

Defines if an alert is sent and the
interval in days (1-99).

Virus/Malware Detected

(AntiVirus only)

Defines the threshold that initiates email notifications due to virus/malware
detection. Define the following options:

Notify When at Least x
Instances of Virus/Malware are
Detected Across All Endpoints
(field)

Defines the number of virus/malware
instances that must be detected before
an email is generated. The default is
100 instances.

Notify When Affecting at Least
x Endpoints (field)

Defines the number of endpoints that
must be affected with viruses/malware
before an email is generated. The
default is 20 endpoints.

Within a Period of x Interval
(field)

Defines the time period in which
viruses/malware are detected before
an email is generated. The default is 4
hours.

Send This Email Notification
at Most Once Every x Interval
(field)

Defines the time period over which
Lumension Endpoint Management and
Security Suite generates one email. The
default is at most once every 8 hours.
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Option Definition

Antivirus Alert Summary

(AntiVirus only)

Defines the threshold that initiates email notifications of AntiVirus alert
summaries. The default is once a day at 9:00 AM (server time).

Select one of the following options:

Send Status Email Once a Day
at Time (field)

Selection of this option sends alerts that
summarize your network's antivirus
status once a day at the selected time.

Send Status Email Once a Week
on Day at Time (list and field)

Selection of this option sends alerts that
summarize your network's antivirus
status once a week on a selected day
and time.

Thresholds define the value that initiate email notifications, but not email notifications themselves. Email
notifications are sent following Discover Applicable Updates (DAU) tasks that find values below the defined
thresholds.

For additional information on defining alert thresholds, refer to Defining Alert Settings on page 111.

RSS Feed
A Real Simple Syndication (RSS)  feed is a notification method to start the import and export process. You can
receive additional security notifications via a Lumension RSS feed.

Use an RSS reader to receive notifications to start the import and export process by subscribing to the following
Lumension feed: http://gssnews.lumension.com/news/default.aspx?oem=Lumension.

Note:  The RSS feed transmits Global Subscription Server notifications. It is not a method of receiving system-
specific notifications (such as email notifications).

Working with Email Notifications
From the Email Notifications page, you can define the email addresses that receive notifications. You can also
define the events and values that trigger notification emails.

• Defining Alert Settings on page 111
• Creating Email Notification Addresses on page 113
• Editing Email Notification Addresses on page 114
• Deleting Email Notification Addresses on page 115
• Testing Email Notifications on page 116

Defining Alert Settings
Alert settings are values that trigger the Lumension Endpoint Management and Security Suite server to send
email notifications. Define these values for preventive maintenance purposes.

http://gssnews.lumension.com/news/default.aspx?oem=Lumension
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Define alert settings from the Email Notifications page.

1. Select Tools > Email Notifications.

2. In the Outgoing Mail Server (SMTP), type (or edit) the name of your outgoing mail server.

Type the name in the following format: mail.company.com.

Note:  The outgoing mail server is not an alert setting value, but is necessary to define email notification
addresses.

3. Define the Low System Disk Space options.

This alert setting defines when email notifications are sent due to low system disk space.

a) Type a value in the Alert When Below x MB field (1-9999).
b) Type a value in the Check Disk Space Every x Interval field (1-99).
c) Select an interval from the Check Disk Space Every x Interval list (Minute(s), Hours, Days).

4. Define the Low Storage Disk Space options.

This alert setting defines when email notifications are sent due to low storage disk space.

a) Type a value in the Alert When Below x MB field (1-9999).
b) Type a value in the Check Disk Space Every x Interval field (1-99).
c) Select an interval from the Check Disk Space Every x Interval list (Minute(s), Hours, Days).

5. Define the Low Available License Count options.

This alert setting defines the number of available licenses that Lumension Endpoint Management and
Security Suite must drop below before an email notification is generated.

a) Type a value in the Alert for any Module That Falls x Licenses field. (1-9999).
b) If applicable, select the check box and type a value in the While License Count Remains Low, Send a

Reminder Email Every x Interval field (1-99).

6. Define the Upcoming License Expiration options.

This alert setting defines the number of days before an email notification is generated to upcoming license
expiration.

a) Type a value in the Alert for any Licenses That Will Fall Within x Days field (1-99).
b) If applicable, select the check box and type a value in the While Licenses Aren't Renewed After This

Alert, Send a Reminder Email Every x Interval field. (1-99).

7. Click Save.

Result: Your alert setting values are saved.
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Creating Email Notification Addresses
You can configure Lumension Endpoint Management and Security Suite (Lumension EMSS) to send emails to
defined email addresses when certain system events occur. Define email notification recipients for preventative
maintenance and administrative purposes.

Prerequisites:

Complete Defining Alert Settings on page 111.

Define email notification recipients from the Email Notifications page.

1. Select Tools > Email Notifications.

2. Click Create.

Step Result: A new row displays in the Email Notifications table.

3. Type an email address in the Notification Address field of the new row.

Note:  Lumension EMSS does not validate email addresses.

4. Select the check boxes associated with the email notifications that you want the email address to receive.

The following table describes each email notification.

Notification Description

New Vulnerabilities

(Patch and Remediation only)

Alerts when a new content item becomes available for deployment.

New Agent Version Alerts when a new version of the agent becomes available for
installation.

Agent Registrations Alerts when an agent registers with the Lumension EMSS server.

Subscription Failure Alerts when any subscription task (download) fails.

Deployment Failure

(Patch and Remediation only)

Alerts when a deployment fails.

Low System Disk Space Alerts when the available system drive space on the Lumension EMSS
server falls below the defined minimum.

Low Storage Disk Space Alerts when the available storage space on the drive where content is
stored falls below the defined minimum.

Low Available License Count Alerts when the number of licenses available to Lumension EMSS fall
below the defined minimum.

Upcoming License Expiration Alerts when licenses will expire within the defined time frame.
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Notification Description

Failed to Clean, Quarantine,
Delete Virus/Malware

(AntiVirus only)

Alerts when AntiVirus fails to clean, quarantine, or delete detected
viruses or malware.

Virus/Malware Detected

(AntiVirus only)

Alerts when viruses or malware are detected.

Antivirus Alert Summary

(AntiVirus only)

Alerts when an AntiVirus status summary is completed.

License Expiration Alerts when a license expires.

5. Click Save.

Result: The email notification address and the selected notifications are saved. The address will receive a
notification when the applicable system events occur.

Editing Email Notification Addresses
After an email notification address is created, you can edit the email address itself, or you can change notification
types it receives.

Edit email notification addresses from the Email Notifications page.

1. Select Tools > Email Notifications.

Step Result: The Email Notifications page opens.

2. From the Notification Address column, edit the desired email address field(s).

3. Select or clear the desired notification type check boxes.

The following table describes each notification type.

Notification Description

New Vulnerabilities

(Patch and Remediation only)

Alerts when a new content item becomes available for deployment.

New Agent Version Alerts when a new version of the agent becomes available for
installation.

Agent Registrations Alerts when an agent registers with the Lumension EMSS server.

Subscription Failure Alerts when any subscription task (download) fails.

Deployment Failure

(Patch and Remediation only)

Alerts when a deployment fails.



Configuring Default Behavior

- 115 -

Notification Description

Low System Disk Space Alerts when the available system drive space on the Lumension EMSS
server falls below the defined minimum.

Low Storage Disk Space Alerts when the available storage space on the drive where content is
stored falls below the defined minimum.

Low Available License Count Alerts when the number of licenses available to Lumension EMSS fall
below the defined minimum.

Upcoming License Expiration Alerts when licenses will expire within the defined time frame.

Failed to Clean, Quarantine,
Delete Virus/Malware

(AntiVirus only)

Alerts when AntiVirus fails to clean, quarantine, or delete detected
viruses or malware.

Virus/Malware Detected

(AntiVirus only)

Alerts when viruses or malware are detected.

Antivirus Alert Summary

(AntiVirus only)

Alerts when an AntiVirus status summary is completed.

License Expiration Alerts when a license expires.

4. Click Save.

Deleting Email Notification Addresses
Delete email notification addresses that no longer need notification of Lumension Endpoint Management and
Security Suite events.

Delete email notification recipients from the Email Notifications page.

1. Select Tools > Email Notifications.

Step Result: The Email Notifications page opens.

2. Select the check box(es) associated with the notification address(es) that you want to delete.

3. Click Delete.

Step Result: The Message from webpage opens indicating the selected recipients have been removed.

4. Click OK.

Result: The notification address is deleted. The address will no longer receive notification emails.

Exporting Email Notification Data
You can export email notification data to a comma separated value (.csv) file for reporting and analytical
purposes.
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All data on the page is exported. To export email notification data, select Tools > Email Notifications and click
Export. For additional information, refer to Exporting Data on page 60.

Testing Email Notifications
Testing email notifications ensures that defined email addresses and Lumension Endpoint Management and
Security Suite are properly configured for alerts. If a test fails, you should first verify that the email address is
typed correctly in the Email Notifications table. If it is, you should then examine email and Lumension Endpoint
Management and Security Suite settings.

Prerequisites:

An email address must be added to the Email Notifications table.

Test email notifications from the Email Notifications page.

1. Select Tools > Email Notifications.

2. From Email Notifications, select the check box(es) associated with the email address(es) you want to test.

3. Click Test.

Result: A notification informs you that the test email was sent. Acknowledge the notification by clicking OK.
Access the applicable email address to ensure the notification was successful.

The Options Page
Within Lumension Endpoint Management and Security Suite, you can control a number of default settings
from the Options page: user interface options, agent options, and so on. While most of these options can be
edited when using product functions, configuring default settings saves time and effort when using these product
functions.
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The Options page contains the following tabs, which contain options related to their labels:

• The General Tab on page 118
• The Agents Tab on page 122
• The Deployments Tab on page 128

Figure 48: Options Page

The Options Page Buttons
The Options page contains several buttons that are common to each of its tabs. These buttons share similar
functions to buttons commonly seen on page toolbars.

The following table describes the Option page button functions.

Button Function

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Reset Cancels any edits made to the options since the tab was loaded.

Save Saves the tab option settings (if any edits were made). You must click this button to implement
your edits.

Viewing the Options Page
Navigating to the Options page lets you view and edit default values for various options, which save you time
when using product features.

You can reach this page at any time from the navigation menu.

1. Select Tools > Options.
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2. Select the desired tab:

• The General tab
• The Agents tab
• The Deployments tab

3. [Optional] Complete a task listed in Working with Options on page 130.

The General Tab
Default settings for user interface options, password options, and report and display options are controlled from
the General tab. The options available on this page are generalized and are not closely related.

Figure 49: General Tab

UI Options
With these options, you can control user interface features according to your preferences.

Select from lists and check boxes to configure UI options.

The following table describes the available options.

Table 60: UI Options

Option Description

Default number of
rows per page

(list)

Defines the default number of rows that display in list pages (25, 50, 100, 200, 500).

Cache timeout

(list)

Defines the maximum number of minutes data is held in the memory before it needs
to be reloaded from the database (5, 10, 15, 20, 30).

Session timeout

(list)

Defines the number of minutes before a repeat login is required due to inactivity (20,
40, 60, 80, 100, 120).
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Option Description

Activate automatic
IP grouping in the
Groups view

(checkbox)

Creates groups organized by IP address in the Groups page Group Browser named
IP Collection.

Compliance &
Reporting URL

(field)

Modifies the link in the product header.

Password Options
The single Password option lets you configure Lumension Endpoint Management and Security Suite to display
a notification warning you of upcoming password expirations. If your user account does not have a password
expiration, this setting is disregarded. When this option is enabled, a password expiration warning displays when
you log in to the Web console.

Complete the field to configure the options.

The following table describes the available Password option.

Table 61: Password Options

Option Description

Display notification x days prior
to password expiration.

(field)

Defines the number of days prior to a required password change (as
controlled by Windows) that a notification displays. A value of 0 disables
the notification.

Discovery and Agent Management Job Logging
During discovery or agent management job, a log of job events is recorded to the Lumension Endpoint
Management and Security Suite server. The Discovery and Agent Management Job Logging options lets you
configure the information that is logged during job activity.
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The following table describes each Discover and Agent Management Job Logging option.

Table 62: Discovery and Agent Management Job Logging Options

Option Description

Logging Level

(Slider)

Defines the information recorded in the job during
discovery scan jobs and agent management jobs.
Values include:

• Trace
• Diagnostic
• Information
• Warning
• Error
• Critical

Include common troubleshooting information for

(Check Boxes)

Defines whether the log include common
troubleshooting information for a given part of a job.
Options include:

• Agent Management
• Discover
• SOAP

Note:  By the default, discovery and agent management job logs are written to <Installation Directory>
\Lumension\EMSS\Web\Services\ScanEngine\Engine\engine.log on the Lumension Endpoint
Management and Security Suite server.

Report and Display Options
These options control date, time, and paper formatting for reports generated in Lumension Endpoint Management
and Security Suite. Modify date and time settings according to how your enterprise formats date and time.
Modify paper settings according the paper types your enterprises uses for printing.

Note:  These options apply only to reports in a PDF format.

Select from the lists to configure the options.
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The following table describes the available Report and display options.

Table 63: Report and Display Options

Option Description

Date Format

(list)

Defines the date format displayed in text-based and graphical reports. Select
from the following options:

• Default (mm/dd/yyyy)
• MM/dd/yyyy
• dd/MM/yyyy
• yyyy-MM-dd
• dd.MM.yyyy
• dd-MM-yyyy
• yyyy/MM/dd

Time Separator

(lists)

Defines the character used to separate hours, minutes, and seconds in
reports. Select from the following options:

• Default (the current character in use)
• Colon (:)
• Period (.)

This option also defines the time notation used in reports. Select from the
following options:

• 12 Hour
• 24 Hour

Time Format

(field)

Displays the selected Date Format punctuated by the selected Time
Separator. This field refreshes as you select different Report and display
options.

Paper Size for Reports

(list)

Defines how reports are formatted for printing. Select from the following
options:

• Default (the currently saved formatting style)
• Letter
• A4
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The Agents Tab
This tab controls aspects related to agent management jobs and agent-to-server communication. Editing options
related to agent management jobs sets default values for agent management jobs.

Figure 50: Agents Tab

Agent Installation
These options define default installation values for agent management jobs. When configuring agent
management jobs, these settings can be changed. Adjusting these settings to frequently used values can save
effort during agent management job configuration.

Use Agent Installation options to define the default settings for the Agent Settings page in the Schedule Agent
Management Job Wizard. Complete the field and select from the lists to define the options.

Table 64: Agent Installation Options

Agent Installation Option Description

Timeout

(drop-down list)

Defines the default number of minutes before an agent installation job
terminates due to non-responsive status (0-30).

Number of retries

(drop-down list)

Defines the default number of attempts an agent installation will retry if
initial and subsequent installations fails (1-10).

Number of simultaneous
installs

(drop-down list)

Defines the default maximum number of agents that can be installed or un-
installed simultaneously during an agent management job (1-25). A setting
of 1 indicates that serial install/uninstalls should occur.
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Agent Installation Option Description

Server identity

(field)

Defines the default text entered in the Server Identity field during agent
installation jobs. Server Identity is the name agents list as their Lumension
Endpoint Management and Security Suite server.

Scan method for pre-selected
targets

(radio buttons)

Defines how endpoints pre-selected from a page list are added to a job's
targets list (discovery scan or agent management) after launching a job
configuration dialog. The options are:

IP Address Adds the selected endpoint to a job's
target list using its IP address.

Computer Name Adds the selected endpoint to a job's
target list using its endpoint name.

Communication
These options define how Lumension Endpoint Management and Security Suite recognizes the agent. Modifying
the Agents should be shown offline when inactive for option changes the time duration before Lumension
Endpoint Management and Security Suite considers an agent offline. Modifying the Stand alone Patch agent
uniqueness based on option changes how the server validates agents during communication.

Complete the fields, select from the list, and select a radio button to configure the options.

The following table describes Communication options.

Table 65: Communication Options

Option Description

Agents should be shown
offline when inactive for

(field and list)

Defines the time period (in minutes, hours, or days) before an agent is considered
offline because it has not checked in with Lumension EMSS. Disabled and un-
installed agents are not considered offline. A value of 0 disables this option.
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Option Description

Stand alone Patch agent
uniqueness based on

(radio buttons)

Defines how the server identifies patch agents during communication (Patch and
Remediation only). The options are:

Endpoint name Configures the server to identify agents
using the NetBIOS name of the endpoint.
Select this option in environments that do
not contain multiple instances of a single
NetBIOS name, as it reduces administrative
maintenance in the event that an endpoint
needs to be re-imaged. This option is
selected by default.

Instance Configures the server to identify agents
using a unique number. Select this option in
larger network environments where multiple
instances of a single NetBIOS exist. This
option prevents communication errors that
may occur if multiple agents share a single
NetBIOS name.

Discover Applicable Updates (DAU) Options
To determine what content is applicable to the host endpoint, an agent runs a Discover Applicable Updates
(DAU) task. Selecting different DAU options determines when this task launches. An increased number of DAU
tasks hastens endpoint vulnerability discovery, but increases network traffic.

Select or clear the check boxes to define the options.

The following table describes the Discover Applicable Updates (DAU) Options.

Table 66: Discover Applicable Updates Options

Option Description

DAU should be run after
subscription replication

(check box)

Determines whether registered agents perform a DAU task following a
subscription replication.

DAU should be run after
inventory change

(check box)

Determines whether registered agents perform a DAU task after detecting a change
in its host endpoint's inventory.

Absentee Agent Deletion
Sporadically, a Lumension Endpoint Management and Security Suite Agent will cease communication with
the Lumension Endpoint Management and Security Suite server. By defining the Absentee Agent Deletion
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option, you are configuring Lumension Endpoint Management and Security Suite to automatically delete
uncommunicative agents.

Complete the field to configure the option.

The following table describes the Absentee Agent Deletion option.

Table 67: Absentee Agent Deletion Option

Option Description

Delete absentee agent after x
days.

Removes an uncommunicative agent after the defined time period (days). A
value of 0 disables this function.

ISAPI Communication
Using these options, you can limit connections between the Lumension Endpoint Management and Security Suite
Agents and the server. Setting communication limits between the two Lumension Endpoint Management and
Security Suite components ensures they do not overuse your network's bandwidth.

Lumension EMSS) supports the Internet server application programming interface (ISAPI) communication
settings for Internet Information Services (IIS). Configure the options by selecting options and completing the
fields.

The following table describes each option.

Table 68: ISAPI Communication Options

Option Description

Concurrent agent limit

(radio buttons and field)

Defines the maximum number of threads used by Lumension EMSS.
Select from the following options:

SQL default (64 threads) Enables the default thread count for a
SQL Server implementation.

Custom setting (5 to 256
threads)

Enables a custom thread count
(5-256).

Connection timeout

(radio buttons and field)

Defines the time (in seconds) before an ISAPI thread expires (times out).
Select from the following options:

Default (30 seconds) Sets the connection timeout to the
default value.

Custom setting (5 to 300
seconds)

Sets the connection timeout to a
custom value (5- 300 seconds).
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Option Description

Command timeout

(radio buttons and field)

Defines the time (in seconds) before an ISAPI command expires (times
out). Select from the following options:

Default (60 seconds) Sets the command timeout to the
default value.

Custom setting (5 to 900
seconds)

Sets the command timeout to a
custom value (5-900 seconds).

Agent Versions
The Lumension Endpoint Management and Security Suite agent comes in multiple versions across multiple
platforms. By defining Agent Version options, you can restrict which versions are available to install, upgrade,
or overwrite. You can restrict available versions for each platform. These options are useful for maintaining
agent uniformity across your network.

To define the options, select from the lists.

The following table describes each Agent Version option.

Table 69: Agent Version Options

Option Description

Windows XP and newer agent
version

(list)

Defines which agent versions are available for installation on endpoints
running Windows XP or a newer Windows-based operating system when
working with the following system dialogs:

• The Manage Agent Versions Dialog
• The Download Agent Installers Dialog
• The Install Agents Wizard

Linux, Unix, & Mac agent
version

(list)

Defines which agent versions are available for installation on endpoints
running Unix-based operating systems when working with the following
system dialogs (Patch and Remediation only):

• The Manage Agent Versions Dialog
• The Download Agent Installers Dialog
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Option Description

When selecting agent version options, remember the following information:

• Newest Available means only the latest agent version is available for installation.

Note:  This option only defines which agent version is available when working with the Manage
Agent Versions dialog, the Download Agent Installers dialog, or the Install Agents Wizard. It does not
automatically install newly released agent versions on network endpoints. To ensure the newest agent
version in stalled on network endpoints, you must manually define the latest version. For additional
information, refer to Defining the Endpoint Agent Version on page 165.

• Agent Version only list items mean only that agent version is available for installation.
• Agent Version + list items mean that agent version and all version that supersede it are available for

installation.

The Agent Version Detail Dialog
This dialog describes the various agent versions. It also lists system requirements, applicable notes, and recent
changes.

Figure 51: Agent Version Detail Dialog

To access this dialog, click the What is different about each version? link on the Agents tab.

The following table describes each field in the Agent Version Detail dialog.

Field Description

Agent Version The agent name and version number.

Description A description of the applicable agent. This field also lists the components that are
installed with the agent.
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Field Description

Operating Systems The operating systems that are supported by the applicable agent.

System Requirements The system requirements to install the agent on a target endpoint.

Installation Notes The information notes pertaining to installation of the agent.

Changes The changes made to the applicable agent since its previous release.

The Deployments Tab
Deploying content is a key feature of Lumension Endpoint Management and Security Suite. The Deployments
tab lets you control basic deployment options.

Use this tab to define and edit options related to deployments, which include Deployment defaults and
Notification defaults.

Figure 52: Deployments Tab

Deployment Defaults
These options let you define how many agents within your network can perform actions simultaneously.
Defining higher values lets you perform more deployment-related actions simultaneously. However, multiple
agents performing actions simultaneously may strain network resources.

Complete the fields to configure the options.

The following table describes the Deployment defaults options.

Table 70: Deployment Default Options

Option Description

Maximum number of deployments that can run
simultaneously

(field)

The maximum number of agents that can
simultaneously receive deployments.

Maximum number of simultaneous Discover
Applicable Updates (DAU) tasks

(field)

The maximum number of agents that can
simultaneously run the DAU task.
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Option Description

Maximum number of reboot tasks that can run
simultaneously

(field)

The maximum number of agents that can
simultaneously receive a deployment requiring a
reboot.

Maximum number of simultaneous Mandatory
Baseline deployments

(field)

The maximum number of agents that can
simultaneously receive Mandatory Baseline
deployments.

Maximum number of times a deployment will be
consecutively attempted

(field)

The number of failed deployment attempts permitted
before Lumension Endpoint Management and Security
Suite disables the deployment. This option does not
apply to Mandatory Baseline deployments. This option
also disables the deployment for agents yet to retrieve.

Note:  You can define deployment notification recipients from the Email Notification page, not the
Notification defaults options.

Notification Defaults
When using the Deployment Wizard, you can configure a deployment to notify deployment recipients.
By defining Notification defaults, you control how notification options are configured by default within
the Deployment Wizard. Define frequently used Notification defaults to save time when working in the
Deployment Wizard.

These notifications alert Lumension Endpoint Management and Security Suite recipients of deployments to their
computers. Clients are notified via dialogs, not email. The behavior defined in these options may be overridden
within an agent policy set or on a per-deployment basis using the Deployment Wizard. Select the check box and
complete the fields to configure the options.

Table 71: Notification Defaults Options

Option Description

Display user notification for
deployment as the topmost
window

(check box)

Defines the default selection for the Deployment Notification Options and
Reboot Notification Options when completing the Deployment Wizard.
Selecting this option forces all deployment and reboot notification dialogs to
display on top of other windows.

Manual Installation

(field)

Defines the default message that displays when the deployment recipient
receives a package requiring manual installation (maximum of 400
characters).

May Reboot

(field)

Defines the default message that displays when the deployment recipient
receives a package that may require the recipient to reboot (maximum of 400
characters).



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 130 -

Option Description

Default deployment message

(field)

Defines the default message that displays with a deployment notification
(maximum of 400 characters).

Default reboot message

(field)

Defines the default message that displays with a deployment reboot
notification (maximum of 400 characters).

User Interface
When using the Deployment Wizard, you can configure a deployment to start according to the agent's local
time or the agent's Coordinated Universal Time (UTC). By using the User Interface options, you can select the
default deployment start time option. These settings can still be changed while using the Deployment Wizard.

Edit User Interface options from the Deployments tab. Select the desired radio button to enable the desired
option.

The following table describes each option.

Table 72: User Interface Option Descriptions

Option Description

Agent Local Time (Deploy at
local time for each individual
node)

(radio button)

Defines Agent Local Time as the default deployment start time when
completing the Deployment Wizard.

Agent UTC Time (Deploy at
UTC time for each individual
node)

(radio button)

Defines Agent UTC Time as the default deployment start time when
completing the Deployment Wizard.

Working with Options
From each Options page tab, you can define default behavior for different Lumension Endpoint Management and
Security Suite features.

• Configuring the General Tab on page 130
• Configuring the Agents Tab on page 132
• Configuring the Deployments Tab on page 135
• Exporting Option Data on page 137

Configuring the General Tab
Configure this tab to define how user interface, password, and report display options behave.

Configure the General tab from the Options page.
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1. Select Tools > Options.

Step Result: The Options page opens.

2. Ensure the General tab is selected.

3. Define the UI options.

These options define general user interface behavior.

a) Select a value from the Default number of rows page list (25, 50, 100, 200, 500).

This option defines the default number of rows that display in list pages.
b) Select a value from the Cache timeout list (5, 10, 15, 20, 30).

This option defines the maximum number of minutes data is held in the memory before it needs to be
reloaded from the database.

c) Select a value from the Session timout list (20, 40, 60, 80, 100).

This option defines the number of minutes before a repeat login is required due to inactivity.
d) Select or clear the Activate automatic IP grouping in the Groups view check box.

This option creates groups organized by IP address in the Groups page Group Browser named IP
Collection.

e) [Optional] Edit the Compliance & Report URL field in the following format:
http(s)://www.website.com.

This field controls what web address the product header links you to. Lumension recommends using the
link to direct you to your reporting and compliance Web site.

4. Define the Password options.

This option defines the number of days prior to a required password change (as controlled by Windows) that
a notification displays. Type a value in the Display notification x days prior to password expiration field.
A value of 0 disables password expiration.

5. Define the Discovery and Agent Management Job Logging options.

These option control what information is recorded during discovery scan jobs and agent management jobs.
Complete the following substeps:

a) Select a Logging Level.

Logging levels incldue:

• Trace
• Diagnostic
• Information
• Warning
• Error
• Critical
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b) Select the checkboxes for the desired Include common troubleshooting information for options.

Option include:

• Agent Management
• Discovery
• SOAP

6. Define the Report and display options.

These options control formatting options for PDF reports. Perform the step(s) required to define each option.

Note:  The Default item available in each Report and display options returns the applicable option to the
last saved value.

Option Step(s)

Date format This option defines the date format displayed in text-based and
graphical reports.

Select a value from the Date format list.

Time seperator This option defines the character used to separate hours, minutes, and
seconds in reports. This option also defines the time notation used in
reports.

1. Select a character from the first Time separator list (colon [:] or
period [.]).

2. Select a value from the second Time separator list (12 Hour or 24
Hour).

Paper size for report This option Defines how reports are formatted for printing.

Select a value from the Paper size for reports list (Letter or A4).

7. Click Save.

Result: The General tab configuration is saved.

Configuring the Agents Tab
Configure this tab to define default agent behavior. Settings include agent installation settings, communication
settings, discover applicable update task settings, ISAPI communication settings, and agent version settings.
Editing these setting results in greater network communication at the cost of network performance.

Configure the Agents tab from the Options page.

1. Select Tools > Options.

Step Result: The Options page opens.

2. Select the Agents tab.
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3. Define the Agent Installation options.

These options define the default behavior of agent management jobs.

a) Select a value from the Timeout list (1-30 minutes).

This option defines the default number of minutes before an agent installation job terminates due to non-
responsive status.

b) Select a value from the Number of retries list (1-10).

This option defines the default number of attempts an agent installation will retry if initial and subsequent
installations fails.

c) Select a value from the Number of simultaneous installs list (1-25).

This option defines the default maximum number of agents that can be installed or un-installed
simultaneously during an agent management job. A value of 1 indicates that serial installs and uninstalls
should occur.

d) Type a value in the Server identity field.

This field defines the default text entered in the Server Identity field during agent installation jobs.
Server Identity is the name agents list as their Lumension Endpoint Management and Security Suite
server. The server identity should be typed in one of the following formats:

• computername.domainname.com

• computername

• 10.10.10.10

e) Select a Scan method for pre-selected targets option:

These buttons define how endpoints pre-selected from a page list are added to a job's targets list
(discovery scan or agent management) after launching a job configuration dialog. The options include:

• IP Address
• Computer Name

4. Define the Communication options.

To define these options, complete the following substeps.

a) Type a value in the Agents should be shown offline when inactive for field (0-9999).

This option defines the time period (in minutes, hours, or days) before an agent is considered offline
because it has not checked in with Lumension EMSS. Disabled and un-installed agents are not considered
offline. A value of 0 disables this option.

b) Select a value from the Agents should be shown offline when inactive for  list.

Select from the following values:

• Minute(s)
• Hour(s)
• Day(s)
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c) Select a Stand alone Patch agent uniqueness based on option.

These options define how the server identifies patch agents during communication (Patch and
Remediation only). Select from the following options:

• Endpoint name
• Instance

5. Define the Discover Applicable Updates (DAU) Options.

These options determine whether registered agents perform a DAU task following a subscription replication
or inventory change. Select or clear the following options:

• DAU should be run after subscription replication
• DAU should be run after inventory change

6. Define the Absentee agent deletion option.

This option defines when an uncommunicative agent after the defined time period (days). A value of 0
disables this function. Type a value in the Delete absentee agent after x Days field (0-999) Days. A value of
0 disables the option.

7. Define the ISAPI communication options.

Option Steps

Concurrent agent limit This option defines the maximum number of threads used by
Lumension EMSS.

To use the default option:

Select the SQL default (64 threads).

To use a custom option:

1. Select the Custom setting (5-256) option.
2. Type a value in the x threads field (5-256).

Connection timeout This option defines the time (in seconds) before an ISAPI thread
expires (times out).

To use the default option:

Select the Default (30 seconds) option.

To use a custom option:

1. Select the Custom setting (5 to 300 seconds) option.
2. Type a value in the seconds field (5-300).
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Option Steps

Command timeout This option defines the time (in seconds) before an ISAPI command
expires (times out).

To use the default option:

Select the Default (60 seconds) option.

To use a custom option:

1. Select the Custom setting (5 to 900 seconds) option.
2. Type a value in the seconds field (5-900).

8. Define the Agent Versions options.

These options define the agent versions that are available for installation during when working with the
following system dialogs:

• The Manage Agent Versions Dialog
• The Download Agent Installers Dialog
• The Install Agents Wizard

a) Select a value from the Windows XP and newer agent version.
b) Select a value from the Linux, Unix, & agent version (Patch and Remediation only).

Because the agent is updated regularly, Agent Versions option list values change frequently. Additionally,
when selecting agent version options, remember the following information:

• Newest Available means only the latest agent version is available for installation.

Note:  This option only defines which agent version is available when working with the Manage
Agent Versions dialog, the Download Agent Installers dialog, or the Install Agents Wizard. It does not
automatically install newly released agent versions on network endpoints. To ensure the newest agent
version in stalled on network endpoints, you must manually define the latest version. For additional
information, refer to Defining the Endpoint Agent Version on page 165.

• Agent Version only list items mean only that agent version is available for installation.
• Agent Version + list items mean that agent version and all version that supersede it are available for

installation.

9. Click Save.

Result: The Agents tab configuration is saved.

Configuring the Deployments Tab
Configuring this tab defines default setting for the Deployment Wizard. Selecting frequently used values from
this tab leads to faster completion of the Deployment Wizard when deploying content.

Configure the Deployments tab from the Options page.
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1. Select Tools > Options.

Step Result: The Options page opens.

2. Select the Deployments tab.

3. Define the Deployments defaults options.

Complete the following substeps.

a) Type a value in the Maximum number of deployments that can run simultaneously field.

This option defines the maximum number of agents that can simultaneously receive deployments.
b) Type a value in the Maximum number of simultaneous "Discover Applicable Updates" (DAU) task

field.

This option defines the maximum number of agents that can simultaneously run the DAU task.
c) Type a value in the Maximum number of reboot tasks that can run simultaneously field.

This option defines the maximum number of agents that can simultaneously receive a deployment
requiring a reboot.

d) Type a value in the Maximum number of simultaneously Mandatory Baseline deployments field.

This option defines the maximum number of agents that can simultaneously receive Mandatory Baseline
deployments.

e) Type a value in the Maximum number of times a deployment will be consecutively attempted field.

This option defines the number of failed deployment attempts permitted before Lumension Endpoint
Management and Security Suite disables the deployment. This option does not apply to Mandatory
Baseline deployments. This option also disables the deployment for agents yet to retrieve.

4. Define the Notifications defaults options.

Complete the following substeps.

a) Select or clear the User notification should always be on top check box.

This option forces all notification dialogs to display on top of other windows.
b) Type the desired message in the Manual installation field (400 characters max).

This option defines the default message that displays when the deployment recipient receives a package
requiring manual installation.

c) Type the desired message in the May reboot field (400 characters max).

This option defines the default message that displays when the deployment recipient receives a package
that may require the recipient to reboot.

d) Type the desired message in the Default deployment message field (400 characters max).

This option defines the default message that displays with a deployment notification.

5. Define the User Interface option.

Select a How should Deployment Wizard Start Times be displayed? option.

• Agent Local Time (Deploy at local time for each individual node)
• Agent UTC Time (Deploy at UTC time for each individual node)
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6. Click Save.

Result: The Deployments tab configuration is saved.

Exporting Option Data
To export the options settings that are listed on any Options page tab to a comma separated value (.csv)
file, click the Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.
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Chapter

6
Licensing and Support

In this chapter:

• The Technical Support Page

• The Product Licensing Page

• Supporting Linux and UNIX
Endpoints

While using Lumension Endpoint Management and Security Suite
(Lumension EMSS), you may need to request technical support or
view information about your Lumension EMSS licenses.

Request technical support from the The Technical Support Page on
page 139. From this page you can request technical support and
review technical information about your Lumension EMSS server.

View licensing information from the The Product Licensing Page on
page 145. This page lists the Lumension EMSS modules you are
licensed for.

The Technical Support Page
Lumension offers a variety of technical support Web pages, as well as Web pages where you can give
Lumension feedback for future product releases. You can access these pages from the Technical Support page.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 140 -

This page also provides a variety of read-only system data pertaining to the Lumension Endpoint Management
and Security Suite environment.

Figure 53: Technical Support Page

Viewing the Technical Support Page
Navigate to this page to access out-of-program technical support pages.

You can access this page at any time from the navigation menu.

1. Select Help > Technical Support.

2. View the page.

Technical Support Page Buttons
The Technical Support page features buttons to download the most recent OS packs. OS packs are files used
detect operating systems.

The following table describes each button.

Table 73: Technical Support Page Buttons

Button Function

Regenerate OS Packs Regenerates and synchronizes the relevant information for each of the operating
systems supported by Lumension Endpoint Management and Security Suite. For
additional information, refer to Regenerating OS Packs on page 144.
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Button Function

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Detail... Opens a dialog that displays a detailed list of Microsoft Directory Access
Components product and file versions. For additional information, refer to
MDAC File Version Information on page 143.

Technical Support Options
Lumension provides access to various out-of-program technical support pages. Use these pages to communicate
with Lumension. Click each link to open the applicable page in a new window.

The following table describes each link.

Table 74: Technical Support Options Links

Link Description

Contact Technical Support Sends an email to technical support at Lumension Support
(support@lumension.com).

Access Product Knowledge Base Accesses the knowledge base at Lumension Support (http://
support.lumension.com).

Access Product Web Site Accesses the Lumension web site (http://www.lumension.com).

Ask a Question Sends a support question to Lumension via the Lumension Customer
Portal (http://portal.lumension.com/).

Request a Patch Sends a patch request to Lumension Support (support@lumension.com).

Request a Feature Sends a feature request to Lumension via the Product Feedback and
Feature Request Page (http://my.lumension.com/feedback.spring).

Provide Product Feedback Sends product input to Lumension via the Product Feedback and
Feature Request Page (http://my.lumension.com/feedback.spring).

Server Information
These fields list general information regarding the Lumension Endpoint Management and Security Suite server.

mailto:support@lumension.com
mailto:support@lumension.com
http://support.lumension.com
http://support.lumension.com
http://support.lumension.com
http://www.lumension.com
http://www.lumension.com
http://portal.lumension.com/
http://portal.lumension.com/
http://portal.lumension.com/
mailto:support@lumension.com
mailto:support@lumension.com
http://my.lumension.com/feedback.spring
http://my.lumension.com/feedback.spring
http://my.lumension.com/feedback.spring
http://my.lumension.com/feedback.spring
http://my.lumension.com/feedback.spring
http://my.lumension.com/feedback.spring
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The following table describes the Server Information fields.

Table 75: Server Information Fields

Field Description

Name The name of the server Lumension Endpoint Management and Security
Suite (Lumension EMSS) is installed on.

URL The URL of the server Lumension EMSS is installed on.

Serial Number The serial number used by Lumension EMSS.

Operating System The operating system installed and running on the Lumension EMSS server.

Operating System Service
Pack

The service pack applied to the operating system, if applicable.

Operating System Version The operating system version number.

Installation Date The date and time Lumension EMSS was installed.

Last Connected The date and time Lumension EMSS last connected to the Global
Subscription Server (GSS).

Subscription Service ID The ID assigned to Lumension EMSS upon registration with the GSS.

Replication Service Version The replication service version number.

Last Agent Connection The date and time a registered Lumension EMSS Agent last connected to
the Lumension EMSS server.

Total Agents Registered The total number of agents registered with Lumension EMSS.

Storage Volume Free Space The amount of free disk space on your storage volume.

System Root Free Space The amount of free disk space on your system volume.

IIS Version The Internet Information Services (IIS) version installed.

.NET Version The .NET Framework version(s) installed.

MDAC Version The Microsoft Data Access Components (MDAC) version. The Detail
button adjacent to the field opens the MDAC File Version Information
dialog.

SQL File Version The SQL Server file version installed.

SQL Version The SQL Server version number followed by detailed information.

Viewing the MDAC File Version Information Dialog
Navigate to this dialog to view MDAC file version information.

You can access this dialog from the Technical Support page.
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1. Select Help > Technical Support.

2. Click Detail.

Step Result: The MDAC File Version Information dialog opens.

3. View the MDAC file version data.

MDAC File Version Information
The MDAC File Version Information dialog lists the individual .dll files included within the version of
Microsoft Data Access Components (MDAC) installed on your Lumension Endpoint Management and Security
Suite server. To open this dialog, click the Detail button within Component Version Information.

Figure 54: MDAC File Version Information Dialog

The following table describes the contents of the MDAC File Version Information dialog.

Table 76: MDAC File Version Information

Column Description

File Name The name of the MDAC .dll file.

Product Version The product version number of the file.

File Version The file version number of the file.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 144 -

Suite Version Information
Suite Version Information displays the version number of Lumension Endpoint Management and Security
Suite (Lumension EMSS), each platform component installed, and each module component installed.

The following table describes each Suite Version Information field.

Table 77: Suite Version Information Fields

Field Description

Server Suite Version The version number of Lumension EMSS installed on your Lumension EMSS
server.

Core Version The version number of the Lumension EMSS core installed on your Lumension
EMSS server.

Module Version The name and version number of a Lumension EMSS module installed on your
Lumension EMSS server. A field appears for each module installed on your server.

Regenerating OS Packs
This task regenerates and synchronizes the relevant information for each of the operating systems supported by
Lumension Endpoint Management and Security Suite.

Regenerate OS packs from the Technical Support page.

1. Select Help > Technical Support.

Step Result: The Technical Support page opens.

2. Click Regenerate OS Packs.

Step Result: A dialog displays, asking you to acknowledge the regeneration.

3. Click OK.

Step Result: A dialog displays, asking you to acknowledge that the regeneration has been scheduled.

4. Acknowledge the scheduling by clicking OK.

Result: The OS pack regeneration is scheduled. The regeneration occurs the next time the Lumension Endpoint
Management and Security Suite server communicates with the Global Subscription Server.

Exporting Technical Support Data
You can export the data listed on the Technical Support page for reporting and analytical purposes.

Exported data includes Technical Support Options, Server Information, and Suite Version Information.
To export this data, select Help > Technical Support and click Export. For additional information, refer to
Exporting Data on page 60.



Licensing and Support

- 145 -

The Product Licensing Page
Use this page to view, validate, and export license information. It summarizes product component licenses
applicable to your endpoint management activities. Product information is updated during daily replication with
the Global Subscription Server. Additionally, the page lists how many agent licenses you have, how many of
those licenses are in use, and how many of those licenses are available.

Figure 55: Product Licensing Page

Viewing the Product Licensing Page
Navigate to this page to view information about license validity and daily replication.

You can access this page at any time through the navigation menu.

1. Select Help > Product Licensing.

2. View your product license data.

The Product Licensing Page Buttons
Use the Product Licensing page buttons to initiate license replications or open Lumension Installation Manager.
Lumension recommends initiating license replication after installing a new module.

The following table describes each button.

Table 78: Product Licensing Page Buttons

Button Function

Validate Initiates a license replication that searches for any changes to your license data. For
additional information, refer to Initiating Subscription License Replication Jobs on
page 147.

Note:  This field does not definitively indicate that replication is working.

Launch Installation
Manager...

Opens Lumension Installation Manager in a new browser window to the New/
Updated Components tab. For additional information on usingLumension
Installation Manager, refer to Lumension Endpoint Management and Security
Suite: Wake on LAN User Guide (http://portal.lumension.com).

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com
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Button Function

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

The Product Licensing Page List
This list itemizes licensing information for each Lumension Endpoint Management and Security Suite module.
View this table for an overview of license availability.

The following reference describes the list columns.

Table 79: Product Licensing Page List

Column Description

Name The product module name.

Version The product module version number.

Vendor The source of the license. The vendor name is a link to the vendor home page,
which opens in a new window.

Total Purchased The total number of licenses purchased for the module.

In Use The number of licenses in use for the module.

Pending The number of licenses pending use or removal for the module.

Available The number of licenses available for the module.

The list item for each product module can be expanded to display license group information. License groups
are blocks of licenses purchased at a time. For example, you may have 3 license groups comprising 500 total
licenses. Initially, a group of 300 licenses was purchased, and then 2 additional groups of 100 licenses were
added during subsequent quarters.

To expand a list item, click the rotating chevron (>). The following table describes each column that displays
after expanding a list item.

Table 80: Expanded Product Licensing List Item

Column Description

Purchase Date (Server) The date and time the license group was purchased.

Effective Date (Server) The date and time the license went into effect. This date is the first day that the
licenses became valid, not necessarily the installation date.
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Column Description

Expiration Date (Server) The date and time the license group expires.

Purchased The total number of licenses purchased in the license group.

Initiating Subscription License Replication Jobs
Initiate these jobs to validate license replication. This replication searches for any changes to your license data.
Perform these jobs after you purchase new modules to update your licensing information.

Validate product licensing from the Product Licensing page.

1. Select Help > Product Licensing.

Step Result: The Product Licensing page opens.

2. Click Validate.

Step Result: A dialog opens, asking you to acknowledge the validation initiation.

3. Click OK.

Result: The job begins. Completion may take several minutes.

Exporting Product Information
You can export product information data to a comma separated value (.csv) file for reporting and analytical
purposes.

To export this data, select Help > Product Licensing and click Export. For additional information, refer to
Exporting Data on page 60.

Supporting Linux and UNIX Endpoints
Prior to patching your Red Hat Enterprise Linux, Oracle Solaris, Oracle Enterprise Linux, or Novell SUSE
Linux systems using Lumension Endpoint Management and Security Suite, you must configure your Lumension
Endpoint Management and Security Suite server to use the subscriber network for your operating system.

Red Hat, Oracle, and Novell require users to subscribe to a subscriber network prior to downloading patches for
their operating systems.

Note:  In order for Red Hat Linux endpoints to receive security content from the Lumension Endpoint
Management and Security Suite (Lumension EMSS) server, the endpoint must have Management Base
entitlements through the Red Hat Network.

To configure Lumension EMSS server to use your Red Hat Network, SunSolve, Oracle Unbreakable Linux
Network, or Novell SUSE subscription credentials you must perform the following tasks:

http://rhn.redhat.com
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1. Obtain valid subscriptions and login credentials to one of the following networks, based on your operating
system:

• Red Hat Network

• My Oracle Support for Solaris

• Oracle Unbreakable Linux Network

• Novell Customer Center

• HP IT Resource Center

2. Configure the Content Credentials Manager. For details, refer to Content Credentials Manager on page
148.

Content Credentials Manager
The Content Credentials Manager is downloaded to the Lumension EMSS server during the first replication
after installing Lumension Endpoint Management and Security Suite 7.3 SP1. The Content Credentials Manager
allows you to register your Lumension EMSS server to receive entitled content. This registration process only
needs to be completed once for each entitled content type.

Red Hat Enterprise Linux Content Support
Before attempting to deploy content to your endpoints running the Red Hat Linux operating system, verify that
your version of Red Hat is supported.

Lumension offers patch and remediation support for the following versions of Red Hat Enterprise Linux:

• Red Hat Enterprise Linux 5 (Server or Desktop, x86 or x86_64)
• Red Hat Enterprise Linux 6 (Server or Desktop, x86 or x86_64)

Configuring Red Hat Network Credentials
Enable enhanced content to allow Lumension Endpoint Management and Security Suite to download content
directly from third parties rather than from the Global Subscription Server. This functionality leads to faster
turnaround time when installing content.

If you are running the Red Hat Linux operating system, you must configure your credentials on the Red Hat
Network in order to receive content.

1. Select Tools > Subscription Updates.

2. Click Update Now.

Step Result: Replication between your Lumension Endpoint Management and Security Suite (Lumension
EMSS) server and the Global Subscription Server begins.

3. When replication is complete, open a command prompt.

4. Navigate to the Replication Services directory. You can locate this directory here: <Installation
Directory>\Lumension\EMSS\Replication Services.

http://rhn.redhat.com
http://support.oracle.com
https://linux.oracle.com/pls/apex/f?p=101:3
http://www.novell.com/customercenter/
http://itrc.hp.com
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5. From a command prompt, enter the following lines, replacing the variables listed below with the appropriate
values:
 CredentialsManager /source:redhat /u:RedHatUserName /p:RedHatPassword /hostname:MyServerName /
release:RedHatRelease /arch:RedHatArchitecture
                    

Table 81: Credentials Manager configuration

Variable Description

RedHatUserName Your user name on the Red Hat Network.

RedHatPassword Your password on the Red Hat Network.

MyServerName The systemid for the computer running Lumension Endpoint
Management and Security Suite server.

RedHatRelease The version of Red Hat that you want to receive content for. Enter one
of the following:

• 5Server
• 5Client
• 6Server
• 6Client

RedHatArchitecture The processor type on the endpoints that you want to receive content for.
Enter one of the following:

• i386
• x86_64

Step Result: A warning appears indicating that registering your server with the Credentials Management
tool may result in a loss of patch deployment history and increased replication times.

6. Enter Y to acknowledge the warning and confirm the registration.

Note:  You must perform the previous step and this step for each Red Hat subscription that you want
Lumension EMSS to remediate.

7. Verify that the systemid you used as the MyServerName above is registered on the Red Hat Network.

a) Go to http://rhn.redhat.com.
b) Log in using the username and password combination that you used for the RedHatUserName and

RedHatPassword above.
c) Verify that the MyServerName that you entered above appears in the Systems list.

http://rhn.redhat.com
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d) Verify that the subscription details match the details you entered above.

After Completing This Task:

Complete Replicating on page 100. You cannot remediate your Linux endpoints until your Lumension EMSS
server replicates with the GSS.

Oracle Solaris Content Support
Before attempting to deploy content to your endpoints running the Oracle Solaris operating system, verify that
your version of Solaris is supported.

Lumension offers patch and remediation support for the following versions of Oracle Solaris:

• Oracle Solaris 9 SPARC
• Oracle Solaris 10 SPARC
• Oracle Solaris 10 x86
• Oracle Solaris 10 x86_64
• Oracle Solaris 11 x86_64

Configuring My Oracle Credentials
Enable enhanced content to allow Lumension Endpoint Management and Security Suite server to download
content directly from third parties rather than from the Global Subscription Server. This functionality leads to
faster turnaround time when installing content.

If you are running the Oracle Solaris operating system, you must configure your credentials with My Oracle in
order to receive content.

1. Select Tools > Subscription Updates.

2. Click Update Now.

Step Result: Replication between your Lumension Endpoint Management and Security Suite (Lumension
EMSS) server and the Global Subscription Server (GSS) begins.

3. When replication is complete, open a command prompt.

4. Navigate to the Replication Services directory. You can locate this directory here: <Installation
Directory>\Lumension\EMSS\Replication Services.
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5. From a command prompt, enter the following line, replacing the variables listed below with the appropriate
values:
CredentialsManager.exe /source:solaris /username:SolarisUserName /password:SolarisPassword 

Result: You can now remediate your Oracle Solaris endpoints through using the Lumension EMSS server.

After Completing This Task:

Complete Replicating on page 100. You cannot remediate your Oracle Solaris endpoints until your Lumension
EMSS server replicates with the GSS.

You must also allow outbound access through ports 80 and 443 to the following URLs:

• https://getupdates2.sun.com

• http://getupdates.oracle.com

• http://a248.e.akamai.net

Oracle Linux Content Support
Before attempting to deploy content to your endpoints running the Oracle Enterprise Linux operating system,
verify that your version of Oracle is supported.

Lumension offers patch and remediation support for the following versions of Oracle Enterprise Linux:

• Oracle Linux 4 x86
• Oracle Linux 4 x86_64
• Oracle Linux 5 x86
• Oracle Linux 5 x86_64
• Oracle Linux 6 x86
• Oracle Linux 6 x86_64

Configuring Oracle Unbreakable Linux Network Credentials
Enable enhanced content to allow Lumension EMSS server to download content directly from third parties rather
than from Global Subscription Server. This leads to faster turnaround time when installing content

If you are running the Oracle Enterprise Linux operating system, you must configure your credentials on the
Oracle Unbreakable Linux Network in order to receive enhanced content.

1. Select Tools > Subscription Updates.

2. Click Update Now.

Step Result: Replication between your Lumension EMSS server and the Global Subscription Server begins.

3. When replication is complete, open a command prompt.

4. Navigate to the Replication Services directory. You can locate this directory here: <Installation
Directory>\Lumension\EMSS\Replication Services.

https://getupdates2.sun.com
http://getupdates.oracle.com
http://a248.e.akamai.net
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5. From a command prompt, enter the following line, replacing the variables listed below with the appropriate
values:

Note:  For a complete list of commands, type /source: oracle /HELP.

 CredentialsManager.exe /source:oracle /u:username /p:password /csi:xxxxxxxx /
hostname: computername /release: x /arch:architecture

Note:  You must perform this step for each Oracle Enterprise Linux subscription that you want Lumension
EMSS server to remediate.

Step Result: A successful registration message displays.

After Completing This Task:

Complete Replicating on page 100. You cannot remediate your Linux endpoints until your Lumension EMSS
server replicates with the GSS.

Novell SUSE Linux Support
Before attempting to deploy content to your endpoints running the Novell SUSE Linux operating system, verify
that your version of SUSE is supported and that you can access package files from Novell.

Lumension offers patch and remediation support for the following versions of Novell SUSE Linux:

• SUSE Linux Enterprise Server 11 x86
• SUSE Linux Enterprise Server 11 x86_64
• SUSE Linux Enterprise Desktop 11 x86
• SUSE Linux Enterprise Desktop 11 x86_64
• SUSE Linux Enterprise Server 10 x86
• SUSE Linux Enterprise Server 10 x86_64
• SUSE Linux Enterprise Desktop 10 x86
• SUSE Linux Enterprise Desktop 10 x86_64
• SUSE Linux Enterprise 9 x86
• SUSE Linux Enterprise 9 x86_64

You must allow outbound access to the following URLs using ports 80 and 443 so that you can receive package
files from Novell:

• https://nu.novell.com
• https://you.novell.com

Enabling Enhanced Content for Novell SUSE Linux
Enable enhanced content to allow Lumension Endpoint Management and Security Suite to download content
directly from third parties rather than from the Global Subscription Server. This functionality leads to faster
turnaround time when installing content.

If you are running the Novell SUSE Linux operating system, you must configure your credentials on the Novell
Customer Center in order to receive content.

1. Select Tools > Subscription Updates.
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2. Click Update Now.

Step Result: Replication between your Lumension Endpoint Management and Security Suite (Lumension
EMSS) server and the Global Subscription Server begins.

3. When replication is complete, open a command prompt.

4. Navigate to the Replication Services directory. You can locate this directory here: <Installation
Directory>\Lumension\EMSS\Replication Services.

5. From a command prompt, enter the command for your operating system's version, replacing the variables
listed below with the appropriate values.

For a complete list of commands, enter: /source:suse /HELP at the command prompt.

• For SUSE 10 and SUSE 11, enter: CredentialsManager.exe /source:suse /a:mirror /
u:<username> /p:<password>.

• For SUSE 9, enter: CredentialsManager.exe /source:suse /a:suse9 /u:<username> /
p:<password>.

Step Result: A successful registration message displays.

6. Optionally, you can list the operating system types registered with the Lumension EMSS server and validate
the status of the channels providing enhanced content. Enter the following commands at the command
prompt.

• To list the operating system types registered with the server, enter: CredentialsManager.exe /
source:suse /list.

• To validate the status of the channels providing the enhanced content, enter:
CredentialsManager.exe /source:suse /validate.

Result: You can now remediate your Novell SUSE Linux endpoints using Lumension EMSS server.

After Completing This Task:

• Complete Replicating on page 100. You cannot remediate your Linux endpoints until your Lumension EMSS
server replicates with the GSS.

• Deploy the C -  Lumension PatchLink Update RPM Linux Module 1.9 package to your endpoints running
SUSE Linux. In order for managed endpoints to receive enhanced content for Novell SUSE Linux, you must
deploy this package. For more information, see Deploying Content on page 396.

HP-UX Content Support
Before attempting to deploy content to your endpoint running the HP-UX operating system, verify that your
version of HP-UX is supported.
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Lumension offers Patch and Remediation support for the following versions of HP-UX:

• HP-UX 11.11 PARISC
• HP-UX 11.23 PARISC
• HP-UX 11.31 PARISC
• HP-UX 11.31 Itanium

Configuring HP IT Resource Center Credentials
The Lumension Endpoint Management and Security Suite (Lumension EMSS) server must be configured to
download content directly from third-party vendors rather than the Global Subscription Server. This functionality
leads to faster turnaround time when installing content.

If you are running the HP-UX operating system, you must configure your credentials with the HP IT Resource
Center in order to receive content.

1. Select Tools > Subscription Updates.

2. Click Update Now.

Step Result: Replication between your Lumension EMSS server and the Global Subscription Server begins.

3. When replication is complete, open a command prompt.

4. Navigate to the Replication Services directory. You can locate this directory here: <Installation
Directory>\Lumension\EMSS\Replication Services.

5. From a command prompt, enter the following lines, replacing the variables listed below with the appropriate
values:
 CredentialsManager /source:hpux /u:HP IT Resource Center UserName /p:HP IT Resource Center
 Password
                    

Table 82: Credentials Manager configuration

Variable Description

HP IT Resource Center
Username

Your user name on HP IT Resource Center.

HP IT Resource Center
Password

Your password on HP IT Resource Center.

Step Result: A warning appears indicating that registering your server with the Credentials Management
tool may result in a loss of patch deployment history and increased replication times.
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6. Enter Y to acknowledge the warning and confirm the registration.

Note:  You must perform the previous step and this step for each Red Hat subscription that you want
Lumension EMSS to remediate.

Result: You can now remediate your HP-UX endpoints using Lumension EMSS.

After Completing This Task:

Complete Replicating on page 100. You cannot remediate your Linux endpoints until your Lumension EMSS
server replicates with the GSS.

Additionally, you must also allow outbound access through ports 80 and 443 to the following URLs:

• http://itrc.hp.com

• http://ftp.itrc.hp.com

http://itrc.hp.com
http://ftp.itrc.hp.com


Lumension Endpoint Management and Security Suite: Patch and Remediation

- 156 -



- 157 -

Chapter

7
Using Endpoints

In this chapter:

• About Endpoints

• The Endpoints Page

• Working with the Endpoints Page

• The Endpoint Details Page

• Working with the Endpoint Details
Page

While using Lumension Endpoint Management and Security Suite
(Lumension EMSS), you can view and manage network endpoints
after installing agents.

The Endpoints page contains a listing of all endpoints that have an
agent registered with the Lumension EMSS server. From this list of
endpoints, you can access the endpoint details. The endpoint details
include endpoint-specific information.

About Endpoints
The Endpoints page is used to manage the computers and devices, referred to as endpoints, on your network. The
Lumension Endpoint Management and Security Suite server manages your endpoints by sending user-defined
and automated commands to your endpoints' agents. When the agent contacts the server, the commands are
executed.

The Endpoints page lists all endpoints registered to the Lumension EMSS server. The page displays general
information about the endpoint, such as the endpoint name, status, operating system, and agent version.

Figure 56: Endpoints Page

Viewing the Endpoints Page
The Endpoints page has filters that allow you to customize your view of the computers and other devices that are
managed on your network.

1. Select Manage > Endpoints.
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2. [Optional] Complete a task listed in Working with the Endpoints Page on page 163.

The Endpoints Page
The Endpoints page contains information about the managed endpoints on your network. From the Endpoints
page, you can use features associated with endpoints.

Figure 57: Endpoints Page

This page contains the following tabs:

• The All Tab on page 158
• The Patch and Remediation Tab on page 160

The All Tab
This tab lists information about endpoints, the agent version installed on them, and the module features active on
them.

This tab displays by default when you open the Endpoints page.

Figure 58: All Tab

The All Tab Toolbar
The All tab toolbar contains buttons used to manage basic endpoint functions.

The following table describes the toolbar functions used in the Endpoints page.

Table 83: All Tab Toolbar Functions

Button Function

Manage Agents...

(menu)

Opens the Manage Agents menu.
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Button Function

Install Agents...

(Manage Agents... menu item)

Install agents on selected endpoints. For additional information, refer to
Installing Agents by Agent Management Job on page 586.

Uninstall Agents...

(Manage Agents... menu item)

Uninstalls agents from selected endpoints. For additional information,
refer to Uninstalling Agents by Agent Management Job on page 600.

Download Agent Installer...

(Manage Agents... menu item)

Downloads an agent installer to the endpoint used to access Lumension
Endpoint Management and Security Suite. For additional information,
refer to Downloading the Agent Installer on page 166.

Delete Deletes a disabled endpoint. For additional information, refer to
Deleting an Endpoint on page 167.

Enable Enables a disabled endpoint. For additional information, refer to
Enabling an Endpoint on page 168.

Note:  This button is only available when an endpoint is disabled.

Disable Disables an enabled endpoint. For additional information, refer to
Disabling an Endpoint on page 169.

Agent Versions... Defines the agent version(s) that can be installed on an endpoint. For
additional information, refer to Defining the Endpoint Agent Version on
page 165.

Manage Modules... Opens the Add/Remove Modules dialog. Use this dialog to toggle
module-specific agent functions. For additional information, refer to
Managing Module Endpoint Components on page 171.

Export Exports the page data to a comma separated value (.csv) file. For
additional information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to
export data successfully. Pop-up blockers in Internet Explorer or other
supported browsers may also suppress export functionality and should
be disabled.

Options Opens the Options menu. For more information, see The Options Menu
on page 53.

The All Tab List
The All tab list itemizes endpoint operating system information, identification information, agent information,
and module information.
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The following table describes the columns within the All tab list.

Table 84: All Tab List Columns

Column Description

Endpoint Indicates the name of the endpoint. Click the link to open the Endpoint
Details page. For additional information, refer to The Endpoint Details
Page on page 174.

IP Address Indicates the IP address of the endpoint.

Agent Status Indicates the status of the endpoint (Online, Offline, or Disabled).

Operating System Indicates the operating system the endpoint is running.

Agent Type Indicates the type of agent that is running on the endpoint and
communicating with the Lumension Endpoint Management and Security
Suite server.

Agent Version Indicates the version number of the agent that is assigned to the endpoint.

Module Installed Indicates whether a component module is installed on the endpoint. A
Module Installed column appears for each component module installed
on your Lumension Endpoint Management and Security Suite server. The
following list defines column entry values:

Yes The module is installed.

Pending The module is pending install or
uninstall.

No The module is not installed.

Error There was an error while installing
or uninstalling the module. Click the
error link for additional information
about the error.

Expired The module license has expired.

The Patch and Remediation Tab
This tab lists endpoint names, endpoint address information, endpoint agent information, and Patch and
Remediation information.
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View this tab from the Endpoints page.

Figure 59: Patch and Remediation Tab

The Patch and Remediation Tab Toolbar
The Patch and Remediation tab toolbar contains the tasks and functions that are available for you to perform for
managed endpoints with Patch and Remediation features enabled.

The following table describes the Patch and Remediation toolbar functions used in the Endpoints page.

Table 85: Patch and Remediation Toolbar Functions

Button Function

Deploy... Launches the Deployment Wizard, which allows you to create a
deployment for the selected endpoints (Patch and Remediation only). For
additional information, refer to Deploying Content to Endpoints (Patch and
Remediation Tab) on page 164.

Manage Agents...

(menu)

Opens the Manage Agents menu.

Install Agents...

(Manage Agents... menu item)

Install agents on selected endpoints. For additional information, refer to
Installing Agents by Agent Management Job on page 586.

Uninstall Agents...

(Manage Agents... menu item)

Uninstalls agents from selected endpoints. For additional information, refer
to Uninstalling Agents by Agent Management Job on page 600.

Download Agent Installer...

(Manage Agents... menu item)

Downloads an agent installer to the endpoint used to access Lumension
Endpoint Management and Security Suite. For additional information, refer
to Downloading the Agent Installer on page 166.

Agent Versions... Defines the agent version(s) that can be installed on an endpoint. For
additional information, refer to Defining the Endpoint Agent Version on
page 165.

Delete Deletes a disabled endpoint. For additional information, refer to Deleting
an Endpoint on page 167.

Enable

(Menu)

Expands the Enable menu.
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Button Function

Enable Agent

(Enable menu item)

Enables a disabled endpoint. For additional information, refer to Enabling
an Endpoint on page 168.

Enable Module

(Enable menu item)

Enables the Patch and Remediation agent module on only selected
endpoints. For additional information, refer to Enabling Modules on an
Endpoint on page 168.

Disable

(Menu)

Expands the Disable menu.

Disable Agent

(Disable menu item)

Disables an enabled endpoint. For additional information, refer to Disabling
an Endpoint on page 169.

Disable Module

(Disable menu item)

Disables the Patch and Remediation agent module on only selected
endpoints. For additional information, refer to Disabling Modules on an
Endpoint on page 169.

Manage Modules... Opens the Add/Remove Modules dialog. Use this dialog to add and
remove modules to or from the endpoint. For additional information, refer
to Managing Module Endpoint Components on page 171.

Scan Now... Prompts the Discover Applicable Updates task to launch immediately
(within the agent hours of operation) and scan all agent-managed endpoints
within your network for vulnerabilities. This scan queues an inventory
of vulnerabilities that will run the next time the agent checks in with the
server (Patch and Remediation only). For additional information, refer to
Using Scan Now to Scan Inventory (Patch and Remediation Tab) on page
171.

Reboot Now... Prompts the selected endpoint to reboot. For additional information, refer
to Rebooting Endpoints on page 172.

Export Exports the page data to a comma separated value (.csv) file. For
additional information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Options Opens the Options menu. For more information, see The Options Menu on
page 53.

The Patch and Remediation Tab List
The Patch and Remediation tab list itemizes identification data, server connectivity, operating system, and agent
information for endpoints with the Patch and Remediation agent module.
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The following table describes the columns within the Endpoints page.

Table 86: Patch and Remediation Tab List Columns

Column Description

Name The name of the endpoint. Clicking the Name  link displays the applicable
Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.

IP Address The IP address of the endpoint.

Status

(icon)

The icon representing the Patch and Remediation module status. You can
mouse over the icon to display description of the Patch and Remediation
status. For additional information, refer to Agent Module Status Icons on
page 526.

Agent Status Indicates the status of the endpoint (Online, Offline, or Disabled).

LPR  Status The status for Patch and Remediation module (the Patch Agent) on the
endpoint (Working, Idle, Sleeping, Offline, Disabled).

DAU Status The status of the Discover Applicable Updates (DAU) scan when last run.
The status is also a link to the applicable Deployment Results page. Status
values include: Success or Failure followed by the failure code, and
Not Available, which indicates that the endpoint has not checked in.

Note:  The Not Available DAU Status is not a hyperlink (Patch and
Remediation only).

Last DAU Scan (Server) The date and time of the last successful DAU scan (server side). A value
of Not Available indicates the endpoint has not completed a DAU scan
(Patch and Remediation only).

Operating System The operating system the endpoint is running.

LPR Running Version The Patch and Remediation module version number running on the
endpoint.

Agent Type The type of agent that is running on the endpoint and communicating
with the Lumension Endpoint Management and Security Suite server
(Lumension EMSS or Patch).

Agent Version The version number of the agent assigned to the endpoint.

Working with the Endpoints Page
You can perform a number of tasks related to endpoints using toolbar buttons on the Endpoints page.

Click a button to perform a task. Some buttons are not available until one or more list item is selected.
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The following list displays the tasks that you can perform from the Endpoints page.

• Deploying Content to Endpoints (Patch and Remediation Tab) on page 164
• Installing an Agent on page 164
• Installing Agents by Agent Management Job on page 165
• Uninstalling Agents by Agent Management Job on page 165
• Downloading the Agent Installer on page 166
• Deleting an Endpoint on page 167
• Enabling an Endpoint on page 168
• Disabling an Endpoint on page 169
• Defining the Endpoint Agent Version on page 165
• Managing Module Endpoint Components on page 171
• Enabling Modules on an Endpoint on page 168
• Disabling Modules on an Endpoint on page 169
• Using Scan Now to Scan Inventory (Patch and Remediation Tab) on page 171
• Rebooting Endpoints on page 172
• Exporting Endpoint Information on page 173

Deploying Content to Endpoints (Patch and Remediation Tab)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Endpoints page Patch and Remediation tab. When deploying from this tab, the Deployment
Wizard is preconfigured to deploy to endpoints selected from the Patch and Remediation tab list.

You can deploy content from the Endpoints page Patch and Remediation tab. For additional information about
deployments, refer to About Deployments on page 213.

1. Select Manage > Endpoints.

2. Select the Patch and Remediation tab.

3. [Optional] Select the endpoints you want to deploy content to.

4. Click Deploy.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete the subsequent tasks.

Installing an Agent
Before you can manage a network endpoint, you must install an agent. You can install an agent manually or
using a wizard.
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There are two ways in which you can install an agent on an endpoint:

• Install an agent remotely by creating an agent management job. For additional information, refer to Installing
Agents by Agent Management Job on page 586.

• Install an agent locally by browsing to the Lumension EMSS server from the endpoint that you want to
manage and downloading the agent installer. For additional information, refer to Downloading the Agent
Installer on page 166.

Installing Agents by Agent Management Job
Within Lumension Endpoint Management and Security Suite, there are multiple methods of installing agents
from endpoints using agent management jobs. To create an agent management job that installs agents from the
Endpoints page, select Manage Agents > Install Agents from the toolbar.

Tip:  You can predefine job targets by selecting endpoints from the page list.

For additional information, refer to Installing Agents by Agent Management Job on page 586.

Uninstalling Agents by Agent Management Job
Within Lumension Endpoint Management and Security Suite, there are multiple methods of uninstalling agents
from endpoints using agent management jobs. To create an agent management job that uninstalls agents from the
Endpoints page, select Manage Agents > Uninstall Agents from the toolbar.

Tip:  You can predefine job targets by selecting endpoints from the page list.

For additional information, refer to Uninstalling Agents by Agent Management Job on page 600.

Defining the Endpoint Agent Version
From the Endpoints page, you define which version(s) of the Lumension Endpoint Management and Security
Suite Agent can be installed on the selected endpoint. Update the agent version to upgrade to agent on the
defined endpoint(s).

Define agent version(s) for selected endpoints from any Endpoints page tab.

1. Select Manage > Endpoints.

Step Result: The Endpoints page opens to the All tab.

2. Select the endpoints on which you want to define agent version(s).

3. Click Agent Versions.

Step Result: The Manage Agent Versions dialog opens.
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4. Define the agent version(s).

Use one of the following methods:

Method Steps

To define a standard agent
version for all listed endpoints:

• From the Select One list, select an agent version.
• Click Apply to All Agents.

To define an agent version for
each endpoint:

Select an agent version from the Agent Version list for each endpoint.

Note:  The agent versions available for selections are defined from the Options page. For additional
information, refer to Configuring the Agents Tab on page 132.

5. Click OK.

Result: The Manage Agent Versions dialog closes. If an agent version other than the defined version is
installed on the endpoints, the defined version is installed over the previous version.

Downloading the Agent Installer
You can install an agent locally by connecting to the Lumension Endpoint Management and Security Suite
server, downloading the agent installer, and running the installer on the endpoint that you want to manage.

The following procedure describes the steps required to download the agent installer to the endpoint that you
want to manage using Lumension Endpoint Management and Security Suite. The agent system requirements
and installation procedure varies by operating system. For complete instructions regarding the installation of
agents on supported operating systems, refer to the Lumension Endpoint Management and Security Suite: Agent
Installation Guide (http://portal.lumension.com).

1. Log on to the target computer as the local administrator (or a member of the Local Administrators group).

2. Log into your Lumension Endpoint Management and Security Suite server.

For additional information, refer to Logging In to Lumension Endpoint Management and Security Suite on
page 50.

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com
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3. From the toolbar, select Tools > Download Agent Installer.

Step Result: The Download Agent Installers dialog displays.

Figure 60: Agent Installer

4. Select the endpoint's operating system from the Operating System drop-down list.

5. Select the agent version that you want to install on the endpoint from the Agent Version drop-down list.

Note:  The agent versions available for selection are defined by the Agent Version Options, which you can
edit from the Options page Agents tab. For additional information, refer to Agent Versions on page 126.

6. Click Download.

Result: A Download File dialog opens, prompting you to save or open the installer.

Deleting an Endpoint
Deleting an endpoint removes it from the list of managed endpoints in Lumension Endpoint Management and
Security Suite. Deleting an endpoint from Lumension Endpoint Management and Security Suite does not delete
the agent on the endpoint.

Prerequisites:

The endpoints you want to delete must have disabled agents. For additional information, refer to Disabling an
Endpoint on page 169.

Delete endpoints from the Endpoints page All tab.

1. Select Manage > Endpoints.
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2. Ensure the All tab is selected.

3. Ensure the page is filtered to display disabled agents.

For additional information, refer to Using Filters on page 56.

4. Select one or multiple endpoints with disabled agents.

5. In the toolbar, click Delete.

Step Result: A delete confirmation dialog displays.

6. Click OK to confirm the deletion.

Result: The endpoint is deleted from the list.

Enabling Modules on an Endpoint
Enabling a module's endpoint component activates the functions an agent's installed module after it has been
disabled.

Prerequisites:

Endpoints must have the applicable agent module installed, and the endpoint must be licensed for the agent
module. For additional information, refer to Managing Module Endpoint Components on page 171.

Enable a module from the applicable Endpoints page tab.

1. Select Manage > Endpoints.

2. Select the tab for the module that you want to enable for an endpoint.

Note:  The tabs available will vary with which module(s) you have installed.

3. Select one or more endpoint that does not have the module enabled.

4. From the toolbar, select Enable > Enable Module.

Result: The module for the selected endpoints is enabled.

Enabling an Endpoint
Disabled endpoints can be reenabled at any time. Enabling an endpoint includes in the security management
activities of the Lumension Endpoint Management and Security Suite.

Enable endpoints from the Endpoints page (any tab).

1. Select Manage > Endpoints.

2. Select the disabled endpoint(s) you want to enable.
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3. Click Enable.

Tip:  You can enable endpoints from any Endpoints page tab. To enable an endpoint from an Endpoints
page tab other than the All tab, select Enable > Enable Agent from the toolbar.

Result: The agent and all modules are enabled.

Disabling Modules on an Endpoint
Disabling a module's endpoint components deactivates the module functions for the endpoint's agent.

Prerequisites:

The module you want to disable must currently be enabled.

Disable a module from the applicable Endpoints page tab.

1. Select Manage > Endpoints.

2. Select the tab for the module that you want to disable for an endpoint.

Note:  The tabs available will vary with which module(s) you have installed.

3. Select one or more endpoints with the agent module enabled.

4. From the toolbar, select Disable > Disable Module.

Step Result: A notification displays, informing you that disabling the module stops module-related
functions.

Note:  Disabling a module does not release applicable agent license. To release an agent
license, you must completely uninstall the agent module on the endpoints. For additional
information, refer to Managing Module Endpoint Components on page 171

5. Click OK to dismiss the notification.

Result: The module for the selected endpoints is disabled.

Disabling an Endpoint
Once an endpoint is disabled, the installed modules no longer function. Disabled endpoints remain listed and can
be reenabled at any time.

Disable endpoints from the Endpoints page.

1. Select Manage > Endpoints.

2. Select the enabled endpoint(s) you want to disable.
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3. Click Disable.

Tip:  You can enable an endpoint from an Endpoints page tab. To enable an endpoint from a tab other than
the All tab, select Disable > Disable Agent from the toolbar.

Result: The endpoint is displayed in the list of endpoints identified with the disabled icon in the Status column.
After disabling an agent, the endpoint can be deleted from Lumension Endpoint Management and
Security Suite.

Note:  Once disabled, the endpoint may not appear in the list based on the Status filter settings. To
include disabled endpoints in the list, ensure you select Disabled or All in the Status filter.

The Add/Remove Modules Dialog
This dialog lists information about each module license you have purchased. You can also use it to install or
remove module endpoint components to or from individual endpoints within your network.

Open this dialog from the Endpoints page by selecting one endpoint or more and clicking Manage Modules.

The following describes each item in the dialog table.

Table 87: Add/Remove Dialog Table

Item Description

Licenses The modules you are currently licensed for. A column appears for each module
you are licensed for.

Purchased The number of licenses purchased for the applicable module.

In Use The number of licenses in use for the applicable module.

Pending The number of licenses pending installation or removal for the applicable module.

Available The number of module licenses available for assignment.

The following table describes each column in the dialog list.

Table 88: Add/Remove Dialog List

Column Description

Endpoint Name Indicates the name of managed endpoint.

IP Address Indicates the IP address of the managed endpoint.

Agent Version Indicates the agent version number defined for the endpoint.
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Column Description

Module Name Indicates if the module endpoint component for the applicable
module is installed on the endpoint. A selected check box
indicates the component is installed on the endpoint. A cleared
check box indicates the module is not installed on the endpoint.

Note:  There is a Module Name column for each module you have purchased.

Managing Module Endpoint Components
Before you can use a module's functions on your Lumension Endpoint Management and Security Suite network
endpoints, you must first install the module's endpoint component on the applicable endpoints. After installing a
module endpoint, you can remove it any time.

Prerequisites:

If installing a module's endpoint components, the module's server component must be installed.

Manage module endpoint components for individual endpoints from the Add/Remove Modules dialog.

1. Select Manage > Endpoints.

2. Select the checkbox(es) associated with the endpoints for which you want to manage modules.

3. Click Manage Modules.

Step Result: The Add/Remove Modules dialog opens.

4. Manage modules for each endpoint.

• To add a module for a particular endpoint, select the module checkbox for the applicable endpoint.
• To remove a module for a particular endpoint, clear the module checkbox for the applicable endpoint.

Tip:  Select or clear the Select All check box(es) associated with a module to globally toggle a module for all
endpoints. Endpoints with unsupported OSs or agents that do not support the module cannot be selected.

5. Click OK.

Result: The Add/Remove Modules dialog closes. The agent features for each edit are updated during the next
Discover Applicable Updates task.

Using Scan Now to Scan Inventory (Patch and Remediation Tab)
You can initiate a discover applicable updates (DAU) task at any time. When you initiate this task, the agent
scans its host endpoint for vulnerabilities and inventory. Scan results are then uploaded to the Lumension
Endpoint Management and Security Suite server, which you can view.

You can launch a DAU task for all network endpoints or selected network endpoints from the Endpoints page
Patch and Remediation tab.

1. Select Manage > Endpoints.
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2. Select the Patch and Remediation tab.

3. Schedule a DAU task for all endpoints or selected endpoints.

Use one of the following methods.

Method Steps

To schedule a DAU task for all
endpoints:

1. Click Scan Now.
2. Select Yes, scan all members of the selected group check box.

To schedule a DAU tasks for
selected endpoints:

1. From the toolbar, select the check boxes associated with the desired
endpoint(s).

2. Click Scan Now.
3. Select the Yes, scan the selected endpoints check box.

4. Click Schedule.

5. Acknowledge the scheduling by clicking Close.

Result: The scan is scheduled. As with all deployments, although the Discovery Applicable Updates task is
scheduled for immediate execution. It will not actually occur until the next time the agent(s) check in.

Rebooting Endpoints
You can use Lumension Endpoint Management and Security Suite to reboot the managed endpoints on your
network. This function is useful after installing content.

Reboot endpoints from the Endpoints page Patch and Remediation tab.

1. Select Manage > Endpoints.

2. Select the Patch and Remediation tab.

3. Select the checkbox(es) associated with the endpoint(s) you want reboot.
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4. Click Reboot Now.

Step Result: The Reboot Now dialog opens.

Figure 61: Reboot Now Dialog

5. Select the Yes, Reboot the selected endpoint check box.

6. Click Reboot.

Step Result: The system schedules the reboot.

7. Click Close.

Result: The dialog closes.

Figure 62: Reboot Now - Success

Exporting Endpoint Information
You can export the endpoint information generated in the Lumension Endpoint Management and Security Suite
so that it can be used in other applications.

The export utility lets you export endpoint information to a comma-separated value (.CSV) file format. For
additional information, refer to Exporting Data on page 60.
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The Endpoint Details Page
The Endpoint Details page lists general endpoint information, agent information, the modules installed on the
endpoints, the groups the endpoint is included in, and the group policies applied to it. This page also includes a
tab for each module installed.

Figure 63: Endpoint Details Page

This page features the following tabs:

• The Information Tab on page 175
• The Vulnerabilities Tab on page 183
• The Inventory Tab on page 185
• The Deployments and Tasks Tab on page 187

Viewing the Endpoint Details Page
The Endpoint Details page contains comprehensive details for an endpoint and its activity within the Lumension
Endpoint Management and Security Suite system.

View the Endpoint Details page for an endpoint by clicking an endpoint name link from the Endpoints page.

1. Select Manage > Endpoints.

Step Result: The Endpoints page opens to the All tab.

2. Click the Name link associated with the endpoint details you want to review.

Step Result: The Endpoint Details page opens to the Information tab.

3. [Optional] Complete a task listed in Working with the Endpoint Details Page on page 190.
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The Information Tab
The Information tab displays information about a selected endpoint. The page displays general information
organized into endpoint, agent, status, component, group, and policy sections.

Figure 64: The Information Tab

The Information Tab Toolbar
The Information tab toolbar contains the endpoint assessment tasks and functions that are available for you to
perform on managed endpoints.

The following table describes the buttons available in the Information tab toolbar.

Table 89: Information Tab Toolbar Buttons

Toolbar Button Description

Deploy... Opens with Deployment Wizard, which lets you deploy content to the
applicable endpoint. For additional information, refer to Deploying Content
(Endpoint Details Page) on page 193.

Enable Enables the endpoint (if it is disabled). For additional information, refer to
Enabling an Endpoint on page 194.

Disable Disables the endpoint (if it is enabled). For additional information, refer to
Disabling an Endpoint on page 194.

Agent Versions... Defines the agent version(s) that can be installed on an endpoint. For
additional information, refer to Defining the Endpoint Agent Version
(Endpoint Details) on page 191.

Manage Modules... Opens the Add/Remove Modules dialog, which lets you manage agent
features for modules install on Lumension Endpoint Management and
Security Suite. For additional information, refer to Managing Endpoint
Modules on page 197.

Scan Now

(Menu)

Opens the Scan Now menu.
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Toolbar Button Description

Discover Applicable Updates...

(Scan Now Menu Item)

Prompts the discover applicable updates task to immediately check the
endpoint. For additional information, refer to Using Scan Now to Scan
Inventory (Endpoint Details Page) on page 198.

Reboot Now...

(Patch and Remediation only)

Prompts the selected endpoint to reboot. For additional information, refer
to Rebooting Endpoints on page 172.

Export Exports the page data to a comma separated value (.csv) file. For
additional information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Endpoint Information
The fields that appear in this section of the Information tab contain identifier and operating system details, such
as the IP address and the operating system.

Figure 65: Endpoint Information

The Endpoint Information section displays the following endpoint data:

Table 90: Endpoint Information Field Descriptions

Field Description

Endpoint Name The name of the endpoint.

DNS The DNS name of the endpoint.

IP The IP Address of the endpoint.

MAC Address The MAC address of the endpoints.

Description The description of the endpoint, if available.

Operating System The abbreviated name of the operating system detected on the endpoint.

OS Version The version number of the operating system running on the endpoint.

OS Service Pack The service pack level of the endpoint.
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Field Description

OS Build Number The build number of the operating system running on the endpoint.

Agent Information
The fields that appear in the Agent Information section of the Information tab contain agent status, version, and
connectivity details for the agent installed on the endpoint.

The Agent Information section displays the following agent data.

Table 91: Agent Information Field Descriptions

Field Description

Agent Version The agent version number defined for the endpoint.

Agent Installation Date (Server) The date and time on the server when the agent registered with Lumension
Endpoint Management and Security Suite. This is typically the date the
agent was installed on the endpoint.

Uninstall Password

(button)

Click View to view the uninstall password assigned to the endpoint.
See Viewing the Agent Uninstall Password on page 190 for more
information.

Status Information
The fields that appear in the Status Information section of the Information tab contain status and connectivity
details for the agent installed on the endpoint.

The Status Information section displays the following agent data.

Table 92: Status Information Field Descriptions

Field Description

Agent status Indicates the status of the endpoint (Online, Offline, or Disabled).

Last connected date
(Server)

The date and time on the server that the agent last communicated with Lumension
Endpoint Management and Security Suite.

LPR status The Patch and Remediation status for the endpoint.

Last DAU scan status The status of the Discover Applicable Updates (DAU) scan when last run. The
status also serves as a link to the Deployment Results page. Status values include:
Success, Failure followed by the failure code, and Not Available, which
indicates that the endpoint has not checked in.

Note:  The Not Available Last DAU Status does not serve as a hyperlink.

Last DAU scan time
(server)

The time of the last successful DAU scan. A value of Not Available indicates
the endpoint has not completed a DAU scan.
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Component Information
This table lists which module components are installed on the endpoint. It also lists additional information about
each module.

The following table describes each Component Information table column.

Table 93: Component Information Table

Column Description

Component Indicates the name of the applicable module.

Available with the Agent
Version

Indicates whether the module agent features are available for the installed agent
version.

Installed Indicates whether the module is installed on the endpoint.

Installation Date/Time
(Server)

Indicates the date and time on the server that the module was installed, if
applicable.

Running Version Indicates the version of the module installed on the agent.

Policy Version Indicates the version of the module that should be installed based on the agent
version defined in the applicable agent policy set.

Group Information
The fields that appear in the Group Information section of the Information tab contain group membership
details for the endpoint.

The Group Information section displays the following group data.

Table 94: Group Information Section Field Descriptions

Field Description

Group Name Indicates the name or the IP address of the group(s) that the endpoint is a
member of. Click the group name to go to the Group Information page.

Originating Group Indicates the name or the IP address of the parent group that the endpoint
is a member of. Click the originating group name to go to the Group
Information page.

Type Indicates the group type. This can be a system created groups (OS),
directory service, or custom group.

Deployments Applicable Indicates that there are applicable deployments available for this endpoint.

Added By Indicates the Lumension Endpoint Management and Security Suite user
who added the endpoint to the group. System created groups indicate
System in this field.
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Field Description

Date Added (Server) Indicates the date and time on the server that the endpoint was added to the
group.

Note:  If the values in the Group Name and the Originating Group fields are the same, then the endpoint is an
actual (not inherited) member of that group. In addition, actual group members are shaded in white and appear at
the top of the Group Information list. Groups that are shaded in gray are inherited.

Policy Information
The fields that appear in the Policy Information section of the Information tab contain details about the policies
used by the endpoint during a deployment.

These policies are the results of applying each of the policies defined by the endpoint’s group membership and
filling in any undefined policies from the Global Policy. Conflict resolution rules are applied when applicable.

Table 95: Policy Information Field Descriptions

Name Description

Agent uninstall protection Indicates whether agent uninstall protection is on.

Hide agent control panel Indicates whether the Agent Control Panel is hidden from an endpoint
user when they log on to their system. Any dialog or notification
launched by the Lumension EMSS agent will also be hidden until
the Agent Control Panel is started manually using Windows Control
Panel.

Core: Download files via HTTP Indicates whether the Lumension EMSS Agent downloads files via
HTTP rather than HTTPS. All other communication occurs over
HTTPS.

Maximum Log File Size Specifies the maximum size of the Lumension EMSS agent log before
it is deleted.

Logging Level Indicates the level of detail recorded in the Lumension EMSS Agent.
The following values indicate each logging level: Critical = 0, Error =
1, Normal = 2, Diagnostic = 3, Trace = 4.

Show alerts on endpoints Indicates whether alerts and notifications are shown to endpoint users.

Core: Heartbeat Interval Indicates the interval at which the Endpoint Service sends a heartbeat
to the server (in minutes).

Core: Receive Interval Indicates the interval at which the Endpoint Service communication
receive delay intervals (in seconds).

Core: Timeout Interval Indicates the interval at which the Endpoint Service communication
receive time intervals (in seconds)
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Name Description

Core: Send Interval Indicates the interval at which the Endpoint Service communication
send delay intervals.

Patch and Remediation only

Maximum Transfer Rate Indicates the maximum bandwidth used when an agent downloads
packages. A setting of 0 disables bandwidth throttling.

Minimum File Size Indicates the smallest file size that will be impacted by bandwidth
throttling.

Agent Scan Mode Indicates the agent detection scan mode (0 = Slow, 1 = Fast the first
time, 2 = Fast).

Scheduling Frequency Indicates the number of hours between regularly scheduled detection
scans.

Deployment: User May Cancel Indicates whether the user can cancel a deployment (Y, N).

Deployment: Always on Top Indicates whether the notification will be the topmost window (Y, N).

Deployment: Deploy Within Indicates the defined time frame (in minutes) during which the user
may snooze or cancel a reboot.

Deployment: User May Snooze Indicates whether the user can snooze a deployment.

Resume Interrupted Downloads Indicates whether resumable downloads are enabled (0 = No, 1 = Yes).

Patch: Fast Path Interval Indicates the interval (configurable in minutes, hours, and
days) between each check by FastPath to determine the fastest
communication path back to the Lumension EMSS server.

Patch: Fast Path Servers Indicates the available Fast Path routes.

Patch: Download packages via
HTTP

Indicates if the agent downloads packages using HTTP, regardless of
whether HTTPS is used for agent to server communication.

Agent Listener Port Indicates the agent listener port. When the agent is contacted on this
port, it responds with its version number and initiates communication
with the Lumension EMSS server. A value of 0 turns the agent listener
off.

Reboot: User May Cancel Indicates whether the user can cancel a reboot (Y, N).

Reboot: Always on Top Indicates whether the notification will be the topmost window (Y, N).

Reboot: Reboot Within Indicates the defined time window (in minutes) during which the user
may snooze or cancel a reboot.

Reboot: User May Snooze Indicates whether the user can snooze a reboot (Y, N).
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Name Description

Patch: Agent to Server
Communication Protocol

Defines how the agent will communicate with the server (http:// or
https://).

Patch: Communication Interval Indicates the time period between agent communication attempts.

Hours of Operation Monday Defines the agent Hours of Operation (HOP) for Monday.

Hours of Operation Tuesday Defines the agent HOP for Tuesday.

Hours of Operation Wednesday Defines the agent HOP for Wednesday.

Hours of Operation Thursday Defines the agent HOP for Thursday.

Hours of Operation Friday Defines the agent HOP for Friday.

Hours of Operation Saturday Defines the agent HOP for Saturday.

Hours of Operation Sunday Defines the agent HOP for Sunday.

InventoryCollectionOptions: BIOS Indicates whether BIOS data will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions: CPU Indicates whether CPU data will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions:
CUSTOM

Indicates whether custom inventory data will be gathered during agent
inventory collection (OFF or ON).

InventoryCollectionOptions:
DISK_DRIVES

Indicates whether data regarding the disk drives will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
ENABLE_WMI

Indicates whether WMI data will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions:
HW_DEV_OTHER

Indicates whether the Windows registry will be scanned for additional
hardware information during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_IDE_CONTROL

Indicates whether data regarding IDE ATA/ATAPI controllers will be
gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_NETWORK_ADAPT

Indicates whether data regarding network adapters will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_NON_PNP

Indicates whether data regarding non-Plug and Play drivers will be
gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_SND_GAME

Indicates whether data regarding sound, video, and game controllers
will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_SYS_DEV

Indicates whether system device data will be gathered during agent
inventory collection (OFF or ON).
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Name Description

InventoryCollectionOptions:
HW_USB

Indicates whether data regarding USB endpoint's inventory (from
\ENUM\USB) will be gathered during agent inventory collection (OFF
or ON).

InventoryCollectionOptions:
HW_USB_CONTROL

Indicates whether data regarding USB controllers will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_USB_STORAGE

Indicates whether data regarding USB device inventory (from \ENUM
\USBSTOR) will be gathered during agent inventory collection (OFF or
ON).

InventoryCollectionOptions:
LAST_REBOOT

Requires ENABLE_WMI = ON: Indicates whether the last boot time
will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
LAST_USER

Indicates whether last logged in user and time will be gathered during
agent inventory collection (OFF or ON).

InventoryCollectionOptions:
MANUF_MODEL

Requires ENABLE_WMI = ON: Indicates whether the computer
manufacturer and model will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions:
OS_SERIAL

Requires ENABLE_WMI = ON: Indicates whether the OS serial
number will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
PC_ASSET_TAG

Requires ENABLE_WMI = ON: Indicates whether the endpoint's asset
tag will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
PC_SERIAL

Requires ENABLE_WMI = ON: Indicates whether the endpoint's
serial number will be gathered during agent inventory collection (OFF
or ON).

InventoryCollectionOptions: RAM Indicates whether the endpoint's total physical RAM will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
SERVICES

Indicates whether a listing of Windows services (not applicable for
Windows 9x or ME) will be gathered during agent inventory collection
(OFF or ON).

InventoryCollectionOptions:
SOFTWARE

Indicates whether a listing of installed software will be gathered during
agent inventory collection (OFF or ON).

InventoryCollectionOptions:
VIRTUAL

Indicates whether the endpoint's virtualization status will be gathered
during agent inventory collection (OFF or ON).

Note:  This reference table does not list the Value contained in the agent policy set details. This column
(which appears in the user interface) contains values that agent policies are set to.
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The Vulnerabilities Tab
The Vulnerabilities tab displays vulnerability information associated with the selected endpoint. The page
displays the same information as is presented in the Vulnerabilities page, although filtered for the endpoint.

Figure 66: The Vulnerabilities Tab

The Vulnerabilities Tab Toolbar
The Vulnerabilities tab toolbar contains the tasks and functions that are available for you to perform on managed
endpoints.

The following table describes the toolbar functions used in the Vulnerabilities tab.

Table 96: Vulnerabilities Tab Toolbar Functions

Button Function

Enable Enables a selected disabled vulnerability. For additional information, refer
to Enabling Content on page 192.

Disable Disables a selected enabled vulnerability. For additional information, refer
to Disabling Content on page 192.

Update Cache Updates the package cache for selected packages. For additional
information refer, to Updating the Cache on page 193.

Deploy... Opens the Deployment Wizard. For additional information, refer to
Deploying Content (Endpoint Details Page) on page 193.

Scan Now... Prompts the Discover Applicable Updates task to launch immediately and
scan all agent-managed endpoints within your network for vulnerabilities.
For additional information, refer to Using Scan Now to Scan Inventory
(Endpoint Details Page) on page 198.

Reboot Now... Prompts the selected endpoint to reboot. For additional information, refer
to Rebooting the Endpoint on page 198.
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Button Function

Export Exports the page data to a comma separated value (.csv) file. For
additional information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options
Menu on page 53.

The Vulnerabilities Tab List
The Vulnerabilities tab list tracks package name, cache status, content type, and deployment data.

The following table describes each list column.

Table 97: Column Definitions

Column Icon Definition

Status  

 

Indicates the content item status.

Package Status  

 

Indicates the content item package status.

Name Indicates the content item name.

Content Type Indicates the content item type.

Number of endpoints
which came up
Patched

 

 

Indicates the total number of endpoints that are patched.

Number of endpoints
which came up Not
Patched

 

 

Indicates the total number of endpoints that are not patched.

Number of endpoints
which came up Error

 

 

Indicates the total number of endpoints that returned an error.
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Column Icon Definition

Number of endpoints
which are detecting

 

 

Indicates the total number of endpoints that are in the process of detecting
(whether the endpoint is patched or not patched).

Total number of
endpoints assigned

 

 

Indicates the total number of assigned or impacted endpoints.

Total Percent
Complete

 

 

Indicates the percentage of the endpoints that have completed the detection =
[(Total Patched + Total Not Patched) / Total Assigned endpoints.]

The Inventory Tab
The Inventory tab displays the inventory information for the selected endpoint. Inventory is organized by
hardware device class. The page displays the same information as is presented in the Inventory page.

Figure 67: Inventory Tab

The Inventory Tab Toolbar
The Inventory tab toolbar contains functions that allow you to detect inventory on managed endpoints.

The following table describes the toolbar functions used in the Inventory tab.

Table 98: Device Inventory Tab Toolbar Functions

Toolbar Item Description

Scan Now... Prompts the discover applicable updates (DAU) task to launch on the
endpoint. For additional information, refer to Using Scan Now to Scan
Inventory (Endpoint Details Page) on page 198.
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Toolbar Item Description

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options
Menu on page 53.

The Inventory Tab List
The Inventory tab lists endpoint inventory by hardware device class. View this tab to an endpoint's
specifications.

Table 99: Column Definitions

Icon Definition

Hardware Device
Class

Indicates the hardware device class.

Each Hardware Device Class can be expanded to list class devices found on managed endpoints. To expand a
class, click the rotating chevron (>). The following tables describes the columns that display after expanding a
class.

Table 100: Expanded Class Column Definitions

Column Definition

Device Indicates the hardware devices found for the class.

Computer Icon Indicates the number of endpoints that host the device.
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The Deployments and Tasks Tab
The Deployments and Tasks tab lists the deployments assigned to an endpoint and their status. Deployments
remain listed until deleted.

Figure 68: Deployments Tab

The Deployments and Tasks Tab Toolbar
The Deployments and Tasks tab toolbar contains buttons that let you control existing deployments and export
deployment data.

The following table describes each toolbar button.

Table 101: Deployments and Tasks Tab Toolbar Functions

Menu Item Function

Enable Enables the selected disabled deployment.  For additional information, refer
Enabling Deployments on page 195.

Disable Disables the selected deployment. For additional information, refer to Disabling
Deployments on page 195.

Abort Cancels the deployment or task for any endpoints which have not already received
the deployment package. For additional information, refer to Aborting Deployments
on page 196.

Delete Removes the deployment from your Lumension Endpoint Management and
Security Suite. For additional information, refer to Deleting Deployments on page
196.

Deploy... Opens the Deployment Wizard. For additional information, refer to Deploying
Content (Endpoint Details Page) on page 193.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.
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Menu Item Function

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Deployments and Tasks Tab List
The Deployments and Tasks tab list contains a record of each deployment for the endpoint. Each list item
remains until deleted.

The following table describes each list column.

Table 102: Deployments and Tasks Tab List Column Descriptions

Column Icon Description

Status and Type Contains an icon that indicates the deployment status and type. For
additional information, refer to Deployment Type on page 220.

Name Indicates the name of the deployment task. Typically, the name of the
vulnerability or task deployed. Clicking on the deployment name displays
the Deployment Details page. For addition information, refer to The
Deployment Details Page on page 256.

Scheduled Date Indicates the date the deployment was scheduled to occur.

Number of
Endpoints/Groups
which were
Successful

 

 

Total number of endpoints or groups that finished the deployment
successfully.

Number of
Endpoints/Groups
which Failed

 

 

Total number of endpoints or groups that finished the deployment
unsuccessfully.

Number of
Endpoints/Groups
assigned to the
Deployment

 

 

Total number of endpoints or groups that are assigned to the deployment.

Number of
Endpoints/Groups
which are In
Progress

 

 

Total number of endpoints or groups that are in the process of executing the
deployment.

Number of
Endpoints/Groups
which have
Completed the
Deployment

 

 

Total number of endpoints or groups that finished the deployment.
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Column Icon Description

Percentage Complete  

 

Percentage of the endpoints or groups that finished the deployment.
Percentage = [Total Finished endpoints / Total Assigned endpoints]

Viewing Deployment and Task Results
Once the deployment or task is complete, the specific results can be displayed by clicking on the status text (of
the Last Run Status column).

Figure 69: Deployment Results

The fields displayed on the Deployment Results tab are defined as follows.

Table 103: Deployment Information Fields

Field Description

Package Name Indicates the name of the package that was deployed.

Deployment Indicates the deployment type.

Associated Impact Indicates if the package is associated with a deployment and displays the
impact of the associated content.

Deployment Status Indicates the overall deployment status information.

Last Run Results Indicates the results of the last time the endpoint performed the
deployment.

Next Run Date Indicates if the deployment is recurring and displays the date when the
endpoint is to perform the deployment again.

Last Run Date Indicates the status of the last time the endpoint performed the
deployment.

Last Run Start Date Indicates the date when the endpoint last started the deployment.

Last Run Completed Date Indicates the date when the endpoint last finished the deployment.
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Working with the Endpoint Details Page
You can perform a number of tasks related to endpoints from the Endpoint Details page. You perform most of
these tasks regardless of the tab selected. However, certain tasks are specific to certain tabs.

To perform mosts tasks associated with endpoints, click a toobar button. To perform some tasks, selecting one or
multiple endpoints from the page list may be necessary.

The following list displays the tasks you can perform from the Endpoint Details page.

• Viewing the Agent Uninstall Password on page 190
• Enabling Content on page 192
• Disabling Content on page 192
• Defining the Endpoint Agent Version (Endpoint Details) on page 191
• Updating the Cache on page 193
• Deploying Content (Endpoint Details Page) on page 193
• Enabling an Endpoint on page 194
• Disabling an Endpoint on page 194
• Managing Endpoint Modules on page 197
• Enabling Deployments on page 195
• Disabling Deployments on page 195
• Aborting Deployments on page 196
• Deleting Deployments on page 196
• Using Scan Now to Scan Inventory (Endpoint Details Page) on page 198
• Rebooting the Endpoint on page 198
• Exporting Endpoint Information on page 199

Viewing the Agent Uninstall Password
The uninstall password for an endpoint is required to remove the agent locally from the endpoint. Enter this
password when uninstalling the agent.

View the agent uninstall password from the endpoint's Endpoint Details page Information tab.

1. Select Manage > Endpoints.

Step Result: The Endpoints page displays.

2. Click the link in the Name column that corresponds to the endpoint for which you want to uninstall the agent
password for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.
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3. Click View.

Step Result: Agent Uninstall Password dialog displays.

Figure 70: Agent Uninstall Password Dialog

4. Click Close to close the Agent Uninstall Password dialog.

The Agent Uninstall Password Dialog
The Agent Uninstall Password dialog contains the endpoint's name and the password that is required to uninstall
the agent locally from an endpoint.

The following table describes the fields that appear on the Agent Uninstall Password dialog.

Table 104: Agent Uninstall Password Dialog Fields

Field Description

Endpoint name The endpoint's name.

Agent uninstall password The password required to uninstall the agent from the endpoint locally.

Defining the Endpoint Agent Version (Endpoint Details)
From the Endpoint Details page, you define which version(s) of the Lumension Endpoint Management and
Security Suite Agent can be installed on the endpoint.

Define agent version(s) for the endpoint from the endpoints from Information tab.

1. Select Manage > Endpoints.

Step Result: The Endpoints page opens to the All tab.
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2. Click the link associated with endpoint you want to define agent version(s) for.

Step Result: The Endpoint Details page for the endpoint opens to the Information tab.

3. Click Agent Versions.

Step Result: The Manage Agent Versions dialog opens.

4. Select an agent version from the Agent Version list.

Note:  The agent versions available for selections are defined from the Options page. For additional
information, refer to Configuring the Agents Tab on page 132.

5. Click OK

Result: The Manage Agent Versions dialog closes. If an agent version other than the defined version is
installed on the endpoints, the defined version is installed over the previous version.

Enabling Content
After disabling a content item, you can renable it from the Vulnerabilities tab. You can only deploy enabled
content.

You can re-enable content from the Endpoint Details page Vulnerabilities tab.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to enable content for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Vulnerabilities tab.

4. [Optional] Use the page filters to sort content.

5. Select one or multiple disabled content items from the list.

6. Click Enable.

Result: The content item displays with the Enabled icon in the status column.

Disabling Content
Disabling a content item will prevent that content item from being deployed.

You can disable content from the Endpoint Details page Vulnerabilities tab.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to disable content for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Vulnerabilities tab.

4. [Optional] Use the page filters to sort content.
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5. Select one or multiple content items from the list.

6. Click Disable.

Result: The content item displays with the disabled icon in the status column.

Updating the Cache
Updating the cache initiates a process that gathers the packages associated with the selected vulnerability and
copies those packages to your Lumension Patch and Remediation Server.

You can update the cache for content from the Endpoint Detail page Vulnerabilities tab.

Note:  For optimum installation order, Lumension recommends caching content prior to deployment. Failure
to cache content prior to deployment may result in repeated endpoint reboots that interrupt work flow on those
endpoints.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to cache content for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Vulnerabilities tab.

4. [Optional] Use the page filters to sort content.

5. Select the check boxes associated with the content to cache.

6. Click Update Cache.

Step Result: The Warning dialog box opens, informing you that the update request and this action may take
an extended period of time.

7. Click OK.

Result: The selected content begins caching.

Deploying Content (Endpoint Details Page)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the tabs of the Endpoints Details page. When deploying from this page, the Deployment Wizard is
preconfigured according to tab you deploy from.

For additional information, refer to About Deployments on page 213.

1. Select Manage > Endpoints.

2. Select the Patch and Remediation tab.

3. Click the link in the Name column that corresponds to the endpoint for which you want to deploy content for.

Step Result: The Endpoints Details page opens.
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4. Deploy content.

To deploy content, select a tab and complete the applicable substeps. Tab selection controls how the
Deployment Wizard is preconfigured for deployment.

Tab Steps

To deploy content from the
Information tab:

1. Ensure the Information tab is selected.
2. Click Deploy

The Deployment Wizard opens, preconfigured to deploy content to the
selected endpoint.

To deploy content from the
Vulnerabilities tab:

1. Select the Vulnerabilities tab.
2. Select the content you want to deploy.
3. Click Deploy

The Deployment Wizard opens, preconfigured to deploy the selected
content to the selected endpoint.

To deploy content from the
Deployments and Tasks page:

1. Select the Deployments and Tasks tab.
2. Click Deploy.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Enabling an Endpoint
Enabling an endpoint includes the endpoint in the content management activities of the Lumension Endpoint
Management and Security Suite.

You can enable an endpoint from the Endpoint Details page.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint that you want to enable.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Click Enable.

Result: The endpoint is enabled.

Disabling an Endpoint
Disabling an endpoint stops agent functions on an endpoint. Disabled endpoints are not included in security
management activity.

You can disable an endpoint from the Endpoint Details page.
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1. Select Manage > Endpoints.

2. Click the link in the  Name column that corresponds with the endpoint you want to disable.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Click Disable.

Step Result: A disable confirmation dialog displays.

4. In the confirmation dialog box, click OK.

Result: The endpoint is disabled. After disabling an agent, the endpoint can be deleted from Lumension
Endpoint Management and Security Suite.

Note:  Once disabled, the endpoint may not appear in the Endpoints page list based on the Status filter
settings. To include disabled devices in the list, ensure you select Disabled or All in the Status filter.

Enabling Deployments
Enabling deployments resumes disabled (or paused) deployments to continue.

You can enable deployments from the Endpoint Details page Deployments and Tasks tab.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to enable
deployments for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Deployments and Tasks tab.

4. [Optional] Use the page filters to sort deployments.

5. Select the disabled deployments you want to enable.

6. Click Enable.

Result: The selected deployments are enabled.

Disabling Deployments
Disabling deployments pauses deployments and stops the distribution of package(s) to an endpoint that has not
already received the deployment.

You can disable deployments for a specific endpoint from the Endpoint Details page Deployments and Tasks
tab.

Note:  You cannot disable deployments of system task packages.

1. Select Manage > Endpoints.
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2. Click the link in the Name column that corresponds to the endpoint for which you want to disable
deployments for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Deployments and Tasks tab.

4. [Optional] Use the page filters to sort deployments.

5. Select the deployments you want to disable.

6. Click Disable.

Result: The selected deployments are disabled.

Aborting Deployments
Aborting deployments cancels deployments for the endpoint that has not already received the deployment.

Note:  The endpoints that have already received the deployment will not be affected. The deployment will be
aborted for endpoints that have not yet received the deployment.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to abort deployments
for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Deployments and Tasks tab.

4. [Optional] Use the page filters to sort deployments.

5. Select the deployments you wish to abort.

6. Click Abort.

Step Result: A confirmation message displays, asking you to confirm that you want to abort the
deployment.

7. Click OK to confirm that you want to abort the deployment.

Result: The selected deployment is canceled.

Note:  You cannot abort system tasks or Mandatory Baseline deployments.

Deleting Deployments
Deleting deployments removes them from Lumension Endpoint Management and Security Suite. Delete a
deployment if you to prevent its content from reaching endpoints.
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You can delete deployments for individual endpoints from their Endpoint Details page Deployments and Tasks
tab.

Note:  Deleting deployments has no effect on endpoints that have already received the deployments. You cannot
delete system task deployments.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to delete
deployments for.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Select the Deployments and Tasks tab.

4. [Optional] Use the page filters to sort deployments.

5. Select the deployments you want to delete.

6. Click Delete.

Step Result: A confirmation message displays, asking you to confirm that you want to delete the selected
deployments.

7. Click OK to delete the deployments.

Managing Endpoint Modules
You may select which modules licenses an endpoint's agent uses. Using this feature allows you control which
modules apply to a particular endpoint.

Manage modules for individual endpoints from the Add/Remove Modules dialog.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds to the endpoint for which you want to manage endpoint
modules.

Step Result: The Endpoints Details page opens with the Information tab selected by default.

3. Click Manage Modules.

Step Result: The Add/Remove Modules dialog opens.

4. Manage modules for each endpoint.

• To add a module to a particular endpoint, select the module checkbox for the applicable endpoint.
• To remove a module from a particular endpoint, clear the module checkbox for the applicable endpoint.

Tip:  Select or clear the Select All check box(es) associated with a module to globally toggle a module for all
endpoints.
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5. Click OK.

Result: The Add/Remove Modules dialog closes. The agent features for each edit are updated during the next
Discover Applicable Updates task.

Using Scan Now to Scan Inventory (Endpoint Details Page)
You can initiate a discover applicable updates (DAU) task at any time. When you initiate this task, the agent
scans its host endpoint for vulnerabilities and inventory. Scan results are then uploaded to the Lumension
Endpoint Management and Security Suite server, which you can view.

You can schedule a DAU task for the selected endpoint from most Endpoint Details page tabs.

1. Select Manage > Endpoints.

2. Select the Patch and Remediation tab.

3. Click the Endpoint Name link of the endpoint you want to schedule a DAU task for.

Step Result: The Endpoint Details page for the endpoint opens.

4. Select one of the following tabs:

• Information
• Vulnerabilities
• Inventory

5. From the toolbar, click Discover Applicable Updates.

Note:  If scheduling from the Information tab, select Scan Now > Discover Applicable Updates.

6. Select the Yes, scan the selected endpoint check box.

7. Click Schedule.

8. Acknowledge the scheduling by clicking Close.

Result: The scan is scheduled. As with all deployments, although the Discovery Applicable Updates task is
scheduled for immediate execution. It will not actually occur until the next time the agent checks in.

Rebooting the Endpoint
You may reboot an endpoint at any time. Rebooting an endpoint may be necessary following some deployments.

You can reboot an individual endpoint from its Endpoint Details page Information tab.

1. Select Manage > Endpoints.

2. Click the link in the Name column that corresponds with the endpoint you want to reboot.

3. Select one of the following tabs:

• The Information tab
• The Vulnerabilities tab
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4. Click Reboot Now.

Step Result: The Reboot Now dialog opens.

Figure 71: Reboot Now Dialog

5. Select the Yes, Reboot the selected device check box.

6. Click Reboot.

Step Result: The system schedules the reboot.

7. Click Close.

Result: The window closes.

Figure 72: Reboot Now - Success

Exporting Endpoint Information
You can export the endpoint information generated in the Lumension Endpoint Management and Security Suite
so that it can be used in other applications.

The export utility lets you export endpoint information to a comma-separated value (.CSV) file format. For
additional information, refer to Exporting Data on page 60.
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Chapter

8
Using Inventory

In this chapter:

• About Inventory

• The Inventory Page

• The Endpoints with Inventory Page

• Using Custom Inventory

After installing agents on network endpoints, you can view a list
of operating systems, software applications, hardware devices, and
services installed and running on the endpoints registered to the
Lumension EMSS server. This list is known as inventory.

The Inventory page lists all inventory devices found in the your
network. You can use this page to track the devices installed on
specific endpoints.

About Inventory
Inventory captures a comprehensive view of the functional components of each agent. An inventory list of
software, hardware, operating systems, and services installed on an endpoint can be retrieved. The inventory list
displays items by inventory type.

In addition to viewing the list of inventory items, the inventory results can be exported to a file (.CSV). Inventory
information is also available at the endpoint and group level.

Note:  Lumension Endpoint Management and Security Suite only captures inventory data for endpoints that
have the agent installed.

Viewing Inventory
After you have installed an agent on an endpoint, you can view the endpoint's inventory.

1. Select Manage > Inventory.

Step Result: The Inventory page displays.

2. Select your filter options.

3. Click Update View.

Step Result: The inventory results display.

4. Click the applicable rotating chevron (>) to view the details of a particular inventory Class.
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The Inventory Page
The Inventory page displays an inventory list. You can filter this list to display operating systems, software,
hardware, or services detected in your network.

Unlike most list pages, which feature static columns, the Inventory page list columns that change based on how
you filter the page. Select different items from the Type filter to change the list columns.

Figure 73: Inventory Page

The following topics describe the Inventory page list based on how you filter it:

• The Inventory Page List (Filtered for Operating Systems) on page 203
• The Inventory Page List (Filtered for Software) on page 204
• The Inventory Page List (Filtered for Hardware) on page 204
• The Inventory Page List (Filtered for Services) on page 205

The Inventory Page Toolbar
The Inventory page toolbar contains functions that are allow you to detect inventory on managed endpoints.

The following table describes the toolbar functions used in the Inventory page.

Table 105: Endpoint Inventory Page Toolbar Functions

Toolbar Item Description

Scan Now... Prompts the discover applicable updates (DAU) task to launch for all
endpoints. For additional information, refer to Using Scan Now to Scan
Inventory (Inventory Page)  on page 207.
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Toolbar Item Description

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options
Menu on page 53.

The Inventory Page List (Filtered for Operating Systems)
When viewing the Inventory page, you can filter the page list to display information about all operating systems
detected in your network. Expanding list items displays the endpoints running the applicable operating system.

The following table describes the list that displays when the Operating Systems type is selected. Filtering using
this type displays information about the operating systems detected in your network. Click the (>) icon to expand
each list item.

Table 106: Inventory Page List (Filtered for Operating Systems)

Column Icon Description

Operating System The name of an detected within the network. A list item is available for
every operating system detected within your network. Each name is a link
to the Endpoints with Inventory page, which displays endpoints running the
applicable operating system.

Number of
Endpoints

The number of endpoints running the operating system.

The following table describes the information displayed when you expand an Inventory page list item (filtered
for operating systems). The expanded list item displays Information about each endpoint running the applicable
operating system.

Table 107: Expanded List Item (List Filtered for Operating Systems)

Column Description

Endpoint Status The icon representing the endpoint status. You can hover over the icon with your
mouse to get a text description of the endpoint status. For more information, refer
to Agent Module Status Icons on page 526.

Endpoint Name The name of the endpoint. Clicking the  Endpoint Name  link displays the
applicable Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.
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Column Description

OS Info Any additional information about the operating system. This column typically lists
any service packs installed.

The Inventory Page List (Filtered for Software)
When viewing the Inventory page, you can filter the page list to display information about all software installed
on endpoints in your network. Expanding list items displays the endpoints hosting the softwaree.

The following table describes the list that displays when the Software type is selected. Filtering using this type
displays each software program detected in the network. Click the (>) icon to expand each list item.

Table 108: Inventory Page List (Filtered for Software)

Column Icon Description

Software Programs The name of a software program detected in the network. The name is a link
to the Endpoint with Inventory page, which lists each endpoint hosting the
software program.

Number of
Endpoints

The number of endpoints hosting the software program.

The following table describes the information that displays when you expand an Inventory page list item (filtered
for software). The expanded list item displays Information about each endpoint hosting the software.

Table 109: Expanded List Item (List Filtered for Software)

Column Description

Endpoint Status The icon representing the endpoint status. You can hover over the icon with your
mouse to get a text description of the endpoint status. For more information, refer
to Agent Module Status Icons on page 526.

Endpoint Name The name of the endpoint. Clicking the  Endpoint Name  link displays the
applicable Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.

OS Info Any additional information about the operating system. This column typically lists
any service packs installed.

The Inventory Page List (Filtered for Hardware)
When viewing the Inventory page, you can filter the page list to display information about all hardware detected
in your network. Expanding list items displays the hardware devices found for a hardware class. Fully expanding
list items displays the endpoints that host a specific hardware device.
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The following table describes the list when the Hardware type is selected. Filtering using this type displays
information about all hardware classes. Click the (>) icon to expand each list item.

Table 110: Inventory Page List (Filtered for Hardware)

Column Description

Inventory Icon The icon representing the hardware device class.

Hardware Device
Classes

The hardware device classification.

The following table displays the information that displays when you expand an Inventory page list item (filtered
for hardware). The expanded list item displays Information about the applicable hardware device class. Each
item can be further expanded. Click the (>) icon to expand each device list item.

Table 111: Expanded List Item (List Filtered for Inventory)

Column Icon Description

Device The name of a hardware device detected in your network. The name is a link
to the Endpoint with Inventory page, which lists all endpoints hosting the
hardware device.

Number of
Endpoints

The number of endpoints hosting the hardware device.

The following table describes the information that displays for a fully expanded Inventory page list item (filtered
for hardware). The fully expanded list item displays information about each endpoint that hosts the applicable
hardware device.

Table 112: Expanded Hardware Device

Column Description

Endpoint Status The icon representing the endpoint status. You can hover over the icon with your
mouse to get a text description of the endpoint status. For more information, refer
to Agent Module Status Icons on page 526.

Endpoint Name The name of the endpoint. Clicking the  Endpoint Name  link displays the
applicable Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.

OS Info Any additional information about the operating system. This column typically lists
any service packs installed.

The Inventory Page List (Filtered for Services)
When viewing the Inventory page, you can filter the page list to display information about all service operating
in your network. Expanding list items displays the endpoints running the service.
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The following table describes the list that displays when the Services type is selected. Filtering using this type
displays information about services detected in the network. Click the (>) icon to expand each list item.

Table 113: Inventory Page List (Filtered by Services)

Column Icon Description

Service Name The name of a service operating in your network. Each name is a link to the
Endpoint with Inventory, which lists each endpoint running the applicable
service.

Number of
Endpoints

The number of endpoints running the service.

The following table describes the information that displays when you expand an Inventory page list item (filtered
for services). The expanded list item displays information about each endpoint running the applicable service.

Table 114: Expanded List Item (List Filtered for Services)

Column Description

Endpoint Status The icon representing the endpoint status. You can hover over the icon with your
mouse to get a text description of the endpoint status. For more information, refer
to Agent Module Status Icons on page 526.

Endpoint Name The name of the endpoint. Clicking the  Endpoint Name  link displays the
applicable Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.

OS Info Any additional information about the operating system. This column typically lists
any service packs installed.

About Scan Now (Scanning Inventory)
The Discover Applicable Updates (DAU) task scans an endpoint's inventory.

In addition to determining security risks and other vulnerabilities, the Discover Applicable Updates (DAU) task
also identifies the endpoint inventory. Each time the DAU runs, the current inventory is compared against the
<Program Files>\Lumension\Patch Agent\localprofile.txt file. If any changes exist, a differential
report is uploaded to the Lumension Endpoint Management and Security Suite server. The following is an
example local profile file (localprofile.txt).
<systemprofile> <computer>   <BuildNumber>2600</BuildNumber>   <Caption>Microsoft Windows XP
 Professional</Caption>   <CSDVersion>Service Pack 2</CSDVersion>   <Version>5.1.2600</Version>
   <computername>\\USER</computername>   <DAversion>7.2.x.xxx</DAversion>   <type>information</
type>   <agentid>XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX</agentid> </computer> <services>   <caption
 svcName="Fax" State="Stopped" Startup="Automatic">Fax</caption> </services> <devices>   <caption
 class="Monitors">Plug and Play Monitor</caption> </devices> <software>   <package>Windows
 Internet Explorer</package> </software></systemprofile>

The DAU task occurs at least once daily and following successful deployments.
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Using Scan Now to Scan Inventory (Inventory Page)
You can initiate a discover applicable updates (DAU) task at any time. When you initiate this task, the agent
scans its host endpoint for vulnerabilities and inventory. Scan results are then uploaded to the Lumension
Endpoint Management and Security Suite server, which you can view.

You can launch DAU tasks that scan all managed endpoints from the Inventory page.

1. Select Manage > Inventory.

2. Click Scan Now.

Step Result: The Scan Now dialog opens.

3. Select the Yes, scan all endpoints check box.

4. Click Schedule.

Step Result: A DAU task for all endpoints is scheduled

5. Click Close to dismiss the scheduling notification.

The Endpoints with Inventory Page
The Endpoints with Inventory page displays a list of managed endpoints that have a selected inventory item
installed on them. This page features functionality identical to the Endpoints page, but the Endpoint with
Inventory page is filtered to list only endpoints with the applicable endpoint.

Figure 74: The Endpoints with Inventory Page

For additional information about working with the Endpoints and Inventory page, refer to The Endpoints Page
on page 158.

Using Custom Inventory
To use a custom inventory file, you must create the custom inventory file in XML and distribute it to each agent.
There is no automated distribution method for custom inventory.

Each agent must have a local file named CustomInventory.xml, which should be located at the filepath
<Program Files>\Lumension\Patch Agent\CustomInventory.xml (for Windows Agents) or
<installdir>/update/conf.d/custominventory.xml (for Linux/Unix/Mac Agents).
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Guidelines for Linux/Unix/Mac-based Operating Systems
Using the syntax in this section, you can create custom inventory for Linux, Unix, or Mac-based operating
systems.

The following section defines the valid XML guidelines for setting up custom inventory scripts for Linux/Unix/
Mac based Operating Systems. In each case, the item will be added to the hardware inventory under the Default
device class unless a specific device class (item class="") is defined.

Literal
Allows the user to assign an actual text value type into XML.

The string added will be of the form "name = value" where name is the tag name, and value is the literal
typed between the open and close tags.

Example XML (This example will return the string value defined between the open and close tags):
<item class="User Defined" name="Example Name" type ="Literal">
    Lumension 7.3 SP1 Custom Inventory
</item>

Returns:
"Example Name = Lumension 7.3 SP1 Custom Inventory"

Dynamic
Allows the user to search using a script.

The string added will be of the form "name = value" where name is the tag name, and value is the result of
the script.

Example XML:
<item class="System" name="Lumension Disk Usage" type="dynamic">
    <command>
        <!-- Define shell -->
        <shell>
            <![CDATA[/bin/sh]]>
        </shell>
        <!-- Define execution directory -->
        <dir>
            <![CDATA[/tmp]]>
        </dir>
        <envs>
            <env>
                <!-- Define the JAVA HOME environment variable -->
                <EnvName>
                    <![CDATA[JAVA HOME]]>
                </EnvName>
                <EnvValue>
                    <![CDATA[/usr/local]]>
                </EnvValue>
            </env>
        </envs>
        <!-- Script -->
        <content>
            <![CDATA[echo -n 'du -ks /usr/local/work/Lumension \(in kb\)]]>
        </content>
    </command>
</item>
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Returns:
"Lumension Disk Usage = 18.1 (in kb)"d

Guidelines for Microsoft Windows-based Operating Systems
Using the syntax in this section, you can create custom inventory for Windows-based operating systems.

The following section defines the XML guidelines for setting up custom inventory scripts for Windows-based
operating systems. In each case, the item will be added to the hardware inventory under the default device class
unless a specific device class (item class="") is defined.

Literal
Allows the user to assign an actual text value type into XML.

The string added will be of the form "name = value" where name is the tag name, and value is the literal
typed between the open and close tags.

Example XML: (This example will return the string value defined between the open and close tags)
<item class="User Defined" name="Example Name" type="Literal">
    Lumension 7.3 SP1 Custom Inventory
</item>

Returns:
"Example Name = Lumension 7.3 SP1 Custom Inventory"

Registry
Allows the user to retrieve the registry key value.

The string added will be of the form "name = value" where name is the tag name and value is the value
stored under the identified registry key.

Example XML (This example will return, from the Registry, the location and name of the custom inventory file):
<item name="Registry Example" type="registry">
    HKEY_LOCAL_MACHINE\Software\PatchLink.com\DiscoveryAgent\InventoryInputFile
</item>

Returns:
"Registry Example= C:\ProgramFiles\Lumension\CustomInventory.xml"

Environment
Allows the user to return the value of an environment value.

The string added will be of the form "name = value" where name is the tag name and value is the expanded
environment variable defined.

Example XML (This example will return the value of the defined environment variable):
<item name="Environment Example" Class="User Defined" type="Environment">
    %PROCESSOR_ARCHITECTURE%
</item>

Returns:
"Environment Example = i386"
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WMI
Windows Management Instrumentation (WMI) allows the user to use scripting to control the WMI component,
and tends to focus on operating system settings.

In the case of a WMI item, two additional attributes, namespace and query are used. If the namespace attribute
is not specified, the default value of ROOT\CIMV2 is used. The query attribute must be defined as a valid WQL
query. The string added will be of the form "name = value" where name is the tag name and value is the
actual value for the specified WMI property.

Example XML (This example will return the Serial Number property from the Operating System):
<item name="Windows SN" type="wmi" query=" SELECT * FROM Win32_OperatingSystem">
    SerialNumber
</item>

Returns:
"Windows SN = ABCD-EFGH-IJKL"

Example XML (This example will retrieve the Manufacturer property of the device):
<item name="Device Manufacturer" type="wmi" query=" SELECT * FROM Win32_OperatingSystem">
    Manufacturer
</item>

Returns:
"Device Manufacturer = Computer Manufacturer A"

Text_File
Allows the user to retrieve text data from a file.

The string added will be of the form "name = value" where each line of the text file contains a Name/Value
pair separated with a delimiter (defined with the delimiter attribute). For each valid line, in the text file, an
entry will be added to inventory. When specifying a file name an environment variable, such as %WINDIR% can
be used.

Example XML (This example will return the Name/Value pairs from a TXTSample.txt file in the Windows
directory):
<item name="ti" type="text_file" delimiter="=">
    %WINDIR%\TXTSample.txt
</item>

Returns:
"Line 1 = This is line one" Line 2 = This is line two"

Note:  Each line item retrieved from the text file cannot exceed 200 characters. In the event that a line within
a defined text file exceeds 200 characters, Lumension recommends truncating the line item below the 200
character limit.

XML_File
Allows the user to retrieve text data from a file.

An external XML file will be referenced. The XML file structure must be defined by the XPath string. When
specifying an XML file name an environment variable, such as %WINDIR% can be used.
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Example XML (This example will return the value of the Asset Number tag from the SampleXML.xml file in the
Windows directory):
<item name="Asset" type="xml_file" xpath="/Top/Inventory/AssetNumber">
    %WINDIR%\SampleXML.xml
</item>

Returns:
"Asset = PLA001"

Example XML (This example will return the value of the Location tag from the SampleXML.xml file in the
Windows directory):
<item name="Building" type="xml_file" xpath="/Top/Inventory/Location">
    %WINDIR%\SampleXML.xml
</item>

Returns:
"Building = Scottsdale-Main"

Where the SampleXML.xml file is as follows:
<?xml version="1.0" encoding="utf-8"?>

<Top> 
    <Inventory> 
        <AssetNumber>PLA001</AssetNumber> 
        <Location>Scottsdale-Main</Location>
    </Inventory> 
</Top>

An example XML file, using the valid Windows agent inventory options, is provided below:
<?xml version="1.0" encoding="utf-8"?>

<customInventory> 
    <items>
        <item name="l1" class="User Defined" type="literal">
            value1
        </item> 
        <item name="r1"class="My New Class" type="registry">
            HKEY_LOCAL_MACHINE\Software\PatchLink.com\DiscoveryAgent\InventoryInputFile
        </item> 
        <item name="e1" class="My New Class" type="environment">
            %PROCESSOR_ARCHITECTURE%
        </item>
        <item 
            name="w1" 
            class="My New Class" 
            type="wmi" 
            namespace="ROOT\CIMV2" 
            query="SELECT * FROM Win32_OperatingSystem">
            SerialNumber
        </item>
        <item name="t1" class="My New Class" type="text_file" delimiter="=">
            c:\sampleInventoryText.txt
        </item>
        <item name="x1" class="My New Class" type="xml_file" xpath="//inventory/AssetTag">
            c:\sampleInventoryXML.xml
        </item> 
    </items> 
    </customInventory>

Where the C:\SampleInventory.txt file is as follows:
Building = MainLocation = Scottsdale, AZDivision = Corporate
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And the C:\SampleInventoryXML.xml file is as follows:
<?xml version="1.0" encoding="utf-8"?> 
    
    <inventory> 
        <AssetTag>
            PLA00012
        </AssetTag> 
    </inventory>
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Chapter

9
Managing Deployments and Tasks

In this chapter:

• About Deployments

• The Deployments and Tasks Page

• Working With Deployments and
Tasks

• Using the Deployment Wizard

• The Deployment Details Page

A deployment initiates the download of security content by the agent
to an endpoint for installation. It is the instruction set for a package,
supplying an agent with the rules and conditions for deployment.

A deployment comprises all the information needed to perform the
task(s) associated with the content. This includes required files and
scripts for installing content, stopping a service, validating a system
condition, or changing a database entry. The deployment is the
mechanism that carries and supports a package.

A task is a deployment that initiates a system task. It contains no
software or patches. Use tasks to reboot network endpoints or initiate
DAU tasks.

About Deployments
The term deployment refers to the process of sending content items to managed endpoints.

Several key concepts and status indicators are associated with a deployment. These concepts are used to define
deployment behavior.

The following sections include some of the key concepts and indicators that give definition to a deployment.

Explaining Deployment
Distribution Order on page
214

The order that the deployment is submitted to target endpoints.

Deployment Types on page
214

Deployments can be based on content, packages, or a Mandatory Baseline.

Standard and Chained
Deployments on page 215

Deployments are processed as either standard or chained.
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Explaining Deployment Distribution Order
When deploying more than one package to an individual endpoint or group of endpoints, the deployments
can be scheduled to process at different times. Order is also influenced by deployment type, status, and reboot
requirements.

Important:  You must install an agent on an endpoint in order to deploy content to the endpoint. A deployment
is assigned to the agent installed on an endpoint.

Deployments proceed in the following order prior to regularly scheduled system tasks and agent processes:

1. Chained deployments
2. Standard deployments
3. System Task: Reboot
4. Task – Reboot System
5. Discover Applicable Updates (DAU)

Although no deployment occurs before its scheduled time, a chained deployment whose scheduled time has
elapsed will always precede a standard deployment whose scheduled time has also elapsed.

If multiple chained deployments are scheduled and some endpoints have the final reboot suppressed, the
determination of a reboot override is based on the last scheduled deployment.

Deployment Types
Deployments are based on the content-type being deployed and how the content is being deployed. Deployment
types include vulnerability-based, package-based, and mandatory baseline-based.

Vulnerability-Based
Deployment

A vulnerability contains multiple associated packages and the target
packages to be deployed. The Discover Applicable Updates process
scans an endpoint for assigned vulnerabilities as Lumension Endpoint
Management and Security Suite determines whether they are applicable to
the endpoint. Based on these results, a Lumension Endpoint Management
and Security Suite user can determine which endpoints should receive
the patch (vulnerability fix). Behind the scenes, Lumension Endpoint
Management and Security Suite ensures the endpoints are assigned the
correct package.

Package-Based Deployment A package contains all vendor-supplied updates and executable code used
to correct or patch security issues for the target endpoints. The majority of
packages are part of specific vulnerabilities, and are deployed to multiple
endpoints within the network. For additional information, refer to About
Packages on page 399.
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Mandatory Baseline-Based
Deployment

The Mandatory Baseline defines a standard level of vulnerabilities or
locally-created packages that must be installed to a group membership.
The Mandatory Baseline comprises the base set of patches, packages, and
other content required for the target endpoint. In terms of vulnerabilities,
a Mandatory Baseline is checked continuously to verify and validate that
the patch identified by the baseline is installed. If the correct patch is not
installed, the patch is deployed and installed. For additional information,
refer to About Mandatory Baselines on page 290.

Standard and Chained Deployments
Deployments come in two varieties: standard deployments and chained deployments.

Standard Deployment A standard deployment is a deployment that has not been chained with
another deployment. While not all standard deployments require a reboot,
if the included package does require one and the reboot is suppressed, the
endpoint will not accept additional deployments until it is rebooted.

Chained Deployment A chained deployment is a deployment grouped with other deployments
so the endpoint will not reboot after each one. Following the first chained
deployment, the endpoint will accept only chained deployments until
rebooted.

Reboot and Chained State
The reboot and chained states are the result of an endpoint not performing the required reboot following a
deployment.

Table 115: Reboot and Chained State

State Description

Reboot State Indicates that the endpoint received a standard deployment requiring a
reboot, but the reboot was suppressed. While in the reboot state, the agent
only accepts deployments. A reboot deployment or a manual reboot clears
this state.

Chained State Indicates that the agent received a chained deployment in which the reboot
was suppressed. While in the chained state, the agent only accepts another
chained deployment or a reboot deployment.
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The following deployments always perform a reboot.

Table 116: Reboot Deployments

Deployment Description

Reboot System Package A system task that is automatically added to the end of chained
deployments where the final reboot is not suppressed. This is also sent to
agents when you click the Reboot Now button on the Endpoints page.

Task - System Reboot A task that permits the user to schedule a reboot using the scheduling
features of the Schedule Deployment Wizard.

Standard packages reboot for one of the following reasons:

• The deployed package required and forced the reboot (unless suppressed), during the installation.
• The package installer determined that it required a reboot.
• The reboot flag was sent to the agent. It is not necessary that the agent receive the Reboot System Package or

Task. The agent performs the reboot on its own.

The Deployments and Tasks Page
Deployments and system tasks are reviewed on the Deployments and Tasks page. The page list displays each
deployment job and the individual deployments or scans assigned to it.

Figure 75: Deployments and Tasks Page

• For additional information about deployments, refer to About Deployments on page 213.

Viewing Deployments and Tasks
There are several pages within the Lumension Endpoint Management and Security Suite from which you can
view deployments and system tasks. Based on the page from which you are viewing deployments, deployments
may be organized by content type, endpoints, groups, or deployments themselves.
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You can view deployments and system tasks on the following pages:

Table 117: Deployment Pages

Navigation Menu Menu Item Menu Sub-Item

All

Critical Vulnerabilities

New Vulnerabilities

Vulnerabilities

Top Vulnerabilities

All

Service Packs

Software Installers

Software

Updates

All

Detection Only

Informationals

Packages

Policies

Recommended

System Management

Tasks

Review

Other

Virus Removal

Endpoints (Patch and
Remediation tab)

Endpoints Endpoint Details (Vulnerabilities
tab, Deployments and Tasks tab)

Note:  To access this page,
click an endpoint link from the
Endpoints page list.

Group Membership view

Endpoint Membership view

Manage

Groups

Vulnerabilities view
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Navigation Menu Menu Item Menu Sub-Item

Deployments and Tasks view

Deployments and Tasks

Viewing All Deployments and Tasks
You can view all deployments and system (either executed or scheduled) within Lumension Endpoint
Management and Security Suite from the Deployment and Tasks page. This page displays all system
deployments, regardless of the page used to schedule the deployment.

View all system deployments and tasks from the Deployments and Tasks page.

Note:  Recurring Virus and Malware Scans do not appear on this page.

1. Select Manage > Deployments and Tasks.

Step Result: The Deployments and Tasks page opens.

Figure 76: Deployments and Tasks Page

2. [Optional] Select the desired filter criteria and click Update View.

3. [Optional] To view the details for a deployment or task, expand a list item by clicking a rotating chevron (>).

Viewing Deployments and Tasks within Endpoints
You can view the deployments and tasks assigned to a specific endpoint from its Endpoint Details page. This
page shows only the deployments for the selected endpoint, not the entire system.

View the deployments and tasks for an endpoint from the Endpoint Details page Deployments and Tasks tab.

1. Select Manage > Endpoints.

2. Select your filter options and click Update View.

Step Result: The applicable endpoints display in the Endpoints page.

3. Click the link for an endpoint with at least one deployment or task to view its details.

Step Result: The Endpoint Details page opens.
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4. Select the Deployments and Tasks tab.

Step Result: The Deployments and Tasks tab opens.

Figure 77: Endpoint Deployments and Tasks Tab

5. [Optional] To view details for a deployment or task, expand it by clicking the applicable rotating chevron (>).

Result: The deployment details display.

Figure 78: Deployments and Tasks Tab Expanded

Viewing Deployments and Tasks within Groups
You can view deployments and tasks for specific endpoint groups from the Groups page. When viewing group
deployments, you can only view deployments for the selected group; other system deployments are not listed.

View group deployments and tasks from the Groups page Deployments and Tasks view.

1. Select Manage > Groups.

2. In the Groups page, select Deployments and Tasks from the View drop-down list.

Step Result: The Deployments and Tasks view displays next to the Group Browser.
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3. Select a group from the directory tree.

Result: The selected group is highlighted and displays the assigned deployments and tasks.

Figure 79: Group Deployments and Tasks

Deployment Type
There are several types of deployments within Lumension Endpoint Management and Security Suite. The
different Lumension Endpoint Management and Security Suite that list deployments also lists each deployment's
type.

The deployment types are described in the following table.

Table 118: Deployment Type

Type Description

New Deployments that were downloaded from the Global Subscription Server
since the last session.

Current Deployments that contain content presently residing on Lumension
Endpoint Management and Security Suite.

Local Deployments that contain a locally created package.

System Task Deployments that contains a system task package.

Mandatory Baseline Deployments that were created through the Mandatory Baseline for a
group. This deployment is automatically created and managed through the
Mandatory Baseline process.

The Deployments and Tasks Page Toolbar
This toolbar contains buttons that let you create new deployments, control existing deployments, and export
deployment data.
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The following table describes each toolbar button

Table 119: Deployments and Tasks Page Toolbar Functions

Menu Item Function

Enable

(Patch and Remediation
only)

Enables the selected disabled deployment or task. For additional information, refer
to Enabling Deployments on page 224.

Disable

(Patch and Remediation
only)

Disables the selected enabled deployment or task. For additional information, refer
to Disabling Deployments on page 224.

Abort

(Patch and Remediation
only)

Cancels the deployment or task for any endpoints which have not already received
the deployment package. For additional information, refer to Aborting Deployments
and Tasks on page 223.

Delete

(Patch and Remediation
only)

Removes the deployment or task from your Lumension Endpoint Management and
Security Suite. For additional information, refer to Deleting Deployments on page
227.

Deploy...

(Patch and Remediation
only)

Deploys the selected packages or tasks. For additional information, refer to
Deploying Content (Deployments and Tasks Page) on page 228.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Deployments and Tasks Page List
A record of each default deployment and each deployment that you have created resides in the Deployments and
Tasks page list.
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The following table describes the columns that appear in the Deployments and Tasks page list. Expand the
deployment list item to view all the available column headers for the item.

Table 120: Deployments and Tasks Page List Column Descriptions

Column Description

Name Indicates the name of the deployment.

Type Indicates the deployment type. For additional information, refer to
Deployment Type on page 220.

Created Date Indicates the date and time the initial deployment job was created.

Created by Indicates the user who created the deployment.

You can expand list items to view additional information about the applicable deployment. Expand list items by
clicking the Rotating Chevron (>). The following table describes each column for an expanded list item.

Table 121: Expanded Deployment Columns

Column Icon Description

Action Contains Edit and Delete icons. Use these controls to edit or delete a
deployment. For additional information, refer to one of the following topics:

• Editing Package Deployment Options on page 224
• Deleting Deployments on page 227

Name Indicates the name of the deployment or tasks. Typically, the name of the
vulnerability or task deployed. Clicking on the name displays the Deployment
Details page. For additional information, refer to The Deployment Details Page
on page 256.

Scheduled Date Indicates the date the deployment or task was scheduled to occur.

Status Icon Contains an icon that indicates the status of the package deployment.

Status Indicates the status of the package deployment.

Number of
Successful
Endpoints

Indicates the total number of endpoints or groups that finished the deployment
successfully.

Number of Failed
Endpoints

Indicates the total number of endpoints or groups that finished the deployment
unsuccessfully.

Number of
Endpoints
Assigned to the
Deployment

Indicates the total number of endpoints or groups that are assigned to the
deployment.
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Column Icon Description

Number of In
Progress Endpoints

Indicates the total number of endpoints or groups that are in the process of
executing the deployment.

Number of
Endpoints That
Have Completed
the Deployment

Indicates the total number of endpoints or groups that finished the deployment.

The Percentage
of Completed
Endpoints

Indicates the percentage of the endpoints or groups that finished the
deployment. Percentage = [Total Finished endpoints / Total Assigned
endpoints]

Working With Deployments and Tasks
There are several procedures associated with deployments and tasks that manage and deploy content. The
controls to begin these procedures are available on the Deployments and Tasks page toolbar.

You can perform the following tasks from the Deployments and Tasks page:

• Aborting Deployments and Tasks on page 223
• Disabling Deployments on page 224
• Enabling Deployments on page 224
• Editing Package Deployment Options on page 224
• Deleting Deployments on page 227
• Deploying Content (Deployments and Tasks Page) on page 228

Aborting Deployments and Tasks
Aborting deployments cancels deployments for endpoints that have not already received the deployment. Abort
deployments when you do not want endpoints to receive their packages.

Abort deployments from the Deployments and Tasks page.

Note:  The endpoints that have already received the deployment will not be affected. The deployment will be
aborted for endpoints that have not yet received the deployment.

1. Select Manage > Deployments and Tasks.

2. Select the deployments you wish to abort.

3. Click Abort.

Step Result: A confirmation message displays, asking you to confirm that you want to abort the
deployment.
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4. Click OK to confirm that you want to abort the deployment.

Result: The selected deployment is canceled.

Note:  You cannot abort system tasks or Mandatory Baseline deployments.

Disabling Deployments
Disabling deployments pauses them, thus temporarily stopping the distribution of the package(s) to endpoints
that have not already received a deployment. Disable deployments when you temporarily want to prevent them
from installing on endpoints.

Disable deployments from the Deployments and Tasks page.

Note:  You cannot disable deployments of system task packages.

1. Select Manage > Deployments and Tasks.

2. Select the deployments you want to disable.

3. Click Disable.

Result: The selected deployments are disabled.

Enabling Deployments
After you have disabled a deployment, reenable it to resume sending content to the deployment's assigned
endpoints.

Reenable deployments from the Deployments and Tasks page.

1. Select Manage > Deployments and Tasks.

2. Select the disabled deployments you want to enable.

3. Click Enable.

Result: The selected deployments are enabled.

Editing Package Deployment Options
After scheduling a deployment, you can edit the package deployment options for each package assigned to the
deployment. Editing a packages deployment options changes the deployment's behavior. This function is useful
when you want each package in a deployment to deploy using different behavior options.

Edit package deployment behavior from the Deployments and Tasks page.

Note:  System task packages are automatically assigned to endpoints, so removing an endpoint from a
deployment of a system task package will have no effect (the endpoint will be re-assigned to the deployment by
the Lumension Endpoint Management and Security Suite).

1. Select Manage > Deployments and Tasks.

2. Expand the deployment job that you want to modify.
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3. Select the individual deployment that you need to modify.

Note:  If the deployment you are editing contains only one package, this list is unavailable.

4. Click the Edit icon.

Step Result: The Package Deployment Options dialog opens.

Figure 80: Package Deployment Options

5. From the Package Name list, ensure the desired package is selected.

6. Define Distribution Options.

Choose from the following options.

Option Steps

To deploy concurrently: 1. Select the Concurrent option.
2. Type the desired number of endpoints you want to deploy to at a

time in the field.

To deploy consecutively: Select the Consecutive option.
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7. If available, select the desired Deployment Flags.

For additional information, refer to Behavior Icon Definitions on page 244.

8. If needed, type additional deployment flags in the Optional Flags field.

For additional information, refer to Package Flag Descriptions on page 418.

9. Define the Deployment Options.

Table 122: Deployment Options

Option Description

Do not notify users of this
deployment

Deploys the Mandatory Baseline package without notifying the
recipients.

Note:  Selection of this option makes the remaining Deployment
Options unavailable.

Notify users of this deployment Deploys the Mandatory Baseline package and notifies the recipients.

Note:  Selection of this option makes the remaining Deployment
Options available.

Message

(field)

Displays a message notifying recipients of the deployment.

Use Policies

(check box)

Uses the group's assigned agent policy set to define the remaining
Deployment Options.

Note:  Selection of this option makes the remaining Deployment
Options unavailable.

Allow user to cancel

(check box and list)

Permits the recipient of the deployment to cancel. Either select the Use
Agent Policy check box or define the Setting list.

Allow user to snooze

(check box and list)

Permits the recipient of the deployment to delay the deployment. Either
select the Use Agent Policy check box or define the Setting list.

Notification on top

(check box and list)

Displays the Agent Deployment dialog when notifying a deployment
recipient. Either select the Use Agent Policy check box or define the
Setting list.

Deploy within

(check box, field, and list)

Defines the time between the deployment creation and the deployment
deadline. If Allow user to snooze is enabled, this value is also the
maximum deployment snooze duration. Either select the Use Agent
Policy check box or define the Setting field and list.
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10. Define the Reboot Options.

Table 123: Reboot Options

Option Description

Do not notify users of this
reboot

Reboots following installation of the Mandatory Baseline package
without notifying recipients.

Note:  Selection of this option makes the remaining Reboot Options
unavailable.

Notify users of this reboot Reboots following installation of the Mandatory Baseline package and
notifies the recipients.

Note:  Selection of this option makes the remaining Reboot Options
available.

Message

(field)

Displays a message notifying recipients of the reboot.

Use Policies

(check box)

Uses the applicable agent policy set to define the remaining
Deployment options.

Note:  Selection of this option makes the remaining Reboot Options
unavailable.

Allow user to cancel

(check box and list)

Permits the recipient of the deployment to cancel the reboot. Either
select the Use Agent Policy check box or define the Setting list.

Allow user to snooze

(check box and list)

Permits the recipient of the deployment to delay the reboot. Either select
the Use Agent Policy check box or define the Setting list.

Reboot within

(check box and list)

Defines the time between the deployment creation and the reboot
deadline. If Allow user to snooze is enabled, this value is also the
maximum reboot snooze duration. Either select the Use Agent Policy
check box or define the Setting field and list.

11. Click OK.

Result: The Package Deployment Options dialog closes and the deployment is modified.

Deleting Deployments
Deleting deployments removes the deployments from the Lumension Endpoint Management and Security Suite.

Note:  Deleting deployments has no effect on endpoints that have already received the deployments. You cannot
delete system task deployments.

1. Select Manage > Deployments and Tasks.
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2. Delete deployments. You can either delete an entire deployments, or you can delete individual packages
included in a deployment.

Complete one of the following substep steps based on whether you want to partially or fully delete a
deployment.

Option Steps

To delete entire deployment(s): 1. Select the deployments you want to delete.
2. From the toolbar, click Delete.

To delete individual packages
in a deployment (partial
deletion):

1. Expand the deployment containing packages you want to delete by
clicking the rotating chevron (>).

2. Click the Delete icon (X) for the package you want to delete.

Tip:  Repeat this process for each package you want to delete.

3. Click Delete.

Step Result: A confirmation message displays, asking you to confirm that you want to delete the selected
deployment(s) or package.

4. Click OK to delete the deployment(s) or package.

Deploying Content (Deployments and Tasks Page)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Deployments and Tasks page. Deploying content remotely installs different types of software on
your network endpoints.

You can deploy content from the Deployments and Tasks page. For additional information about deployments,
refer to About Deployments on page 213.

1. Select Manage > Deployments and Tasks.

2. Click Deploy.

Result: The Deployment Wizard opens.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Explaining Deployment Deadlines
Deadlines determine when a deployment or reboot should occur. A deadline can be calculated based upon the
agent’s group policy or defined by you as a specific date and time.
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When using deadlines, define the deadline using the following parameters:

• Date and time.
• Starting date and time.
• Ability to snooze the deployment or reboot, as many times as desired, up to the defined deadline.

Using the Deployment Wizard
The Deployment Wizard is the dialog used to create or edit deployment schedules for multiple endpoints and
multiple packages. The wizard assists in selecting endpoints, scheduling the deployment, and if needed, setting
recurring deployments.

The following table describes the scenarios for a deployment. These options are selected prior to starting the
Deployment Wizard.

Table 124: Deployment Actions

Deployment Selection Result

Endpoint The Deployment Wizard deploys only to the selected endpoint.

Content The Deployment Wizard automatically selects all the endpoints and
packages required for the content.

Package The Deployment Wizard deploys the selected package to the selected
groups or endpoints selected within the wizard.

Group The Deployment Wizard deploys the applicable packages to the selected
group members.

For additional information on configuring a deployment, refer to Introduction Page on page 229.

Introduction Page
The Introduction page of the Deployment Wizard explains the purpose and capabilities of the wizard.

This page can be hidden during future deployments by selecting the Do not display this page in the future
checkbox.

If this page displays, click Next to continue to the Available Endpoints/Groups Page on page 230.
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Available Endpoints/Groups Page
When scheduling a deployment, you must define endpoints to receive content. Use the Available Endpoints/
Groups page to select endpoints and/or endpoint groups as deployment recipients.

Figure 81: Available Endpoints/Groups Page

You can select deployment recipients by endpoint(s), endpoint group(s), or a combination of the two.

Tip:  Selecting endpoints before opening the Deployment Wizard (from the Endpoints or Groups page, for
example) preselects these endpoints on the Available Endpoints/Groups page.

Endpoints are displayed in a list organized by endpoints. Clicking a list link displays the corresponding
endpoints.
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Endpoint groups are displayed in a directory tree formatted by user groups, system groups, or directory service
groups. Use the search field to find specific groups quickly. Wildcards are not supported.

Note:  Lumension Endpoint Management and Security Suite assesses endpoints for content applicability.
If you open the Deployment Wizard after selecting content (from the Vulnerabilities page, for example) the
system evaluates all managed endpoints for compatibility. Therefore, remember the following information when
preselecting content for deployment:

• Endpoints that fail the preselected content's requirements cannot be added to the deployment (for example,
lacking a software prerequisite).

• Groups that fail the preselected content's requirements cannot be added when all group endpoints are
deficient. However, if just one meets the requirements, the group can be added.

• Endpoints that meet the preselected content's requirements that do not have the content installed are
automatically added to the deployment.

After defining deployment recipients, click Next to proceed to the Available Packages Page on page 232.

For additional information on selecting deployment recipients, refer to one (or both) of the following topics:

• To select individual endpoints as deployment recipients, complete Creating an Endpoint Deployment on page
231.

• To select endpoint groups as deployment recipients, complete Creating a Group Deployment on page 231.

Creating an Endpoint Deployment
When creating deployments, you can define deployment recipients by selecting individual endpoints, regardless
of group membership.

Select endpoints as deployment recipients from the Available Endpoints/Groups page.

1. From the Available Endpoint list, select the Endpoint OS Name required.

Step Result: The list of endpoints within that operating system display.

2. Select an endpoint (or endpoints) from the list.

Step Result: The endpoint(s) are highlighted.

Result: Endpoints are targeted as deployment recipients.

Creating a Group Deployment
You can select single groups, multiple groups, and group hierarchies as deployment recipients using the
Available Groups directory tree. This method of selecting recipients lets you select multiple groups for a
deployment without having to create deployments for each individual group.

Select endpoints as deployment recipients from the Available Endpoints/Groups page.

Note:  If endpoints are added to a group after a deployment is created but before the time the deployment occurs,
the newly-added endpoints will receive the deployment.
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From the Available Groups directory tree, select the group or groups requiring the deployment.

Selecting a parent group also selects its child hierarchy. If you do not want to deploy to a parent's child group
hierarchy, cancel the deployment for the desired groups by clearing the applicable check boxes.

Result: Groups are targeted as deployment recipients.

Available Packages Page
While completing the Deployment Wizard, packages must be selected for installation on target endpoints. These
packages are selected from the Available Packages page.

When selecting packages for deployment, remember the following helpful information:

• Only vendors and packages applicable to the selected endpoint(s) display. Inapplicable content is hidden.
• If you opened the Deployment Wizard from one of the Content pages after selecting content items from the

page list, those items are preselected in the wizard. Finding the packages you want to deploy is unnecessary
(although you can select more packages if desired).

Note:  If you pre-selected vulnerabilities for deployment, the Available Packages page may display more
packages selected for deployment that the number of vulnerabilities you selected. This discrepancy is because
a vulnerability may contain more than one package.

• An icon in the listed packages indicates if the package your want to deploy is already cached. If you already
have the package cached, you can deploy it more quickly. Lumension recommends caching packages before
deployment.

After defining the Available Packages page, click Next to proceed to the Licenses Page on page 233.

For additional information of selecting packages, refer to Selecting Deployment Packages on page 232.

Selecting Deployment Packages
Selecting packages to deploy to selected endpoint remediates endpoint vulnerabilities.

Select packages for deployment from the Available Packages page.

1. Select the Vendor link containing the package(s) you want to deploy.

Step Result: A list of the vendor's packages for the selected deployment recipients opens.

2. Select the package(s) needed.

Step Result: The packages are selected.

3. [Optional] Repeat the selection process for additional vendors.

4. [Optional] Click a Package Name link to open the Associated Vulnerability Analysis page. For additional
information, refer to Associated Vulnerability Analysis Page on page 233.

5. [Optional] Click Next to proceed to the Licenses page.

When using the Deployment Wizard, the wizard will not necessarily install service packs first. Verify that
all relevant service packs have deployed successfully before creating deployments using the Deployment
Wizard.
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Associated Vulnerability Analysis Page
The Associated Vulnerability Analysis page shows the applicability of the packages for the endpoints associated
with the deployment.

Figure 82: Associated Vulnerability Analysis Page

The following table describes the page columns.

Table 125: Associated Vulnerability Analysis Columns

Name Description

Computer Name Name of endpoint receiving the deployment.

Platform Info Name of the applicable operating systems.

Results Patch status, which indicates whether the selected package applies to the
endpoint (Patched, Not Patched, Not Applicable).

When finished viewing the page, click Back to return to the Available Packages Page on page 232.

Licenses Page
To continue configuration of your deployment, you must first accept the vendor license agreement(s).

The number of different license agreements that appear depend upon how many packages you selected to install.
For example, you selected four different packages for installation and these packages were created by three
different vendors, you would have to agree to three different license agreements.
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For additional information on accepting license agreements, refer to Accepting License Agreements on page
234.

After accepting licenses, click Next to proceed to the Deployment Information Page on page 234.

Accepting License Agreements
To continue configuration of your deployment, you must first accept the vendor license agreement(s).

Accept licenses from the Licenses Page.

Figure 83: Licenses Page

1. Review the agreement.

2. If you accept the agreement, select the I ACCEPT the terms and conditions of this end user license
agreement option.

3. If there are multiple agreements, repeat the previous steps.

All agreements must be accepted before continuing.

4. [Optional] Click Next to proceed to the Deployment Information page.

Deployment Information Page
You can control the user notification options associated with a deployment using the Deployment Information
page. You can set the deployment job name, start time, manner, and add notes.
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The following information may be useful when completing this page:

• Job and task names will later be used to identify deployment results.
• Deploying using Agent Local Time is useful in geographically dispersed networks. This deployment method

helps ensure deployments complete off peak business hours.
• Deploying using UTC time is useful when you want to deploy content at one specific time.
• Concurrent deployments ensure endpoint receive packages near simultaneously, but may consume excessive

network bandwidth.
• Consecutive deployments reduces network bandwidth consumption, but endpoints may receive deployment at

different times.

After defining deployment information, click Next to proceed to the Package Deployment Behavior Options
Page on page 243.

For additional information of defining deployment information, refer to Defining Deployment Information on page
235.

Defining Deployment Information
Deployment information consists of identifiers for the deployment job and deployment task, the timing of the
deployment, and the deployment manner.

Prerequisites:

• Accept license agreements. For additional information, refer to Licenses Page on page 233.

Configure deployment information from the Deployment Information page.

1. Type the applicable information in the following fields.

Field Description

Job name The display name of the deployment job.

Task name The editable display name of the deployment task. The Package Name
variable will be replaced with the name of the package included in the
task.

2. [Optional] Edit the Start time. For information on configuring a deployment schedule, refer to Schedule
Configuration Page on page 237.

3. Select the desired Deployment time zone option.

The following table defines the options.

Option Description

Agent Local Time Deploys at local time for each individual node.
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Option Description

Agent UTC Time Deploys at UTC time for each individual node.

Note:  If you deploy to a group using Agent Local Time, the deployment remains in progress until all time
zones have passed. This behavior ensures any endpoints added to the group following deployment start also
receive content. This behavior does not occur when using Agent UTC Time.

4. Select Manner options.

Note:  The Concurrent and Consecutive options cannot be used simultaneously.

The following table describes the Manner options.

Option Description

Concurrent This option deploys the package(s) to a defined number of endpoints
simultaneously. New deployments are distributed when agents report
back after completing the previous deployment. If an endpoint takes
longer than four hours to complete the deployment, it is no longer
counted against the concurrent deployment limit.

Note:  If you select this option, you can also edit the Deploy to x
nodes at a time field.

Consecutive This option deploys the packages simultaneously to all endpoints.
However, the global deployment limit will always take precedence over
the defined distribution options defined.

Suspend the deployment of this
package if it fails to deploy to
one or more nodes.

(Checkbox)

This option suspends all subsequent deployments following any
deployment failure.

Deploy package even if the
computer has been previously
patched.

(Checkbox)

This option deploys the package(s) to all selected endpoint regardless
of patch status.

5. [Optional] Type notes and comments in the Notes field.

Result: Deployment information is defined. Click Next to continue to the Package Deployment Order and
Behavior page.
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Schedule Configuration Page
You can set the timing and frequency of a deployment using the Schedule Configuration page. Deployments can
be defined as one-time or recurring. Additional schedule configuration options are also available.

Note:  If endpoints are added to a group after a deployment is created but before the deployment occurs, the
newly-added endpoints will receive the deployment.

Figure 84: Schedule Configuration Page

Complete one of the following tasks based on how you want to schedule the deployment:

• If you want to run the deployment once, complete Scheduling a One Time Deployment on page 237.
• If you want to run the deployment on a recurring basis, complete Scheduling a Recurring Deployment on page

238.

Scheduling a One Time Deployment
A one time deployment starts on the selected day at the selected time.

Prerequisites:

• Begin Defining Deployment Information on page 235.

1. From the Deployment Wizard Schedule Configuration page, click Change located in the Start Time option.
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2. Select One Time.

Step Result: The deployment will start on the selected day at the defined time. If a one time deployment
is scheduled for a date and time in the past, the agents will start the deployment the next time
they contact the Lumension Endpoint Management and Security Suite.

3. Select 12 hour or 24 hour to determine 12-hour format or 24-hour format.

4. Select the hour for the deployment from the Hour drop-down list.

5. Select the minute for the deployment from the Minute drop-down list.

6. Select AM or PM using the drop-down list.

7. Click Next.

Step Result: The changes are saved and the Deployment Information page opens.

After Completing This Task:

Complete Defining Deployment Information on page 235.

Scheduling a Recurring Deployment
A recurring schedule starts deployments on the selected day at the selected time. The deployment repeats every
day, week, or month and if defined, ends on a specific date.

Figure 85: Schedule Configuration Page
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To schedule a recurring deployment, complete one of the following tasks:

• Configuring a Daily Recurring Deployment on page 239.
• Configuring a Weekly Recurring Deployment on page 240.
• Configuring a Monthly Recurring Deployment on page 240.

Configuring a Daily Recurring Deployment
You can configure a deployment to happen every day. Recurring deployments are useful to ensure selected
content remains installed on endpoints.

Prerequisites:

• Begin Defining Deployment Information on page 235.

Schedule deployments for daily recurrence from the Deployment Information page

1. From the Deployment Information page, click Change, located in the Start Time section of the page.

Step Result: The Schedule Configuration page opens.

2. Select Recurring.

3. In the Occurs field, select Daily.

Step Result: The Deployment Wizard displays the Daily Deployment Options field.

Figure 86: Daily Option

4. From the Daily Every X Days drop down list, select the frequency. The valid options are: 1 through 365.

5. Select the frequency of the deployment.

• Occurs once a day at the scheduled start time - the deployment starts at the same time as scheduled in
the Schedule Configuration page.

• Occurs every - the valid options are 1 through 60 if minutes are selected and 1 through 24 if hours are
selected.

6. Complete Selecting the Deployment Start and End Functions on page 241.

7. Click Next.

After Completing This Task:

Complete Defining Deployment Information on page 235.
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Configuring a Weekly Recurring Deployment
You can configure a deployment that happens every week. Recurring deployments are useful to ensure selected
content remains installed on endpoints.

Prerequisites:

• Begin Defining Deployment Information on page 235.

Schedule deployments for weekly recurrence from the Deployment Information page.

1. From the Deployment Information page, click Change, located in the Start Time section of the page.

Step Result: The Schedule Configuration page opens.

2. Select Recurring.

3. In the Occurs field, select Weekly.

Step Result: The Schedule Configuration page displays the Weekly Deployment Options field.

Figure 87: Weekly Options

4. From the Every X week(s) on: Mon, Tue, Wed, Thur, Fri, Sat, Sun, select the deployment to be scheduled
every X weeks on the selected days.

5. Click Next.

6. Complete Selecting the Deployment Start and End Functions on page 241.

After Completing This Task:

Complete Defining Deployment Information on page 235.

Configuring a Monthly Recurring Deployment
You can configure a deployment that happens every month. Recurring deployments are useful to ensure selected
content remains installed on endpoints.

Prerequisites:

• Begin Defining Deployment Information on page 235.

Configure deployments for monthly recurrence from the Deployment Wizard's Schedule Configuration page.

1. From the Deployment Information page, click Change, located in the Start Time section of the page.

2. Select Recurring.

Step Result: The Recurring Deployment options display.
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3. In the Occurs field, select Monthly.

Step Result: The Schedule Configuration page displays the Monthly Deployment Options fields.

Figure 88: Monthly Options

4. Select the frequency of the deployment:

• Day X of every X month(s) - Schedules the deployment on a specific date every X months. Valid date
options are 1 through 31, with the ability to choose 1 through 99 months.

• The Xth Weekday of every X month(s) - Schedules the deployment to be run on a specific day every
X months. The valid day options are: 1st, 2nd, 3rd, 4th, or Last, weekday options are: Sunday through
Saturday, Day, Week day, or Weekend day and monthly recurrence options are: 1 through 99 months.

Figure 89: Common Deployment Options

5. Complete Selecting the Deployment Start and End Functions on page 241.

6. Click Next.

After Completing This Task:

Complete Defining Deployment Information on page 235.

Selecting the Deployment Start and End Functions
When scheduling a deployment, you can configure it to start and end at specific times. Additionally, if you are
scheduling the deployment to recur, you can define a date to end the recurrence.
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The frequency fields specify a date and time deployments. Review the table to determine scheduling needs.

Table 126: Deployment Start and End Functions

Select To

12 hour, 24 hour Set the schedule to either a standard 12-hour format or a 24-hour format.

Occurs once at Set the deployment to occur once daily at the time defined here.

Note:  Agent communication interval and Hours of Operation (HOP)
settings modify the actual deployment time.

Occurs every Set the deployment to occur multiple times on the scheduled day, between
the hours defined in the starting at: and ending at: fields with a delay of
the defined hours or minutes.

Start Date Schedule a recurring deployment to begin at a later date. Defaults to the
current date.

No End Date Continue with the defined recurrence schedule and no defined end date.

End Date Activate the end date calendar function and define the date the deployment
will no longer be deployed.

Click Next to save the changes and return to the Deployment Information Page on page 234.
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Package Deployment Behavior Options Page
The packages selected for deployment can have their order and behavior edited. For instance, you may want a
particular package deployed before another. Use the Package Deployment Behavior Options page to edit order
and behavior.

Figure 90: Package Deployment Order and Behavior Page

The following table describes each page column.

Table 127: Package Deployment Order and Behavior Columns

Column Description

Action Contains Edit and Delete icons. Click the Edit icon to open Package Deployment
Behavior Options page, which you can use to change package behavior options.
Click the Delete icon to remove the package from the deployment. For additional
information on editing package behavior, refer Package Deployment Behavior
Options Page on page 247

Order Indicates the order number of the package.

Package Name Indicates the name of the package.

Selected Options Displays icons that indicate behaviors selected for the package. Mouse over for a
text description of the behavior. For additional information, refer to Behavior Icon
Definitions on page 244.
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Column Description

Reboot Displays icons that indicate whether a reboot follows the package deployment. For
additional information, refer to Reboot Icon Definitions on page 246.

From this page, you can change the order that packages are deployed in using the page controls. For additional
information on settings the package deployment order, refer to Setting Package Deployment Order on page
246.

Modify package behavior by clicking its edit icon. For additional information, refer to Package Deployment
Behavior Options Page on page 247.

Note:  Chained packages cannot be moved without first removing their chained status. When a package is
chained, Lumension Endpoint Management and Security Suite determines the deployment order. However, when
no longer chained, the package can be deployed at anytime following the chained deployments.

After defining deployment order and behavior, click Next to proceed to the Notification Options Page on page
250.

Behavior Icon Definitions
Behavior icons appear on the Package Deployment Order and Behavior page and indicate the activities related
to the deployment configuration.

The following table describes the deployment behavior icons and their descriptions. The icons representing the
selected behaviors appear in the Selected Options column.

Table 128: Behavior Icon Definitions

Icon Action Use to

Uninstall Uninstall the packages.

Force Shutdown Force all applications to close if the package causes a
reboot.

Do Not Backup Uninstall package without backing up files.

Suppress Reboot Prevent a reboot after installation.

Quiet Mode Suppress any user interfaces during the deployment.

Unattended Setup Set up packages in unattended mode.

List Hot Fixes Return a listing of hot fixes installed on the target devices.
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Icon Action Use to

Force Reboot Force a reboot regardless of package requirements.

Reboot is Required Indicate a reboot is required prior to completing the
installation.

Chain Packages Set the package as chainable (package must support
chaining).

Suppress Chained Reboot Suppress the reboot, so that other chained packages can
be sent following this package. When creating multiple
deployment jobs, this option is recommended.

Repair File Permissions Repair file permissions following the package installation.

Download Only Distribute the package without running the package
installation script.

Suppress Notification Suppress any user notifications during installation.

Debug Mode Run the package installation in debug mode.

Do Not Repair Permissions Suppress the repair of file name permissions after the
reboot.

May Reboot Force a reboot, if required.

Multi-User Mode Perform the installation in multi-user mode.

Single-User Mode Perform the installation in single-user mode.

Restart Service Restart the service following the deployment.

Do Not Restart Service Suppress the restart of the service following the deployment.

Reconfigure Perform the system reconfigure task following deployment.
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Icon Action Use to

Do Not Reconfigure Suppress the system reconfigure task following deployment.

Note:  When using a chained deployment, reboots are suppressed whenever possible. The final deployment is
represented as May Reboot because Lumension Endpoint Management and Security Suite determines if the
agent is in a dirty state. If so, a System Task - Reboot deployment is sent before deploying the remaining
packages.

Reboot Icon Definitions
Reboot icons appear on the Package Deployment Order and Behavior page and determine the reboot conditions
for a deployment.

The following table describes the reboot icons.

Table 129: Reboot Icon Definitions

Icon Name Reboot Status

Reboot may occur The device may be rebooted, dependent upon the package
installer requirements (at the time of install).

Reboot may occur chained The device may be rebooted, dependent upon the package
requirements. However if a reboot is required and the device
is not rebooted, the device will enter a reboot state.

Reboot required No other (chainable or non-chainable) packages will be
installed until the device reboots.

Reboot required chained Only chainable packages will continue to be installed until
the device has been rebooted.

Reboot will occur The device will be rebooted following the package
installation.

Click Next to proceed to the Notification Options Page on page 250 page.

Click Finish to create the deployments and proceed to the Deployment Confirmation Page on page 254.

Setting Package Deployment Order
Set the deployment order to determine which packages are installed first.

Define the deployment order from the Package Deployment Order and Behavior page.

1. Select the package(s) you want to move within the queue.
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2. Move the selected packages within the queue.

Click the following icons to move packages to desired queue position.

Icon Description

Double Up Arrow Moves the selected package(s) to the top of the queue.

Up Arrow Moves the selected package(s) up one queue position.

Double Down Arrow Moves the selected package(s) to the bottom of the queue.

Down Arrow Moves the selected package(s) down one queue position.

3. [Optional] Edit deployment behavior options for packages.

For additional information, refer to Selecting Deployment Behavior Options on page 249.

Result: Package deployment order is defined. Click Next to proceed to the Notification Options page.

Package Deployment Behavior Options Page
You can set the behavior options for each of the packages associated with a deployment using the Package
Deployment Behavior Options page of the Deployment Wizard. The package options are active or inactive,
depending on the patch selected.

Figure 91: Behavior Options

Note:  Modification of a package’s behavior options will cause the package order to be reevaluated by the
Deployment Wizard, which may result in a change in the package order.
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Package Flag Descriptions
You can attach behavior to package deployments using package flags.

The following table defines flag behavior and their descriptions:

Table 130: Package Flag Descriptions

Description (flag behavior) Display Flag Select Flag

Perform an uninstall; can be used with -mu or -q. -yd -y

Force other applications to close at shutdown. -fd -f

Do not back up files for uninstall. -nd -n

Do not restart the computer when the installation is done. -zd -z

Use quiet mode, no user interaction is required. -qd -q

Use unattended setup mode. -dmu -mu

Install in multi-user mode (UNIX, Linux only). -dsu -su

Restart service after installation (UNIX, Linx only). -drestart -restart

Do not restart service after installation (UNIX, Linux only). -dnorestart -norestart

Reconfigure after installation (UNIX, Linux only). -dreconfig -reconfig

Do not reconfigure after installation (UNIX, Linux only). -dnoreconfig -noreconfig

This package is chainable and will run Qchain.exe (Windows) or
(UNIX/Linux).

-dc -c

Suppress the final chained reboot. -dc -sc

Repair permissions. -dr -r

Deploy only. -PLD1 -PLD0

No Pop-up -PLN1 -PLNP

Debug -PLDG -PLDEBUG

Suppress Repair -dsr -sr

Force the script to reboot when the installation is done. -1d -1

Reboot is required. Not applicable -2

Reboot may occur. Not applicable -3

Reboot is required, and may occur. Not applicable -4
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Package Display Options
You can designate how a deployment will appear on endpoints when the deployment occurs using package
display options.

Table 131: Package Display Options

Option Description

Notes Displays the expected deployment behavior.

Description Displays the package description.

After configuring options, click Next to save your changes and return to the Package Deployment Behavior
Options Page on page 243.

Selecting Deployment Behavior Options
Each package in a deployment can have its behavior changed by selecting behavior options.

Select deployment behavior options for a package from the Package Deployment Behavior Options page.

1. Select the check box for each behavior you want the package to use.

2. Define additional behaviors typing entries in the Optional Flags field.

For a complete listing of behavior flags, refer to Package Flag Descriptions on page 248.

3. Select a Display option.

This option defines the notification that deployment recipients receive when user notifications are enabled.
Select one of the following options.

Option Description

Behavior options settings Displays the expected deployment behavior.

Package description Displays the package description.

Note:  Modifying behavior options initiates a system reevaluation of the deployment, which may result in a
change in the package order.

Result: The package enables the selected behaviors. Click Next to return to the Package Deployment Order
and Behavior page.
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Notification Options Page
You can define whether users will receive notification of deployments and/or reboots, and if so, what the
notification will contain using the Notification Options page of the Deployment Wizard.

Figure 92: Notification Options Page

Note:  When an agent is installed on a server where multiple users are logged in simultaneously, the deployment
manager will provide each user with the ability to snooze or reject the deployment and/or reboot if snooze or
reject is enabled.

For additional information on defining notification options, refer to Setting Notification Options on page 250.

After editing the Notifications Options page, click Next to view the Deployment Confirmation Page on page
254.

Setting Notification Options
During deployments, you can notify recipients that their endpoints are receiving deployment or require an
endpoint. From the Notification Options page, you can define the message that recipients receive.

Define notification options from the Notification Options page.

1. Select a Define the Deployment Notification Options option.

• Do not notify users of this deployment.
• Notify users of this deployment.
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2. If you selected Notify users of this deployment option, complete the following substeps.

a) [Optional] Type a notification in the Message field.
b) Select whether you want to manually define remaining notification options or use the default settings

defined in the Global Policy Set.

• To manually define remaining notification options, ensure the Use Policies check box is cleared and
continue to the next substep.

• To use the default notification option settings defined in the agent policy set associated with the target
endpoints, select the Use Policies check box and continue to the next step.

c) Define the Allow user to cancel option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

d) Define the Allow use to snooze option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

e) Define the Notification on top option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

For additional information about this option, refer to About the Show on Top Option on page 252.

f) Select and define a Deploy option.

• To deploy the notification within a specific time frame, select the Within option and define the field
and list (minutes, hours, days).

• To deploy the notification by a specific deadline, select the By option and define a date and time.

Use the calender controls that display to define the date and time, and then click OK.

3. Select a Define the Reboot Notification Options option.

• Do not notify users of this reboot.
• Notify users of this reboot.

4. If you selected Notify users of this reboot option, complete the following substeps to define the remaining
options.

a) [Optional] Type a notification in the Message field.
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b) Select whether you want to manually define remaining notification options or use the default settings
defined in the agent policy set associated with the target endpoints.

• To manually define remaining notification options, ensure the Use Policies check box is cleared and
continue to the next substep.

• To use the default notification option setting defined in the agent policy set that applies to the target
endpoints, select the Use Policies check box and continue to the next step.

c) Define the Allow user to cancel option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

d) Define the Allow use to snooze option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

e) Define the Notification on top option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

For additional information about this option, refer to About the Show on Top Option on page 252.

f) Define the Reboot within option.

• To manually define this option, enter a value in the field and select a value from the list (minutes,
hours, days).

• To use the default notification option setting defined in the agent policy set associated with the target
endpoints, select the Use Agent Policy check box.

Result: Notification options are configured. Click Next to continue to the Deployment Confirmation page.

About the Show on Top Option
When creating a deployment or a mandatory baseline item, you can define the Show on Top options. Theses
options determine whether notifications for deployments or reboots display on top or on bottom of all other open
endpoint windows.

There are two different Show on Top options:

• A Show on Top option for Deployment Notification Options
• A Show on Top option for Reboot Notification Options
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The following table describes the notification dialog behaviors for each option setting (Yes or No).

Table 132: Always on Top Option Setting Description

Always on Top Option
Setting

Notification Dialog Behaviour

Yes The deployment or reboot notification displays as the topmost window. All other
open windows display behind it.

No The deployment or reboot notification displays as the bottommost window. All
other open windows display in front of it.

Note:  When sending a deployment or reboot notification for the first time, the
deployment or reboot notification displays as the topmost window (with the
exception of some dialogs, such as Windows Task Manager). The notifications
will display as the bottommost window in subsequent notifications.

Tip:

You can configure an agent policy to define the default Show on Top option setting for deployments and reboots
when configuring a deployment or mandatory baseline. For additional information, refer to the following tasks:

• Creating an Agent Policy Set on page 347
• Editing an Agent Policy Set on page 352
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Deployment Confirmation Page
The Deployment Confirmation page of the Deployment Wizard displays a summary of the options selected for
the deployment. This information is provided for your verification before creating the deployment.

Figure 93: Deployment Confirmation Page

Note:  When an agent is installed on a server where multiple users are logged in simultaneously, the deployment
manager will provide each user with the ability to snooze or reject the deployment and/or reboot if snooze or
reject is enabled.

After reviewing the Deployment Confirmation page, click Finish to proceed to the Deployment Summary Page
on page 254.

Deployment Summary Page
The Deployment Summary page lists the deployment's parameters that you have defined on the previous wizard
pages. If you did not define a deployment option, the deployment will use the default setting. Review this page
before finishing the deployment.

Note:  When an agent is installed on a server where multiple users are logged in simultaneously, the deployment
manager will provide each user with the ability to snooze or reject the deployment and/or reboot if snooze or
reject is enabled.
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The following items appear in the summary.

Table 133: Deployment Confirmation Summary Options

Summary Item Description

Job Name Indicates the name given the deployment job defined in the Deployment
Options page.

Schedule Indicates the schedule for the deployment defined in the Deployment
Options page.

Manner Indicates if these deployments are sequential or parallel. If the deployment
is sequential, how many deployments will be distributed at once.

Deployment Notification Indicates if users will receive a deployment notification (as defined under
the Notification Options page).

Reboot Notification Indicates if users will receive a reboot notification, if the deployment must
reboot (as defined under the Notification Options page).

Total Selected Packages Indicates the total number of packages selected for deployment.

Total Selected Endpoints /
Groups

Indicates the number of groups selected, if the deployment is a group
deployment. If the deployment is for individual devices, indicates the total
number of endpoints selected.

Notes Indicates the deployment's creator and the creation date.

The following table describes each column in the Selected Packages Summary table when all packages selected
for deployment are cached.

Table 134: Selected Packages Summary

Column Description

Order The package deployment order.

Package Name The name of the package being deployed.

Selected Options The selected deployment options.

Reboot The package’s reboot options.

Endpoint/Groups The number of endpoint or groups receiving the deployment.
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When the packages you have selected are not cached, the Selected Packages Summary contains different
columns, which pertain to caching the deployment packages.

Table 135: Selected Packages Summary (Caching Packages)

Column Description

Package Icon Contains an icon that indicates if the package is cached or is being
requested. Mouse over the icon for a description.

Package Name The name of the package being deployed.

Status Indicates the packages cache status (cached or requesting).

You can complete the Deployment Wizard without caching the packages by clicking Deploy Unordered.
However, completing the wizard without caching packages may result in deployment of packages in an
unoptimized order, which may cause unintended reboots. Lumension recommends caching packages before
completing the Deployment Wizard. While packages are caching, you can click Refresh to update the page.

After you finish reviewing the summary, click Finish to dismiss the Deployment Wizard.

The Deployment Details Page
The Deployment Details page shows targeted endpoint groups, targeted endpoints, deployment status, and
deployment times for individual deployments.

Figure 94: The Deployment Details Page

Viewing the Deployment Details
The Deployment Details page for details about a specific deployment.

View the Deployment Details page by clicking a name link from the Deployments and Tasks page.

1. Select Manage > Deployments and Tasks.

Step Result: The Deployments and Tasks page opens.

2. Expand the list item containing the deployment you want to view details for.

3. Click the Name link associated with the deployment you want to view details for.
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The Deployment Details Page Toolbar
The Deployment Details page toolbar contains functionality that you can use to enable and disable deployments
and export deployment detail information.

The following table describes each toolbar button.

Table 136: Deployments Details Page Toolbar

Menu Item Function

Enable Enables the selected disabled deployment (Patch and Remediation only). For
additional information, refer to Enabling Deployments on page 224.

Disable Disables the selected enabled deployment (Patch and Remediation only). For
additional information, refer to Disabling Deployments on page 224.

Abort Cancels the deployment for any endpoints which have not already received the
deployment package. For additional information, refer to Aborting Deployments
and Tasks on page 223.

Delete Removes the deployment from your Lumension Endpoint Management and
Security Suite. For additional information, refer to Deleting Deployments on page
227.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Deployment Details Page List
Details for individual deployments that you select from the Deployments and Tasks page reside in the
Deployment Details page list.

Table 137: Deployment Details Column Definitions

Column Description

Agent Status Icon Indicates the status of the endpoint or endpoint group. For additional
information, refer to Agent Module Status Icons on page 526.
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Column Description

Name Indicates the name of the endpoint or endpoint group. The group name
is a link; clicking the link displays the group membership and individual
endpoint results.

Status Indicates the current status of the deployment.

Last Run Status Indicates the deployment's status when last ran. The status is a link;
clicking the link will displays the Deployment Results page. For additional
information, refer to Viewing Deployment and Task Results on page 189.

Last Run Start Date Indicates the date and time the deployment began.

Last Run Complete Date Indicates the date and time the deployment completed.

Next Run Date Indicates the next scheduled start date and time for this deployment.
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Chapter

10
Using Groups

In this chapter:

• About Groups

• The Groups Page

• The Information View

• The Group Membership View

• The Endpoint Membership View

• The Mandatory Baseline View

• The Vulnerabilities View

• The Inventory View

• The Deployments and Tasks View

• The Agent Policy Sets View

• The Roles View

• The Dashboard View

• The Settings View

Groups are collections of endpoints. By organizing endpoints into a
group, you can manage them collectively rather than individually.

You can organize groups using any desired criteria. Some examples
are:

• Operating System
• Endpoint Function
• Organization Divisions
• User Roles

Use of groups reduces individual endpoint maintenance.

About Groups
A group is a collection of endpoints that lets you manage endpoints collectively. Within Lumension Endpoint
Management and Security Suite you can create groups and then add endpoints to them.

Lumension Endpoint Management and Security Suite (Lumension EMSS) contains the following group types:

• Predefined System Groups
• Custom Groups

For additional information about group types, refer to Defining Groups on page 261.

Within Lumension EMSS, you can nest groups; groups can contain other groups. These related groups, called
parent and child groups, minimize Lumension EMSS maintenance.
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The Groups Page
Use this page to control groups. The functions from many other Lumension Endpoint Management and Security
Suite pages are available from this page (the Endpoints page, the Users and Roles page, and so on). However,
the functions performed on the Groups page pertain primarily to the selected group's endpoints.

Groups are selected from the Group Browser directory tree, a Groups page pane. The browser displays an
expandable directory tree that lists parent and child groups. From this browser, you can access group information
by clicking a group. Information for the selected group displays in the main pane.

Figure 95: Groups Page

Unlike most other Lumension Endpoint Management and Security Suite pages, which are organized by tabs, the
Groups page is organized by views, which are selectable from the View list. The information displayed for a
selected group changes according to view.

The views are:

• The Information View on page 263
• The Group Membership View on page 268
• The Endpoint Membership View on page 275
• The Mandatory Baseline View on page 290
• The Vulnerabilities View on page 309
• The Inventory View on page 314
• The Deployments and Tasks View on page 315
• The Agent Policy Sets View on page 319
• The Roles View on page 327
• The Dashboard View on page 332
• The Settings View on page 335

The Group Browser Directory Tree
The Group Browser directory tree, a Groups page pane, displays each group in Lumension Endpoint
Management and Security Suite. Use it to select a group. The number of groups in the tree depends on the
number of groups created.
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Within the Group Browser, groups are nested in a hierarchy. Click an Expand icon (+) to view custom, system,
and directory service groups. By continuing to expand the tree, you can view parent groups and their nested child
groups.

To display detailed group information, select a group name.

After selecting a group, use the View list to access different views, such as the Information view or the Group
Membership view.

Figure 96: Group Browser Directory Tree

Parent and Child Groups
Within the Group Browser directory tree, groups are nested in hierarchical relationships. This hierarchy
contains parent groups and child groups. These terms are used to describe groups (parent groups) that contains
any number of nested groups (child groups). Each group has only one parent. However, a parent group can have
multiple child groups. Nesting child groups within parent groups creates an inheritance, which lets you apply one
agent policy set to a parent and its descendants.

Parent-child relationships creates the following hierarchies within groups:

Group Hierarchy Refers to the entire group hierarchy from the original to the deepest child
group.

Parent Hierarchy Refers to the entire group hierarchy above a specific group.

Child Hierarchy Refers to the entire subordinate group hierarchy below a specific group.

Inheritance Refers to the permissions a group has set. Group inheritance settings must
have a value of True to inherit its parent settings.

Note:  System and directory service group hierarchies cannot be modified.

Defining Groups
Within Lumension Endpoint Management and Security Suite, there are several types of groups. Some groups are
created by users, while others are created by the Lumension Endpoint Management and Security Suite system.
When working with groups, only user-created groups can be deleted.
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Groups are categorized into the following classifications.

Table 138: Group Definitions

Icon Group Type Definition

Parent System Groups

System Groups

Endpoints identified in your network are automatically assigned
a group membership based on their operating system, Active
Directory (AD) membership, or IP address. Not all operating
systems, AD groups, or IP ranges may be shown. This omission
is because Lumension Endpoint Management and Security Suite
creates system groups based on only the endpoints present in
your network. Groups are also created for virtual machines (the
Virtual Machines group) and managed endpoints that have not
yet been added to a custom group (the Ungrouped group). You
cannot modify system groups or their hierarchies.

Parent Directory Service
Groups

Directory Service Groups

These groups are created when an agent submits a directory
service hierarchy that does not already exist in Lumension
Endpoint Management and Security Suite. You cannot modify
directory service groups or their hierarchies.

Custom Groups (Parent &
Child)

Custom groups are created and managed by the user.

Viewing Groups
Navigate to the Groups page to work with groups. After navigating to the page, select a group and a view.

You can select this page from the navigation menu at any time.

1. Select Manage > Groups.

2. Expand the Group Browser directory tree to the desired group.

3. Select the group you want to view.

Step Result: The selected group’s information displays.

4. Select the desired view from the View list.

Result: The selected group’s information displays on the main pane. Select a different view from the View list
to change the information displayed.

Searching for a Group
The Group Browser contains a field you can use to search for groups. Use this field in network environments
containing many groups. After entering search criteria, the browser directory tree changes to a listing of groups
specified in the field.

This field uses a contains search condition. Wildcards are not supported.
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1. Select Manage > Groups.

Step Result: The Groups page opens.

2. In the Group Browser field, type your search criteria.

Step Result: The results for your search displays below the Group Browser field as you type.

3. Click the desired group.

Result: Information for the selected group displays on the Groups page. Click the Group Browser delete icon
to return to the directory tree.

The Information View
This view includes basic information about the selected group's membership, hierarchy, agent policy sets, roles,
and so on. Select this view for a comprehensive listing of the selected group's settings.

Group settings and information appear in sections. Each section displays information for each type of group
settings. Empty sections indicate undefined settings.

The Information view features the following sections:

• Group Information on page 264
• Email Notification Addresses on page 265
• Child Groups on page 265
• Mandatory Baseline Items on page 266
• Agent Policy Sets on page 266
• Resultant Agent Policy Set Information on page 266
• Roles on page 267

Figure 97: Group Information
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The following table describes the Information view buttons.

Table 139: Information View Button

Button Function

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Group Information
The first section in the Information view displays general information about the selected group's settings. These
settings are controlled within the various Groups page views. Select this view when you want to see a group's
settings from a single source.

The following table describes the first fields within the first section of the Information view.

Table 140: Group Information

Field Description

Name Indicates the name of the group.

Distinguished Name Indicates the system-created name based upon the group’s parent
hierarchy.

Created Date Indicates the date and time the group was created.

Created By Indicates the user who created the group.

Last Modified Date Indicates the date and time the group was last modified.

Last Modified By Indicates the user who last modified the group.

Description Indicates the description of the group.

Directly Assigned Endpoints Indicates the number of endpoints assigned to the group. Inherited
endpoints are not included.

Source Group Assigned
Endpoints

Indicates the number of endpoints assigned to the source group.

Derived Endpoints from Child
Hierarchy

Indicates the number of endpoints inherited from child groups.

Policy Inheritance Indicates if agent policy sets are inherited from the group’s parent (True or
False).
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Field Description

Policy Enabled Indicates if agent policy sets can be assigned to the group (True or
False).

Deployment Enabled

(Patch and Remediation only)

Indicates if deployments can be created for the group (True or False).

Mandatory Baseline Inheritance

(Patch and Remediation only)

Indicates if Mandatory Baseline settings are inherited from the group’s
parent (True or False).

Mandatory Baseline Enabled

(Patch and Remediation only)

Indicates if Mandatory Baseline deployments are created based upon the
group’s Mandatory Baseline configuration (True or False).

Email Notification Addresses
After a group is created, it can be assigned an email address. This email is intended to be attributed to the group's
owner, which is the user that created the group.

Email addresses are not assigned from the Information view; this view merely displays the assigned addresses.
For additional information on assigning an email address to a group, refer to Editing Group Settings on page
335.

The following reference describes the Email Notification Addresses table.

Table 141: Email Notification Addresses Table

Column Description

Notification Address The email addresses of the group owner.

Child Groups
This section lists the selected group's direct child groups. Only direct children are listed; deeper descendants such
as grandchild groups are not listed. Assign child groups to the selected group via the Group Membership view.

The following reference describes each table column.

Table 142: Child Groups Table

Column Description

Type The group type (Custom Group, System Group, or Directory Service
Group).

Group Name The name of the child group.

Distinguished Name The system-created name of the group, which is based upon the group’s parent
hierarchy.

Group Description The description of the group.
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Mandatory Baseline Items
This section lists the content items assigned to the selected group's Mandatory Baseline. However, this section
merely lists assigned Mandatory Baseline items; you cannot use it to assign them. Assign Mandatory Baseline
items to a group via the Mandatory Baseline view.

The following reference describes the Mandatory Baseline Items table.

Table 143: Mandatory Baseline Items Table

Column Description

Name The name of the Mandatory Baseline (content) item.

Impact The impact of the Mandatory Baseline item.

OS List The list of operating systems the Mandatory Baseline applies to.

Note:  Mandatory Baseline Items only shows Mandatory Baseline items directly assigned to the group.
Inherited Mandatory Baseline items are displayed in the Mandatory Baseline view.

Agent Policy Sets
This section lists the agent policy sets assigned to the selected group, and whether or not that policy set is directly
assigned or assigned via inheritance. This section only lists assigned policy sets; you cannot use it to assign them.
Assign policy sets to the selected group via the Policies view.

The following reference describes the Policy Sets table.

Table 144: Policy Sets

Field Description

Policy Set Name Indicates the name of the agent policy set.

Assigned Indicates if the agent policy set is directly assigned to the group or inherited. A value
of True indicates the agent policy set is directly assigned.

Note:  When a group's Policy Enabled setting is enabled, the group will uses the global system policy set to
define undefined policies. For additional information, refer to Defining Agent Policy Inheritance Rules on page
369.

Resultant Agent Policy Set Information
When a group is assigned two or more agent policy sets, some of the policy settings may conflict. When conflicts
occur, the system applies the agent policy conflict resolution rules to determine which policy settings to apply.
This section lists the resultant policy settings used when agent policy sets conflict.
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The following reference describes the Resultant Agent Policy Set Information table.

Table 145: Resultant Agent Policy Set Information

Field Description

Name The name of the agent policy.

Value The agent policy value. When determining the policy value, directly assigned policies
supersede inherited policies. Additionally, directly assigned policies that conflict are
resolved by the conflict resolution rules.

Description The description of the agent policy.

Note:  Only agent policies inherited or directly assigned to the group are displayed in Resultant Agent
Policy Set Information. To see a complete listing of all policies assigned to a managed endpoint, refer to The
Information Tab on page 175.

Roles
Within Lumension Endpoint Management and Security Suite, you can restrict user access to specific groups
based on roles. This section lists the user roles that can access the selected group. This section merely lists the
roles that can access the group; you cannot use it to assign roles to the group. To define roles that access the
group, edit the accessible groups when creating or editing a role.

The following reference describes the Roles table.

Table 146: Roles

Field Description

Role Name Indicates the name of the user role that can access the group.

Role Source Indicates the name of the group that the assigned role is inherited from. If the role source
contains no value, the role is directly assigned to the selected group.

Assigned Indicates if the role is inherited or directly assigned to the group. A value of True indicates
the role is directly assigned to the group.

Exporting Information View Data
To export the information displayed within the Information view to a comma separated value (.csv) file, click
the toolbar Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.
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The Group Membership View
This view lets you view the selected group's direct child groups. If the selected group is a custom group, you can
also create new custom child groups that you can populate with the desired endpoints. Custom groups also let
you edit or delete any listed preexisting child groups.

This view only lists direct child groups; you cannot manage grandchild groups or further descendants.

Figure 98: Group Membership View

The Group Membership View Toolbar
This toolbar contains buttons related to the creation and management of groups.

The following table describes the toolbar functions. Some functions are common to all the Groups page views.

Table 147: Group Membership Toolbar

Button Function

Create Creates a new group. For additional information, refer to Creating a Group on page 269.

Delete Deletes a group. For additional information, refer to Deleting Groups on page 271.

Move... Assigns a group to a new parent group. For additional information, refer to Moving a Group
on page 272.

Deploy... Deploys content to selected groups. For additional information, refer to Deploying Content
to Groups (Group Membership View) on page 273.

Scan Now

(menu)

Opens the Scan Now menu.

Discover
Applicable
Updates...

(Scan Now
menu item)

Prompts the Discover Applicable Updates task to launch immediately and check a group
for vulnerabilities. For additional information, refer to Using Scan Now to Scan Group
Inventory on page 274.
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Button Function

Reboot Now... Initiates the Reboot task for endpoints in the selected group(s). For additional information,
refer to Rebooting Groups on page 274.

Export Exports the page data to a comma separated value (.csv) file. For additional information,
refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in
Internet Explorer or other supported browsers may also suppress export functionality and
should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page
53.

The Group Membership View List
This list displays the selected group's direct child groups. Each listing contains group identification information
and icons used to edit identification information or delete the group altogether.

The following table displays the Group Membership view list details.

Table 148: Group Membership View

Column Icon Description

Action Contains Edit and Delete icons. Use these icons to edit or delete the associated
group.

Groups Contains an icon that indicates the group type (system custom, or
directory service ).

Name Indicates the name of the child group.

Description Indicates the description of the group.

Distinguished
Name

Indicates the system-created name based upon the group’s parent hierarchy.

Endpoints Indicates the number of endpoints assigned to the group.

Note:  System and Directory Service groups cannot have their child group or endpoint memberships edited.
However, their assigned agent policy sets can be edited.

Creating a Group
Lumension Endpoint Management and Security Suite provides preconfigured groups. However, you can also
create custom groups. Populate custom groups with desired endpoints. You can only create custom groups within
the Group Browser custom group hierarchy.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 270 -

Create groups from the Group Membership view.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. Select the Custom Group  from the directory tree that you want to create a child group for.

4. Click Create.

Step Result: A new row appears on the page.

Figure 99: New Row

5. In the Name field, type a name for the group.

6. [Optional] Type a brief description about the group in the Description field.

7. Click the Save icon associated with the new group.

Result: The group is saved to the list and is added to the directory tree. A Distinguished Name is generated for
the group.

After Completing This Task:

Add endpoints to the group. For additional information, refer to Adding Endpoint Members on page 281.

Editing Groups
You can edit the names and descriptions for custom groups. In the Group Membership view, you can only edit
group names and descriptions, not their settings.

You can only edit the names for groups within the Custom Groups hierarchy. Edit groups from the Group
Membership view.

Note:  The My Groups group Name and Description cannot be edited. Additionally, within the System
Groups and Directory Service Groups hierarchies, only group Descriptions can be edited, not their Names.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the parent group of the group you want to edit.
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4. Click the Edit icon associated with the group you want to edit.

5. [Optional] Edit the Name field associated with the group.

6. [Optional] Edit the Description field associated with the group.

7. Click the Save icon.

Result: The changes are saved to the group.

Note:  Within the Group Membership view, you can only edit the group name and description. To edit
group behavior, use the Groups page views.

Deleting Groups
Delete a group when you no longer need to manage its endpoints collectively. Only custom groups can be
deleted. After deleting a group, you cannot recover it; you must recreate the group.

Delete custom groups from the Groups Membership view.

Note:  Deleting a group does not prevent an endpoint within that group from rebooting, deploying, or scanning;
these tasks occur at the endpoint level.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the parent group of the group(s) you want to delete.

Note:  Only groups within the Custom Groups hierarchy can be deleted.

4. Delete the desired group(s).

Use one of the following methods.

Method Steps

To delete a single group: Click the Delete icon associated with the group you want to delete.

To delete multiple groups: 1. Select the check boxes associated with the groups you want to
delete.

2. From the toolbar, click Delete.

Step Result: A dialog appears asking you to acknowledge the deletion.

5. Acknowledge the deletion by clicking OK.

Result: The selected groups are deleted.

Caution:  When a group is deleted, its child hierarchy is deleted as well.
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Moving a Group
After creating a group, you can change its position within the Group Browser directory tree.

You can only move groups within the Custom Groups hierarchy.

Note:  When moving a group, if the group is configured to inherit agent policies, roles, or any other settings, the
group inherits those values from its new parent.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the parent group of the group you want to move.

4. Select the check box associated with the group you want to move.

5. Click Move.

Step Result: The Move Groups dialog opens.

Figure 100: Move Groups Dialogs

6. Select a new parent group.
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7. Click Next.

Step Result: The group is moved to the new parent group.

Note:  If the group you are moving contains a child hierarchy, those groups are moved as
well.

Figure 101: Move Confirmation

8. Click Finish.

9. Click Close.

Result: The select group is moved to its new place in the group hierarchy.

Deploying Content to Groups (Group Membership View)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Groups page Group Membership view. When deploying from this view, the Deployment Wizard is
preconfigured to deploy to the selected group.

For additional information, refer to About Deployments on page 213.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the group you want to deploy content to.
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4. Click Deploy.

Result: The Deployment Wizard opens, preconfigured to deploy to the selected group.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Using Scan Now to Scan Group Inventory
You can initiate a discover applicable updates (DAU) task for all endpoints in a selected group. When you
initiate this task, the agent scans its host endpoint for vulnerabilities and inventory. Scan results are then
uploaded to the Lumension Endpoint Management and Security Suite server, which you can view.

You can launch a DAU task for managed endpoints in a selected group. Perform this task from the Groups page
Group Membership view.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the group you want to scan.

4. Click Scan Now > Discover Applicable Updates.

Step Result: The Scan Now dialog opens.

5. Select the Yes, scan all members of the selected group.

6. [Optional] Select the Include child groups in the scan.

7. Click Schedule.

8. Acknowledge the scheduling by clicking Close.

Result: The scan is scheduled. As with all deployments, although the Discovery Applicable Updates task is
scheduled for immediate execution, it will not actually occur until the next time the agent checks in.

Rebooting Groups
Within Lumension Endpoint Management and Security Suite, you can reboot all endpoints within a given group.

Reboot entire groups from the Group Membership view.

1. Select Manage > Groups.

2. From the View list, select Group Membership.

3. From the directory tree, select the group you want to reboot.

4. Click Reboot Now.

Step Result: The Reboot Now dialog opens.

5. Select the Yes, reboot all members of the selected group check box.

6. Select the Reboot child groups check box.
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7. Click Reboot.

8. Acknowledge the reboot scheduling by clicking Close.

Result: The reboot is scheduled. As with all deployments, although the reboot is schedule for immediate
execution, it will not actually occur until the next time the agent checks in.

Exporting Group Membership View Data
To export information displayed in the Group Information view list to a comma separated value (.csv) file,
click the toolbar Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.

The Endpoint Membership View
This view lists the endpoints that hold membership in the selected group. If the group selected is a custom group,
you can also use this view to add endpoints. Use this view to manage endpoints assigned to the selected group.
This view contains features similar to those available from the Endpoints page.

This view features two tabs:

• The All Tab (Groups Page) on page 276
• The Patch and Remediation Tab (Groups Page) on page 278

Figure 102: Endpoint Membership View
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The All Tab (Groups Page)
Use the All tab to perform tasks related to a selected group's endpoint. This tab is similar to the Endpoints page
All tab, but lets you perform tasks from a group level.

Figure 103: All Tab

The All Tab Toolbar (Groups Page)
The All tab toolbar contains buttons for you to perform tasks and functions for managed endpoints.

The following table describes the toolbar functions used in the All tab, available on the Groups page Endpoint
Membership view.

Table 149: All Tab Toolbar (Groups Page)

Button Description

Manage Adds or removes managed endpoints to or from the selected group. For additional
information, refer to one of the following topics:

• Adding Endpoint Members on page 281
• Removing Endpoint Members on page 282

Manage Agents...

(menu)

Opens the Manage Agents menu.

Install Agents...

(Manage Agents... menu
item)

Installs agents on selected endpoints. For additional information, refer to Installing
Agents by Agent Management Job on page 284.

Uninstall Agents...

(Manage Agents... menu
item)

Deletes agents from selected endpoints. For additional information, refer to
Uninstalling Agents by Agent Management Job on page 284.

Download Agent
Installer...

(Manage Agents... menu
item)

Downloads an agent installer to the endpoint used to access Lumension Endpoint
Management and Security Suite. For additional information, refer to Downloading
the Agent Installer on page 284.
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Button Description

Delete Deletes a disabled endpoint. For additional information, refer to Deleting Endpoint
(Groups Page) on page 285.

Enable Enables a disabled endpoint. For additional information, refer to Enabling or
Disabling Endpoints within a Group on page 286.

Disable Disables an enabled endpoint. For additional information, refer to Enabling or
Disabling Endpoints within a Group on page 286.

Agent Versions... Defines the endpoint agent version. For additional information, refer to Defining
the Endpoint Agent Version (Groups Page) on page 284.

Manage Modules... Opens the Add/Remove Modules dialog. Use this dialog to toggle module-specific
agent functions. For additional information, refer to Managing Endpoint Modules
(Groups Page) on page 287.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The All Tab List (Groups Page)
The All tab list itemizes endpoint operating system information, identification information, agent information,
and module information.

The following table describes the columns within the All tab list.

Table 150: All Tab List Columns

Column Description

Endpoint Indicates the name of the endpoint. Click the link to open the Endpoint
Details page. For additional information, refer to The Endpoint Details
Page on page 174.

IP Address Indicates the IP address of the endpoint.

Agent Status Indicates the status of the endpoint (Online, Offline, or Disabled).

Operating System Indicates the operating system the endpoint is running.
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Column Description

Agent Type Indicates the type of agent that is running on the endpoint and
communicating with the Lumension Endpoint Management and Security
Suite server.

Agent Version Indicates the version number of the agent that is assigned to the endpoint.

Module Installed Indicates whether a component module is installed on the endpoint. A
Module Installed column appears for each component module installed
on your Lumension Endpoint Management and Security Suite server. The
following list defines column entry values:

Yes The module is installed.

Pending The module is pending install or
uninstall.

No The module is not installed.

Error There was an error while installing
or uninstalling the module. Click the
error link for additional information
about the error.

Expired The module license has expired.

The Patch and Remediation Tab (Groups Page)
Use the Patch and Remediation tab to perform tasks related to a selected group's endpoint. This tab is similar to
the Endpoints page Patch and Remediation tab, but lets you perform tasks from a group level.

Figure 104: Patch and Remediation Tab

The Patch and Remediation Toolbar (Groups Page)
The Patch and Remediation tab toolbar contains the tasks and functions that are available for you to perform for
managed endpoints with Patch and Remediation features enabled.
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The following table describes the toolbar functions used in the Patch and Remediation tab on the Groups page
Endpoint Membership view.

Table 151: Patch and Remediation Tab Toolbar (Groups Page)

Button Description

Manage Adds or removes managed endpoints to or from the selected group. For additional
information, refer to one of the following topics:

• Adding Endpoint Members on page 281
• Removing Endpoint Members on page 282

Deploy... Launches the Deployment Wizard, which allows you to create a deployment for
the selected endpoints (Patch and Remediation only). For additional information,
refer to Deploying Content to Endpoints (Endpoint Membership View) on page
283.

Manage Agents...

(menu)

Opens the Manage Agents menu.

Install Agents...

(Manage Agents... menu
item)

Installs agents on selected endpoints. For additional information, refer to Installing
Agents by Agent Management Job on page 284.

Uninstall Agents...

(Manage Agents... menu
item)

Deletes agents from selected endpoints. For additional information, refer to
Uninstalling Agents by Agent Management Job on page 284.

Download Agent
Installer...

(Manage Agents... menu
item)

Downloads an agent installer to the endpoint used to access Lumension Endpoint
Management and Security Suite. For additional information, refer to Downloading
the Agent Installer on page 284.

Delete Deletes a disabled endpoint. For additional information, refer to Deleting Endpoint
(Groups Page) on page 285.

Agent Versions... Defines the endpoint agent version. For additional information, refer to Defining
the Endpoint Agent Version (Groups Page) on page 284.

Enable

(Menu)

Expands the Enable menu.

Enable Agent

(Enable menu item)

Enables a disabled endpoint. For additional information, refer to Enabling an
Endpoint on page 168.

Enable Module

(Enable menu item)

Enables the Patch and Remediation agent module (Patch Agent) on only selected
endpoints. For additional information, refer to Enabling or Disabling Endpoints
Modules within a Group on page 286.
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Button Description

Disable

(Menu)

Expands the Disable menu.

Disable Agent

(Disable menu item)

Disables an enabled endpoint. For additional information, refer to Disabling an
Endpoint on page 169.

Disable Module

(Disable menu item)

Disables the Patch and Remediation agent module (Patch Agent) on only selected
endpoints. For additional information, refer to Enabling or Disabling Endpoints
Modules within a Group on page 286.

Manage Modules... Opens the Add/Remove Modules dialog. Use this dialog to toggle module-specific
agent functions. For additional information, refer to Managing Endpoint Modules
(Groups Page) on page 287.

Scan Now... Launches the DAU task on selected endpoints. For additional information, refer to
Using Scan Now to Scan Group Endpoint Inventory on page 288.

Reboot Now... Prompts the selected endpoint to reboot. For additional information, refer to
Rebooting Group Endpoints on page 289.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Patch and Remediation Tab List (Groups Page)
The Patch and Remediation tab list itemizes endpoint identification data, server connectivity, operating system,
and agent information.

The following table describes the columns within the Patch and Remediation tab on the Groups page Endpoint
Membership view.

Table 152: Patch and Remediation Tab List Columns

Column Description

Name The name of the endpoint. Clicking the Name  link displays the applicable
Endpoint Details page. See The Endpoint Details Page on page 174 for
additional information.

IP Address The IP address of the endpoint.
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Column Description

Status

(icon)

The icon representing the Patch and Remediation module status. You can
mouse over the icon to display description of the Patch and Remediation
status. For additional information, refer to Agent Module Status Icons on
page 526.

Agent Status Indicates the status of the endpoint (Online, Offline, or Disabled).

LPR  Status The status for Patch and Remediation module (the Patch Agent) on the
endpoint (Working, Idle, Sleeping, Offline, Disabled).

DAU Status The status of the Discover Applicable Updates (DAU) scan when last run.
The status is also a link to the applicable Deployment Results page. Status
values include: Success or Failure followed by the failure code, and
Not Available, which indicates that the endpoint has not checked in.

Note:  The Not Available DAU Status is not a hyperlink (Patch and
Remediation only).

Last DAU Scan (Server) The date and time of the last successful DAU scan (server side). A value
of Not Available indicates the endpoint has not completed a DAU scan
(Patch and Remediation only).

Operating System The operating system the endpoint is running.

LPR Running Version The Patch and Remediation module version number running on the
endpoint.

Agent Type The type of agent that is running on the endpoint and communicating
with the Lumension Endpoint Management and Security Suite server
(Lumension EMSS or Patch).

Agent Version The version number of the agent assigned to the endpoint.

Adding Endpoint Members
Add endpoints to a group when those endpoints serve a similar function. Adding endpoints to a group lets you
manage them collectively. You can only add endpoints to custom groups.

Add endpoints to a group from the Endpoint Membership view.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select one of the following tabs:

• The All Tab
• The Patch and Remediation Tab

4. Select a custom group from the directory tree.
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5. From the toolbar, click Manage.

Figure 105: Manage Endpoints

6. Add endpoints to the group.

Use one of the following methods.

Method Steps

To add individual endpoints: 1. From the Endpoints list, select the check boxes associated with the
endpoints you want to add to the group.

2. Click Assign.

To add all endpoints: Click Assign All.

To add endpoints through
importation via a list:

1. Select the Import Endpoint List option.
2. Select a group from the Import endpoint list from existing group

list. Selecting a group from this list will automatically populate the
field with applicable endpoint names.

3. Type the desired endpoint names in the field. Separate endpoint
names with commas (,).

4. Click Assign All.

Step Result: Endpoints are added to the Selected Endpoints table according to your input.

7. Click OK.

Result: The selected endpoints are added to the group. Click Update View to review the endpoint assignment.

Removing Endpoint Members
When an endpoint no longer fits within the context of a group (for example, it no longer requires content
applicable to the rest of the group), remove it from the group. You can re-add endpoints at any time.

Group endpoint removal takes place from the Endpoint Membership view.
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1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select one of the following tabs:

• The All Tab
• The Patch and Remediation Tab

4. Select a custom group from the directory tree.

5. Click Manage.

6. Remove endpoints from the group.

Use one of the following methods.

Method Steps

To remove individual
endpoints:

1. From the Selected Endpoints list, select the check boxes associated
with the endpoints you want to remove from the group.

2. Click Remove.

To remove all endpoints: Click Remove All.

Step Result: Chosen endpoints are removed from the Selected Endpoints table.

7. Click OK.

Result: The selected endpoints are removed from the group. Click Update View to review the endpoint
assignment.

Deploying Content to Endpoints (Endpoint Membership View)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Groups page Endpoint Membership view. When deploying from this page, the Deployment
Wizard is preconfigured to deploy content to selected endpoints within a selected group.

For additional information, refer to About Deployments on page 213.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. From the directory tree, select the group containing endpoints you want to deploy content to.

4. Select the Patch and Remediation tab.

5. [Optional] Select endpoints to receive deployments.
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6. Click Deploy.

Result: The Deployment Wizard opens, preconfigured to deploy to selected endpoints.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Installing Agents by Agent Management Job
Within Lumension Endpoint Management and Security Suite, there are multiple methods of installing agents
on endpoints using agent management jobs. To create an agent management job that installs agents from the
Endpoint Membership view, select Manage Agents > Install Agents from the toolbar.

For additional information, refer to Installing Agents by Agent Management Job on page 586.

Uninstalling Agents by Agent Management Job
Within Lumension Endpoint Management and Security Suite, there are multiple methods of uninstalling agents
from endpoints using agent management jobs. To create an agent management job that uninstalls agents from the
Endpoint Membership view, select Manage Agents > Uninstall Agents from the toolbar.

To prepopulate the Schedule Agent Management Job - Uninstall Wizard target list, first select the desired
group from the Group Browser Directory Tree, and then select the check boxes associated with the desired
endpoints.

For additional information, refer to Uninstalling Agents by Agent Management Job on page 600.

Downloading the Agent Installer
If you want to install an agent on the endpoint that you are currently using to access Lumension Endpoint
Management and Security Suite, you can perform this task from the Endpoint Membership view.

To download an agent installer from the Endpoint Membership view, select Manage Agents > Download
Agent Installer from the toolbar. For additional information, refer to Downloading the Agent Installer on page
166.

Defining the Endpoint Agent Version (Groups Page)
From the Groups page, you can define which version(s) of the Lumension Endpoint Management and Security
Suite Agent can be installed on group endpoints.

Define agent version(s) for group endpoints from the Groups page Endpoint Membership view.

1. Select Manage > Groups.

Step Result: The Groups page opens.

2. From the View list, select Endpoint Membership.

3. From the Group Browser directory tree, select an endpoint group.

4. Select the endpoints on which you want to define agent version(s).
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5. Click Agent Versions.

Step Result: The Manage Agent Versions dialog opens.

6. Define the agent version(s).

Use one of the following methods:

Method Steps

To define a standard agent
version for all listed endpoints:

• From the Select One list, select an agent version.
• Click Apply to All Agents.

To define an agent version for
each endpoint:

Select an agent version from the Agent Version list for each endpoint.

Note:  The agent versions available for selections are defined from the Options page. For additional
information, refer to Configuring the Agents Tab on page 132.

7. Click OK.

Result: The Manage Agent Versions dialog closes. If an agent version other than the defined version is
installed on the endpoints, the defined version is installed over the previous version.

Deleting Endpoint (Groups Page)
You can delete the list item for an endpoint.

Delete endpoint listing from the Endpoint Membership view.

Note:  You can only delete disabled endpoints. For additional information, refer to Enabling or Disabling
Endpoints within a Group on page 286.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select a custom group from the directory tree.

4. Select the endpoint listings you want to delete.

Tip:  You can delete endpoints from any module tab.

5. Click Delete.

Step Result: A confirmation dialog opens.

6. Click OK to confirm the deletion.

Result: The list item for the selected endpoints are deleted.
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Enabling or Disabling Endpoints within a Group
Disabling an endpoint effectively deactivates its agent functionality. Disabled endpoints do not contact the
Lumension Endpoint Management and Security Suite server, use Lumension Endpoint Management and Security
Suite features, or occupy Lumension Endpoint Management and Security Suite licenses. Disable an endpoint if it
will be unused for a prolonged period. You can re-enable an endpoint at any time.

Disable an endpoint within a group from the Endpoint Membership view.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select one of the following tabs:

• The All Tab
• The Patch and Remediation Tab

4. Select a group from the directory tree.

5. If necessary, define filter criteria and click Update View.

6. Select the check box(es) associated with the endpoint(s) you want to enable or disable.

7. Enable or disable the selected endpoint(s):

Use one of the following methods.

Method Steps

To enable a disabled endpoint: Click Enable.

To disable an enabled
endpoint:

1. Click Disable.
2. Acknowledge the disablement by clicking OK.

Result: The applicable endpoints are enabled or disabled. The Endpoint Membership view and Endpoints page
reflect your changes.

Note:  Disabling an endpoint within a group is not limited to the group; the endpoint is completely
disabled within the Lumension Endpoint Management and Security Suite system.

Enabling or Disabling Endpoints Modules within a Group
From the groups page, you can disable an agent's individual modules. Disable an endpoint's module component if
it will be unused for a prolonged period. You can re-enable the endpoint module at any time.

Prerequisites:

Endpoints must have the applicable agent module installed, and the endpoint must be licensed for the agent
module. For additional information, refer to Managing Module Endpoint Components on page 171.
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Disable an endpoint within a group from the Endpoint Membership view.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select a group from the directory tree.

4. Select the tab for the module you want to enable or disable.

Tip:  The tabs available depend on which modules you have purchased and installed.

5. [Optional] Define filter criteria and click Update View.

6. Select the check box(es) for endpoint(s) with module components you want to enable or disable.

7. Enable or disable the selected endpoint module(s):

Use one of the following methods.

Method Steps

To enable a disabled module
component:

Select Enable > Enable Module.

To disable an enabled
endpoint:

1. Select Enable > Enable Module.
2. Acknowledge the disablement by clicking OK.

Result: The applicable endpoint module components are enabled or disabled. The Endpoint Membership view
and Endpoints page reflect your changes.

Note:  Disabling an endpoint module within a group is not limited to the group; the endpoint module is
completely disabled within the Lumension Endpoint Management and Security Suite system.

Managing Endpoint Modules (Groups Page)
You can manage endpoint module licences from the Groups page. Using this feature allows you control which
modules apply to a particular endpoint.

Manage modules for individual endpoints from the Groups page Endpoint Membership view.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select one of the following tabs:

• The All Tab
• The Patch and Remediation Tab

4. From the directory tree, select the group containing endpoints you want to manage.

5. Select the checkbox(es) associated with the endpoints for which you want to manage modules.
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6. Click Manage Modules.

Step Result: The Add/Remove Modules dialog opens.

7. Manage modules for each endpoint.

• To activate a module for a particular endpoint, select the module checkbox for the applicable endpoint.
• To deactivate a module for a particular endpoint, clear the module checkbox for the applicable endpoint.

Tip:  Select or clear the Select All check box(es) associated with a module to globally toggle a module for all
endpoints.

8. Click OK.

Result: The Add/Remove Modules dialog closes. The agent features for each edit are updated during the next
Discover Applicable Updates task.

Using Scan Now to Scan Group Endpoint Inventory
You can initiate a discover applicable updates (DAU) task for all endpoints in a selected group or only selected
endpoint within the group. When you initiate this task, the agent scans its host endpoint for vulnerabilities and
inventory. Scan results are then uploaded to the Lumension Endpoint Management and Security Suite server,
which you can view.

You can launch a DAU task for all endpoints in a selected group or individual endpoints in a selected group.
Perform this task from the Groups page Endpoint Membership view.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select the Patch and Remediation tab.

4. From the directory tree, select the group containing endpoints you want to schedule DAU tasks for.

5. Schedule a task for the entire group or individual endpoints.

Use one of the following methods.

Method Steps

To schedule a task for an entire
group:

1. From the toolbar, select Scan Now > Discover Applicable
Updates.

2. Select Yes, scan all members of the selected group check box.
3. Select the Include child groups in the scan  check box. This

option schedules tasks for all groups in the selected group's child
hierarchy.
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Method Steps

To schedule a task for
individual endpoints:

1. From the toolbar, select the check boxes associated with the desired
endpoint(s).

2. Select Scan Now > Discover Applicable Updates.
3. Select the Yes, scan the selected endpoint check box.

6. Click Schedule.

7. Acknowledge the scheduling by clicking Close.

Result: The scan is scheduled. As with all deployments, although the Discovery Applicable Updates task is
scheduled for immediate execution, it will not actually occur until the next time the agent checks in.

Rebooting Group Endpoints
From the Endpoint Membership view, you can reboot entire groups or endpoints within a group.

1. Select Manage > Groups.

2. From the View list, select Endpoint Membership.

3. Select the Patch and Remediation tab.

4. From the directory tree, select the group containing endpoints you want to reboot.

5. Reboot the entire group or individual endpoints.

Use one of the following methods.

Method Steps

To reboot an entire group 1. Click Reboot Now.
2. Select Yes, reboot all members of the selected group check box.
3. Select the Reboot child groups check box.

To reboot individual
endpoints:

1. Select the check boxes associated with the desired endpoint(s).
2. Click Reboot Now.
3. Select the Yes, reboot the selected endpoint check box.

6. Click Reboot.

7. Acknowledge the reboot by clicking Close.

Result: The reboot is scheduled. As with all deployments, although the reboot is schedule for immediate
execution, it will not actually occur until the next time the agent checks in.
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Exporting Endpoint Membership View Data
To export information displayed in the Endpoint Membership view list to a comma separated value (.csv) file,
click the toolbar Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.

The Mandatory Baseline View
This view lets you add content to the selected group's Mandatory Baseline. It also lists each content item
included in the group's Mandatory Baseline. The list also shows whether or not each endpoint within the group
has that content item installed.

Use this view to define the selected group's Mandatory Baseline.

Figure 106: Mandatory Baseline

About Mandatory Baselines
A Mandatory Baseline is a minimum set of content that must be installed on a group's endpoints. Composed of
user-defined content items deemed essential to the group, this baseline continually verifies that the applicable
items are installed on group endpoints. If a group endpoint is found in a non-compliant state (does not have
an item defined in the baseline installed), Lumension Endpoint Management and Security Suite automatically
deploys the applicable content until the endpoint is once again compliant. Mandatory Baselines ensure group
endpoints are never without essential security content.

For example, you can set a Mandatory Baseline for all endpoints within a group that must have Microsoft
Windows Messenger installed. If Messenger is deleted on a group member’s endpoint, Lumension Endpoint
Management and Security Suite reinstalls Messenger.
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Remember the following rules when working with Mandatory Baselines:

• Mandatory Baseline inheritance indicates that a group’s endpoints (both inherited and assigned) are included
by the parent group when evaluating its own baseline items and inheritance.

• If endpoints receive a Mandatory Baseline item via inheritance, the Mandatory Baseline item will also be
displayed on the child group’s Mandatory Baseline view. However, the inherited baseline items will be
unavailable, indicating the Mandatory Baseline originates from a parent group.

• Disabling Mandatory Baseline deployments only applies to the Mandatory Baseline items that are directly
assigned to the group, and will prevent those directly assigned items from being inherited by the group’s child
hierarchy.

• Disabling Mandatory Baseline deployments does not disable the deployments created through Mandatory
Baseline inheritance. Additionally, disabling the baseline deployments will not remove the baseline items
from the group’s Mandatory Baseline view.

Note:  Unless stringent hours of operation agent policies are in effect, do not apply Mandatory Baselines to
groups of mission-critical servers or other endpoints where unscheduled reboots would disrupt daily operations.

About Mandatory Baseline Import/Export
Within Lumension Endpoint Management and Security Suite, you can import or export Mandatory Baselines.
Importing and Exporting Mandatory Baselines simplifies application of Baselines to different groups.

After establishing a Mandatory Baseline, you can export the baseline from Lumension Endpoint Management
and Security Suite. After exporting a baseline, you can then import the baseline to a different group or
Lumension Endpoint Management and Security Suite installation.

Lumension recommends using the Mandatory Baseline import/export feature in the following situations:

• When reinstalling Lumension Endpoint Management and Security Suite. Export Mandatory Baselines before
beginning reinstallation, and then import Mandatory Baselines to groups after installation. This use of import/
export eliminates the manual reestablishment of baselines, easing administrative burden.

• When establishing similar or identical Mandatory Baselines for multiple groups. Rather than manually
creating baselines for each group, export a Mandatory Baseline and then import it to other groups. Use this
method to quickly establish baselines for multiple groups. After importing a baseline, you can then edit it to
suit a group's particular requirements.

The Mandatory Baseline Process
After content items are added to a group's Mandatory Baseline, Lumension Endpoint Management and Security
Suite schedules a series of scans and deployments until the group complies with the baseline.

The following chart depicts the Mandatory Baseline process following the addition of a content item to a
baseline.

Lumension Endpoint Management and Security Suite automatically schedules a
Discover Applicable Updates (DAU) task for all endpoints within the applicable group.
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Following the DAU, Lumension Endpoint Management and Security Suite determines
which endpoints are not compliant with the Mandatory Baseline.

Necessary content is deployed to non-compliant endpoints as soon as possible.

Note:  Some content requires both reboots and an administrator-level log in to complete. If these or similar
content items are added to a baseline, the deployment will stop until the log in occurs.

Viewing a Group Mandatory Baseline
Navigate to a group's Mandatory Baseline to see the content items that all its members must have installed.

See the Mandatory Baseline for a selected group from the Mandatory Baseline view.

1. Select Manage > Groups.

2. Select the desired group from the directory tree.

3. From the View list, select Mandatory Baseline.

Result: The Mandatory Baseline associated with the group is displayed.

The Mandatory Baseline View Toolbar
This toolbar contains buttons related to the management of Mandatory Baselines. It also contains a button
that lets you cache content items after adding them to the baseline. This caching process ensures swift content
installations if an endpoint falls out of compliance.

The following table lists the available toolbar buttons and their functions.

Table 153: Mandatory Baseline View Toolbar

Button Function

Manage Adds or removes content to or from the group’s Mandatory Baseline. For additional
information, refer to either Adding Content to Mandatory Baselines on page 295 or
Removing Content from Mandatory Baselines on page 298.

Update Cache Caches (downloads) the package associated with the selected Mandatory Baseline item(s)
(or the scripts associated with downloading the package). For additional information, refer
to Updating the Mandatory Baseline Cache on page 304.
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Button Function

Import Imports an Mandatory Baseline template into the group, defining Mandatory Baseline
item. For additional information, refer to Importing Mandatory Baseline Templates on page
304.

Export

(menu)

Opens the Export menu.

CSV file

(Export menu
item)

Exports the page data to a comma separated value (.csv) file. For additional information,
refer to Exporting Data on page 60.

Template
(*.XML)

(Export menu
item)

Exports the group Mandatory Baseline as a template in .xml format. For additional
information, refer to Exporting Mandatory Baselines Templates on page 308.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page
53.

The Mandatory Baseline View List
This list displays the content items included in the selected group's Mandatory Baseline. You can also filter this
list to display different types of content.

The following table describes the Mandatory Baseline view list.

Table 154: Mandatory Baseline View List

Column Icon Description

Item Type Contains an icon that indicates the Mandatory Baseline item status and type.
For a description of each Mandatory Baseline item icon, refer to Content
Status and Type on page 385.

Mandatory
Baseline
Compliance

Indicates Mandatory Baseline compliance status for the applicable item.

For a description of each compliance icon, refer to Mandatory Baseline Item
Compliance Icons on page 294.

Note:  If the Mandatory Baseline fails to deploy more than twice, it will be
recorded as an error in the Status column. However, this notification will
only show in the Mandatory Baseline view.

Mandatory
Baseline Item

Indicates the Mandatory Baseline item name. The name doubles as a link the
item's Review page.
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Column Icon Description

Impact Indicates the impact of the Mandatory Baseline item. For a description of
each impact, refer to one of the following pages based on the applicable type
of Mandatory Baseline item:

• Vulnerabilities on page 378
• Software Content on page 378
• Other Content on page 378

Status Indicates the status of the Mandatory Baseline item (Enabled or Disabled).

OS List Indicates the operating systems that the Mandatory Baseline item applies to.

Note:  The Mandatory Baseline Item, Impact, Status, and OS List are identical to the content items that the
Mandatory Baseline items represent.

Each item on the Mandatory Baseline view list can be expanded to display additional details about the item.
This information lists each endpoint in the group, and whether or not these endpoints comply with the expanded
Mandatory Baseline item. Click the Rotating Chevron (>) next to a Mandatory Baseline item to view these
details.

The following table describes each column within the details of a Mandatory Baseline item.

Table 155: Package Column Definitions

Column Icon Description

Endpoint Status
Icon

Displays an icon that indicates the current status of the applicable endpoint.
For additional information, refer to Agent Module Status Icons on page
526.

Mandatory
Baseline Icon

Displays an icon that indicates the status of the endpoint in relation to the
expanded Mandatory Baseline item. For additional information, refer to
Mandatory Baseline Item Compliance Icons on page 294.

Name Indicates the name of the endpoint within the selected group.

OS Indicates the operating system that runs on the endpoint.

Compliance Indicates whether the endpoint complies with the expanded Mandatory
Baseline item.

Mandatory Baseline Item Compliance Icons
Each item on the Mandatory Baseline view list contains an icon that indicates if all applicable endpoints within
the group have the associated content installed. Familiarizing yourself with these icons will help you understand
if the selected group currently complies with its Mandatory Baseline. Additionally, after expanding a Mandatory
Baseline items, compliance icons also appear for each endpoint.
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The following table describes the compliance icons for Mandatory Baseline items.

Table 156: Mandatory Baseline Item Compliance Icons

Icon Status

Indicates one or more group members are either detecting, obtaining the package, awaiting detection,
or is in a deployment-not-started state.

Indicates one or more group members are deploying the package.

Indicates all group members are disabled.

Indicates all group members are either not applicable or in compliance with this package (some can
also be disabled).

Indicates one or more group members are not compliant and had an error during deployment. Error
information displays in the mouseover text.

The following table describes the compliance icons for endpoints (which appear when a Mandatory Baseline
item is expanded).

Table 157: Endpoint Compliance Icons

Icon Status

Indicates the group member is either detecting, obtaining the package, awaiting detection, or is in a
deployment-not-started state.

Indicates the group member is receiving the package.

Indicates the Mandatory Baseline item does not apply to the group member.

Indicates the group member complies with the Mandatory Baseline item.

Indicates the group member does not comply with the Mandatory Baseline item.

Adding Content to Mandatory Baselines
Add content to a selected group's Mandatory Baseline to ensure that content is installed on group endpoints at all
times.

Add content to a group's Mandatory Baseline from the Mandatory Baseline view.

1. Select Manage > Groups.

2. From the View list, select Mandatory Baseline.
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3. From the directory tree, select the desired group.

4. Click Manage.

Figure 107: Adding Content

5. Add content to the Mandatory Baseline.

Use one of the following methods.

Note:  When adding content items to a group Mandatory Baseline, ensure the content items you add are
not locally created packages. Locally created packages do not contain fingerprint files for detecting package
presence on group endpoint.

Method Steps

To add an individual content
items:

1. From the Vulnerabilities table, select the check boxes associated
with content items you want to add to the Mandatory Baseline. You
may need to page or scroll to find the desired items.

2. Click Assign.

To add all content items: Click Assign All.

Step Result: Content items are added to the Selected Vulnerabilities table according to your input.

Note:  Lumension recommends caching content before adding it to a Mandatory Baseline.
This practice ensures optimal package installation order. Failure to cache content prior to
Mandatory Baseline addition may result in repeated endpoint reboots that interrupt employee
workflow. Additionally, Lumension recommends filtering the Vulnerabilities table before
using Assign All. Adding all content to the Mandatory Baseline without filtering may
consume excessive network bandwidth and endpoint hard drive space.
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6. Click OK.

Result: The selected content is added to the selected group's Mandatory Baseline. The Groups page reflects
your changes.

Note:  To deploy Mandatory Baseline items, the group Mandatory Baselines enabled setting must be
set to True. For additional information, refer to Editing Group Settings on page 335.

Using the Filter Functions to Select Content
When managing Mandatory Baseline content items, you can filter the items according to your criteria. Use this
feature to find specific content items quickly.

Filter content when managing Mandatory Baselines from the Mandatory Baselines view.

1. From the Vulnerabilities or Selected Vulnerabilities table, click the Show Filters link.

2. Type your filter criteria in the Name and/or the Information fields.

3. Click the Apply Filters link.

Result: The Vulnerabilities or Selected Vulnerabilities table is filtered according to your criteria. If desired,
click the Clear Filters to start another search.

Showing Only the Required Vulnerabilities
When creating Mandatory Baselines, you can select content from the Needed Detection Vulnerabilities dialog
rather than the Vulnerabilities table. The Needed Detection Vulnerabilities dialog lists only content that is both
group-applicable and yet-to-be-installed versus the Vulnerabilities table, which lists all content on the Global
Subscription Server.

This dialog is accessible when adding Mandatory Baseline items.
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1. Click the Filter button.

Step Result: The Needed Detection Vulnerabilities dialog opens.

Figure 108: Needed Detection Vulnerabilities Dialog

2. Select the check boxes associated with content items you want to add to the Mandatory Baseline.

Note:  The Needed Detection Vulnerabilities dialog lists only content that is both applicable and yet-to-be-
installed on endpoints within the selected group.

3. Click OK.

Result: The Needed Detection Vulnerabilities dialog closes and the selected content items are added to the
Selected Vulnerabilities table.

Removing Content from Mandatory Baselines
When a group of endpoints no longer requires the constant presence of specific content, remove the applicable
content items from that group's Mandatory Baseline. Removing content from a Mandatory Baseline does not
remove it from the group's endpoints.

Remove content from Mandatory Baselines from the Mandatory Baseline view.

1. Select Manage > Groups.

2. From the View list, select Mandatory Baseline.

3. From the directory tree, select the desired group.

4. Click Manage.
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5. Remove content from the Mandatory Baseline.

Use one of the following methods.

Method Steps

To remove individual content
items:

1. From the Selected Vulnerabilities table, select the check boxes
associated with the content items you want to remove from the
Mandatory Baseline.

2. Click Remove.

To remove all content items: Click Remove All.

Step Result: Content items are removed from the Selected Vulnerabilities table according to your input.

6. Click OK.

Result: The selected content is removed from the selected group's Mandatory Baseline. The Groups page
reflects your changes.

Setting Mandatory Baseline Deployment Options
Like other deployments, automated Mandatory Baseline deployments also have customizable options.
After adding content items to a group's Mandatory Baseline, you can set deployment options for each item.
Configuring these options defines the manner in which Mandatory Baseline packages are deployed.

Prerequisites:

• A content item must be added to a group Mandatory Baseline.

Configure Mandatory Baseline package deployment options from the Mandatory Baseline view.

1. Select Manage > Groups.

2. Select the desired group from the directory tree.

3. From the View list, select Mandatory Baseline.

4. Click Manage.
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5. Click the Options button associated with the Mandatory Baseline item for which you want to define
deployment options.

Step Result: The Package Deployment Options dialog opens.

Figure 109: Package Deployment Options Dialog

6. From the Package Name list, ensure the desired package is selected.

7. Define Distribution Options.

Choose from the following options.

Option Steps

To deploy concurrently: 1. Select the Concurrent option.
2. In the field, type the desired number of endpoints to receive

simultaneous deployments.

To deploy consecutively: Select the Consecutive option.

8. If available, select the desired Deployment Flags.

For additional information, refer to Behavior Icon Definitions on page 244.
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9. If needed, type additional deployment flags in the Optional Flags field.

For additional information, refer to Package Flag Descriptions on page 418.

10. Select a Deployment Option.

• Do not notify users of this reboot.
• Notify users of this reboot.

11. If you selected Notify users of this deployment option, complete the following substeps.

a) [Optional] Type a notification in the Message field.
b) Select whether you want to manually define remaining notification options or use the default settings

defined in the Global Policy Set.

• To manually define remaining notification options, ensure the Use Policies check box is cleared and
continue to the next substep.

• To use the default notification option settings defined in the agent policy set associated with the target
endpoints, select the Use Policies check box and continue to the next step.

c) Define the Allow user to cancel option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

d) Define the Allow use to snooze option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

e) Define the Notification on top option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

For additional information about this option, refer to About the Show on Top Option on page 252.

f) Define the Deploy within option.

• To manually define this option, type a value in the field and select a value from the list (minutes,
hours, days).

• To use the default notification option setting defined in the agent policy set associated with the target
endpoints, select the Use Agent Policy check box.

12. Select a Reboot Option.

• Do not notify users of this reboot.
• Notify users of this reboot.
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13. If you selected Notify users of this reboot option, complete the following substeps.

a) [Optional] Type a notification in the Message field.
b) Select whether you want to manually define remaining notification options or use the default settings

defined in the agent policy set associated with the target endpoints.

• To manually define remaining notification options, ensure the Use Policies check box is cleared and
continue to the next substep.

• To use the default notification option setting defined in the agent policy set that applies to the target
endpoints, select the Use Policies check box and continue to the next step.

c) Define the Allow user to cancel option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

d) Define the Allow use to snooze option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

e) Define the Notification on top option.

• To manually define this option, select yes or no from the Setting list.
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

For additional information about this option, refer to About the Show on Top Option on page 252.

f) Define the Reboot within option.

• To manually define this option, define the field and list (minutes, hours, days).
• To use the default notification option setting defined in the agent policy set associated with the target

endpoints, select the Use Agent Policy check box.

Result: The Package Deployment Options dialog closes. Repeat these instructions for additional Mandatory
Baseline items if necessary.

Removing Deployments Created by Mandatory Baselines
Occasionally, deployments associated with a Mandatory Baseline may need to be stopped. However, how you
stop the deployment will change based on context; in some instances, you may want to stop the deployment for
all endpoints within the group; in others, you may only want to stop the deployment for specific endpoints within
the group.

Mandatory Baseline deployments can be stopped one of two ways: either stop the deployment itself or disable
the endpoints receiving the deployment.
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The removal of Mandatory Baseline deployments does not take place within the Mandatory Baselines view.
Rather, it takes place within the Deployments and Tasks view.

Note:  If the Mandatory Baseline still applies, the deployment will be recreated.

Removing a Mandatory Baseline Deployment from a Group
In the event that a Mandatory Baseline deployment needs to be removed for all endpoints within a group, delete
the deployment itself. Using this method prevents packages associated with the baseline from being installed on
all endpoints within the group.

Stop Mandatory Baseline deployments using this method from the Deployments and Tasks view.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. Select the applicable group from the directory tree.

4. Select the check box associated with the Mandatory Baseline deployment you want to delete.

5. Click Delete.

Step Result: A dialog displays, asking you to acknowledge the deletion.

6. Click OK to acknowledge the deletion.

Note:  If the Mandatory Baseline(s) still applies, the deployment(s) is recreated.

Result: The Mandatory Baseline deployment is stopped. It no longer appears in the Deployments and Tasks
view.

Stopping a Deployment for Specific Endpoints
In the event that a Mandatory Baseline deployment needs to be stopped for specific endpoints within a group,
disable those endpoints. Using this method prevents packages associated with the baseline from being installed
on specific endpoints within the group rather than all endpoints within the group.

Stop Mandatory Baseline deployments using this method from the Deployments and Tasks view.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. Select a group from the directory tree.

4. Click the desired deployment name link.

5. Select the check box(es) associated with the desired endpoint(s).
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6. Click Disable to disable the deployment(s) for the selected endpoint(s).

Note:  If the Mandatory Baseline still applies, the deployment is recreated.

Result: The selected endpoints are disabled, preventing them from receiving the Mandatory Baseline
deployment. Remember to re-enable the endpoints to resume vulnerability management activities
following management of the Mandatory Baseline.

Updating the Mandatory Baseline Cache
You can cache content that you have included in a group's Mandatory Baseline. Updating the cache for content
items downloads the packages (or the scripts that will download the packages) associated with those items.
Cached content items can be deployed immediately.

Cache content for Mandatory Baseline items from the Mandatory Baseline view.

1. Select Manage > Groups.

2. From the View list, select Mandatory Baseline.

3. From the directory tree, select the group with Mandatory Baseline items (content items) that you want to
cache.

4. If necessary, designate filter criteria for the desired Mandatory Baseline item and click Update View.

5. Select the check boxes associated with the Mandatory Baseline item you want to cache.

6. Click Update Cache.

Result: The selected content begins caching.

Importing Mandatory Baseline Templates
After a Mandatory Baseline template has been exported, import the template and apply it to a new group.
Importing a Mandatory Baseline template is faster than creating a new, identical Mandatory Baseline.

Import Mandatory Baseline templates from the Mandatory Baseline view.

1. Select Manage > Groups.

Step Result: The Groups page opens.

2. From the View list, select Mandatory Baseline.

3. From the directory tree, expand to the group with which you want to import a Mandatory Baseline template.
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4. From the toolbar, click Import.

Step Result: The Import Mandatory Baseline Wizard opens to the Welcome to the Import Mandatory
Baseline Wizard page.

Figure 110: Welcome Page

5. Click Next.

Step Result: The Import Mandatory Baseline page opens.

Figure 111: Import Mandatory Baseline Page

6. Define the Mandatory Baseline template that you want to import.

a) Click Browse.

Step Result: The Choose file dialog opens.

b) Browse to the Mandatory Baseline template you want to import.
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c) Click Open.

Step Result: The Mandatory Baseline template name displays in the Mandatory Baseline template
(*.XML) field.

7. If you do not want to import the deployment options associated with the Mandatory Baseline and use the
system defaults defined on your Lumension Patch and Remediation server, select the Import without
deployment options and use system default check box.

8. Click Next.

9. Based upon the page or dialog that opens, complete the applicable steps.

Page/Dialog Steps

If the This group already has
Mandatory Baseline items
assigned dialog opens:

1. Select either the Append to the list of existing items and replace
duplicates option or the Replace all existing items with new items

2. Click OK.

If the One or more of the
Mandatory Baseline items are
not available because they are
not included in the server's
content subscription dialog
displays:

Click OK to proceed with the import or Cancel to cancel the import.

If the Review Mandatory
Baseline Items page opens:

Proceed to the next step.

10. Review the Mandatory Baseline items and edit them as needed.

Figure 112: Review Mandatory Baseline Items Page
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The following table describes each page column.

Column Description

Mandatory Baseline Icon Displays an icon that indicates the cache status of the Mandatory
Baseline item. For additional information, refer to Content Icons and
Descriptions on page 386.

Name Lists the name of the Mandatory Baseline item. The Mandatory
Baseline item name is identical to the content item.

Cache Status The cache status of the Mandatory Baseline item. The cache status
indicates whether the content item has been downloaded to your
Lumension Patch and Remediation server (Cached or Not Cached).

11. [Optional] Edit the list.

Edit the list according to the following task steps.

Task Steps

To delete items: 1. Select the check box(es) associated with the applicable Mandatory
Baseline item(s).

2. Click Delete.

To update the cache for items: Important:  Updating the cache for Mandatory Baseline items ensures
they are deployed in the proper chain sequence. Failure to cache
Mandatory Baseline items may result in multiple deployment recipient
endpoint reboots.

1. Select the check box(es) associated with the applicable Mandatory
Baseline item(s).

2. Click Update Cache.

To configure deployment
options for an item:

1. Select the check box associated with the applicable Mandatory
Baseline item.

2. Click Deployment Options.
3. Complete Setting Mandatory Baseline Deployment Options on page

299 from step 6.

To refresh item cache statuses: Click Refresh.

Tip:  If the Auto Refresh check box is selected, Mandatory Baseline
item cache statuses will periodically refresh automatically.
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12. Click Next.

Step Result: The License Agreement page opens.

13. Review the license agreement for each mandatory basline item and select I ACCEPT the terms and
condition of the end user license agreement option.

Scrolling may be necessary to review and accept all license agreements.

14. Click Finish.

Step Result: The import process begins. A bar indicates progress.

15. Click Close

Result: The Mandatory Baseline is imported to the selected group. List items for applicable Mandatory
Baseline items appear within the Mandatory Baseline view. All endpoints within the group are now
subject to the Mandatory Baseline.

Exporting Mandatory Baselines Templates
You can export Mandatory Baseline templates in an XML format. This feature is useful for setting up Mandatory
Baselines across multiple groups and Lumension Endpoint Management and Security Suite servers via
importation.

Export Mandatory Baselines templates from the Mandatory Baseline view.

1. Select Manage > Groups.

Step Result: The Groups page opens.

2. From the View list, select Mandatory Baseline.

Step Result: The Mandatory Baseline view displays.

3. From the directory tree, select the group assigned the Mandatory Baseline you want to export.

Expand the tree as necessary.

4. From the toolbar, select Export > Template (*.XML).

Step Result: The File Download dialog opens.

Note:  If using Mozilla Firefox, the procedure to export the Mandatory Baseline will differ
slightly.

5. Click Save.

Step Result: The Save As dialog opens.

6. Define the filepath where you want to save the Mandatory Baseline.

7. [Optional] Edit the File name field.

8. Click Save.
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9. If you want to export Mandatory Baselines for additional groups, repeat the Mandatory Baseline exportation
process from step 4.

Result: Your Mandatory Baseline(s) are exported.

Exporting Mandatory Baseline View Data
To export information displayed in the Mandatory Baseline view list to a comma separated value (.csv) file,
select Export > CSV File from the toolbar. Exporting data lets you work with that data in other programs for
reporting and analytical purposes.

For additional information, refer to Exporting Data on page 60.

The Vulnerabilities View
Similar to content pages (the Vulnerabilities page, the Software page, and the Other page), the Vulnerabilities
view lets you work with content. However, unlike those pages, which display all content available from the
Global Subscription Server, this view displays only content applicable to the endpoints within a group.

Figure 113: Vulnerabilities View

The Vulnerabilities View Toolbar
This toolbar contains buttons related to the management of content. You can also launch deployments using this
toolbar.

The following table describes the Vulnerabilities view toolbar functions.

Table 158: Vulnerabilities View Toolbar

Button Function

Enable Enables the selected disabled content item(s). For additional information, refer to Enabling
Content within a Group on page 312.

Note:  This button is only available when a disabled item is selected.
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Button Function

Disable Disables the selected enabled content item(s). For additional information, refer to Disabling
Content on page 388.

Note:  This button is only available when a enabled item is selected.

Update Cache Caches (downloads or re-downloads) the package associated with the selected content
item(s) (or the scripts associated with downloading the package(s). For additional
information, refer to Updating the Cache on page 390.

Deploy... Deploys selected content. For additional information, refer to Deploying Selected Content
(Vulnerabilities View) on page 313.

Scan Now

(Menu)

Opens the Scan Now menu.

Discover
Applicable
Updates...

(Scan Now Menu
Item)

Prompts the discover applicable updates task to immediately check the endpoints (Patch
and Remediation only). For additional information, refer to Using Scan Now to Scan
Inventory (Endpoint Details Page) on page 198.

Export Exports the page data to a comma separated value (.csv) file. For additional information,
refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully. Pop-
up blockers in Internet Explorer or other supported browsers may also suppress export
functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page
53.

The Vulnerabilities View List
This list displays content that applies to the selected group. You can also filter this list to display specific content
items. Additionally, each item lists identification information and endpoint statistics.

The following table describes each Vulnerabilities view list column.

Table 159: Vulnerabilities View List

Column Icon Description

Content Status and Type  

 

Indicates the content status and type. For additional information,
refer to Content Status and Type on page 385.
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Column Icon Description

Package Status and Type  

 

Indicates the content cache status and type. For additional
information, refer to Content Icons and Descriptions on page 386.

Name Indicates the content name. Typically includes the vendor, specific
application name, and version information.

Content Type Describes the impact of the content. For more information, see one of
the following topics:

• Vulnerabilities on page 378
• Software Content on page 378
• Other Content on page 378

Number of endpoints which
came up Patched

 

 

Total number of endpoints that are patched.

Number of endpoints which
came up Not Patched

 

 

Total number of endpoints that are not patched.

Number of endpoints which
came up Error

 

 

Total number of endpoints that returned an error.

Number of endpoints which
are Error

 

 

Total number of endpoints that are in the process of detecting
(whether the endpoint is patched or not patched).

Total number of endpoints
Assigned

 

 

Total number of assigned or impacted endpoints.

Total Percent Complete  

 

Percentage of the endpoints that have completed the detection =
[(Total Patched + Total Not Patched) / Total Assigned endpoints.]
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Disabling Content within a Group
You can disable content items from the Groups page as well as the content pages. Disabled content moves to the
bottom of the list and is noted with a disabled status icon. Disable content to prevent it from being deployed.

Note:  Disabling content within the Vulnerabilities view also disables it on all content pages.

1. Select Manage > Groups.

2. From the View list, select Vulnerabilities.

3. Select a group from the directory tree.

4. If necessary, define filter criteria and click Update View.

5. Select the check box(es) associated with content you want to disable.

6. Click Disable.

Result: The selected content is disabled.

Enabling Content within a Group
After disabling a content item, re-enable it for deployment availability. You can re-enable content from the
Vulnerability view regardless of where it was disabled. Enabled content is noted with an enabled status icon.

Note:  Re-enabling a content item from the Vulnerabilities also re-enables it on all content pages.

1. Select Manage > Groups.

2. From the View list, select Vulnerabilities.

3. Select a group from the directory tree.

4. If necessary, define filter criteria and click Update View.

5. Select the check box(es) associated with the disabled content you want to enable.

6. Click Enable.

Result: The selected content is re-enabled.

Updating the Groups Cache
From the Vulnerabilities view, you can update the cache for selected content items. Updating the cache for
content items downloads the packages (or the scripts that will download the packages) associated with those
items so you can deploy them immediately.

You can update the cache for content from the Vulnerabilities view, not just other content pages.

1. Select Manage > Groups.

2. From the View list, select Vulnerabilities.

3. From the directory tree, select the group with applicable vulnerabilities that you want to cache.



Using Groups

- 313 -

4. If necessary, designate filter criteria for the desired content and click Update View.

5. Select the check boxes associated with the content you want to cache.

6. Click Update Cache.

Step Result: The Warning dialog opens, informing you that the update request and this action may take an
extended period of time.

7. Click OK.

Result: The selected content begins caching.

Deploying Selected Content (Vulnerabilities View)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Groups page Vulnerabilities view. When deploying from this page, the Deployment Wizard is
preconfigured to deploy your selected content to the selected group.

For additional information, refer to About Deployments on page 213.

1. Select Manage > Groups.

2. From the View list, select Vulnerabilities.

3. From the directory tree, select the group you want to deploy content to.

4. Select the content you want to deploy.

5. Click Deploy.

Result: The Deployment Wizard opens, preconfigured to deploy selected content to the selected group.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Exporting Vulnerability View Data
To export information displayed in the Vulnerability view list to a comma separated value (.csv) file, click the
toolbar Export button. Exporting data lets you work with that data in other programs for reporting and analytical
purposes.

For additional information, refer to Exporting Data on page 60.
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The Inventory View
The Inventory view displays the software, hardware, services, and operating systems detected on the endpoints in
the group. This view is identical to the Inventory page but only displays the inventory of the selected group.

Figure 114: Inventory View

The Inventory View Toolbar
This toolbar contains only basic options related to data exportation and page viewing. It offers no functionality
related to endpoint inventory.

The following table describes buttons available from the Inventory view toolbar.

Table 160: Inventory View Toolbar

Button Function

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.
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Exporting Inventory View Data
To export information displayed in the Inventory view list to a comma separated value (.csv) file, click the
toolbar Export button. Exporting data lets you work with that data in other programs for reporting and analytical
purposes.

For additional information, refer to Exporting Data on page 60.

The Deployments and Tasks View
The Deployments and Tasks view is similar to the Deployments and Tasks page because it lists pending,
active, and completed deployments or tasks. However, unlike the Deployments and Tasks page (which lists all
deployments), this view only lists the deployments that apply to the selected group. Additionally, you can use
this view to manage and create deployments.

Figure 115: Deployments and Tasks View

Note:  This view does not display the deployments and tasks for each member; only the group’s assigned
deployments.

The Deployments and Tasks View Toolbar
This toolbar contains buttons that offer functionality related to the management and creation of deployments.
Selection of list items associated with deployments may be necessary to use some buttons.

The following table describes the Deployments and Tasks view toolbar.

Table 161: Deployments and Tasks View Toolbar

Button Function

Enable Enables the selected disabled deployment or task. For additional information, refer to Enabling
Group Deployments on page 317.

Disable Disables the selected enabled deployment or tasks. For additional information, refer to Deleting
Group Deployments on page 318.

Abort Cancels the selected deployment or tasks for any endpoints that are yet to receive the deployment.
For additional information, refer to Aborting Group Deployments on page 318.
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Button Function

Delete Removes the deployment or tasks from Lumension Patch and Remediation. For additional
information, refer to Deleting Group Deployments on page 318.

Deploy... Deploys the selected packages. For additional information, refer to Deploying Content
(Deployments and Tasks View) on page 318.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.

The Deployments and Tasks View List
This list itemizes all deployments and deployment details applicable to the selected group.

View the Deployments and Tasks View list from the Groups page. The following table describes each
Deployments and Tasks View list columns.

Column Icon Description

Name The name of the deployment.

Scheduled Date The date and time the deployment was created.

Number of
Endpoints/Groups
which were
Successful

The total number of endpoints or groups that finished the deployment
successfully.

Number of
Endpoints/Groups
which Failed

The total number of endpoints or groups that finished the deployment
unsuccessfully.

Number of
Endpoints/Groups
Assigned to the
Deployment

The total number of endpoints or group that are assigned to the deployment.
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Column Icon Description

Number of
Endpoints/Groups
which are in
Progress

The total number of endpoints or group that are in the process of executing
the deployment.

Note:  If you deploy to a group using Agent Local Time, the deployment
remains in progress until all time zones have passed. This behavior ensures
any endpoints added to the group following deployment start also receive
content. This behavior does not occur when using Agent UTC Time.

Number of
Endpoints/Groups
which have
Completed the
Deployment

The total number of endpoints or group that finished the deployment.

Percentage
Complete

The percentage of the endpoints or groups that finished the deployment
(percentage = total of finished endpoints/ total of assigned endpoints).

Enabling Group Deployments
Within Lumension Patch and Remediation, you can re-enable paused, group-specific deployments from the
Deployments and Tasks view.

Enable group deployments from the Deployments and Tasks view, not the Deployments and Tasks page.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. From the directory tree, select the group containing the deployment you want to enable.

4. Select the select the check box associated with the disabled deployment you want to enable.

5. Click Enable.

Result: The selected deployment is enabled.

Disabling Group Deployments
Within Lumension Endpoint Management and Security Suite, you can pause group-specific deployments from
the Deployments and Tasks view.

Disable group deployments from the Deployments and Tasks view, not the Deployments and Tasks page.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. From the directory tree, select the group containing the deployment you to disable.

4. Select the deployment you want to disable.
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5. Click Disable.

Result: The selected deployment is disabled.

Aborting Group Deployments
Within Lumension Endpoint Management and Security Suite, you can abort group-specific deployments from the
Deployments and Tasks view.

Abort group deployments from the Deployments and Tasks view, not the Deployments and Tasks page.

Note:  The endpoints that have already received the deployment will not be affected. Only the endpoints that
have not yet received the deployment will have the deployment aborted.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. From the directory tree, select the group containing the deployment you want to abort.

4. Select the check box associated with the deployment you want to abort.

5. Click Abort.

Result: The selected deployment is aborted.

Note:  You cannot abort system tasks or Mandatory Baseline deployments.

Deleting Group Deployments
Within Lumension Endpoint Management and Security Suite, you can delete group-specific deployments from
the Deployments and Tasks view.

Delete group deployments from the Deployments and Tasks view, not the Deployments and Tasks page.

Note:  Deleting a deployment will have no effect on endpoints that have already received the deployment. You
cannot delete system task deployments.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. From the directory tree, select the group containing the deployment you want to delete.

4. Select the check box associated with the deployment you want to delete.

5. Click Delete.

Result: The selected deployment is deleted.

Deploying Content (Deployments and Tasks View)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including the Groups page Deployments and Tasks view.
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For additional information, refer to About Deployments on page 213.

1. Select Manage > Groups.

2. From the View list, select Deployments and Tasks.

3. From the directory tree, select the group deploy content to.

4. Click Deploy.

Result: The Deployment Wizard opens.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Exporting Deployments View Data
To export information displayed in the Deployments and Tasks view list to a comma separated value (.csv) file,
click the toolbar Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.

The Agent Policy Sets View
After creating agent policy sets, you can apply them to a group using the Agent Policy Sets view. From this view
you can add or remove existing agent policy sets to or from the selected group. Additionally, you can create
policy sets from this view. However, this view, unlike the Agent Policy Sets page, does not let you edit policy
sets or view their details. This view is only applicable to agent policy sets.

Figure 116: Agent Policy Set View

For additional information about agent policy sets, refer to About Agent Policies and Agent Policy Sets on page
341.

The Agent Policy Sets View Toolbar
This toolbar contains buttons that let you manage agent policy sets in relation to groups. You can also create
agent policy sets from this toolbar. Policy sets created from this toolbar can be applied to any group, not just the
selected group.
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The following table describes the Agent Policy Sets view toolbar.

Table 162: Agent Policy Sets View Toolbar

Button Function

Assign Assigns an agent policy set to the selected group and its child groups. For additional information,
refer to Assigning an Agent Policy Set to a Group on page 320.

Remove Removes a selected agent policy set from the group. For additional information, refer to
Unassigning an Agent Policy Set from a Group on page 321.

Create... Creates an agent policy set. For additional information, refer to Creating an Agent Policy Set
(Groups Page) on page 322.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.

The Agent Policy Sets View List
This list itemizes all agent policy sets and policy details assigned to the selected group.

View the Agent Policy Sets View list from the Groups page. The following table describes each  Agent Policy
Sets View list.

Column Description

Action Contains an Unassign icon. Use this icon to remove a policy set from the selected
group. For additional information, refer to Unassigning an Agent Policy Set from a
Group on page 321.

Name The name of the agent policy set.

Assigning an Agent Policy Set to a Group
Associating an agent policy set with a group defines functional rules for the group to follow. Groups that do not
have an associated agent policy set use the Global System Policy.

Prerequisites:

Create an agent policy set.

Assign agent policy sets to a group from the Agent Policy Set view.
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1. Select Manage > Groups.

2. From the View list, select Agent Policy Set.

3. Select a group from the directory tree.

4. Click Assign.

5. Select an agent policy set from the Select a Policy Set list.

6. Click the Save icon.

Result: The policy set is saved and associated with the group.

Unassigning an Agent Policy Set from a Group
When desired, you can unassign an agent policy set from a group. Groups without associated policy sets use the
global system policy to define their behavior.

Remove agent policy sets from a group from the Agent Policy Sets view.

Note:  You cannot remove inherited policy sets. Instead, you must change the group policy inheritance setting or
remove the inherited policy set from the parent group.

1. Select Manage > Groups.

2. From the View list, select Agent Policy Sets.

3. Select a group from the directory tree.

4. Remove the desired policy sets.

Use one of the following methods.

Method Steps

To remove one agent policy set: Click the Unassign icon associated with the policy set you want to
remove.

To remove multiple agent
policy sets:

1. Select the check boxes associated with the agent policy sets you
want to remove.

2. From the toolbar, click Remove.

Step Result: A dialog appears, asking you to acknowledge the removal.

5. Acknowledge the removal by clicking OK.

Result: The agent policy set is no longer associated with the group and is removed from the Agent Policy Set
view.
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Creating an Agent Policy Set (Groups Page)
You can create agent policy sets from the Agent Policy Set view. Agent policy sets are collections of values that
can be assigned to groups to regulate how agents behave.

Note:  When creating an agent policy set from the Agent Policy Set view, the created policy set will be
immediately applied to the group selected in the directory tree.

1. Select Manage > Groups.

2. From the View list, select Agent Policy Set.

3. From the directory tree, select the desired group.

4. Click Create.

Step Result: The Create Agent Policy Set dialog opens.

5. Type the applicable information in the Policy Set Details fields.

Field Name Type

Policy Set Name The name of the agent policy set.

Policy Set Description A description of the agent policy set (optional).

6. Define the Agent Hardening option.

These options define the steps required to delete an agent.

Option Description

Agent uninstall protection (list) Select from the list to define whether the agent requires a password to
be uninstalled. The default value is On.

7. Define the Agent Logging options.

The following table describes each option.

Option Step

Logging level

(button)

Click to open the Logging Level dialog. Use this dialog to select the
agent logging level. For additional information, refer to Defining Agent
Policy Logging Levels on page 359.

Maximum log file size

(field)

Type the amount of disk space that triggers the agent to delete its log
(1-500 MB). A value of 10 is the default setting.
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8. Define the Lumension EMSS Agent Communication options.

The following table describes each option.

Options Step

Use HTTP for file download

(list)

Select whether packages are downloaded using HTTP, regardless of
whether HTTPS is used for communication between the agent and
Lumension EMSS (True or False). The default value is True.

Send interval

(list)

Select the amount of time that the agent should wait before sending
an event to the Lumension EMSS server (0-5 seconds). A value of 2
seconds is the default setting.

Receive interval

(field and list)

Type and select the amount of time that the agent should delay before
reattaching events from the Lumension EMSS server. This value
cannot exceed one day. A value of 0 seconds is the default setting.

Timeout interval

(field and list)

Type and select the amount of time the agent should stay attached to
the Lumension EMSS server before disconnecting (1 minute-7 days). A
value of 12 hours is the default setting.

Heartbeat interval

(field and list)

Type and select the amount of time between agent check-ins with the
Lumension EMSS server (1 minute-1 day). A value of 15 minutes is the
default setting.

9. Define the Lumension EMSS Agent Notification Defaults options.

The following table describes each option.

Option Description

Hide Agent Control Panel This option controls whether the Agent Control Panel (and all
associated dialogs and notifications) are hidden or accessible to an
endpoint user after logging on (True or False).

Note:

• This policy will not take effect until the agent is restarted.
• This policy can hide only the Lumension EMSS Agent for

Windows. Agents installed on Linux, Unix, or Mac endpoints
cannot be hidden.

• When set to True, endpoint users can still open the Agent Control
Panel using Windows Control Panel.

• This policy cannot hide the Patch Agent or the LES Agent.
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Option Description

Show Alerts on Endpoint This option control whether the associated dialogs and notifications for
the Agent Control Panel are hidden or accessible to an endpoint user
after logging on (True or False).

10. Define the Agent Communication option.

a) From the Use SSL for agent to server communication list, select True or False.

This option defines whether agents under policy control use secure communication when contacting the
Lumension EMSS server.

11. Define the Patch Agent Communication options.

The following table describes each option.

Option Step

Use SSL for agent to server
communication

(list)

Select whether the Patch Agent uses HTTPS when communicating with
the Lumension EMSS server.

Use HTTP for file download

(list)

Select whether files are downloaded using HTTP, regardless of whether
HTTPS is used for communication between the agent and Lumension
EMSS (True or False). The default value is False.

Agent Listener Port

(field)

Select the agent listener port number. When the agent is contacted
using this port, it responds with the agent version number and initiates
communication with Lumension EMSS. The default value of 0 disables
the agent listener.

Agent Scan Mode

(list)

Select the mode that the Discover Applicable Updates (DAU) task runs
in. These modes include:

Normal Performs the DAU task normally,
which uses the least amount of
resources.

Initial Only Performs the first DAU task in
fast mode, but subsequent DAU
tasks in normal mode.

Fast Scan Performs the DAU task faster, but
uses more resources.

The default value is Normal.

Communication Interval

(field and list)

Type and select the interval (in minutes, hours, or days) between agent
and Lumension EMSS communication (1 minute-1 day). The default
value is 15 minutes.
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Option Step

Inventory Collection Options

(button)

Click to open the Select Inventory Collection dialog. Use this dialog
to select the inventory values for recording during agent scanning. For
additional information, refer to Defining Inventory Collection Options on
page 361.

Resume Interrupted
Downloads

(list)

Select whether the agent resumes interrupted downloads at the point of
interruption (True or False). The default value is True.

Hours of Operation

(button)

Click to open the Edit Agent Hours of Operation dialog. Hours of
operation are based on agent local time, allowing for further definition
of the agent start and end times. For additional information, refer to
Defining Agent Hours of Operation on page 364.

12. Define the Deployment Notification Defaults options.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the deployment
(True or False). The default value is False.

User May Snooze

(list)

Select whether the deployment recipient can snooze the deployment
(True or False). The default value is True.

Deploy Within

(field)

Select the default time (in minutes) between the creation of the
deployment and the deployment deadline (1-1440). The default value is
5 minutes.

Always On Top

(list)

Select whether deployment and reboot notification dialogs appear
above all other windows (True or False). The default value is True.

13. Define the Reboot Notification Defaults.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the reboot (True or
False). The default value is True.

User May Snooze

(list)

Select whether the deployment recipient can snooze the reboot (True or
False). The default value is True.

Reboot Within

(field)

Type the default time (in minutes) between the creation of the
deployment and the reboot deadline (1-1440). The default value is 5
minutes.
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14. Define the Discover Applicable Updates (DAU) option.

Option Step

Scheduling Frequency

(field)

Type the frequency (in hours) of the DAU task (1-8760). The default
value is 26 hours.

15. Define the FastPath Servers options.

Option Step

Interval

(field and list)

Type the time interval (in minutes, hours, or days) between agent
and server communication (0 minutes-7 days). The default value of 0
disables the option.

Servers

(button)

Click to open the Edit FastPath Servers dialog. Use this dialog to
add FastPath (caching proxy) servers. FastPath servers allow for the
redirection of an agent based upon the fastest route. For additional
information, refer to Adding/Editing FastPath Servers on page 366.

16. Define the Bandwidth Throttling options.

Option Step

Maximum Transfer Rate

(field)

Type the maximum amount of network bandwidth (in Kbps), per
endpoint that can be used by the agent for content download (0-1024).
The default value of 0 disables bandwidth throttling.

Minimum File Size

(field)

Type the threshold (in KB) at which a file will be managed by
bandwidth throttling (0-1024). Files smaller than the defined value will
not be managed by bandwidth throttling. The default value is 100.

17. Click Save.

Result: Your agent policy set is saved and assigned to the selected group. You can also assign the agent policy
set to other endpoint groups or edit the set.

Exporting Agent Policy Set View Data
To export information displayed in the Agent Policy Set view list to a comma separated value (.csv) file, click
the toolbar Export button. Exporting data lets you work with that data in other programs for reporting and
analytical purposes.

For additional information, refer to Exporting Data on page 60.
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The Roles View
This view lists the user roles that can access the selected group. This view is similar to the Roles page, but
applies only to the selected group rather than the entire system. From this view, you can manage which group can
access the selected group or create new user roles.

Figure 117: Roles View

For additional information about roles, refer to Defining Roles on page 468.

The Roles View Toolbar
This toolbar contains buttons that let you add (or remove) roles that can access the selected group. You can also
use it to create new user roles.

The following table describes the functionality of each Roles view toolbar button.

Table 163: Roles View Toolbar

Button Function

Add Adds an established role to the group. For additional information, refer to Adding a Role to a
Group on page 328.

Remove Removes a role from the group. For additional information, refer to Removing a Role from a
Group on page 329.

Create... Creates a new user role. For additional information, refer to Creating User Roles (Roles View) on
page 330.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.
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Button Function

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.

The Roles View List
This list displays the roles that can access the selected group. Use the Action column to remove user roles.
Additionally, you can filter this table using the filter row.

The following table describes each Roles view list column.

Table 164: Roles View List

Column Description

Action Contains a Remove icon. Use this icon to remove a role from the associated group.

Status Contains an icon that indicates the type of role. For additional information, refer to
one of the following topics:

• Predefined System Roles on page 469
• Custom Roles on page 469

Name Indicates the name of the user role.

Source Group Indicates the group from which the role was created.

Adding a Role to a Group
Add a user role to a group to grant it group access. If the selected group's Policy inheritance setting is set to
true, the added user role will also be able to access the selected group's descendant groups.

Add roles to a group from the Roles view.

1. Select Manage > Groups.

2. From the View list, select Roles.

3. Select a group from the directory tree.
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4. Click Add.

Step Result:

Figure 118: Add a Role

5. Select a role from the Select a Role list.

Select from the following roles:

• Administrator
• Manager
• Operator
• Guest
• Custom Role(s)

Note:   Custom Role(s)  are only available if a custom role has been created.

6. Click the Save icon.

Result: The role is saved and associated with the group.

Removing a Role from a Group
Remove a user role from a group to deny its associated users group access. If the selected group has policy
inheritance set to true, removing a role will remove the role from the selected group's descendant groups as
well.

Remove user roles from a group using the Roles view.

1. Select Manage > Groups.

2. From the View list, select Roles.

3. Select a group from the directory tree.
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4. Remove roles from the group.

Use one of the following methods.

Method Steps

To remove a single role: Click the Remove icon associated with the role you want to remove
from the group.

To remove multiple roles: 1. Select the check boxes associated with the roles you want to remove
from the group.

2. From the toolbar, click Remove.

Note:  Inherited roles cannot be removed. To remove inherited roles, either edit the group’s inheritence
policy or remove the roles from the applicable parent group. To understand group policy inheritance and its
effects, refer to Defining Agent Policy Inheritance Rules on page 369.

Step Result: A dialog displays, asking you to acknowledge the removal.

5. Acknowledge the removal by clicking OK.

Result: The role is removed and is no longer associated with the group.

Creating User Roles (Roles View)
Custom roles let you select individual access rights, accessible groups, and accessible endpoints for that role.
Create a custom role when predefined system roles do not contain the access rights needed for a particular user.
Creating a custom role is also useful when you require a role that can only access specific groups or endpoints.

You can create roles from the Roles view as well as the Roles tab.

1. Select Manage > Groups.

2. From the View list, select Roles.

3. From the directory tree, select the desired group.

4. Click Create.

Step Result: The Create Role dialog appears with the Information tab selected by default.

5. Type a name in the Name field.

6. Type a description in the Description field.

7. Select a role template from the Role Template list.

Any existing role can be used as a template. The selected role determines initial access rights. You can later
change which access rights are assigned to the role.

8. Select the Access Rights tab.
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9. Select or clear the desired access rights.

For additional information, refer to Predefined System Roles on page 469.

Tip:  Select or clear the All check box to globally select or clear all access rights. Additionally, child access
rights are unavailable until their parent access rights are selected.

10. Select the Groups tab.

11. Assign the desired accessible endpoint groups to the role.

Use one of the following methods to assign groups.

Method Steps

To assign individual groups: 1. From the Available Groups table, select the check box(es)
associated with the group(s) you want to assign.

2. Click Assign.

To assign all groups: Click Assign All.

Tip:  Remove groups using Remove and Remove All.

12. Select the Endpoints tab.

13. Assign the desired accessible endpoints to the role.

Use one of the following methods to assign endpoints.

Method Steps

To assign individual endpoints: 1. From the Available Endpoints table, select the check box(es)
associated with the endpoint(s) you want to assign.

2. Click Assign.

To assign all endpoints: Click Assign All.

Tip:  Remove endpoints using Remove and Remove All.

14. Click OK.

Result: The new role is saved and assigned to the selected group. It can now be assigned to users. Additionally,
it can be edited from the Users and Roles page Roles tab.

Exporting Roles View Data
To export information displayed in the Roles view list to a comma separated value (.csv) file, click the toolbar
Export button. Exporting data lets you work with that data in other programs for reporting and analytical
purposes.

For additional information, refer to Exporting Data on page 60.
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The Dashboard View
Similar to the Home page dashboard, the Dashboard view displays widgets depicting Lumension Endpoint
Management and Security Suite activity. However, unlike the Home page dashboard, the Dashboard view
widgets include only information about endpoints within the selected group and its child hierarchy.

Widgets graphs and information are generated based on the latest Lumension Endpoint Management and
Security Suite server and agent data available.

Figure 119: Dashboard View

Note:  The widgets displayed in the Dashboard view include data from the selected group’s child hierarchy.
Configuration changes made to the dashboard settings apply to all groups; not just the selected group.

Group Dashboard Widgets
The widgets available on the Home page dashboard are also available from the Dashboard view. The data
depicted on each dashboard changes according to which group is selected.

The following table describes the available widgets.

Table 165: Group Dashboard Widgets

Widget Description

Agent Module Installation Status Displays the installation and licensing statistic of each agent module.

Agent Status Displays all agents grouped by status.

Applicable Content Updates Displays applicable content updates grouped by content updates.

Critical Patch Status by Endpoint Displays the patch status of all endpoints with applicable
vulnerabilities grouped by when they were released.
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Widget Description

Discovery Scan Results: Agents Displays the total number of agent-supported endpoints discovered in
the last-run discovery scan job and identifies how many have an agent
installed.

Endpoints with Unresolved Updates Displays all endpoints with applicable content updates that have not
yet been applied, grouped by content type.

Incomplete Deployments Displays all deployments with elapsed start dates and a status of not
started or in progress.

Mandatory Baseline Compliance Displays the percentage of endpoints grouped by Mandatory Baseline
compliance.

Offline Patch Agents Displays all offline agents grouped by the amount of time since they
last checked in.

Patch Agent Module Status Widget Displays all agents with the Patch and Remediation modules installed,
which are grouped by Patch and Remediation status.

Scheduled Deployments Displays endpoints with applicable content updates grouped by
content type and the deployment status within each category.

Time Since Last DAU Scan Displays all active agents (not including disabled or offline) grouped
by the amount of time since their last Discover Applicable Updates
(DAU) task.

Un-remediated Critical
Vulnerabilities

Displays the total number of un-remediated critical vulnerabilities that
are applicable to your environment grouped by age.

Tip:  For information about how to edit the group dashboard, refer to Editing the Dashboard on page 86.

Widget Setting and Behavior Icons
Setting and behavior icons are user interface controls that let you manage widgets and the dashboard within the
Groups view. Click these controls to maximize, minimize, hide, and refresh widgets.

The following table describes each icon action.

Table 166: Widget Setting and Behavior Icons

Icon Action

Opens the Dashboard Settings dialog.

Opens the dashboard in print preview mode.
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Icon Action

Collapses the associated widget.

Expands the associated collapsed widget.

Hides the associated widget.

Refreshes the associated widget (or the entire dashboard).

Note:  Not all widgets contain Refresh icons.

Previewing and Printing the Dashboard
As with the Home page dashboard, you can preview and print the Group page Dashboard view. Dashboard
view widgets display data that applies only to the selected group.

To preview the Dashboard view, select the applicable group from the Group Browser Directory and click the
print icon.

For additional information, refer to Previewing and Printing the Dashboard on page 85.

Editing the Dashboard
Just as with the Home page dashboard, you can edit the widgets displayed on the Group page Dashboard view.
Dashboard view widgets display data that only applies to the selected group.

To edit the widgets displayed within the Dashboard view, select the applicable group from the Group Browser
Directory and edit icon.

For additional information, refer to Editing the Dashboard on page 86.
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The Settings View
This view lets you edit various basic settings for the selected group. The settings in this view are miscellaneous
settings that cannot be grouped with other settings.

Figure 120: Settings View

The following table describes Settings view button functions.

Table 167: Settings View Toolbar

Button Function

Save Saves the settings defined in the page.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Editing Group Settings
If different settings are required, you can edit the default settings for a group. Modifying group settings not only
modifies settings for the selected group, but also potentially determines settings for descendant groups.

Modify group settings from the Settings view.

1. Select Manage > Groups.

2. From the View list, select Settings.

3. Select the desired group from the directory tree.
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4. Under General, edit the following options as necessary.

Option Description

Group Name

(field)

The group name.

Note:  Only Custom group names can be edited.

Distinguished Name A system-created group name that represents the group’s parent
hierarchy.

Note:  The Distinguished Name cannot be edited.

Group Description

(field)

The group description.

Q Chain Mode

(list)

(Patch and Remediation only)

Defines chain behavior during Mandatory Baseline deployments. Select
from the following options:

• Standard -- Set Individually
• Auto QChain with Manual Reboots
• Auto QChain with Automatic Reboots

Deployments Enabled

(list)

(Patch and Remediation only)

Defines whether deployments may be created for the group. A True
value allows authorized users to create deployments for the group.

Note:  The Deployments Enabled list only impacts the ability to create deployments for a group.
Deployments created prior to disabling group deployments will still occur as scheduled. Additionally, any
deployments created for the endpoint will occur as scheduled.

5. Under Mandatory Baseline, edit the following lists as necessary (Patch and Remediation only).

List Description

Mandatory Baseline
Inheritance

Defines whether the group inherits the agent policies assigned to the
group’s parent hierarchy. A True value sets the group to inherit its
parent hierarchy’s Mandatory Baseline settings.

Mandatory Baseline Enabled Defines whether Mandatory Baselines may be assigned to the group. A
True value allows users to create Mandatory Baseline deployments for
the group.

Important:  The Mandatory Baselines enabled setting applies only to the selected group. Therefore, if the
selected group has a parent group with a Mandatory Baselines enabled setting of True, the selected group
will receive its parent group Mandatory Baseline items regardless of its own Mandatory Baselines enabled
setting.
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6. Under Policy, edit the following lists as necessary.

List Description

Policy Inheritance Defines whether the group inherits the agent policies assigned to the
group’s parent hierarchy. A True value sets the group to inherit its
parent hierarchy’s agent policy settings.

Note:  To understand agent policy inheritance and its effects, refer to
Defining Agent Policy Inheritance Rules on page 369.

Policies Enabled Defines whether agent policies may be assigned to the group. A True
value allows users to assign agent policies directly to the group.

7. Under Other, edit the following fields as necessary.

Field Description

Group Owners User-defined email addresses indicating the owners of the group.

Source Groups (button) User-defined group or groups whose agents are dynamically assigned
to the group. For additional information, refer to Assigning a Source
Group to a Custom Group on page 338.

8. Click Save.

Result: The new settings are saved and applied to the group.

Defining Source Groups
Source groups are groups that automatically assign managed endpoints to a associated custom group. Use a
source group to maintain multiple endpoint memberships by editing only a single group. This feature simplifies
maintenance of endpoint membership among groups.

When working within the Groups page Settings view, you can assign the selected view a source group. By
assigning the selected group a source group, the selected group will be modified when the source group has
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endpoints added or removed. Source groups only affect endpoint membership, not group agent policies and
settings.

Figure 121: Source Group Diagram

When selecting a source group, all endpoints within the source group's child hierarchy are included, regardless of
whether the child groups are selected. Additionally, if the source group (or any of its child groups) has a source
group, those endpoints are also included. Source groups can only be assigned to custom groups.

The preceding diagram and the following bullets clarify how group sources operates.

• If group 3 uses group 5 as a source group, then group 3 would include endpoints 9 and 10, as well as
endpoints 5 and 6.

• Because group 3 is in group 1's hierarchy, group 1 also includes endpoints 9 and 10.
• If group 4 uses group 1 as a source group, group 4 would include endpoints 7 and 8 (through direct

assignment), endpoints 1 and 2 (through a directly assigned source group), endpoints 3, 4, 5, and 6 (through
group 1's hierarchy), and endpoints 9 and 10 (through an indirectly assigned source group for [group 5 is a
source group for group 3]).

Assigning a Source Group to a Custom Group
When a custom group is created, you can assign it a source group, which is a group that automatically assigns
managed endpoints to associated groups. For example, if you assign Group 1 as a source group to Group 2, any
agents assigned to Group 1 are automatically assigned to Group 2.

Assign a group a source group from the Settings view.

Note:  Source groups can only be assigned to custom groups.



Using Groups

- 339 -

1. Select Manage > Groups.

2. From the View list, select Settings.

3. Select a custom group from the directory tree.

4. Under Other, click Modify.

If necessary, scroll to the button.

Step Result: The Edit Source Groups dialog opens.

Figure 122: Edit Source Groups Dialog

5. Expand the directory tree or use the search field to locate the group you want to use as a source.

6. Select the check box(es) associated with the group(s) you require as a source.

Note:  When selecting a source group, all endpoints within the source group's child hierarchy are included,
regardless of whether the child groups are selected. Additionally, if the source group (or any of its child
groups) has a source group, those endpoints are also included. For additional information, refer to Defining
Source Groups on page 337.

7. Click OK.

Result: The custom group now uses the selected group(s) as its source. As new agents are added to (or removed
from) the source group, they are also added to (or removed from) the custom group.

Exporting Settings View Data
To export information displayed in the Settings view to a comma separated value (.csv) file, click Export.
Exporting data lets you work with that data in other programs for reporting and analytical purposes.
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For additional information, refer to Exporting Data on page 60.
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Chapter

11
Managing Agent Policy Sets

In this chapter:

• The Agent Policy Sets Page

• Working with Agent Policy Sets

Use agent policy sets to control agent behavior. These sets are
composed of policies, which define how individual agent functions
behave.

Apply agent policy sets to groups to implement your policies. There is
a policy for every agent function.

The Agent Policy Sets Page
You can govern how agents behave by creating and assigning agent policy sets. Use the Agent Policy Sets page
to define agent rules of behavior.

You can access this page at any time from the navigation menu.

Figure 123: Agent Policy Sets Page

About Agent Policies and Agent Policy Sets
Agent policies are values assigned to agents that govern their operations. With agent policies, you can control all
aspects of agent behavior. Assign agent policies to endpoint groups via agent policy sets, which are a collection
of agent policy values.

Based on group membership, agents operate according to assigned agent policy values. Assignment of agent
policy sets is optional.

Groups without assigned policy sets or policies have their behavior defined by the Global System Policy. This
policy set:

• Defines behavior for groups with no assigned policy set.
• Defines policy values for incomplete agent policy sets.
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When agents holding multiple group memberships are assigned conflicting agent policy values, they are resolved
with conflict resolution rules. These rules are a set of protocols that determine which policy value an agent uses
when conflicts occur. For additional information, refer to Defining Agent Policy Conflict Resolution on page
370.

Viewing the Agent Policy Sets Page
Navigate to this page to view agent policy sets and their policy settings. Expand policy sets to view the
individual policy settings.

You can access this page any time using the navigation menu.

1. Select Manage > Agent Policy Sets.

Step Result: The Agent Policy Sets page opens.

2. [Optional] Expand policy sets by click rotating chevron(s) (>).

3. [Optional] Complete a task listed in Working with Agent Policy Sets on page 347.

The Agent Policy Sets Page Toolbar
This toolbar contains buttons that lets you create and edit agent policy sets.

The following table describes each toolbar button.

Table 168: Agent Policy Sets Page Toolbar

Button Function

Delete Deletes the selected agent policy set(s). For additional information, refer to Deleting an Agent
Policy Set on page 357.

Create... Creates a new agent policy set. For additional information, refer to Creating an Agent Policy Set
on page 347.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer to
Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in Internet
Explorer or other supported browsers may also suppress export functionality and should be
disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.

The Agent Policy Sets Page List
For each agent policy set that you create, an item for that set appears in the Agent Policy Sets page list. This list
names each existing agent policy set and provides access to editing functionality.
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The following table describes each list column.

Table 169: Agent Policy Sets Page List

Column Description

Action Contains Edit and Delete icons. Use these icons to edit and delete the associated agent policy set.
For additional information, refer to the following topics:

• Editing an Agent Policy Set on page 352
• Deleting an Agent Policy Set on page 357

Note:  The Global System Policy cannot be deleted.

Name The name of the agent policy set.

Each item listed on the Agent Policy Sets page can be expanded to list its individual policy settings. Viewing
agent policy set details from this list is faster than viewing them in the Edit Agent Policy Set dialog. To view
agent policy set details from the page list, click the Rotating Chevron (>) associated with the applicable agent
policy set, which opens a table containing additional details.

The following reference describes each column in the agent policy sets details table.

Table 170: Agent Policy Set Details Table

Name Description

Policy Name Indicates the unique name of the agent policy set.

Type Indicates the type of agent policy set (System or User Defined).

Description Indicates the description of the agent policy set.

Created By Indicates the name of the user that created the agent policy set.

Created Date Indicates the date and time that the agent policy set was created.

Modified By Indicates the name of the user that last modified the agent policy set.

Modified Date Indicates the date and time that the agent policy set was last modified.

Agent uninstall protection Indicates whether agent uninstall protection is on.

Hide agent control panel Indicates whether the Agent Control Panel is hidden from an endpoint
user when they log on to their system. Any dialog or notification
launched by the Lumension EMSS agent will also be hidden until
the Agent Control Panel is started manually using Windows Control
Panel.

Core: Download files via HTTP Indicates whether the Lumension EMSS Agent downloads files via
HTTP rather than HTTPS. All other communication occurs over
HTTPS.
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Name Description

Maximum Log File Size Specifies the maximum size of the Lumension EMSS agent log before
it is deleted.

Logging Level Indicates the level of detail recorded in the Lumension EMSS Agent.
The following values indicate each logging level: Critical = 0, Error =
1, Normal = 2, Diagnostic = 3, Trace = 4.

Show alerts on endpoints Indicates whether alerts and notifications are shown to endpoint users.

Core: Heartbeat Interval Indicates the interval at which the Endpoint Service sends a heartbeat
to the server (in minutes).

Core: Receive Interval Indicates the interval at which the Endpoint Service communication
receive delay intervals (in seconds).

Core: Timeout Interval Indicates the interval at which the Endpoint Service communication
receive time intervals (in seconds)

Core: Send Interval Indicates the interval at which the Endpoint Service communication
send delay intervals.

Patch and Remediation only

Maximum Transfer Rate Indicates the maximum bandwidth used when an agent downloads
packages. A setting of 0 disables bandwidth throttling.

Minimum File Size Indicates the smallest file size that will be impacted by bandwidth
throttling.

Agent Scan Mode Indicates the agent detection scan mode (0 = Slow, 1 = Fast the first
time, 2 = Fast).

Scheduling Frequency Indicates the number of hours between regularly scheduled detection
scans.

Deployment: User May Cancel Indicates whether the user can cancel a deployment (Y, N).

Deployment: Always on Top Indicates whether the notification will be the topmost window (Y, N).

Deployment: Deploy Within Indicates the defined time frame (in minutes) during which the user
may snooze or cancel a reboot.

Deployment: User May Snooze Indicates whether the user can snooze a deployment.

Resume Interrupted Downloads Indicates whether resumable downloads are enabled (0 = No, 1 = Yes).

Patch: Fast Path Interval Indicates the interval (configurable in minutes, hours, and
days) between each check by FastPath to determine the fastest
communication path back to the Lumension EMSS server.

Patch: Fast Path Servers Indicates the available Fast Path routes.
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Name Description

Patch: Download packages via
HTTP

Indicates if the agent downloads packages using HTTP, regardless of
whether HTTPS is used for agent to server communication.

Agent Listener Port Indicates the agent listener port. When the agent is contacted on this
port, it responds with its version number and initiates communication
with the Lumension EMSS server. A value of 0 turns the agent listener
off.

Reboot: User May Cancel Indicates whether the user can cancel a reboot (Y, N).

Reboot: Always on Top Indicates whether the notification will be the topmost window (Y, N).

Reboot: Reboot Within Indicates the defined time window (in minutes) during which the user
may snooze or cancel a reboot.

Reboot: User May Snooze Indicates whether the user can snooze a reboot (Y, N).

Patch: Agent to Server
Communication Protocol

Defines how the agent will communicate with the server (http:// or
https://).

Patch: Communication Interval Indicates the time period between agent communication attempts.

Hours of Operation Monday Defines the agent Hours of Operation (HOP) for Monday.

Hours of Operation Tuesday Defines the agent HOP for Tuesday.

Hours of Operation Wednesday Defines the agent HOP for Wednesday.

Hours of Operation Thursday Defines the agent HOP for Thursday.

Hours of Operation Friday Defines the agent HOP for Friday.

Hours of Operation Saturday Defines the agent HOP for Saturday.

Hours of Operation Sunday Defines the agent HOP for Sunday.

InventoryCollectionOptions: BIOS Indicates whether BIOS data will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions: CPU Indicates whether CPU data will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions:
CUSTOM

Indicates whether custom inventory data will be gathered during agent
inventory collection (OFF or ON).

InventoryCollectionOptions:
DISK_DRIVES

Indicates whether data regarding the disk drives will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
ENABLE_WMI

Indicates whether WMI data will be gathered during agent inventory
collection (OFF or ON).



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 346 -

Name Description

InventoryCollectionOptions:
HW_DEV_OTHER

Indicates whether the Windows registry will be scanned for additional
hardware information during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_IDE_CONTROL

Indicates whether data regarding IDE ATA/ATAPI controllers will be
gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_NETWORK_ADAPT

Indicates whether data regarding network adapters will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_NON_PNP

Indicates whether data regarding non-Plug and Play drivers will be
gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_SND_GAME

Indicates whether data regarding sound, video, and game controllers
will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_SYS_DEV

Indicates whether system device data will be gathered during agent
inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_USB

Indicates whether data regarding USB endpoint's inventory (from
\ENUM\USB) will be gathered during agent inventory collection (OFF
or ON).

InventoryCollectionOptions:
HW_USB_CONTROL

Indicates whether data regarding USB controllers will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
HW_USB_STORAGE

Indicates whether data regarding USB device inventory (from \ENUM
\USBSTOR) will be gathered during agent inventory collection (OFF or
ON).

InventoryCollectionOptions:
LAST_REBOOT

Requires ENABLE_WMI = ON: Indicates whether the last boot time
will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
LAST_USER

Indicates whether last logged in user and time will be gathered during
agent inventory collection (OFF or ON).

InventoryCollectionOptions:
MANUF_MODEL

Requires ENABLE_WMI = ON: Indicates whether the computer
manufacturer and model will be gathered during agent inventory
collection (OFF or ON).

InventoryCollectionOptions:
OS_SERIAL

Requires ENABLE_WMI = ON: Indicates whether the OS serial
number will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
PC_ASSET_TAG

Requires ENABLE_WMI = ON: Indicates whether the endpoint's asset
tag will be gathered during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
PC_SERIAL

Requires ENABLE_WMI = ON: Indicates whether the endpoint's
serial number will be gathered during agent inventory collection (OFF
or ON).



Managing Agent Policy Sets

- 347 -

Name Description

InventoryCollectionOptions: RAM Indicates whether the endpoint's total physical RAM will be gathered
during agent inventory collection (OFF or ON).

InventoryCollectionOptions:
SERVICES

Indicates whether a listing of Windows services (not applicable for
Windows 9x or ME) will be gathered during agent inventory collection
(OFF or ON).

InventoryCollectionOptions:
SOFTWARE

Indicates whether a listing of installed software will be gathered during
agent inventory collection (OFF or ON).

InventoryCollectionOptions:
VIRTUAL

Indicates whether the endpoint's virtualization status will be gathered
during agent inventory collection (OFF or ON).

Note:  This reference table does not list the Value contained in the agent policy set details. This column
(which appears in the user interface) contains values that agent policies are set to.

Working with Agent Policy Sets
There are many tasks that you can perform from the Agent Policy Sets page related to agent policy sets. Some
tasks are performed by clicking toolbar buttons, while others are performed by interacting with list items.

• Creating an Agent Policy Set on page 347
• Editing an Agent Policy Set on page 352
• Deleting an Agent Policy Set on page 357
• Defining the Global Uninstall Password on page 358
• Defining Agent Policy Logging Levels on page 359
• Defining Inventory Collection Options on page 361
• Defining Agent Hours of Operation on page 364
• The Edit FastPath Servers Dialog on page 365
• Adding/Editing FastPath Servers on page 366
• Defining Agent Policy Conflict Resolution on page 370
• Exporting Agent Policy Set Data on page 372

Creating an Agent Policy Set
Within Lumension Endpoint Management and Security Suite (Lumension EMSS), you can create a limitless
number of agent policy sets to define how agents behave. Following creation, associate a policy set with a group
or endpoint to apply policy settings. After installing Patch and Remediation, new Patch and Remediation options
are available when creating an agent policy set.

Create agent policy sets from the Create Agent Policy Set dialog.

1. Select Manage > Agent Policy Sets.
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2. Click Create.

Step Result: The Create Agent Policy Set dialog opens.

3. Type the applicable information in the Policy Set Details fields.

Field Name Type

Policy Set Name The name of the agent policy set.

Policy Set Description A description of the agent policy set (optional).

4. Define the Agent Hardening option.

These options define the steps required to delete an agent.

Option Description

Agent uninstall protection (list) Select from the list to define whether the agent requires a password to
be uninstalled. The default value is On.

5. Define the Agent Logging options.

The following table describes each option.

Option Step

Logging level

(button)

Click to open the Logging Level dialog. Use this dialog to select the
agent logging level. For additional information, refer to Defining Agent
Policy Logging Levels on page 359.

Maximum log file size

(field)

Type the amount of disk space that triggers the agent to delete its log
(1-500 MB). A value of 10 is the default setting.

6. Define the Lumension EMSS Agent Communication options.

The following table describes each option.

Options Step

Use HTTP for file download

(list)

Select whether packages are downloaded using HTTP, regardless of
whether HTTPS is used for communication between the agent and
Lumension EMSS (True or False). The default value is True.

Send interval

(list)

Select the amount of time that the agent should wait before sending
an event to the Lumension EMSS server (0-5 seconds). A value of 2
seconds is the default setting.
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Options Step

Receive interval

(field and list)

Type and select the amount of time that the agent should delay before
reattaching events from the Lumension EMSS server. This value
cannot exceed one day. A value of 0 seconds is the default setting.

Timeout interval

(field and list)

Type and select the amount of time the agent should stay attached to
the Lumension EMSS server before disconnecting (1 minute-7 days). A
value of 12 hours is the default setting.

Heartbeat interval

(field and list)

Type and select the amount of time between agent check-ins with the
Lumension EMSS server (1 minute-1 day). A value of 15 minutes is the
default setting.

7. Define the Lumension EMSS Agent Notification Defaults options.

The following table describes each option.

Option Description

Hide Agent Control Panel This option controls whether the Agent Control Panel (and all
associated dialogs and notifications) are hidden or accessible to an
endpoint user after logging on (True or False).

Note:

• This policy will not take effect until the agent is restarted.
• This policy can hide only the Lumension EMSS Agent for

Windows. Agents installed on Linux, Unix, or Mac endpoints
cannot be hidden.

• When set to True, endpoint users can still open the Agent Control
Panel using Windows Control Panel.

• This policy cannot hide the Patch Agent or the LES Agent.

Show Alerts on Endpoint This option control whether the associated dialogs and notifications for
the Agent Control Panel are hidden or accessible to an endpoint user
after logging on (True or False).

8. Define the Agent Communication option.

a) From the Use SSL for agent to server communication list, select True or False.

This option defines whether agents under policy control use secure communication when contacting the
Lumension EMSS server.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 350 -

9. Define the Patch Agent Communication options.

The following table describes each option.

Option Step

Use SSL for agent to server
communication

(list)

Select whether the Patch Agent uses HTTPS when communicating with
the Lumension EMSS server.

Use HTTP for file download

(list)

Select whether files are downloaded using HTTP, regardless of whether
HTTPS is used for communication between the agent and Lumension
EMSS (True or False). The default value is False.

Agent Listener Port

(field)

Select the agent listener port number. When the agent is contacted
using this port, it responds with the agent version number and initiates
communication with Lumension EMSS. The default value of 0 disables
the agent listener.

Agent Scan Mode

(list)

Select the mode that the Discover Applicable Updates (DAU) task runs
in. These modes include:

Normal Performs the DAU task normally,
which uses the least amount of
resources.

Initial Only Performs the first DAU task in
fast mode, but subsequent DAU
tasks in normal mode.

Fast Scan Performs the DAU task faster, but
uses more resources.

The default value is Normal.

Communication Interval

(field and list)

Type and select the interval (in minutes, hours, or days) between agent
and Lumension EMSS communication (1 minute-1 day). The default
value is 15 minutes.

Inventory Collection Options

(button)

Click to open the Select Inventory Collection dialog. Use this dialog
to select the inventory values for recording during agent scanning. For
additional information, refer to Defining Inventory Collection Options on
page 361.

Resume Interrupted
Downloads

(list)

Select whether the agent resumes interrupted downloads at the point of
interruption (True or False). The default value is True.
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Option Step

Hours of Operation

(button)

Click to open the Edit Agent Hours of Operation dialog. Hours of
operation are based on agent local time, allowing for further definition
of the agent start and end times. For additional information, refer to
Defining Agent Hours of Operation on page 364.

10. Define the Deployment Notification Defaults options.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the deployment
(True or False). The default value is False.

User May Snooze

(list)

Select whether the deployment recipient can snooze the deployment
(True or False). The default value is True.

Deploy Within

(field)

Select the default time (in minutes) between the creation of the
deployment and the deployment deadline (1-1440). The default value is
5 minutes.

Always On Top

(list)

Select whether deployment and reboot notification dialogs appear
above all other windows (True or False). The default value is True.

11. Define the Reboot Notification Defaults.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the reboot (True or
False). The default value is True.

User May Snooze

(list)

Select whether the deployment recipient can snooze the reboot (True or
False). The default value is True.

Reboot Within

(field)

Type the default time (in minutes) between the creation of the
deployment and the reboot deadline (1-1440). The default value is 5
minutes.

12. Define the Discover Applicable Updates (DAU) option.

Option Step

Scheduling Frequency

(field)

Type the frequency (in hours) of the DAU task (1-8760). The default
value is 26 hours.
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13. Define the FastPath Servers options.

Option Step

Interval

(field and list)

Type the time interval (in minutes, hours, or days) between agent
and server communication (0 minutes-7 days). The default value of 0
disables the option.

Servers

(button)

Click to open the Edit FastPath Servers dialog. Use this dialog to
add FastPath (caching proxy) servers. FastPath servers allow for the
redirection of an agent based upon the fastest route. For additional
information, refer to Adding/Editing FastPath Servers on page 366.

14. Define the Bandwidth Throttling options.

Option Step

Maximum Transfer Rate

(field)

Type the maximum amount of network bandwidth (in Kbps), per
endpoint that can be used by the agent for content download (0-1024).
The default value of 0 disables bandwidth throttling.

Minimum File Size

(field)

Type the threshold (in KB) at which a file will be managed by
bandwidth throttling (0-1024). Files smaller than the defined value will
not be managed by bandwidth throttling. The default value is 100.

15. Click Save.

Result: Your agent policy set is saved. You can now assign the agent policy set to endpoint groups or edit the
set.

After Completing This Task:

To assign an agent policy set to a group, complete Assigning an Agent Policy Set to a Group on page 320.

Editing an Agent Policy Set
Following the creation of an agent policy set, you can modify a policy set to suit your needs as endpoints and
groups change within Lumension Endpoint Management and Security Suite (Lumension EMSS).

The Edit A Policy Set dialog allows you to modify an agent policy set.

1. Select Manage > Agent Policy Sets.

2. Click the Edit icon associated with the policy set you want to edit.

Step Result: The Edit a Policy Set dialog opens.
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3. [Optional] Edit the Policy Set Details fields.

Field Name Type

Policy Set Name The name of the agent policy set.

Policy Set Description A description of the agent policy set (optional).

4. [Optional] Edit the Agent Hardening options.

Option Step

Agent uninstall protection (list) Select from the list to define whether the agent requires a password to
be uninstalled. The default value is On.

Global Uninstall Password
(button)

Click Modify to open the Global Uninstall Password dialog. Use this
dialog to define a password for manually uninstalling the agent. For
additional information, refer to Defining the Global Uninstall Password
on page 358.

Note:  This option only available when editing the Global
System Policy agent policy set. Only users assigned to the built-in
Administrator role may view or modify the global uninstall password.

5. [Optional] Edit the Agent Logging options.

Option Step

Logging level

(button)

Click to open the Logging Level dialog. Use this dialog to select the
agent logging level. For additional information, refer to Defining Agent
Policy Logging Levels on page 359.

Maximum log file size

(field)

Type the amount of disk space that triggers the agent to delete its log
(1-500 MB). A value of 10 is the default setting.

6. [Optional] Edit the Lumension EMSS Agent Communication options.

Options Step

Use HTTP for file download

(list)

Select whether packages are downloaded using HTTP, regardless of
whether HTTPS is used for communication between the agent and
Lumension EMSS (True or False). The default value is True.

Send interval

(list)

Select the amount of time that the agent should wait before sending
an event to the Lumension EMSS server (0-5 seconds). A value of 2
seconds is the default setting.
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Options Step

Receive interval

(field and list)

Type and select the amount of time that the agent should delay before
reattaching events from the Lumension EMSS server. This value
cannot exceed one day. A value of 0 seconds is the default setting.

Timeout interval

(field and list)

Type and select the amount of time the agent should stay attached to
the Lumension EMSS server before disconnecting (1 minute-7 days). A
value of 12 hours is the default setting.

Heartbeat interval

(field and list)

Type and select the amount of time between agent check-ins with the
Lumension EMSS server (1 minute-1 day). A value of 15 minutes is the
default setting.

7. [Optional] Define the Lumension EMSS Agent Notification Defaults options.

The following table describes each option.

Option Description

Hide Agent Control Panel This option controls whether the Agent Control Panel (and all
associated dialogs and notifications) are hidden or accessible to an
endpoint user after logging on (True or False).

Note:

• This policy will not take effect until the agent is restarted.
• This policy can hide only the Lumension EMSS Agent for

Windows. Agents installed on Linux, Unix, or Mac endpoints
cannot be hidden.

• When set to True, endpoint users can still open the Agent Control
Panel using Windows Control Panel.

• This policy cannot hide the Patch Agent or the LES Agent.

Show Alerts on Endpoint This option control whether the associated dialogs and notifications for
the Agent Control Panel are hidden or accessible to an endpoint user
after logging on (True or False).

8. [Optional] Edit the Patch Agent Communication options.

Option Step

Use SSL for agent to server
communication

(list)

Select whether the Patch Agent uses HTTPS when communicating with
the Lumension EMSS server.
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Option Step

Use HTTP for file download

(list)

Select whether files are downloaded using HTTP, regardless of whether
HTTPS is used for communication between the agent and Lumension
EMSS (True or False). The default value is False.

Agent Listener Port

(field)

Select the agent listener port number. When the agent is contacted
using this port, it responds with the agent version number and initiates
communication with Lumension EMSS. The default value of 0 disables
the agent listener.

Agent Scan Mode

(list)

Select the mode that the Discover Applicable Updates (DAU) task runs
in. These modes include:

Normal Performs the DAU task normally,
which uses the least amount of
resources.

Initial Only Performs the first DAU task in
fast mode, but subsequent DAU
tasks in normal mode.

Fast Scan Performs the DAU task faster, but
uses more resources.

The default value is Normal.

Communication Interval

(field and list)

Type and select the interval (in minutes, hours, or days) between agent
and Lumension EMSS communication (1 minute-1 day). The default
value is 15 minutes.

Inventory Collection Options

(button)

Click to open the Select Inventory Collection dialog. Use this dialog
to select the inventory values for recording during agent scanning. For
additional information, refer to Defining Inventory Collection Options on
page 361.

Resume Interrupted
Downloads

(list)

Select whether the agent resumes interrupted downloads at the point of
interruption (True or False). The default value is True.

Hours of Operation

(button)

Click to open the Edit Agent Hours of Operation dialog. Hours of
operation are based on agent local time, allowing for further definition
of the agent start and end times. For additional information, refer to
Defining Agent Hours of Operation on page 364.
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9. [Optional] Edit the Deployment Notification Defaults options.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the deployment
(True or False). The default value is False.

User May Snooze

(list)

Select whether the deployment recipient can snooze the deployment
(True or False). The default value is True.

Deploy Within

(field)

Select the default time (in minutes) between the creation of the
deployment and the deployment deadline (1-1440). The default value is
5 minutes.

Always On Top

(list)

Select whether deployment and reboot notification dialogs appear
above all other windows (True or False). The default value is True.

10. [Optional] Edit the Reboot Notification Defaults.

Option Step

User May Cancel

(list)

Select whether the deployment recipient can cancel the reboot (True or
False). The default value is True.

User May Snooze

(list)

Select whether the deployment recipient can snooze the reboot (True or
False). The default value is True.

Reboot Within

(field)

Type the default time (in minutes) between the creation of the
deployment and the reboot deadline (1-1440). The default value is 5
minutes.

11. [Optional] Edit the Discover Applicable Updates (DAU) option.

Option Step

Scheduling Frequency

(field)

Type the frequency (in hours) of the DAU task (1-8760). The default
value is 26 hours.

12. [Optional] Edit the FastPath Servers options.

Option Step

Interval

(field and list)

Type the time interval (in minutes, hours, or days) between agent
and server communication (0 minutes-7 days). The default value of 0
disables the option.
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Option Step

Servers

(button)

Click to open the Edit FastPath Servers dialog. Use this dialog to
add FastPath (caching proxy) servers. FastPath servers allow for the
redirection of an agent based upon the fastest route. For additional
information, refer to Adding/Editing FastPath Servers on page 366.

13. [Optional] Edit the Bandwidth Throttling options.

Option Step

Maximum Transfer Rate

(field)

Type the maximum amount of network bandwidth (in Kbps), per
endpoint that can be used by the agent for content download (0-1024).
The default value of 0 disables bandwidth throttling.

Minimum File Size

(field)

Type the threshold (in KB) at which a file will be managed by
bandwidth throttling (0-1024). Files smaller than the defined value will
not be managed by bandwidth throttling. The default value is 100.

14. Click Save.

Result: Your edits are saved. The new policy values take effect the next time the applicable agents
communicate with the Lumension EMSS server.

Deleting an Agent Policy Set
As your network environment changes, agent policy sets may no longer be applicable. When this event occurs,
delete the unnecessary policy set.

You can delete agent policy sets at any time from the Agent Policy Sets page.

1. Select Manage > Agent Policy Sets.

2. Delete one or more agent policy set.

Use one of the following methods.

Method Steps

To delete one agent policy set: Click the Delete icon associated with an agent policy set.

To delete multiple agent policy
sets:

1. Select the check boxes associated with the agent policy sets you
want to delete.

2. From the toolbar, click the Delete button.

Note:  Assigned agent policy sets and the Global System Policy cannot be deleted.

Step Result: A dialog displays, asking you to acknowledge the deletion.
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3. Acknowledge the deletion by clicking OK.

Result: The agent policy set is deleted.

Defining the Global Uninstall Password
To uninstall a Lumension Endpoint Management and Security Suite Agent from its host endpoint, you must enter
one of two passwords: the password specific to that endpoint, or the global uninstall password. You can use the
global uninstall password to uninstall any Lumension Endpoint Management and Security Suite Agent registered
to your Lumension Endpoint Management and Security Suite server. This feature ensures that endpoint users
cannot uninstall the agent without the knowledge and permission of a network administrator.

Define the global uninstall password when editing the Global System Policy.

1. Select Manage > Agent Policy Sets.

2. Click the edit icon associated with the global system policy set.

Step Result: The Edit a Policy Set dialog opens.

3. Under the Agent Hardening section, click the Modify button adjacent to the Global uninstall password
field.

Step Result: The Global Uninstall Password dialog opens.

Figure 124: Global Uninstall Password Dialog

4. Type the desired password in the New password field.

5. Retype the password in the Confirm new password field.

6. Click Save.
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7. Finish any desired edits to the agent policy set and click Save.

Result: The Global Uninstall Password dialog closes. Your edits take effect the next time Lumension Endpoint
Management and Security Suite and the applicable agents communicate.

Note:  Password edits are not saved until the agent policy set itself is saved.

Defining Agent Policy Logging Levels
All Lumension Endpoint Management and Security Suite Agents record a log of events that transpire on their
host endpoint. An agent policy set's logging level setting controls how much memory an agent's host endpoint
allocates for event logs. Define logging levels carefully: a low logging level may not record enough information
to be useful; however, a high logging level may record verbose information at the cost of higher disk space.

Define logging levels when creating or editing an agent policy set.

1. Select Manage > Agent Policy Sets.

2. Perform one of the following procedures based on your context.

Context Procedure

If you are creating an agent
policy set:

Click Create.

If you are editing an agent
policy set:

Click the edit icon associated with the policy set containing the logging
level setting you want to edit.

Step Result: Either the Create an Agent Policy Set or the Edit a Policy Set dialog opens.

3. Under the Agent Logging section perform one of the following procedures based on your context.

Context Procedure

If you are defining the logging
level for the first time:

Click the Define button adjacent to the Logging level field.
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Context Procedure

If you are modifying the
logging level:

Click the Modify button adjacent to the Logging level field.

Step Result: The Logging Level dialog opens.

Figure 125: Logging Level Dialog

4. Move the slider to the desired logging level.

The following table describes each logging level.

Logging Level Description

Trace Logs all errors and system actions.

Diagnostic Logs all errors and major system actions.

Normal Logs all errors and basic system action and usage information.

Error Logs only errors.

Critical Logs only critical events.

5. Click Save.

6. Finish any additional edits to the agent policy set and click Save.

Result: The Logging Level dialog closes. Your edits take effect the next time the Lumension Endpoint
Management and Security Suite server and the applicable agents communicate.

Note:  Logging level edits are not saved until the agent policy set itself is saved.
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Defining Inventory Collection Options
Each Lumension Endpoint Management and Security Suite agent compiles a list of hardware and software
present on its host endpoint. However, you can control how detailed this inventory is; you can configure what
hardware and software items the agent should scan for. Selecting fewer items from the list requires fewer system
resources, but the resulting inventory is not as robust.

Perform this task from Select Inventory Collection dialog when editing or creating an agent policy set.

1. Select Manage > Agent Policy Sets.

2. Perform one of the following procedures based on your context.

Context Procedure

If you are creating an agent
policy set:

Click Create.

If you are editing an agent
policy set:

Click the edit icon associated with the policy set containing the logging
level setting you want to edit.

Step Result: Either the Create Agent Policy Set or the Edit a Policy Set dialog opens.

3. Under the Patch Agent Communication section perform one of the following procedure based on your
context.

Context Procedure

If you defining inventory
collection options for the first
time:

Click the Define button adjacent to the Inventory Collection Options
field.
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Context Procedure

If you modifying inventory
collection options:

Click the Modify button adjacent to the Inventory Collection Options
field.

Step Result: The Select Inventory Collection dialog opens.

Figure 126: Select Inventory Collection Dialog

4. Select or clear the check boxes associated with the desired inventory collection options.

The following table describes each option.

Tip:  Selecting an option with child options automatically selects the child options as well.

Option Description

Allow use of WMI during
inventory collection

Required if Windows Management Instrument (WMI) data will be
gathered.

Hardware Selects or clears all options grouped under Hardware.

USB controllers Scans for data regarding USB device inventory (from
HKEY_LOCAL_MACHINE\Enum\USB).

IDE ATA/ATAPI controllers Scans for data regarding IDE ATA/ATAPI controllers.

Other hardware devices Scans for system device data.

Processors Scans for processor data.
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Option Description

USB Storage Devices Scans for data regarding USB device inventory (from
HKEY_LOCAL_MACHINE\Enum\USBSTOR).

Network adapters and MAC
address (may use WMI)

Scans for data regarding network adapters.

Physical RAM - amount Scans for the endpoint’s total physical RAM.

System devices Scans the Windows registry for additional hardware information.

Non-Plug and Play drivers Scans for data regarding non plug-and-play drivers.

Locally attached drives, total,
and free space

Scans for data regarding the disk drives.

USB devices Scans for data regarding USB controllers.

BIOS information Scans for BIOS data.

Sound, video, and game
controllers

Scans for data regarding sound, video, and game controllers.

Services Scans for a listing of Windows services (not applicable for Windows
9x or ME).

Software Scans for a listing of installed software.

Other Selects or clears all child options grouped under Other.

OS serial number (requires
WMI)

Scans for the OS serial number (requires WMI).

Virtual Machines Scans to determine if the endpoint is a virtual machine.

Endpoint serial number
(requires WMI)

Scans for the endpoint’s serial number (requires WMI).

Endpoint manufacturer and
model (may use WMI)

Scans for the computer manufacturer and model.

Endpoint asset tag (requires
WMI)

Scans for the endpoint’s asset tag (requires WMI).

User - last logged on Scans for last logged in user and time.

System uptime (may use WMI) Scans for and returns the time since last reboot (system uptime).

Custom import from file (may
use WMI)

Scans for files containing custom inventory data.

5. Click OK.
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6. Finish any desired edits in the agent policy set dialog and click Save.

Note:  Edits to the Inventory Collection Options are not saved until you click Save in the agent policy set
dialog.

Result: Your edits are saved. These edits take effect the next time Lumension Endpoint Management and
Security Suite and the applicable agents communicate.

Defining Agent Hours of Operation
Agent hours of operations determine when a patch agent is active on its host endpoint. In other words, this
setting restricts agent operations to a specific time range. By applying a specific hours of operation setting, you
can configure the agents to operate at optimal hours. For example, setting your agents to only work during the
weekend will ensure bandwidth remains open during operation hours, helping to maintain worker efficiency.
Optimal agent hours of operation vary by network.

Edit agent hours of operation when creating or editing an agent policy set.

1. Select Manage > Agent Policy Sets.

2. Perform one of the following procedures based on your context.

Context Procedure

If you are creating an agent
policy set:

Click Create.

If you are editing an agent
policy set:

Click the edit icon associated with the policy set containing the logging
level setting you want to edit.

Step Result: Either the Create Agent Policy Set or the Edit a Policy Set dialog opens.

3. Under Patch Agent Communication perform one of the following procedure based on your context.

Context Procedure

If you are creating an agent
policy set:

Click the Define button adjacent to the Hours of Operation field.
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Context Procedure

If you are editing an agent
policy set:

Click the Modify button adjacent to the Hours of Operation field.

Step Result: The Edit Agent Hours of Operation dialog opens.

Figure 127: Edit Agent Hours of Operation Dialog

4. Click time units to define agent hours of operation.

Green units indicate days and times of enablement, while red units indicate days and times of disablement.

• Click All to toggle all Time units on or off.
• Click Day to toggle time units for a day on or off.
• Click Time units to toggle individual units on or off.

5. Click OK.

6. Finish any desired edits in the dialog and click Save.

Note:  Changes made to the Hours of Operation schedule will not be saved until you have clicked Save in
the agent policy set dialog.

Result: Your edits are saved. These edits take effect the next time Lumension Endpoint Management and
Security Suite and the applicable agents communicate.

The Edit FastPath Servers Dialog
FastPath servers are servers that Lumension Endpoint Management and Security Suite uses to speed
communication and content delivery; they find the shortest route between the Lumension Endpoint Management
and Security Suite server and patch agents. From the Edit FastPath Servers dialog, you can view a listing of
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FastPath servers in use that are associated with the applicable agent policy set. You can also use this dialog to
assign new FastPath servers.

To access this dialog, click the Define/Modify button adjacent to the Servers field within the Create/Edit A
Policy Set dialog.

Figure 128: Edit FastPath Servers Dialog

The following table describes each column in the Edit FastPath Servers dialog.

Table 171: Edit FastPath Servers Dialog Columns

Column Description

Action Contains Edit and Delete icons. Use these icons to edit or delete FastPath server entries.

URL The URL of the applicable FastPath server.

Port The port number the FastPath server uses for communication with the Lumension Endpoint
Management and Security Suite server and agents.

The following table describes the buttons specific to the Create/Edit FastPath Servers dialog.

Table 172: Edit FastPath Servers Dialog Buttons

Button Description

Add Opens the Add/Modify FastPath Server dialog. For additional information, refer to Adding/
Editing FastPath Servers on page 366.

Adding/Editing FastPath Servers
Defining FastPath servers optimizes communication routes between the Lumension Endpoint Management and
Security Suite server and agent. You can add an unlimited number of servers.
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You can add or edit FastPath servers from the Add/Modify FastPath Server dialog when creating or editing
agent policy sets.

1. Select Manage > Agent Policy Sets.

2. Perform one of the following procedures based on your context.

Context Procedure

If you are creating an agent
policy set:

Click Create.

If you are editing an agent
policy set:

Click the edit icon associated with the policy set containing the logging
level setting you want to edit.

Step Result: Either the Create Agent Policy Set or the Edit a Policy Set dialog opens.

3. Under FastPath Servers perform one of the following procedures based on context.

Context Procedure

If defining FastPath servers for
the first time:

Click the Define button adjacent to the Servers field.

If modifying FastPath servers
that have already been defined:

Click the Modify button adjacent to the Servers field.

Step Result: The Edit FastPath Servers dialog opens.

4. Based on action you want to perform, complete the applicable step.

Action Step

If you are adding a new
FastPath server:

Click Add.
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Action Step

If you are editing an existing
FastPath server settings:

Click the Edit icon

Step Result: The Add/Modify FastPath Server dialog opens.

Figure 129: Add FastPath/Modify Server Dialog

5. Add or edit a FastPath server.

Type the applicable information in the following fields, or edit them as needed.

Field Description

URL The URL of the FastPath server, preceded by http://.

Port The port number that the FastPath server will use to communicate with
Lumension Endpoint Management and Security Suite.

6. If using a FastPath server that requires authentication, select the Authenticated check box and type the
applicable information in the following fields.

Field Description

User Name A user name that authenticates with the FastPath server.

Password The password associated with the user name.

Confirm Password The password retyped.

7. Click OK.

Step Result: The Add/Modify Fastpath Server dialog closes.

8. Click OK to close the Edit FastPath Servers dialog.
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9. Finish any desired edits in the Edit A Policy Set dialog and click Save.

Note:  FastPath servers added will not be saved until you click Save in the Create/Edit A Policy Set dialog.

Result: Your edits are saved. Your edits take effect the next time Lumension Endpoint Management and
Security Suite and the applicable agents communicate.

Deleting FastPath Servers
When you no longer want to use a FastPath server, delete its entry from the Edit FastPath Servers dialog.

Delete FastPath Servers from the Edit FastPath Servers dialog. You can delete FastPath servers when creating
or editing an agent policy set.

1. Manage > Agent Policy Sets.

2. Click the Edit icon associated with the agent policy set that contains the FastPath server you want to delete.

Step Result: The Edit a Policy Set dialog opens.

3. Under Fastpath Servers click the Modify button adjacent to the Servers field.

Step Result: The Edit FastPath Servers dialog opens.

4. Click the Delete icon associated with the FastPath server you want to delete.

Step Result: A dialog opens asking you to acknowledge the deletion.

5. Acknowledge the deletion by clicking OK.

Result: The FastPath server is deleted.

Defining Agent Policy Inheritance Rules
A group's behavior is defined via an agent policy set, which can be assigned directly to the group or inherited
using a group's Policy inheritance setting.

Because a group can inherit policies and have them directly assigned, policy conflicts may arise. The following
rules apply when a group has Policy Inheritance set to True:

1. Any conflicting policies that are assigned to the parent, but not the child, are resolved at the parent level per
the conflict policy resolution rules.

2. Agent policy set values assigned directly to a group supersede inherited agent policy set values.
3. Any conflicting policies that are assigned directly to the child group are resolved per the conflict resolution

rules.
4. Any agent policy set values that are undefined by the group’s directly assigned policy are defined by the

parent’s group policy.
5. Policy values still undefined are defined by the global system policy set.

For more information on how to enable a group's Policy inheritance setting, refer to Editing Group Settings on
page 335.
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For more information on conflict policy resolution rules, refer to Defining Agent Policy Conflict Resolution on
page 370.

Defining Agent Policy Conflict Resolution
On occasion, a group or endpoint may be assigned two different agent policy sets that have conflicting settings.
When this occurs, the system determines which of the conflicting settings to use based on agent policy conflict
resolution, which is a series of protocols that determine which settings take priority.

Conflicting policies are resolved in the following order.

1. Group Policies - Conflicting policy sets assigned to a group are resolved before conflicting policy sets
assigned to an agent are resolved.

The following rules apply if a group has Policy Inheritance set to False:

a. The applicable group does not inherit its parent’s policy set. Therefore, only policy sets assigned directly
to the group require resolution.

b. Conflicting policy set values are resolved according to the agent policy conflict resolution rules.

The following rules apply if a group has Policy Inheritance set to True:

a. The applicable child group inherits its parent’s policy set. Any conflicting policy sets that are assigned to
the parent, not the child, are resolved at the parent level.

b. Conflicting policy sets assigned directly to the child group are resolved according to the agent policy
conflict resolution rules. Policy set values assigned directly to a group supersede inherited policy set
values.

c. Finally, any policy set values that are undefined by the group’s directly assigned policy are defined by the
parent’s group policy (if defined by the parent group).

2. Agent Policies - After resolving the group policies, the conflicting policies assigned to an agent (via its group
membership) are resolved. The following rules apply:

a. The resultant policies of all groups to which the agent is a member are resolved according to the agent
policy conflict resolution rules.

b. Any policy values that have not been defined via the agent’s group membership are populated based on
the policy settings defined in the Global Policy Set.

Note:  The Global Policy Set policy values are used to fill undefined values in other agent policy sets.
Therefore, conflict resolution rules do not apply to the Global Policy Set.

The following table defines the rules used when resolving conflicting policy settings:

Table 173: Agent Policy Conflict Resolution Rules

Policy Setting Resolution

Agent Hardening

Agent uninstall protection The agent uses the On.

Global uninstall password Setting for global password.
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Policy Setting Resolution

Agent Logging

Maximum log file size The agent uses the largest log file size value.

Logging level The agent uses the most comprehensive logging level value (Trace [4] >
Diagnostic [3] > Normal [2] > Error [1] > Critical [0]).

Agent Bandwidth Throttling

Maximum transfer rate The agent uses the smallest transfer rate.

Minimum file size The agent uses the smallest file size.

Lumension EMSS Agent Communication

Use HTTP for file download The agent uses true (Y).

Send interval The agent uses the largest send interval frequency value.

Receive interval The agent uses the largest receive interval frequency value.

Timeout interval The agent uses the largest timeout interval frequency value.

Heartbeat interval The agent uses the largest heartbeat interval frequency value.

Lumension EMSS Agent Communication Deafults

Hide agent control panel The agent uses true (Y).

Show alerts on endpoint The agent uses true (Y).

Patch Agent Communication

Use SSL for agent to server
communication

The agent uses false (N).

Use HTTP for package
download

The agent uses false (N).

Agent listener port If any group has an agent listener port defined (not 0 ), the agent listens on
the highest defined port.

Agent scan mode The agent uses the fastest agent scan mode value (Fast Scan [2] > Initial Scan
[1] > Normal Scan [0]).

Communication interval The agent uses the shortest communication interval value.

Inventory collection options The agent uses an all inclusive set of Inventory Collection options.

Resume interrupted
downloads

If any group is not using Resumable Downloads, the agent will not use
resumable downloads.
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Policy Setting Resolution

Hours of operation If any group is not using hours of operation, the agent will not use hours of
operation. However, if all groups are using hours of operation, the agent uses
an all inclusive setting. The on value takes precedence during this operation.

Deployment Notification Defaults

User may cancel The agent uses True.

User may snooze The agent uses True.

Deployment within x minutes The agent uses the smallest Deploy Within value.

Always on top The agent uses True.

Reboot Notification Defaults

User may cancel reboot The agent uses True.

User may snooze reboot The agent uses True.

Reboot within x minutes The agent uses the smallest Reboot Within value.

Always on top The agent uses True.

Discover Applicable Updates

Scheduling frequency The agent uses the shortest possible DAU task frequency.

FastPath Servers

Interval The agent uses the shortest FastPath interval.

Servers The agent uses all of the defined FastPath servers.

Exporting Agent Policy Set Data
To export the list of agents policy sets listed on the Agent Policy Sets page to a comma separated value (.csv)
file, click the toolbar Export button. Exporting data lets you work with data in other programs for reporting and
analytical purposes.

Data for policy values are also exported. For additional information, refer to Exporting Data on page 60.

Assigning an Agent Policy Set to a Group
Associating an agent policy set with a group defines functional rules for the group to follow. Groups that do not
have an associated agent policy set use the Global System Policy.

Prerequisites:

Create an agent policy set.

Assign agent policy sets to a group from the Agent Policy Set view.
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1. Select Manage > Groups.

2. From the View list, select Agent Policy Set.

3. Select a group from the directory tree.

4. Click Assign.

5. Select an agent policy set from the Select a Policy Set list.

6. Click the Save icon.

Result: The policy set is saved and associated with the group.

Unassigning an Agent Policy Set from a Group
When desired, you can unassign an agent policy set from a group. Groups without associated policy sets use the
global system policy to define their behavior.

Remove agent policy sets from a group from the Agent Policy Sets view.

Note:  You cannot remove inherited policy sets. Instead, you must change the group policy inheritance setting or
remove the inherited policy set from the parent group.

1. Select Manage > Groups.

2. From the View list, select Agent Policy Sets.

3. Select a group from the directory tree.

4. Remove the desired policy sets.

Use one of the following methods.

Method Steps

To remove one agent policy set: Click the Unassign icon associated with the policy set you want to
remove.

To remove multiple agent
policy sets:

1. Select the check boxes associated with the agent policy sets you
want to remove.

2. From the toolbar, click Remove.

Step Result: A dialog appears, asking you to acknowledge the removal.

5. Acknowledge the removal by clicking OK.

Result: The agent policy set is no longer associated with the group and is removed from the Agent Policy Set
view.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 374 -



- 375 -

Chapter

12
Using Content

In this chapter:

• About Content

• The Content Pages

• Working With Content

• The Patch Status Page

• Working with Content Items

The term content encompasses all updates across all endpoints
registered to the Lumension Patch and Remediation Server.

Within Lumension Patch and Remediation, content consists of:

• The content description.
• Signatures and fingerprints required to determine whether the

content is patched or not patched.
• Associated package or packages for performing the patch.

Packages contain all vendor-supplied updates and executable code
used to correct or patch security issues.

The following graphic illustrates the relationship between content
and packages. Typically, a single content item is shared by multiple
endpoints on multiple operating system platforms. There may be a
series of separate patches to remediate the same content in different
environments. The separate patches are grouped in packages identified
by their respective product or OS. As a result, a series of packages may
be included for one content item.

Figure 130: Content and Package relationship
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About Content

The various pages pertaining to content display a listing of known vulnerabilities, software updates, and other
patches. Once reported and analyzed, the content is distributed to your Lumension Endpoint Management and
Security Suite server through the Global Subscription Server agent.

The agent installed on each endpoint checks for known content using the Discover Applicable Updates (DAU)
task. The DAU runs an inventory scan and sends the results back to the Lumension Endpoint Management and
Security Suite server, which compares it with the list of known content. If the endpoint is found to be missing
security items, a deployment can be set up to resolve the issues.

Figure 131: Discover Applicable Updates Task

Defining Content Structure
The structure of a content item allows the ability to create one patch applicable for many different operating
systems and software versions. This allows for different packages and signatures capable of identifying the
presence of patch files within an endpoint.
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As depicted in the following diagram, for each content item you can have more than one signature. For each
signature, you can have multiple fingerprints and pre-requisites. However, you can only have one package per
signature.

Figure 132: Patch Structure

Content Item
A content item is the container for the entire object. All properties set for the content item are viewed in content
pages. Each security content item can have one or more signatures.

Signatures
Signatures recognize specific combinations of installed software in an operating system. Vulnerabilities usually
contain multiple signatures to compensate for variances within applications. Frequently, a patch will require
different executables, dynamic-link libraries, and switches in order to run or detect the patch within different
operating systems.

Fingerprints
A fingerprint can represent a unique file, folder, registry key, or other data value somewhere within a system.
Each signature can contain one or more fingerprints detecting if a patch is present in the system.

Pre-requisites
A pre-requisite is a signature belonging to another vulnerability with its own fingerprints.

Adding a pre-requisite to a signature requires the pre-requisite be met before analyzing the signature for the
current patch. If that signature's pre-requisite is met, the agent will analyze the fingerprints of the current
signature, otherwise they will be ignored and the patch will not be applied to the device.

Packages
The package contains the actual files used to update or install software on the system. Each package contains the
script commands for installing the package files or running the executable that installs the patch.
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Vulnerabilities
Vulnerabilities are fixes for critical security issues. They are categorized by content type, which indicates the
level of need for an endpoint to have the vulnerability deployed and installed.

Vulnerabilities are classified into the following content types:

Critical Lumension or the product manufacturer has determined that this patch
is critical and should be installed as soon as possible. Most of the recent
security updates fall in to this category. The patches for this category
are automatically downloaded and stored on your Lumension Patch and
Remediation server.

Critical - 01 Lumension or the product manufacturer has determined that this patch is
critical and should be installed as soon as possible. This patch is older than
30 days and has not been superseded.

Critical - 05 Lumension or the product manufacturer has determined that this patch is
critical and should be installed as soon as possible. These patches have been
superceded.

Critical - Intl An international patch, where Lumension or the product manufacturer
has determined that this patch is critical and should be installed as soon
as possible. Most of the recent international security updates fall in to this
category. After 30 days international patches in this category will be moved
to Critical - 01.

Software Content
Software content consists of content intended to keep software up to date.

You can review software content in the following categories:

Service packs Collections of software fixes and enhancements that apply to installed
software.

Software installers Installers for third party software.

Updates Non-critical updates to installed software.

In addition to the categories listed above, you can also view a list of all available software security content.

Other Content
Other content includes items that are not directly related to patching an endpoint or updating software. It is
categorized by content type, which indicates the level of need for an endpoint to have the vulnerability deployed
and installed.
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Other content items are classified into the following content types:

Detection Only These security content items contain signatures that are common to
multiple vulnerabilities. They contain no associated patches and are only
used in the detection process.

Informational These security content items detect a condition that Lumension or the
product manufacturer has determined as informational. If the report has an
associated package, you may want to install it at your discretion.

Policies These security content items apply security policies to an endpoint.

Recommended Lumension or the product manufacturer has determined that these security
content items, while not critical or security related is useful and should be
applied to maintain the health of your computers.

Task These security content items contain tasks which administrators may use to
run various detection or deployment tasks across their network.

Virus Removal This security content items contain packages which administrators may use
to run various virus detections across their network. Anti-Virus tools and
updates are included in this category.

The Content Pages
Within Lumension Endpoint Management and Security Suite there are a variety of pages that display content:
vulnerabilities, content, and so on. These pages, which are organized identically, let you deploy the different
types of content.

Figure 133: Content Page Example

The following table itemizes navigation menu selections that open content pages. Use these pages to work with
different types of content.

Table 174: Content Page Navigation Menu Items

Menu Menu Item Sub-Menu Item

AllReview Vulnerabilities

Critical Vulnerabilities
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Menu Menu Item Sub-Menu Item

New Vulnerabilities

Top Vulnerabilities

All

Service Packs

Software Installers

Software

Updates

All

Detection Only

Informational

Packages

Policies

Recommended

System Management

Tasks

Other

Virus Removal

To Access the Content Pages
Review content to see which content items are available and which items you may want to deploy to your
managed endpoints.

1. Select Review from the main menu.

2. Select the type of content that you want to view: Vulnerabilities, Software, or Other.

3. Select a content sub-type.

The Content Type Filter
Regardless of the content page initially selected from the navigation menu, you can reorganize the page list to
display any content type available. Select the content featured on the page list by selecting a new item from the
Content Type filter.

For example, you can select Review > Vulnerabilities > All to open the Vulnerabilities, which initially lists
all vulnerability content available for deployment. However, if you select if you select Tasks from the Content
Type filter list, the page list will display all available task content.

Tip:  The page list can be further filtered by using the other page filters
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The following table describes how the page list is filtered based on the item selected from the Content Type
filter list.

Table 175: Content Type Filter Item Descriptions

Item Description

All Displays all available content.

All Critical Displays all content Lumension or the product manufacturer has deemed should be
installed as soon as possible.

Critical > 30 Days Displays all content Lumension or the product manufacturer has deemed should
be installed as soon as possible. This content is fewer than 30-days old. Most of
the recent security updates fall into this category. The content in this category are
downloaded and stored on your Lumension Endpoint Management and Security
Suite Server.

Critical International
(New)

Displays international content that Lumension or the product manufacturer has
deemed should be installed as soon as possible. Most of the recent international
security updates fall in to this category. After 30 days, international patches in this
category are moved to Critical > 30 Days.

Critical and Not
Superseded

Displays all content Lumension or the product manufacturer has deemed should be
installed as soon as possible. Content in this category has not been superseded by
new content.

Critical but Superseded Displays all content Lumension or the product manufacturer has deemed should be
installed as soon as possible. Content in this category has been superseded by new
content.

Software All Displays a list of available software.

Software Installers Displays a list of available software installers

Software Updates (Not
Critical)

Displays a list of updates to existing software. These patches are not critical to the
applicable software's operation.

Not Applicable Displays a list of content that is not applicable to endpoints in your network.
Content is deemed not applicable following discover applicable update tasks.

Not Critical Displays a list of content applicable to your endpoints, but is not critical for
security or operation (content listed under All Critical, Critical > 30 Days, and
Critical and Not Superseded).

Detection Only Displays a list of content that contain signatures that common to vulnerabilities.
This content contains no associated patches and are only used in the detection
process.

Informational Displays a list of content that detect a condition that Lumension of the product
manufacturer has determined as informational. If the report has an associated
package, you may want to install it as your discretion.
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Item Description

Policy Displays a list of content that impacts policy.

Recommended Displays a list of content that Lumension or the product manufacturer determined
that, while not critical or security related, is useful and should be applied to
maintain the operation of your endpoints.

Tasks Displays a list of tasks that administrators may use to run various virus detections
across their network. Anti-Virus tools and updates are included in this category.

Virus Removal Displays a list of content that removes viruses and other malware.

Critical & Not
Superseded/
Recommended

Displays all content classified as All Critical , Critical and Not Superseded, and
Recommended.

Note:  The page's Content Type filter Software All item combines the following Content Type filter items
into one type:

• Software
• Recommended
• Informational

The Content Pages Toolbar
Each page you can use to deploy content contains a toolbar of common functions.

The following table describes the toolbar functions used in each content page.

Table 176: Content Pages Toolbar Functions

Button Function

Enable Enables a selected disabled content item. For additional information, refer
to Enabling Content on page 388.

Note:  If no content items are disabled, Enable is unavailable.

Disable Disables a selected enabled content item. For additional information, refer
to Disabling Content on page 388.

Update Cache Updates the package cache for the selected content item. For additional
information, refer to Updating the Cache on page 390.

Deploy... Opens the Deployment Wizard. For additional information, refer to Using
the Deployment Wizard on page 229.
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Button Function

Scan Now... Prompts the Discover Applicable Updates task to launch immediately and
scan all agent-managed endpoints within your network for vulnerabilities.
For additional information, refer to Using Scan Now to Scan Inventory
(Content Pages) on page 388.

Export Exports the page data to a comma separated value (.csv) file. For
additional information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet
Explorer suppresses export functionality and must be disabled to export
data successfully. Pop-up blockers in Internet Explorer or other supported
browsers may also suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options
Menu on page 53.

The Content Pages List
Each page used to deploy content contains a list of content items.

The following table describes the columns in each content page list.

Table 177: Column Definitions

Column Icon Definition

Status  

 

Indicates the content item status. For additional information, refer to
Content Status and Type on page 385.

Package Status  

 

Indicates the content item package status. For additional information, refer
to Content Icons and Descriptions on page 386

Name Indicates the content item name. The name is a link to the content item's
Patch Status page. For additional information, refer to Content Name on
page 387.

Content Type Indicates the content item type. For additional information, refer to Content
Status and Type on page 385.

Number of endpoints
which came up
Patched

 

 

Indicates the total number of endpoints that are patched.
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Column Icon Definition

Number of endpoints
which came up Not
Patched

 

 

Indicates the total number of endpoints that are not patched.

Number of endpoints
which came up Error

 

 

Indicates the total number of endpoints that returned an error.

Number of endpoints
which are detecting

 

 

Indicates the total number of endpoints that are in the process of detecting
(whether the endpoint is patched or not patched).

Total number of
endpoints assigned

 

 

Indicates the total number of assigned or impacted endpoints.

Total Percent
Complete

 

 

Indicates the percentage of the endpoints that have completed the detection
= [(Total Patched + Total Not Patched) / Total Assigned endpoints.]

Additionally, you can expand each content item by clicking the rotating chevron (>). The following table
describes each field that displays when you expand a content item.

The following detail information appears on this page.

Table 178: Content Item Field Descriptions

Name Description

Type The content item type.

Content Type The content item's category.

Status The enabled/disabled/completed status of the content item.

Downloaded On The date and time on which the content was downloaded.

Vulnerability Results The result of whether the content item is current.

Common Vulnerability Exploit
(CVE)

The CVE number associated with content, if applicable.

Vulnerability Code Description A description of the vulnerability associated with the content item.

Reference Text The reference text(s) associated with the content item vulnerability.
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Name Description

Description The narrative description of the distribution package. This section may
include important notes about the content item.

Associated Packages The number of packages associated with the content item.

Packages Status The current status of the package, stating if the package is enabled and
ready to be requested from the Global Subscription Server.

Vendor The vendor that created the content item.

Released On The date on which the vendor released the content item.

Vendor Product ID The identifier given to the security content item by the vendor.

Note:  Content items may contain multiple Common Vulnerability Exploit, Vulnerability Code
Description, and Reference Text entries.

Note:  The page's Content Type filter Software All item combines the following Content Type filter items
into one type:

• Software
• Recommended
• Informational

Content Status and Type
An icon in the Status column indicates the status of content items. The menu options and filter criteria that you
select determines which content items are displayed. You can set the available filters to display content items of a
certain status type.

Table 179: Status and Descriptions

Status Description

New Downloaded from the Global Subscription Server since the last session.

Current Present content items residing on Lumension Patch and Remediation.

Tasks System task package.

Local Locally created package.

Beta Released to the Lumension BETA community.
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The following table includes descriptions of the security content status icons.

Table 180: Security Content Status Icons and Descriptions

New Current Beta Status Description

Active content.

The content has been disabled.

Content Cache Status and Type
A content item may have any number of packages associated with it. A package contains the patch to address the
security issue. Each package may be cached (downloaded) from the Global Subscription Server.

The downloading of packages can occur automatically if the security content item impact is rated as critical or
if a deployment has been created for a particular package or content item. Selecting the Package Status icon
displays a list of the individual packages associated with the content item.

Content Icons and Descriptions
An icon in the Package Status column indicates the cache status of content items. The menu options and filter
criteria that you select determines which content items are displayed. You can set the available filters to display
content items of a certain status type.

The content status icons and their status are classified as follows:

Table 181: Security Content Status Icons and Descriptions

New Current Tasks Local Description

 

 

 

 

 

 

N/A The package is not cached.

 

 

 

 

 

 

N/A The package has been scheduled to be cached or
is in the process of being cached.

 

 

 

 

 

 

N/A An error occurred while trying to cache the
package.

 

 

 

 

 

 

 

 

The package is cached and ready for
deployment.



Using Content

- 387 -

New Current Tasks Local Description

 

 

 

 

 

 

 

 

The package is currently deploying (animated
icon).

 

 

 

 

 

 

 

 

The package is disabled.

Content Name
The names of content items typically include the vendor (manufacturer of the content item) and specific
application and version information.

Working With Content
There are several tasks designed to assist with management and deployment of content items. These are available
from buttons located within the toolbar on the Review pages for the individual content types.

These tasks include:

• Deploying Selected Content (Content Pages) on page 387
• Viewing Content Patch Statuses on page 391
• Disabling And Enabling Content on page 388
• Updating the Cache on page 390
• Using Scan Now to Scan Inventory (Content Pages) on page 388
• Exporting Content Data on page 390

Deploying Selected Content (Content Pages)
Within Lumension Endpoint Management and Security Suite, content can be deployed from a number of pages,
including any Content page. When deploying from these pages, the Deployment Wizard is preconfigured
according to the content you select.

For additional information, refer to About Deployments on page 213.

1. Select Review > Vulnerabilities > All.

Tip:  You can deploy content from any content page. To deploy custom packages, deploy from the Packages
page.

2. From the list, select the content you want to deploy.
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3. Click Deploy.

Result: The Deployment Wizard opens, preconfigured to deploy the selected content.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Disabling And Enabling Content
Enabled content items are included in the scanning activity of the Discover Applicable Updates (DAU) system
task. All content items are initially enabled. When a content item is disabled, it is not included in the list for the
DAU system task.

Once disabled, content items may not appear in the content items list based on your filter settings. To include
disabled content in the list, select Disabled Vulnerabilities or All in the Status filter.

Disabling Content
Disabling a content item will prevent that content item from being deployed.

1. Select Review from the main menu.

2. Select the type of content that you want to view: Vulnerabilities, Software, or Other.

3. Select a content sub-type.

4. Select one or multiple content items from the list.

5. Click Disable.

Result: The content item displays with the disabled icon in the status column.

Enabling Content
Enabling a previously disabled content item allows you to deploy the content item to your endpoints.

1. Select Review from the main menu.

2. Select the type of content that you want to view: Vulnerabilities, Software, or Other.

3. Select a content sub-type.

4. Select a disabled content item.

5. Click Enable.

Result: The content item displays with the enabled icon in the status column.

Using Scan Now to Scan Inventory (Content Pages)
You can initiate a discover applicable updates (DAU) task at any time. When you initiate this task, the agent
scans its host endpoint for vulnerabilities and inventory. Scan results are then uploaded to the Lumension
Endpoint Management and Security Suite server, which you can view.

From the Content pages, you can schedule a DAU tasks for all managed endpoints in your network.
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1. Select Review > Vulnerabilities > All.

Note:  You can select any Review menu item related to content to complete this task.

2. Click Scan Now....

Step Result: The Scan Now dialog opens.

Figure 134: Scan Now

3. Select the Yes, scan all endpoints.

4. Click Schedule.

Step Result: A notification displays, informing you that the scan has been scheduled. The notification
contains a link to view the scheduled deployment.

Figure 135: Scan Now - Success

Note:  Although the DAU task is scheduled for immediate execution, it does not execute until
the next agent check in.
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5. Click Close.

Result: The dialog closes.

Updating the Cache
Updating the cache initiates a process that gathers the packages associated with the selected vulnerability and
copies those packages to your Lumension Patch and Remediation server.

Within Review pages, the Update Cache feature is designed to assist with the management and deployment of
content items.

Note:  For optimum installation order, Lumension recommends caching content prior to deployment. Failure
to cache content prior to deployment may result in repeated endpoint reboots that interrupt workflow on those
endpoints.

1. Select Review > My Default View.

2. If necessary, designate filter criteria for the desired content and click Update View.

3. Select the check boxes associated with the content to cache.

4. Click Update Cache.

Step Result: The Warning dialog box opens, informing you that the update request and this action may take
an extended period of time.

5. Click OK.

Result: The selected content begins caching.

Exporting Content Data
From the various content pages, you can export all information listed on the page to a comma separated value
(.CSV) file. The exported information can be used for reporting and analytical purposes.

For additional information, refer to Exporting Data on page 60.

The Patch Status Page
Each content item has its own Patch Status page and is accessed by selecting the name of the content item from
the displayed list. This page lists information about the content item and the patch's status in relation to each
network endpoint.

The following table lists and describes each page tab.

Table 182: Patch Status Page Tabs

Tab Description

Not Patched This tab lists endpoints that require the content item's patch.

Patched This tab lists endpoints that have the content item's patch installed.
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Tab Description

Error This tab lists endpoints that generated an error during the deployment of the
content item or subsequent Discover Applicable Updates (DAU) task.

Detecting This tab lists endpoints running or waiting for the DAU to begin.

Information This tab lists information about the content item.

The Not Patched, Patched, Error, and Detecting tabs list endpoint information in relation to the content item.
However, the Information tab contains information about the content item itself. It contains no information
about endpoints.

Viewing Content Patch Statuses
You can view details of a specific content item by selecting the desired content item and clicking the item name.

View a content item's patch status by clicking a content item's hyperlink from a content page list. The Patch
Status page represents the results of the content item analysis and displays detailed data regarding the content
item.

1. Select Review from the main menu.

2. Select the type of content that you want to view: Vulnerabilities, Software, or Other.

3. Select a content sub-type.

4. Select a content item from the list. You can only view the details of one content item at a time.

5. Click the content item’s name.

Result: The Patch Status page for the selected content item opens.

The Patch Status Page Toolbar
Each tab on the Patch Status page contains an identical toolbar. Use this toolbar to complete tasks related to
applicable content item.

The following table describes each button in the toolbar.

Table 183: Patch Status Page Toolbar Buttons

Button Description

View Package Opens the Packages page and displays the package for the applicable content item.

Deploy... Opens the Deployment Wizard. For additional information, refer to Using the
Deployment Wizard on page 229.
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Button Description

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Patch Status Page List
Each tab in the Patch Status page displays basic information for managed endpoints.

The following table describes the Patch Status page columns.

Table 184: Patch Status Page Column Descriptions

Column Description

Endpoint Status Displays an icon that indicates the endpoint status. For additiona information, refer to
Endpoint Status on page 392.

Name Indicates the name of the endpoint.

DNS Name Indicates the DNS name for the endpoint. The endpoint IP address displays if it does not
have an assigned DNS name.

IP Address Indicates the IP address of the endpoint.

Operating System Indicates the operating system (abbreviated) running on the endpoint.

OS Service Pack Indicates any additional operating system version information.

Analysis Date Indicates the date the agent on the device last ran the Discover Applicable Updates
system task.

Endpoint Status
An icon in the Endpoint Status column indicates the agent status and activity on an endpoint.
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Also displayed in the Patch Status page is the status of the agent installed on the endpoint.

Table 185: Endpoint Status Icons

Active Pending Description

 

 

N/A The agent is currently working on a deployment (animated icon). Patch and
Remediation only.

 

 

 

 

The agent is idle, and has pending deployments. Patch and Remediation only.

 

 

 

 

The agent is offline.

 

 

 

 

The agent is sleeping due to its hours of operation settings.

 

 

 

 

This agent is disabled.

 

 

 

 

The agent is offline and is in a chain status (can accept chained deployments until
only after reboot). Patch and Remediation only.

 

 

 

 

The agent is offline and is in a reboot status (can accept no more deployments until
after it reboots). Patch and Remediation only.

 

 

 

 

The agent is in a chain status (the agent can accept chained deployments only until
after a reboot). Patch and Remediation only.

 

 

 

 

The agent is in a reboot status (the agent can accept no more deployments until after
it reboots). Patch and Remediation only.
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Active Pending Description

 

 

 

 

The agent is in a chain status (the agent can accept chained deployments only until
after a reboot) and is sleeping due to its hours of operation settings. Patch and
Remediation only.

 

 

 

 

The agent is in a reboot status (the agent can accept no more deployments until
after it reboots) and is sleeping due to its hours of operation settings. Patch and
Remediation only.

 

 

Unable to identify the agent status.

The Information Tab
The Information tab, unlike other Patch Status page tabs, features no toolbar or list. Rather, it features reference
information for the applicable content item.

The Information tab feature the following sections:

• Vulnerability Information on page 395
• CVE Information on page 395

Note:  Only content items associated with a CVE ID display CVE Information

The Information Tab Buttons (Package Details Page)
The Information tabs contains buttons used to complete tasks related to applicable content item.

The following table describes each button.

Table 186: Information Tab Buttons

Button Description

View Package Opens the Packages page and displays the package for the applicable content item.

Deploy... Opens the Deployment Wizard. For additional information, refer to Using the
Deployment Wizard on page 229.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.



Using Content

- 395 -

Button Description

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

Vulnerability Information
This section displays information about the applicable content item.

The following table describes each Vulnerability Information field.

Table 187: Content Item Field Descriptions

Name Description

Vulnerability Name The name of the content item.

Type The content item type.

Content type The content item's category.

Status The enabled/disabled/completed status of the content item.

Modified On The date and time the package was last modified.

Vulnerability Results The result of whether the content item is current.

Description The narrative description of the distribution package. This section may include
important notes about the content item.

Associated Packages The number of packages associated with the content item.

Packages Status The current status of the package, stating if the package is enabled and ready to be
requested from the Global Subscription Server.

Vendor Name The vendor that created the content item.

Released On The date on which the vendor released the content item.

Vendor Product ID The identifier given to the security content item by the vendor.

CVE Information
This section lists the common vulnerability exploit information (CVE) of a content item. The CVE is a dictionary
of publicly known information security vulnerabilities and exposures.
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The following table describes each CVE Information field. Because a content item may be associated with more
than one CVE ID, these fields may appear more than once.

Table 188: CVE Information Fields

Field Description

Common Vulnerability
Exploit (CVE)

The CVE ID associated with the content item.

Vulnerability Code
Description

The description of exploit associated with the content item.

Reference Text The Microsoft reference text associated with the content item.

Note:  Only content items associated with a CVE ID display CVE Information.

Working with Content Items
From the Patch Status page, you can perform tasks related to a specific content item.

From the different page tabs, you can perform the following tasks:

• View Packages on page 396
• Deploying Content on page 396
• Exporting Content Item Data on page 397

View Packages
While viewing the Patch Status page for a content item, you can immediately view that content item's page.

Perform this tasks from any Patch Status page tab.

1. Select the desired tab:

• Not Patched
• Patched
• Error
• Detecting
• Information

2. Click View Package.

Result: The Packages page opens, displaying the package for the applicable content item.

Deploying Content
Deploying content items to endpoints is a key function of the Lumension Patch and Remediation module.
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Deployments are initiated by clicking Deploy... and completing the Deployment Wizard. The Deployment
Wizard provides step-by-step instructions for defining and distributing security content items to the protected
endpoints in the network. For additional information, refer to Working With Deployments and Tasks on page 223.

Exporting Content Item Data
When viewing the Patch Status page, you can export the all data displayed for the selected tab to a comma
separated value (.csv) file.

For additional information, refer to Exporting Data on page 60.
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Chapter

13
Managing Packages

In this chapter:

• About Packages

• The Packages Page

• Working with Packages

• The Package Details Page

• Using the Package Editor

Packages contain the actual files used to update or install software on
the system. Each package contains the script commands for installing
the package files or running the executable that installs the patch.

Packages can run tasks, scripts, install software applications, send files
to a specified location, and change the configuration of an application
or service.

About Packages
Packages contain all vendor-supplied updates and executable code used to correct or patch security issues. The
Packages page displays a listing of known vulnerabilities, software updates, and other patches.

The Packages Page
You can expand a package's listing on the Package page to view it's details.

Figure 136: Packages Page
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Viewing Packages
The Packages page lists packages by package name. You can expand the page to view package details.

1. Select Review > Other > Packages from the navigation menu.

2. If needed, select filter criteria from the available fields and click Update View.

Result: The system displays the existing package list in the Packages page.

The Packages Page Toolbar
The toolbar on the Packages page contains buttons that initiate the tasks that you can perform on packages.

The following table describes each toolbar button.

Table 189: Packages Page Buttons and Descriptions

Button Description

Delete Deletes the package. For more information, refer to Deleting a Package on
page 404.

Update Cache Sends a request to the Global Subscription Server to get the latest version
of the package. For more information, refer to Updating the Package
Cache on page 404.

Create... Opens the Package Editor Wizard, allowing you to create custom
packages. For more information, refer to Using the Package Editor on page
411.

Edit Opens the Package Editor Wizard, allowing you to edit custom packages.
For more information, refer to Editing a Package on page 405.

Deploy... Opens the Deployment Wizard, allowing you to deploy content to
managed endpoints. For more information, refer to Working With
Deployments and Tasks on page 223.

Export Opens a File Download dialog, allowing you to view package details
or save them in a comma-separated value (.CSV) format. For more
information, refer to Exporting Data on page 60.

Options Opens the Options menu. For additional information, refer to The Options
Menu on page 53.

The Packages Page List
The Package page list contains identification, origin, operating system, and associated deployment information.
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The following table describes the column definitions on the Packages page.

Table 190: Package Column Definitions

Column Icon Definition

Package Status  

 

Indicates the content item package status. For additional information, refer to
Content Icons and Descriptions on page 386.

Name Name includes vendor, application, and version information.

Origin The origin of the task or which company created the package.

Operating Systems The platforms that are supported by the package.

Cache Status Indicates if the package is cached (Imported), in progress (Pending), not
cached or in progress (column entry is blank).

Cache Date The date on which the package cache was updated most recently.

Deployments Number of times the package has been deployed.

Additionally, you can expand each package by clicking the rotating chevron (>). The following table describes
each field that displays when you expand a package.

Table 191: Package Field Descriptions

Field Description

Package Name Title of the package.

Origin Point of origin of the package. An origin of Lumension or System refers to
packages created by Lumension.

Status The current status of the package, stating if the package is enabled and ready to be
requested from the Global Subscription Server.

Cache Status The current cache status of the package. A package is considered cached when it
has been downloaded from the Global Subscription Server and actually resides on
the local server.

Cache Request Status Indicates if the package has been requested from the Global Subscription Server.

Deployment Availability Indicates if the package is available for deployment.

OS Platforms The operating systems and platforms that the package supports and may be
deployed to.

Created By Username The user who created the package. Packages created by Lumension may have a
value of Patchlink Corp. in this field.
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Field Description

Created On The date and time the package was created.

Last Modified By
Username

The user who last modified the package. Packages created by Lumension may have
a value of Patchlink Corp. in this field.

Last Modified On The date and time of the last change to the package.

Last Created
Deployment Date

The date and time a deployment was last created using this package.

More Information If available, presents a link to detailed package information. This might be an
article or other resource from a third-party.

License Information If available, presents a link to detailed license information.

Description Narrative description of the distribution package. Also includes links to any
relevant Lumension knowledge base articles.

Version The package version.

Total Directories in
Package

The number of directories contained in the package.

Total Files in Package The number of files contained in the package.

Compressed Size of
Package

The file size of the compressed package (in KB).

Number of Prescripts The total number of prescripts contained in the package.

Number of Postscripts The number of postscripts contained in the package.

Number of Command-
Line Scripts

The number of command-line scripts contained in the package.

Number of
Dependencies

The number of dependencies associated with the distribution package.

Total Idle Deployments The number of idle deployments.

Total Running
Deployments

The number of running deployments.

Total Failed
Deployments

The number of failed deployments.

Total Successful
Deployments

The number of successful deployments.

Content Package Icons and Descriptions
Package icons indicate whether a package is cached, deploying, or disabled.
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The package status icons and their status are classified as follows:

Table 192: Security Content Status Icons and Descriptions

New Current Tasks Local Description

 

 

 

 

 

 

N/A The package is not cached.

 

 

 

 

 

 

N/A The package has been scheduled to be cached or
is in the process of being cached.

 

 

 

 

 

 

N/A An error occurred while trying to cache the
package.

 

 

 

 

 

 

 

 

The package is cached and ready for
deployment.

 

 

 

 

 

 

 

 

The package is currently deploying (animated
icon).

 

 

 

 

 

 

 

 

The package is disabled.

Working with Packages
There are several tasks that you can perform using Lumension Patch and Remediation to assist you in the
management and deployment of packages. These are available from commands located in the toolbar on the
Packages page.

These tasks include:

• Deploying Selected Packages on page 404
• Deleting a Package on page 404
• Updating the Package Cache on page 404
• Editing a Package on page 405
• Creating a Package on page 405
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Deploying Selected Packages
Within Lumension Endpoint Management and Security Suite, you can deploy packages from the Packages page.

For additional information, refer to About Deployments on page 213.

1. Select Review > Vulnerabilities > Packages.

2. From the list, select the packages you want to deploy.

Tip:  Unless you are deploying custom content, Lumension recommends using the vulnerability content type
for deployments. Vulnerabilities can contain multiple packages for multiple platforms, thus simplifying the
remediation process.

3. Click Deploy.

Result: The Deployment Wizard opens, preconfigured to deploy the selected content.

After Completing This Task:

Review Using the Deployment Wizard on page 229 and complete subsequent tasks.

Deleting a Package
Deleting a package removes it from the list of available packages. All records of the package are removed from
the database. However, system-task packages cannot be removed.

Note:  Package metadata for Lumension-provided packages that were deleted will be re-downloaded from
the Global Subscription Server. However, the package will not be cached unless it is associated with a critical
content item or included in a deployment.

1. Select Review > Other > Packages.

2. In the Packages list, select one or multiple packages.

3. In the toolbar, click Delete.

Step Result: The Warning dialog box opens, which displays the expected processing time for the action.

4. Click OK to confirm the request to delete the package(s).

Step Result: The package(s) is deleted from the packages list.

Updating the Package Cache
Updating the system cache initiates the process to cache (or re-cache) the selected packages.

Note:  When you update the package cache, the package itself is not cached. The scripts that are used when the
package is deployed are cached.

1. Select Review > Other > Packages.

2. In the Packages list, select one or multiple packages.
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3. In the toolbar, click Update Cache.

Step Result: The Warning dialog box opens, informing you of the expected processing time for the action.

4. Click OK.

Step Result: The Package scripts are cached.

Creating a Package
Creating a package is a multi-step process that you can accomplish using the Package Editor wizard.

Complete the following steps to create a package.

1. Select Review > Other > Packages.

2. Click Create.

Step Result: The Welcome to the Package Editor page opens.

3. Refer to Using the Package Editor on page 411 for details on changing packages through the Package
Editor Wizard.

Editing a Package
Changing a package is restricted to custom packages created by you or another Lumension Patch and
Remediation administrator.

Note:  Packages with an origin of Lumension or System cannot be modified.

1. Select Review > Other > Packages.

2. In the Packages list, select a package.

3. In the toolbar, click Edit.

Step Result: The package is displayed in the Edit Packages dialog box.

4. Make the desired edits and click OK.

The Package Details Page
This tabbed page lists the information and deployment history for a selected package. Select a tab to view
deployments or information. You can also use this page to perform tasks related to the package.

The Package Details page contains the following tabs:

• The Deployments Tab (Package Details Page) on page 406
• The Information Tab (Package Details Page) on page 409

Viewing the Package Details Page
View this page to view information about a specific package or to performs tasks related to it.
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View the Package Details page by selecting a package from the Packages page.

1. Select Review > Other > Packages.

Step Result: The Packages page opens.

2. Click the Name link associated with the package you want to view.

You may have to page through the list to find the package you want to view.

Result: The Package Details page opens.

The Deployments Tab (Package Details Page)
The Deployments tab lists the deployment history for the selected package. It also contains a toolbar you can use
to perform tasks related to the package.

Figure 137: Deployments Tab

The Deployments Tab Toolbar (Package Details Page)
The Package Details page Deployments tab contains a toolbar you can use to performs tasks related to the
selected deployment.

The Deployments tab contains a toolbar that allows you to perform actions on packages.

Table 193: Deployments Tab Toolbar

Menu Item Function

Enable

(Patch and Remediation
only)

Enables the selected disabled deployment or task. For additional information, refer
to Enabling Deployments on page 224.

Disable

(Patch and Remediation
only)

Disables the selected enabled deployment or task. For additional information, refer
to Disabling Deployments on page 224.
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Menu Item Function

Abort

(Patch and Remediation
only)

Cancels the deployment or task for any endpoints which have not already received
the deployment package. For additional information, refer to Aborting Deployments
and Tasks on page 223.

Delete

(Patch and Remediation
only)

Removes the deployment or task from your Lumension Endpoint Management and
Security Suite. For additional information, refer to Deleting Deployments on page
227.

Deploy... Opens the Deployment Wizard. For additional information, refer to Using the
Deployment Wizard on page 229.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

The Deployments Tab List (Package Details Page)
The Package Details page Deployments tab list contains information and statistics about package deployments.

The following table describes each column in the list.

Table 194: Deployments Tab List

Column Icon Description

Name The name of the package.

Scheduled Date The date on which the package was scheduled to deploy.

Number of
Endpoints/Groups
which were
Successful

 

 

Total number of endpoints or groups that finished the deployment
successfully.

Number of
Endpoints/Groups
which Failed

 

 

Total number of endpoints or groups that finished the deployment
unsuccessfully.
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Column Icon Description

Number of
Endpoints/Groups
assigned to the
Deployment

 

 

Total number of endpoints or groups that are assigned the deployment.

Number of
Endpoints/Groups
which are In
Progress

 

 

Total number of endpoints or groups that are in the process of executing the
deployment.

Number of
Endpoints/Groups
which have Complete
the Deployment

 

 

Total number of endpoints or groups that finished the deployment.

Percentage Complete  

 

Percentage of the endpoints or groups that finished the deployment. = [Total
Finished Endpoints / Total Assigned Endpoints]

Each deployment listed be expanded to display additional details about the package. The following table
describes each field listed when you expand a deployment.

Table 195: Expanded Package Deployment

Name Value

Deployment Name The name of the deployment.

Scheduled Date The date and time the deployment was scheduled.

Last Modified Date The date and time the deployment was last modified.

Last Modified By The user that last modified the deployment.

Created Date The date and time the deployment was created.

Created By The user that created the deployment.

Deployment Manner The manner in which the package was deployed.

Schedule Type The schedule type selected during deployment configuration.

Notes The notes entered during deployment configuration.
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The Information Tab (Package Details Page)
You can access information similar to that found on the Package Details page by clicking the package name and
selecting the Information tab.

Figure 138: Information Tab

The Information Tab Buttons (Package Details Page)
The Information tabs contains buttons used to complete tasks related to applicable content item.

The following table describes each button.

Table 196: Information Tab Buttons

Button Description

View Package Opens the Packages page and displays the package for the applicable content item.

Deploy... Opens the Deployment Wizard. For additional information, refer to Using the
Deployment Wizard on page 229.

Export Exports the page data to a comma separated value (.csv) file. For additional
information, refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully.
Pop-up blockers in Internet Explorer or other supported browsers may also
suppress export functionality and should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu
on page 53.

Package Information
The Package Details page Information tab lists package information, deployment information, and package
contents for the selected package.
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The following table describes each field listed on the Information tab.

Table 197: Package Information Definitions

Status Description

Package Information

Package Name Title of the package

Status The current status of the package, stating if the package is enabled and
ready to be requested from the Global Subscription Server.

Origin The origin of the task or which company created the package.

Created By The user who created the package.

Last Modified By The user who last modified the package.

Cached On The date and time the distribution package was last cached.

More Information If available, presents a link to detailed package information. This might be
an article or other resource from a third-party.

Description Narrative description of the distribution package. Also includes links to
any relevant Lumension knowledge base articles.

Operating Systems The operating systems and platforms that the package supports and may be
deployed to.

Version The package version.

Created On The date and time the package was created.

Last Modified On The date and time of the last change to the package.

License Information If available, presents a link to detailed license information.

Deployment Information

Total Deployments The total number of deployments.

Total Scheduled The number of scheduled deployments.

Total In Progress The number of running deployments.

Total Success The number of successful deployments.

Package Contents

Files The number of files contained in the package.

Disk Space The file size of the compressed package (in KB).

Scripts The total number of scripts (includes Prescripts, Postscripts, and
Command-line scripts) contained in the package.
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Status Description

Directories The number of directories contained in the package.

Dependencies The number of dependencies associated with the distribution package.

Using the Package Editor
Creating distribution packages is performed using the Package Editor wizard.

Note:  The Package Editor is supported in the Internet Explorer Web browser only. To use the Package Editor
with the Internet Explorer Web browser, you must install an ActiveX control.

Caution:  If the Application Control module has been installed and its Easy Lockdown feature applied to an
endpoint, a browser on that endpoint will not be able to install a new ActiveX control. Before using Package
Editor in this situation, the administrator must create a Trusted Publisher policy that assigns the Lumension
Security certificate to that endpoint. For additional information, refer to Easy Lockdown in Practice and Creating
a Trusted Publisher Policy within the .

1. Select Review > Other > Packages.

2. In the Packages list, click Create.

Step Result: The Welcome to the Package Editor screen opens.

Figure 139: Package Editor Welcome Page
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3. Click Next.

Step Result: The Package Editor displays.

Figure 140: The Package Editor

4. Type Package Information in each field.

The following table describes the information you type in each field.

Field Description

Name A name or title for the package. Lumension recommends using short
and descriptive names. Duplicate package names are permitted, and
package names can be edited after initial creation.

Description A description of package details. Lumension recommends adding
information as the package is modified, providing necessary
information as needed.

Information URL Link(s) to additional information about the content and usage of the
package. The information URL is displayed when viewing package
information.

Note:  Deployment options for manual installations of a patch can be included in the Description field. For
more information about using deployment options, refer to Including Deployment Options in a Package on
page 418.

5. Click Next.

Step Result: The Select Operating System page opens displays.
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6. In the Operating Systems page, select the target operating systems from the list. These are the platforms
running endpoints that are the target for the package deployment.

Figure 141: Package Editor - Select Operating System

Note:  Since directory structures, executable file types, and available scripting languages vary greatly within
operating systems, a package designed for one operating system may fail when applied to another operating
system.
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7. Click Next.

Step Result: The Add Files page opens.

Figure 142: Package Editor - Add Files

8. Add files to the package.

For additional details regarding adding files to a package, refer to Adding File and Directories to a Package on
page 419.
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9. Click Next.

Step Result: The Create Scripts page displays.

Figure 143: Create Script

10. If needed, add a script to run on the target endpoint during the deployment process.

For additional details regarding package scripts, refer to Creating Scripts for a Package on page 424.

Figure 144: Script Editor
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11. Click Next.

Step Result: The Enter a License page opens.

Figure 145: Package Editor - License URL

12. In the License Agreement dialog, select the License Agreement check box and enter the appropriate URL in
the destination address of the License URL field.

The License Agreement dialog allows you to enter in an optional License URL, which can link to licensing
information for the contents of the package. This option is primarily for packages containing items such
as operating system service packs, endpoint drivers, and so on. The License URL displays when viewing
package information and allows the user to link to the license information.
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13. Click Next.

Step Result: The Summary page displays.

Figure 146: Package Editor - Summary

14. Click Upload.

15. In the Summary page, review the summary of the package to be deployed.

Selecting the Make this package available for rollout check box enables the package to display in the list of
available packages. You may clear this option if you are creating a package that will contain additional files
or details added at a later date or do not want to deploy the package at this time.
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16. The Upload Status page verifies that the data is unpacking and uploading. Once all files are uploaded, click
Next.

Step Result: The Upload Summary page displays.

Figure 147: Package Editor - Upload Summary

17. Click Finish.

Result: The page refreshes and the Package page opens with the custom package. When you refresh the
Packages page, you can view the package by the name you gave it, and view the operating systems that
you chose to deploy to during the patch building process.

Including Deployment Options in a Package
Package flags control the behavior of a distribution package when it is deployed.

The following flags indicate a manual installation of the patch is required. To use this option, type (manual
install) in the Description field.

A number of additional deployment options are available by including them in with the flags delimiter. To add
these, enter(PLFlags: <Your Flags>) to the Description field.

Package Flag Descriptions
Package flags allow you to attach behavior to package deployments.

The following table defines flag behavior and their descriptions:

Table 198: Package Flag Descriptions

Description (flag behavior) Display Flag Select Flag

Perform an uninstall; can be used with -mu or -q. -yd -y
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Description (flag behavior) Display Flag Select Flag

Force other applications to close at shutdown. -fd -f

Do not back up files for uninstall. -nd -n

Do not restart the computer when the installation is done. -zd -z

Use quiet mode, no user interaction is required. -qd -q

Use unattended setup mode. -dmu -mu

Install in multi-user mode (UNIX, Linux only). -dsu -su

Restart service after installation (UNIX, Linx only). -drestart -restart

Do not restart service after installation (UNIX, Linux only). -dnorestart -norestart

Reconfigure after installation (UNIX, Linux only). -dreconfig -reconfig

Do not reconfigure after installation (UNIX, Linux only). -dnoreconfig -noreconfig

This package is chainable and will run Qchain.exe (Windows) or
(UNIX/Linux).

-dc -c

Suppress the final chained reboot. -dc -sc

Repair permissions. -dr -r

Deploy only. -PLD1 -PLD0

No Pop-up -PLN1 -PLNP

Debug -PLDG -PLDEBUG

Suppress Repair -dsr -sr

Force the script to reboot when the installation is done. -1d -1

Reboot is required. Not applicable -2

Reboot may occur. Not applicable -3

Reboot is required, and may occur. Not applicable -4

Adding File and Directories to a Package
There are several options for adding files, folders, and macros to a package.
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Files and directories can be added to the package by right-clicking the Package Content window, and selecting
one of the following options:

• Adding a Directory to a Package on page 420
• Creating a Drive for a Package on page 421
• Adding a New Macro to a Package on page 421
• Creating a Folder for a Package on page 422
• Adding a File to a Package on page 423
• Deleting a File from a Package on page 423
• Renaming a File within a Package on page 423
• Folder Properties for a Package on page 423

Figure 148: Package Content

Adding a Directory to a Package
Once a macro, directory, or folder has been created, a new directory can be added to it. A file system window is
opened where you can locate and select an existing directory to add to the package.

1. Right-click the macro, directory, or folder associated with the target computer.

2. Select Add Directory.

Step Result: The Browse for Folder window opens.

3. Select the directory to add to the macro, directory, or folder.
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4. Click Open.

Step Result: The directory is added to the macro, directory, or folder.

Creating a Drive for a Package
Use the New Drive option to deploy a package to a drive other than the C:\ or %TEMP% drives.

1. Right-click inside the Target Computer window.

2. Select Create Drive... from the pop-up menu.

Step Result: The Create Drive window opens.

Figure 149: Create Drive

3. In the Drive or Volume Name field, type the letter you require for the drive name, followed by a colon in X:
format.

4. Click OK.

Step Result: The drive is added to the Target Computer window.

Adding a New Macro to a Package
Macros access existing system directories. A macro can be either an environment variable, as defined by the
operating system, or a macro that only the agent can expand.
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The following pre-defined macros are available under the New Macro menu:

• %TEMP% - The operating system temp directory location. Expands to C:\Windows\Temp, C:\Temp, C:
\WinNT\Temp, or /tmp depending on operating system and configuration.

• %WINDIR% - The operating system windows directory location. %WINDIR% typically expands to C:
\Windows.

• %BOOTDIR% - The operating system boot directory location. Typically expands to C:\.
• %ROOTDIR% - The operating system root directory location. Typically expands to C:\.
• %PROGRAM FILES% - The operating system program files location. Typically expands to C:\Program

Files.
• %COMMON FILES% - The operating system common files location. Typically expands to C:\.

Note:

Not all macros are available on all operating systems. Choose only the macros that are compatible with the
operating systems and configurations you are using.

1. Right-click inside the Target Computer window.

2. Select Create Macro.

Example:

Figure 150: Macro Menu

3. Select the macro required for the package.

Step Result: The selected macro displays in the Target Computer window.

Creating a Folder for a Package
The Create Folder window allows for creating a folder within the Package Content directory.

1. Right-click inside the Target Computer window.

2. Select Create Folder.

Step Result: The Create Folder window opens.

3. In the Folder Name field, type the name of the new folder.
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4. Click OK.

Step Result: The folder is added to the Target Computer window.

Adding a File to a Package
Once a folder, directory, or macro has been created, a file can be added. A file system window is opened where
you can locate and select an existing file to add to the Package.

1. Right-click the directory, folder, or macro associated with the Target Computer.

2. Select Add File.

Step Result: The Open window opens.

3. Select the file to add to the directory, folder, or macro.

4. Click Open.

Step Result: The file is added to the directory, folder, or macro.

Deleting a File from a Package
You can remove a directory or file from a package. This option is available only for files added to the Target
Computer window.

1. Right-click the directory, folder, or macro associated with the Target Computer that you want to delete.

2. Select Delete.

Step Result: The file is deleted for the package.

Renaming a File within a Package
The Rename option allows for renaming of a previously created drive or macro within the package.

1. In the Target Computer directory tree, select the directory where the file is to be renamed

Step Result: The file is highlighted and the cursor becomes active.

2. Type the new name of the file.

3. Click OK.

Step Result: The folder name is changed and displays in the Target Computer window.

Folder Properties for a Package
The Properties window allows you to set properties for the selected item. Only available when you right click on
a folder that has previously been added to the Target Computer window.

1. In the Target Computer window, select the directory where the file is located.
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2. Right-click the selected file.

3. Select Properties.

Step Result: The Properties window opens.

Figure 151: Properties

4. In the Attribute field, select or deselect the Overwritable check box.

Example:
Note:  Removing the check-mark from the Overwritable attribute will prevent subsequent
patches that contain the same file from overwriting the file.

5. Click Apply.

Step Result: The folder properties are changed.

Creating Scripts for a Package
You can add functionality to packages using scripts.

There are three types of scripts. These scripts can be written in Microsoft Visual Basic Script or Microsoft
Jscript. Documentation regarding these languages can be found at MSDN Library: Scripting (http://
msdn2.microsoft.com/en-us/library/ms950396).

The following scripts are listed by the order in which they execute within the package:

1. Pre-Script - Used to test for a machine condition or shutdown a service. For example you can stop the
package rollout in the pre-script by using the SetReturnCode in the PLCCAgent script object.

http://msdn2.microsoft.com/en-us/library/ms950396
http://msdn2.microsoft.com/en-us/library/ms950396
http://msdn2.microsoft.com/en-us/library/ms950396
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2. Command Line Script - Used to launch executable files. The format is the same as a standard .CMD or .BAT
file.

3. Post-Script - Used for any clean-up operations such as the deletion of files, starting services, or running an
installed file.

There can be a maximum of one of each script type in a software package. When all three scripts are present,
they will be executed in the order listed above.

Note:  Unless the Execution Directory option is selected and a valid directory is defined, all scripts run in the
ROOT directory.

1. Select the type of script to execute from the Type of Script drop-down list.

2. Select the scripting type from the Script Language drop-down list.

3. Click Edit.

Step Result: The Script Editor window opens.

Figure 152: The Script Editor

4. Type or copy the script to be added in the Script field.

5. Click Run.

Step Result: The script is checked and the Errors box displays Success when the script is validated.

6. Click OK.

Step Result: The Script Editor window closes and returns to the Package Editor wizard.
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7. If needed, select Script Execution Directory if a different directory location is required.

Step Result: The Script Execution Directory field becomes active.

8. Type the back-up directory path, or click Browse.

Step Result: The location displays in the Script Execution Directory field.
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Chapter

14
Patch and Remediation Reporting

In this chapter:

• About Patch and Remediation
Reports

• The Patch and Remediation Report
Pages

Lumension Endpoint Management and Security Suite can generate a
variety of reports pertaining to Patch and Remediation functions.

Use these reports for internal reporting, management briefing, and
assistance when using Lumension Endpoint Management and Security
Suite.

About Patch and Remediation Reports
Reports are records that document activity and information pertaining to your network environment. When
the Patch and Remediation module is installed, Lumension Endpoint Management and Security Suite includes
reports that include data related to Patch and Remediation.

Lumension Endpoint Management and Security Suite offers multiple predefined report templates that list and/
or depict data collected during network management. Data for Patch and Remediation-related reports include
information about content and deployments. Reports are created by selecting a report type and defining its
parameters.

Additionally, report formats vary. Some reports are in a HTML (.html) file format, while others are in a PDF
(.pdf) format.
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The Patch and Remediation Report Pages
From these pages, you can generate all available Patch and Remediation reports. Use this page to generate
reports related the module's various functions. Before generating the report, select the report type and define the
report parameters.

Figure 153: All Reports Page

Note:  From the Reports menu, you can select multiple All Reports page variants. Based on which Reports
menu item you select, the resulting page that opens groups its Display menu differently.

The following table lists the items available in the Reports navigation menu when Patch and Remediation is
installed.

Table 199: Reports Menu Commands

Command Description

Deployments Reports are grouped with the Deployments group expanded. Deployment
reports display information related to content deployment.

Inventory Reports are grouped with the Inventory group expanded. Inventory
reports display information related to network assets and endpoint
hardware and software.
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Command Description

Policy and Compliance Reports are grouped with the Policy and Compliance group expanded.
These reports display information about agent policy sets, Mandatory
Baselines, and Mandatory Baseline endpoint compliance.

Risks Reports are grouped with the Risks group expanded. This report displays
information about possible vulnerabilities in your network.

Vulnerabilities Reports are grouped with the Vulnerabilities group expanded. This
report displays information about network vulnerabilities.

Viewing the Patch and Remediation Report Pages
Navigate to these pages to generate either HTML or PDF reports related to the Patch and Remediation modules.

Access this page from the navigation menu.

1. Select one of the following menu items from the navigation menu:

• Reports > Deployments
• Reports > Inventory
• Reports > Policy and Compliance
• Reports > Risks
• Reports > Vulnerabilities

2. Generate the desired report.

Generating a Report
Lumension Endpoint Management and Security Suite provides multiple predefined reports for Patch and
Remediation. Generate reports to brief management or to view network behavior and statistics.

Generate reports from any Patch and Remediation report page.

1. Select one of the following menu items from the navigation menu:

• Reports > Deployments
• Reports > Inventory
• Reports > Policy and Compliance
• Reports > Risks
• Reports > Vulnerabilities

2. From the Display list, select a report you want to generate.
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3. Using one of the following methods, select the required report parameters.

• Add parameters to the Selected Parameters list using the Include or Include All arrows.
• Select parameters from the available drop-down lists, data grids, or list boxes.

Note:  Refer to individual report descriptions for details regarding which parameters are required and which
parameters are optional.

4. [Optional] Select the optional report parameters.

5. Click Generate Report.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses pop-up windows
from appearing and must be disabled to display report data successfully. Pop-up blockers in Internet Explorer
or other supported browsers may also suppress report display functionality and should be disabled.

Result: The report is generated in a new window.

Deployment Detail Report
This report provides information about a selected list of deployments. In the report, each deployment name
is listed in the Deployment Name column. The report provides information as to the status of the particular
deployment activity.

Optional Parameters: Deployments, Packages, Date Range

Note:  If no parameter selection is made, the report generates using all available data.

Figure 154: Deployment Detail Report

The following table describes each report column.

Table 200: Deployment Detail Report Column Definitions

Column Definition

Deployment Name The name of the deployment.

Package Name The name of the package.

Endpoint Name The name of the endpoint.

Deployment Status The deployment status or stage.

Deployment Date The date the deployment was sent.
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Column Definition

Install Date The date the agent was installed on the endpoint.

Vulnerability Status The content item patch status.

Date Last Verified The date of the last Discover Applicable Updates (DAU) task.

Note:  If a selected content item does not have an associated deployment, it will not appear in the report.

Deployment Error Report
This report provides information about deployments that have returned an error.

Optional Parameters: Deployments, Packages, Endpoints, Date Range

Note:  If no parameter selection is made, the report generates using all available data.

Figure 155: Deployment Error Report

The following table describes each report column.

Table 201: Deployment Error Report Column Definitions

Column Definition

Deployment Status The deployment status or stage.

Status Code The reference code for support identification. When contacting support, use this code
to help identify the deployment issue.

Error Message The actual error text returned by the deployment.

Install Date The date the agent was installed on the endpoint.

Package Name The name of the package.

Deployment Name The name of the deployment.

Endpoint Name The name of the endpoint.

Deployment History Report
This report allows selection of multiple patch deployments. It also displays a single pie chart for each
deployment and shows deployment status counts for the deployment.
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Required Parameters: Selection of one or multiple deployment(s).

Figure 156: Deployment History Report

The following table describes each report field.

Table 202: Deployment History Report Field Definitions

Field Definition

Deployment Name The name of the deployment.

Package Name The name of the package.

Deployment Status The deployment status or stage.

Deployment Date The date the deployment was sent.

Created Date The date and time the deployment was scheduled.

Created By The user who created the deployment.

Graph Key

Added to the Group
After the Deployment
Started

The percentage of deployments that did not complete because the endpoint was
added to the group after the deployment started.

Already Patched The number (or percentage) of endpoints that are already patched.

Caching Package The percentage of deployment packages that are being cached.

Deployment Aborted by
Client User

The percentage of deployments that were aborted by endpoint users.
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Field Definition

Deployment Aborted by
User

The percentage of deployments that were aborted by Lumension Endpoint
Management and Security Suite users.

Disabled The number (or percentage) of deployments that were disabled.

Failure The percentage of deployments that failed.

In-Progress The percentage of deployments that are in progress.

Not Applicable The number (or percentage) of endpoints where the deployment does not apply.

Not Started The percentage of deployments that have not started.

Not Started - Recurring The percentage of recurring deployments that have not started deploying.

Removed from
Deployment and Group

The percentage of deployments removed from deployments and groups.

Removed from
Deployment by User

The percentage of deployments removed by users.

Success The percentage of successful deployments.

Total The total number of endpoints assessed.

Note:  If there are no occurrences of a particular status during a deployment, that status does not appear in the
Deployment History Report graph key.

Deployment In-Progress Report
This report provides information about deployments that have started but have not yet completed. Reports can be
generated for each deployment, package, or endpoint. It also provides the status of the deployment.

Optional Parameters: Deployments, Packages, Endpoints, Groups

Note:  Selecting no parameters will generate the report using all available data.

Figure 157: Deployment In Progress Report

The following table describes each report column.

Table 203: Deployment In-Progress Report Column Definitions

Column Definition

Deployment Name The name of the deployment.
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Column Definition

Package Name The name of the package.

Deployed The total number of endpoints that were assigned the deployment.

Already Patched The number (or percentage) of endpoints that are already patched.

Not Applicable The number (or percentage) of endpoints where the deployment does not apply.

Successful The number of endpoints patched successfully.

In-Progress The number of endpoints currently receiving deployment.

Not Started The number of endpoints yet to receive the deployments.

Caching Package Indicates whether the deployment package is being cached.

1 = Caching, 0 = Complete

Failed The total number of deployments that failed.

Disabled The total number of endpoints that are disabled and cannot receive the deployment.

Percent Success The percentage of endpoints that successfully received the deployment.

Percent Failure The percentage of endpoints on which the deployment has failed.

Deployment Status Report
This report provides the current status of a specified package deployment. It also includes a pie chart that shows
deployment status counts for the deployment, as well as status details.

Required Parameters: Selection of one deployment.
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Optional Parameters: Deployment status details.

Figure 158: Deployment Status Report

The following table describes the report fields and columns.

Table 204: Deployment Status Report Field and Column Definitions

Field / Column Definition

General Information

Deployment Name The name of the deployment.

Package Name The name of the package.

Deployment Status The deployment status or stage.

Deployment Date The date the deployment was sent.

Created Date The date and time the deployment was scheduled.

Created By The user who created the deployment.

Graph Key

Added to the Group
After the Deployment
Started

The percentage of deployments that did not complete because the endpoint was
added to the group after the deployment started.

Already Patched The number (or percentage) of endpoints that are already patched.

Caching Package The percentage of deployment packages that are being cached.

Deployment Aborted by
Client User

The percentage of deployments that were aborted by endpoint users.
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Field / Column Definition

Deployment Aborted by
User

The percentage of deployments that were aborted by Lumension Endpoint
Management and Security Suite users.

Disabled The number (or percentage) of deployments that were disabled.

Failure The percentage of deployments that failed.

In-Progress The percentage of deployments that are in progress.

Not Applicable The number (or percentage) of endpoints where the deployment does not apply.

Not Started The percentage of deployments that have not started.

Not Started - Recurring The percentage of recurring deployments that have not started deploying.

Removed from
Deployment and Group

The percentage of deployments removed from deployments and groups.

Removed from
Deployment by User

The percentage of deployments removed by users.

Success The percentage of successful deployments.

Total The total number of endpoints assessed.

Table Columns

Server Name The IP address of the Lumension Endpoint Management and Security Suite server
where the deployment originated.

Agent Name The name endpoint that hosts the agent.

IP Address The IP address of the endpoint.

Install Date The date and time the deployment commenced.

Status Detail Displays the status details applicable to the endpoint.

Failure Reason Displays applicable failure reasons.

Note:  If there are no occurrences of a particular status during a deployment, that status does not appear in the
Deployment Status Report graph key.

Deployment Summary Report
This report provides information about a selected list of deployments. It also provides a summary of the
particular deployment activity.
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Optional Parameters: Deployments, Packages, Date Range

Note:  If no parameter selection is made, the report generates using all available data.

Figure 159: Deployment Status Report

The following table describes each report column.

Table 205: Deployment Summary Report Column Definitions

Column Definition

Deployment Name The name of the deployment.

Package Name The name of the package.

Deployed The total number of endpoints that were assigned the deployment.

Already Patched The number (or percentage) of endpoints that are already patched.

Not Applicable The number (or percentage) of endpoints where the deployment does not apply.

Total Successful The total number of endpoints successfully patched.

Total In-Progress The total number of endpoints currently receiving the deployment.

Not Started The number of endpoints yet to receive the deployments.

Caching Package Indicates whether the deployment package is being cached.

1 = Caching, 0 = Complete

Failed The total number of deployments that failed.

Disabled The total number of endpoints that are disabled and cannot receive the deployment.

Total Patched The total number of endpoints patched by the deployment.

Percent Success The percentage of endpoints that successfully received the deployment.

Percent Failure The percentage of endpoints on which the deployment has failed.

Note:  If a selected content item has no associated deployment, it does not appear in the report.

Detection Results Not Found Report
This report returns a list of endpoints that have not completed a Discover Applicable Updates (DAU) task
with the server. The report lists each agent name, the installation date of the agent, and information required to
identify and locate the endpoint.
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Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 160: Detection Results Not Found Report

The following table describes each report column.

Table 206: Detection Results Not Found Report Column Definitions

Column Description

Agent Name The name endpoint that hosts the agent.

OS Abbr Name The abbreviated operating system name.

Agent Version The version of the agent.

Last Contact Date The last date the Lumension Endpoint Management and Security Suite had contact with
the agent.

Installation Date The date and time the agent was installed on the endpoint.

IP Address The IP address of the endpoint.

DNS Name The name used by the Domain Name System (DNS) to identify the endpoint.

OS Info A description of the operating system.

Last DAU Date The date of the last Discover Applicable Updates (DAU) task.

Last DAU Status The status of the last Discover Applicable Updates (DAU) task.

Endpoint Name Duplicate Report
This report returns a list of duplicate endpoints registered with Lumension Endpoint Management and Security
Suite. Duplicate endpoints are usually the result of applying the agent uniqueness feature that permits an agent
installed on ghost images to register multiple times with Lumension Endpoint Management and Security Suite.
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Optional Parameters: Date Range

Note:  If no parameter selection is made, the report generates using all available data.

Figure 161: Endpoint Name Duplicate Report

The following table describes each report column.

Table 207: Device Duplicate Report Column Definitions

Column Definition

Endpoint
Name

The name of the endpoint.

Status The current status of the endpoint.

Install Date The date the agent was installed on the endpoint.

Hardware Inventory Detail Report
This report provides information about hardware associated with an endpoint and endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 162: Hardware Inventory Detail Report

The following table describes each report column.

Table 208: Hardware Inventory Detail Report Column Definitions

Column Definition

Hardware Device Class The type of hardware.

Hardware Device Name The name of the hardware device.
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Column Definition

Endpoint Name The name of the endpoint.

Device OS Info A description of the operating system.

Hardware Inventory Summary Report
This report provides a summary of reported hardware and the endpoints associated with them.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 163: Hardware Inventory Summary Report

The following table describes each report column.

Table 209: Hardware Inventory Summary Report Column Definitions

Column Definition

Hardware Device Class The type of hardware.

Hardware Device Name The name of the hardware device.

Instances The number of times this device occurs.

(Within the parameters of the report.)

Mandatory Baseline Detail Report
This report provides information about the Mandatory Baseline status associated with an endpoint.
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Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 164: Mandatory Baseline Detail Report

The following table describes each report column.

Table 210: Mandatory Baseline Detail Report Column Definitions

Column Definition

Endpoint Name The name of the endpoint.

Assigned By Group The distinguished name of the group that assigned the Mandatory Baseline.

Package Name The name of the package.

Mandatory Baseline Enabled Indicates whether the Assigned By Group has Mandatory Baselines
enabled.

Package Enabled Indicates whether the package is enabled. If the package is disabled, it
cannot be deployed to an endpoint.

Mandatory Status Identifies whether the endpoint is applicable, patched, or needs patching by
the Mandatory Baseline.

Deployment Status The deployment status or stage.

Package Release Date The date the package was released.

Date Deployed The date the package was deployed.

Date Installed The date the package was installed on the endpoint.

Date Last Verified The date of the last Discover Applicable Updates (DAU) task.

Assigned Indicates whether the Mandatory Baseline is assigned to the endpoint.

1 = Assigned, 0 = Not Assigned

Mandatory Baseline Summary Report
This report returns a summary list of patch content and deployment information for all Mandatory Baseline
packages and content associated with the selected list of endpoints.
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Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 165: Mandatory Baseline Summary Report

The following table describes each table column.

Table 211: Mandatory Baseline Summary Report Column Definitions

Column Definition

Mandatory Baseline Item
Name

Name of the Mandatory Baseline content item.

Total Endpoints The total number of endpoints.

Total Patched The total number of endpoints patched by the deployment.

Total Not Applicable The total number of endpoints for which the deployment does not apply.

Total In-Progress The total number of endpoints currently receiving the deployment.

Disabled The total number of endpoints that are disabled and cannot receive the
deployment.

Total Error Condition The total number of endpoints on which the deployment has failed.

Percent Patched The percentage of applicable endpoints that are patched.

Operating System Inventory Detail Report
This report provides information about the operating system associated with an endpoint and the endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 166: Operating System Inventory Detail Report
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The following table describes each report column.

Table 212: Operating System Inventory Detail Report Column Definitions

Column Definition

Operating System The operating system name and description.

Endpoint Name The name of the endpoint.

Operating System Inventory Summary Report
This report provides a summary about the operating system associated with an endpoint and the endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates all available data.

Figure 167: Operating System Inventory Summary Report

The following table describes each report column.

Table 213: Operating System Inventory Detail Report Column Definitions

Column Definition

Operating System The operating system name and description.

Instances The number of times this operating system occurs.

(Within the parameters of the report.)

Package Compliance Detail Report
This report provides information about patch and deployment status for a specific package or endpoint. The
report lists each package associated with the selected endpoint(s) or group(s). In the report, each package is listed
in the Package Name column. The report also provides details for the vulnerability status for each package, and
the associated endpoint, status, and deployment details.
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Optional Parameters: Packages, Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 168: Package Compliance Detail Report

The following table describes each report column.

Table 214: Package Compliance Detail Report Column Definitions

Column Definition

Package Name The name of the package.

Endpoint Name The name of the endpoint.

Vulnerability Status The content item patch status.

Last DAU Date The date of the last Discover Applicable Updates (DAU) task.

Last DAU Status The status of the last Discover Applicable Updates (DAU) task.

Date Last Verified The date of the last Discover Applicable Updates (DAU) task.

Deployment Name The name of the deployment.

Deployment Status The deployment status or stage.

Package Release Date The date the package was released.

Date Deployed The date the package was deployed.

Date Installed The date the package was installed on the endpoint.

Date Scheduled The date the package was scheduled for deployment to the endpoint.

Note:  If a selected package has no associated deployment, it does not appear in the report.

Package Compliance Summary Report
This report returns a summary list of patch and deployment information by package name for all applicable
endpoints.
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Optional Parameters: Packages, Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 169: Package Compliance Summary Report

The following table describes each report column.

Table 215: Package Compliance Summary Report Columns

Column Definition

Package Name The name of the package.

Total Endpoints The total number of endpoints.

Applicable Endpoints The total number of applicable endpoints.

Endpoints Detecting The number of endpoints currently running a Discover Applicable Updates
(DAU) task.

Endpoints Patched The number of endpoints that are already patched.

Not Patched/Not Scheduled The number of endpoints not patched, and have no deployment scheduled.

Not Patched/Scheduled The number of endpoints not patched, but are scheduled for a deployment.

Deployments Completed The number of deployments that have completed successfully.

Deployments Failed The number of failed deployments.

Deployments In-Progress The number of endpoints currently receiving the deployment.

Note:  If a package has no associated deployment, it does not appear in the report.

Patch Agent Configuration Report
This report provides a simple-to-read view of patch agent configurations. There are no options for this report.
However, when generating this report, you must select an agent group.
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Required Parameter: Selection of one agent group.

Figure 170: Patch Agent Configuration Report

The following table describes each report field.

Table 216: Patch Agent Configuration Report Field Definitions

Field Definition

Policy (Group) Information

Name The name of the selected agent group.

Description A description of the selected group.

General Information

Polling Interval
(minutes)

Indicates the interval (in minutes) between agent and Lumension Endpoint
Management and Security Suite communication.

User Defined Indicates whether the group policy is user defined or predefined.

Last Modified The date and time the group policy was last modified.

Deployment Notification Options

User May Cancel Indicates if deployment recipients can cancel deployments.

Users May Snooze Indicates if deployment recipients can snooze deployments.

Deploy Within (minutes) Indicates the maximum time frame a deployment recipient can snooze
deployments.

Reboot Notification Options

User May Cancel Indicates if deployment recipient can cancel reboots.

User May Snooze Indicates if deployment recipients can snooze reboots.
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Field Definition

Reboot Within (minutes) Indicates the maximum time frame a deployment recipient can snooze reboots.

Notification Window Options

Always On Top Indicates if the deployment and reboot notifications windows open on top of all
other windows until the recipient acknowledges the notification (yes or no).

Patch Agent Inventory Report
This report provides the details of the agents with the patch module installed associated with the specified agent
groups. This includes a pie chart that shows the patch status count for the agent groups and details (IP address,
name, operating system, and status) for each agent.

Required parameters: Selection of one or multiple agent groups.

Optional parameters (default setting): Sort By (IP address, machine name, operating system [OS]),
Included OSs, Included IP adresses.

Figure 171: Patch Agent Inventory Report
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The following table describes each report field and column.

Table 217: Patch Agent Inventory Report Field and Column Definitions

Field / Column Definition

General Information

Server Name The Lumension Endpoint Management and Security Suite server name.

Agent Groups The agent groups included in the report.

Agent Status Summary

Total Known Endpoints The total number of endpoints with the patch module installed.

Agents Checking In The number of agents communicating with Lumension Endpoint Management and
Security Suite.

Working The number (or percentage) of patch modules that are working on a deployment.

Idle The number (or percentage) of patch modules that are idle.

Sleeping The number (or percentage) of patch modules that are sleeping due to hours of
operation settings.

Agents Not Checking In The number of patch modules that are not communicating with Lumension
Endpoint Management and Security Suite.

Offline The number (or percentage) of patch modules that are offline.

Disabled The number (or percentage) of patch modules that are disabled.

Agent Status Summary Graph

Disabled The number (or percentage) of patch modules that are disabled.

Idle The number (or percentage) of patch modules that are idle.

Offline The number (or percentage) of patch modules that are offline.

Sleeping The number (or percentage) of patch modules that are sleeping due to hours of
operation settings.

Working The number (or percentage) of patch modules that are working on a deployment.

Total The total number of patch modules assessed.

Agent Inventory Table

Agent IP The IP address of the endpoint the agent is installed on.

Agent Name The name endpoint that hosts the agent.

Operating System The operating system name and description.
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Field / Column Definition

Patch and Remediation
Status

The current status.

Patchable Status Report
This report returns the current status of the selected endpoints (or endpoints in the selected groups). In the report,
each endpoint is listed in the Endpoint Name column. The report then provides information about the particular
endpoint.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 172: Patchable Status Report

The following table describes each report column.

Table 218: Patchable Status Report Column Definitions

Column Definition

Endpoint Name The name of the endpoint.

DNS Name The name used by the Domain Name System (DNS) to identify the endpoint.

IP Address The IP address of the endpoint.

OS Name The operating system name.

OS Build No. The operating system’s build number.

OS Service Pack The latest service pack applied to the operating system (if applicable).

Agent Version The version of the agent.

Last Contact Date The last date the Lumension Endpoint Management and Security Suite server had contact
with the agent.

Patchable Status The reboot/chained status of the agent.

Group List A listing of the groups, by distinguished name, to which the endpoint belongs.
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Potential Data Leakage Report
This report returns a list of Windows-based endpoints that have removable storage.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 173: Potential Data Leakage Report

The following table describes each table column.

Column Definition

AgentName The name of the endpoint hosting the agent.

HardwareClass The type of external storage device associated with the agent.

HardwareName The name of the applicable external storage device.

Quantity The number of external storage devices associated with the agent.

IPAddress The IP address of the agent.

DetectionDate The date and time the endpoint and its external storage device(s) were detected.

Services Inventory Detail Report
This report provides information about the service associated with an endpoint and the endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 174: Services Inventory Detail Report
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The following table describes each report column.

Table 219: Services Inventory Detail Report Column Definitions

Column Definition

Service Name The name of the service.

Endpoint Name The name of the endpoint.

Service Startup State The state the service should enter upon endpoint boot.

Service Current State The current state of the endpoint.

Services Inventory Summary Report
This report provides summary information about the services associated with an endpoint and the endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 175: Services Inventory Summary Report

The following table describes each report column.

Table 220: Services Inventory Summary Report Column Definitions

Column Definition

Service Name The name of the service.

Instances The number of times this service occurs.

(Within the parameters of the report.)

Software Inventory Detail Report
This report provides information about the software associated with an endpoint and the endpoint status.
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Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 176: Software Inventory Detail Report

The following table describes each report column.

Table 221: Software Inventory Detail Report Column Definitions

Column Definition

Software Program The name of the software installed on the endpoint.

Endpoint Name The name of the endpoint.

Software Inventory Summary Report
This report provides information about the software associated with an endpoint and the endpoint status.

Optional Parameters: Endpoints, Groups

Note:  If no parameter selection is made, the report generates using all available data.

Figure 177: Software Inventory Summary Report

The following table describes each report column.

Table 222: Software Inventory Summary Report Column Definition

Column Definition

Software Program The name of the software installed on the endpoint.
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Column Definition

Instances The number of times this software occurs.

(Within the parameters of the report.)

Vulnerability Analysis Report
This report summarizes the remediation status for the selected content items. The report lists each vulnerability
affecting the selected endpoint or group. The report can also be generated for a single or multiple content items.
In the report, each content item is listed in the Vulnerability Name column. The report also provides patch status
details for each content item and if a deployment is required.

Optional Parameters: Endpoints, Groups, Vulnerabilities

Note:  If no parameter selection is made, the report generates using all available data.

Figure 178: Vulnerability Analysis Report

The following table describes each report column.

Table 223: Vulnerability Analysis Report Column Definitions

Column Definition

Vulnerability Name The name of the content item.

Vulnerability Release Date The date the content item was released.

Total Endpoints The total number of endpoints.

Applicable Endpoints The total number of applicable endpoints.

Endpoints Detecting The number of endpoints currently running a Discover Applicable Updates
(DAU) task.

Endpoints Patched The number of endpoints that are already patched.

Not Patched The number of endpoints not patched.
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Column Definition

Percent Patched The percentage of applicable endpoints that are patched.

Note:  If a selected content item has no associated deployment, it does not appear in the report.
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Chapter

15
Managing Lumension EMSS Users and Roles

In this chapter:

• The Users and Roles Page

• The Users Tab

• Working with Users

• The Roles Tab

• Working with Roles

User and role management features let you add, edit, and delete
Lumension Endpoint Management and Security Suite users, and also
assign users access rights.

Create, configure, and manage users and roles from the Users and
Roles page.

The Users and Roles Page
This page lets you create users and user roles for user within Lumension Endpoint Management and Security
Suite (Lumension EMSS). Users are a name or title used to log in to the Lumension EMSS Web console, while
user roles are sets of access rights, accessible groups, and accessible endpoints assigned to users that determine
what functions and pages are available.

Existing users and user roles are listed on their respective tabs.

The Users and Roles page contains the following tabs:

• The Users Tab on page 456
• The Roles Tab on page 468

Figure 179: Users and Roles Page
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Viewing the Users and Roles Page
Navigate to this page to create and manage users and user roles.

You can access this page at any time using the navigation menu.

1. Select Tools > Users and Roles.

2. Select a tab based on the task you want to accomplish:

• To work with users, select the Users tab.
• To work with roles, select the Roles tab.

3. [Optional] Complete a task.

• To complete a task related to users, perform a task listed in Working with Users on page 459.
• To complete a task related to roles, perform a task listed in Working with Roles on page 478.

Defining User Access
Lumension Endpoint Management and Security Suite supports the establishment of security policies that
conform to your network needs. Two mechanisms determine security access: Windows-based authentication and
Lumension Endpoint Management and Security Suite access rights.

Windows-Based Authentication
Lumension Endpoint Management and Security Suite (Lumension EMSS) authentication is controlled by the
Windows operating system. Users who have access to Lumension EMSS are members of the local Windows
group PLUS Admins.

Lumension EMSS Access Rights
After a user logs in to Lumension EMSS, the system authenticates the user’s assigned role. If a user does not
have access to a given Lumension EMSS page or function, an access denied message displays, or the feature is
simply unavailable.

On the Users and Roles page, the Roles tab is where roles are defined, while the Users tab is where you can add
or remove users and assign them a role.

The Users Tab
This tab lets you create and manage users. It also lists each user in the Lumension Endpoint Management and
Security Suite system and its details.
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Additionally, you can use this tab to edit users, remove users, or assign them user roles.

Figure 180: Users Tab

Defining Users
Users are names or titles that people use to access Lumension Endpoint Management and Security Suite. Users
can be defined as individuals (John Smith) or conceptual users (Quality Assurance Manager). The user profile
includes access credentials (user name and password) and the role assigned to the user. A user can be assigned
only one role, but many users can share one role.

There are two methods of introducing users to the system: creating users and adding users.

Creating New Users When a user is created, that user is added to both Lumension Endpoint
Management and Security Suite (Lumension EMSS) and Windows.
Additionally, new users assigned the Manage Users access right are added
to the Windows Administrators group; without addition to this group, the
user would be unable to modify other users.

Adding Existing Windows
Users

You can grant existing Windows users (both local users and domain users)
access to Lumension EMSS. Using this method, you can search Windows
for existing users and add them to Lumension EMSS. Additionally, added
users assigned the Manage Users access right are added to the Windows
Administrators group; without addition to this group, the user would be
unable to modify other users.

Note:  Microsoft IIS Web server software, used by Lumension EMSS, does not support user names or
passwords in languages that require unicode characters (such as Korean or Kanji).

The Users Tab Toolbar
This toolbar contains buttons that let you create and manage users.
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The following table describes the function of each toolbar button.

Table 224: Users Tab Toolbar

Button Function

Remove Removes the selected user. For additional information, refer to Removing Lumension EMSS
Users on page 464.

Delete Deletes the selected user. For additional information, refer to Deleting Lumension EMSS Users
on page 465.

Create... Creates a new user. For additional information, refer to Creating New Lumension EMSS Users
on page 459.

Change
Password...

Changes the password for the selected user. For additional information, refer to Changing a
User Password on page 465.

Export Exports the page data to a comma separated value (.csv) file. For additional information, refer
to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer suppresses
export functionality and must be disabled to export data successfully. Pop-up blockers in
Internet Explorer or other supported browsers may also suppress export functionality and
should be disabled.

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page 53.

The Users Tab List
This list displays each user role within the system. Use the list icons to edit or remove users. Additionally, you
can also filter the lists to display only specified roles.

The following table describes the Users tab list columns.

Table 225: Users Tab List

Column Description

Action Contains Edit and Remove icons. Use these icons to edit or remove the associated user.
For additional information, refer to one of the following topics:

• Editing Lumension EMSS Users on page 463
• Removing Lumension EMSS Users on page 464

Name The Lumension Endpoint Management and Security Suite user name.

Full Name The full name of the user.

Role The role assigned to the user.
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Column Description

First Login The date and time of the first time the user logged in.

Last Login The date and time of the last time the user logged in.

Working with Users
To perform tasks associated with users, click a toolbar button or list icon. To perform some tasks, selecting one
or multiple users from the list may be necessary.

• Creating New Lumension EMSS Users on page 459
• Adding Existing Windows Users to Lumension EMSS on page 461
• Editing Lumension EMSS Users on page 463
• Removing Lumension EMSS Users on page 464
• Deleting Lumension EMSS Users on page 465
• Changing a User Password on page 465
• Changing Your Password on page 466
• Exporting User Data on page 467

Creating New Lumension EMSS Users
Create a new Lumension Endpoint Management and Security Suite (Lumension EMSS) user when you need to
allow a person within your organization access to Lumension EMSS. New users are added to both Lumension
EMSS and Windows.

Create new users from the Users tab.

1. Select Tools > Users and Roles.

2. Ensure the Users tab is selected.
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3. Click Create.

Step Result: The Create User Wizard opens.

Figure 181: Creating a New Local User

4. Select the Creating a new local user option.

5. Click Next.

6. Define the user credentials.

Type the applicable information in the following fields.

Field Name Description

User name The desired user name.

Note:  The User Name must be 1-20 characters in length and cannot
include any of the following characters:

• ‘ \ “ @ ^ % & { } ( ) [ ] ; < > ! # : ? / = |

Password The desired password.

The Password Strength indicator factors password effectiveness based
on password length, complexity, character variety, and common word
resemblance.

Strong passwords contain eight characters or greater and combine
symbols, numbers, uppercase letters, and lowercase letters. Also,
they do not resemble common words or names, including words with
numbers in place of letters.

Confirm Password The password retyped.
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7. From the User Role list, select the desired role for each user.

Select from the following roles:

• Administrator
• Manager
• Operator
• Guest
• Custom Role(s)

Note:   Custom Role(s)  are only available if a custom role has been created.

8. [Optional] Define the user information.

Type the applicable information in the remaining fields.

Field Name Description

Description The description of the user.

Full name The full name of the user.

Office phone The office phone number of the user.

Cell phone The cell phone number of the user.

Pager The pager number of the user.

E-mail The email address of the user.

9. Click Finish.

10. Click Close.

Result: The Create User Wizard closes and the user is created. The new user can now access all authorized
features of Lumension EMSS. Lumension EMSS administrators can edit the user from the Users tab.

Adding Existing Windows Users to Lumension EMSS
When you want to add a pre-existing Windows domain or local user as a user within Lumension Endpoint
Management and Security Suite (Lumension EMSS), you can add that user instead of creating a new one. Import
a user from an existing domain by logging into that domain as a domain user.

Add existing Windows users from the Users tab.

1. Select Tools > Users and Roles.

2. Ensure the Users tab is selected.
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3. Click Create.

Step Result: The Create User Wizard opens.

Figure 182: Adding Existing Local or Domain Users

4. Select the Adding existing local or domain users option.

5. Click Next.

6. In the Search for the following users field, type a user name, or the beginning characters of one or more user
names. Use semicolons to separate user names.

To search for users within a specific domain, prefix the user name with the domain
(DOMAINNAME\UserName).

Note:  There must be a secure connection between the domain and the Lumension EMSS’s domain, or the
user will be unable to access Lumension EMSS.

7. Click Next.

8. From the User Role list, select the desired role for each user.

Select from the following roles:

• Administrator
• Manager
• Operator
• Guest
• Custom Role(s)

Note:   Custom Role(s)  are only available if a custom role has been created.

9. Click Finish.
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10. Click Close.

Result: The Create User Wizard closes and the user is added. The added Windows user can now access
Lumension EMSS and all authorized features.

Editing Lumension EMSS Users
Edit existing Lumension Endpoint Management and Security Suite users to change their assigned role(s) or
contact information.

Edit users from the Users tab.

1. Select Tools > Users and Roles.

2. Ensure the Users tab is selected.

3. Click the Edit icon associated with the user you want to edit.

Step Result: The Edit User dialog opens.

Figure 183: Edit User Dialog

4. [Optional] Edit the Full name field.

5. [Optional] Select a new role from the Role list.

Select one of the following roles:

• Administrator
• Manager
• Operator
• Guest
• Custom Role(s)

Note:  Custom Role(s) are only available if a custom role has been created.
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6. [Optional] Edit the following fields.

Field Name Description

Office phone The user’s office phone number.

Cell phone The user’s cell phone number.

Pager The user’s pager number.

E-mail The user’s email address.

Description The user’s description.

7. Click Next.

8. Click Finish.

9. Click Close.

Result: The user is updated according to your changes.

Removing Lumension EMSS Users
Removing a user account removes it from Lumension Endpoint Management and Security Suite without deleting
that user account within Windows or on Active Directory. Remove users when you no longer want them to have
access to Lumension Endpoint Management and Security Suite yet still want their user accounts to exist.

Once removed, the user is removed from the Lumension Endpoint Management and Security Suite endpoint
groups and the user list on the Users and Roles page. Remove users from the Users tab.

Note:  You cannot remove users assigned the Administrator role. You must first edit the user, change the role,
then remove the user.

1. Select Tools > Users and Roles.

2. Ensure the Users tab is selected.

3. Remove the desired user(s).

Use one of the following methods.

Method Steps

To remove a single user: Click the Remove icon associated with the user you want to remove.

To remove multiple users: 1. Select the check boxes associated with the users you want to
remove.

2. From the toolbar, click the Remove button.

Step Result: A dialog displays, asking you to acknowledge the removal.



Managing Lumension EMSS Users and Roles

- 465 -

4. Acknowledge the removal by clicking OK.

Result: The user is removed from Lumension Endpoint Management and Security Suite. You can re-add the
removed user at any time if the user’s Windows account still exists.

Deleting Lumension EMSS Users
Delete a Lumension Endpoint Management and Security Suite (Lumension EMSS) user when you want to
remove it from both Lumension EMSS and Windows. Deleting users removes them from Lumension EMSS and
Windows (locally), whereas removing users only removes them from Lumension EMSS.

Delete users from the Users and Roles page Users tab.

Note:  You cannot delete users assigned the Administrator role. You must first edit the user, change the role,
then remove the user.

1. Select Tools > User and Roles.

2. Ensure the Users tab is selected.

3. Select the check box(es) associated with the user(s) you want to delete.

4. Click Delete.

Caution:  Deleting a user deletes them from both Lumension EMSS and Windows (locally).

Step Result: A dialog displays, asking you to acknowledge the deletion.

5. Acknowledge the deletion by clicking OK.

Result: The user is deleted from both Lumension EMSS and Windows (locally).

Note:  Deleting a Lumension EMSS user that was added from your Active Directory will not delete
the Windows user account within Active Directory. The account will only be removed from Lumension
EMSS.

Changing a User Password
If you have the Change Password access right, you can edit other user’s passwords. Changing a user’s password
in Lumension Endpoint Management and Security Suite also changes the user’s Windows password on the
Lumension Endpoint Management and Security Suite server or Active Directory. Change a password for security
reasons or if a user has forgotten theirs.

Change user passwords from the Users tab.

1. Select Tools > Users and Roles.

2. Ensure the Users tab is selected.

3. Select the check box associated with the user whose password you want to change.

4. Click Change Password.

Step Result: The Change password for dialog opens.
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5. Type a new password in the New Password field.

The Password Strength indicator factors your password security based on length, complexity, character
variety, and common word resemblance.

Strong passwords contain eight characters or greater and combine symbols, numbers, and letters (both upper
and lowercase). Also, they do not resemble common words or names, including words with numbers in place
of letters.

Attention:  Passwords must adhere to Windows local and/or domain password policies.

Figure 184: Change My Password Dialog

6. Retype the password in the Confirm Password field.

7. Click Finish.

Result: The password is changed.

Changing Your Password
You can change your own password at any time. Changing your password in Lumension Endpoint Management
and Security Suite (Lumension EMSS) also changes your Windows password on the Lumension EMSS server or
Active Directory.

Change your password from the navigation menu.
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1. Select Tools > Change My Password.

Step Result: The Change My Password dialog opens.

Figure 185: Change My Password Dialog

2. Type your old password in the Old password field.

The Password Strength indicator factors password effectiveness based on password length, complexity,
character variety, and common word resemblance.

Strong passwords contain eight characters or greater and combine symbols, numbers, uppercase letters, and
lowercase letters. Also, they do not resemble common words or names, including words with numbers in
place of letters.

Attention:  Passwords must adhere to Windows local and/or domain password policies.

3. Type your new password in the New Password field.

4. Retype your new password in the Confirm New Password field.

5. Click OK.

Result: Your password is changed. Use your new password the next time you log in to Lumension EMSS,
Windows, or Active Directory.

Exporting User Data
You can export the data displayed on the Users tab list so that it can be used in other applications. This data is
exported to a comma separated value (.csv) file.

To export data, click the Export button. For additional information, refer to Exporting Data on page 60.
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The Roles Tab
This tab lets you create new user roles and manage existing user roles. It also lists each role in the Lumension
Endpoint Management and Security Suite system and its details.

Additionally, you can use this tab to edit roles or remove roles.

Figure 186: Roles Tab

Defining Roles
User Roles are assignable sets of access rights, accessible groups, and accessible endpoints that determine what
functions and pages are available to Lumension Endpoint Management and Security Suite users. Roles can be
customized and assigned to various users.

Lumension Endpoint Management and Security Suite (Lumension EMSS) uses two types of roles: system roles
and custom roles.

System Roles These roles are included with the default Lumension EMSS installation.
These roles are predefined with access rights appropriate for various users.
System roles cannot be edited or disabled, and they can access all system
groups and endpoints.

Custom Roles These roles are created after Lumension EMSS installation by users with
the Manage Users access right. Custom roles let you grant users unique
sets of access rights. Additionally, these roles let you define specific
endpoints and groups that can be accessed and managed.

Roles are defined by a combination of three attributes: access rights, accessible groups, and accessible endpoints.

Table 226: Role Attribute Descriptions

Role Attribute Description

Access Rights Define the pages and functions available to the user.

Accessible Groups Define the specific endpoint groups accessible to the user.
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Role Attribute Description

Accessible Endpoints Define the specific endpoints accessible to the user.

Predefined System Roles
Predefined system roles are the default roles offered by Lumension Endpoint Management and Security Suite.
The commonly used access rights selected for these roles are usually adequate for most networks and their users.
Additionally, these roles can access and manage all groups and endpoints.

These roles assist you in assigning commonly used access rights to new users. Users with the Manage Users
access rights can assign these system roles to a user, or use them as templates for creating a custom role. The
following table describes the predefined system roles and the icons that denote them.

Table 227: Predefined System Role Descriptions

Role Icon Description

Administrator Users have full access to all Lumension Endpoint Management and Security Suite
(Lumension EMSS) pages and functions. Administrators are the only users who
can delegate newly installed endpoints to other user roles. The administrator role
includes all access rights. At least one user must be assigned the administrator role
at all times.

Guest Users can access various Lumension EMSS pages, but cannot use their functions;
this role allows read-only access.

Manager Users can access most Lumension EMSS pages and functions.

Operator Users can perform all routine functions (detect, export, and so on). Operators can
only perform typical daily functions.

Note:  A user assigned a system role has access to all endpoints and groups.

Custom Roles
Custom roles are user roles that only have the user access rights, accessible groups, and accessible endpoints you
select. Create custom roles for users who require unique sets of access rights.

Custom roles are created by users with the Manage Users access right. Preexisting roles can be used as
templates when creating custom roles. Additionally, you can configure a custom group to restrict users to
management of specific groups and endpoints. Finally, unlike system roles (which cannot be disabled or deleted),
you can disable or delete a custom role at any time. Custom roles are denoted by the Wool Hat icon.

Defining Access Rights
Access rights are individual privileges that define whether a user can access a system feature. These rights
control availability for every Lumension Endpoint Management and Security Suite (Lumension EMSS) page,
feature, function, and action. The pages and features available to users are based on the access rights associated
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with the role assigned to them. The system roles are assigned a default set of access rights. Users inherit the
access rights of the role they are assigned.

Access rights begin with read-only access to system pages and permission to export data. At the administrative
level, users can be assigned rights to fully manage the various system pages and functions. These functions
include deployment initiation, user and role creation, and so on.

Note:  If a software expansion is installed with Lumension EMSS, access rights for the expansion may be added
to the access rights list.

The following table identifies and describes the default set of access rights for each system role: Administrator
(Admin.), Manager (Man.), Operator (Op.), and Guest.

Table 228: User Role Access Rights

Access Right Description Admin. Man. Op. Guest

Dashboard

View Dashboard Access to view the Home page
dashboard.

X X X X

View Current Status Access to view the status of the server. X X X X

View LPR Widgets Access dashboard widgets for the
Patch and Remediation module.

X X X X

Jobs

View Discovery Scan Jobs Access to view discovery scan jobs. X X

Create Discovery Scan
Jobs

Access to create and copy discovery
scan jobs.

X X

View Agent Management
Jobs

Access to view agent management
jobs.

X X

Create Agent Management
Jobs

Access to create and copy agent
management jobs.

X X

Manage Modules via Jobs Access to install or uninstall agent
modules via agent management jobs.

X X

Manage Jobs Cancel, pause, resume, deleted, or
merge all jobs the user has access to.

X X

Export Jobs Export the jobs list. X X

Content & Vulnerabilities

View Content Access the vulnerability and other
content data.

X X X X
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Access Right Description Admin. Man. Op. Guest

Manage Content Enable and disable vulnerabilities and
other content.

X X

Export Content Export vulnerability and other content
data list.

X X X

View Content Details Access the detailed information for
vulnerabilities and other content data.

X X X

Endpoints

View Endpoints Access the manage endpoints All tab
and endpoint details.

X X X X

Manage All Tab Enable and disable agents, delete
endpoints, and change agent versions.

X X

Export All Tab Export the All tab endpoints list. X X X

View LPR Tab Access the Patch and Remediation tab. X X X X

Manage LPR Tab Install, uninstall, enable, and disable
the Patch and Remediation tab.

X X

Export LPR Tab Export the Patch and Remediation tab
endpoints list.

X X X

Download Agent Installers Access the Download Agent Installer 
page.

X X X

Scan Now Discover
Applicable Updates

Scan endpoints using the DAU Scan
Now dropdown/button.

X X X

Reboot Endpoints Reboot endpoints using the Reboot
Now button.

X

Inventory

View Inventory Access the endpoint inventory. X X X X

Export Inventory Export the endpoint inventory. X X X

Groups

View Groups Access the groups. X X X X

Manage Groups Add, edit, enable, disable, and delete
groups.

X X

Export Groups Export the groups. X X X

Users/Roles
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Access Right Description Admin. Man. Op. Guest

View Users Access the users and roles. X X X X

Manage Users Create, delete, enable, and disable
users and roles.

X

Export Users Export the users and roles data. X X

Change Password Ability to change the password for
users other than themselves.

X

Deployments and Tasks

Create Deployments Ability to create new deployments. X X X

View My Deployments and
Tasks

Access the deployments that this user
has create.

X X X X

View All Deployments Access the deployments that all users
have created.

X X X

Manage Deployments and
Tasks

Deploy, enable, disable, abort, and
delete deployments that his user has
access to.

X X X

Export Deployments and
Tasks

Export the deployments and tasks in
the list the user has access to.

X X X

Packages

View Packages Access the package data. X X X X

Manage Packages Create, edit, and delete packages. X X

Export Packages Export the package data. X X X

Cache Packages Ability to initiate a download
packages from the Global Subscription
Server.

X X

Agent Policy Sets

View All Agent Policy Sets Access the agent policy sets. X X X X

Manage All Agent Policy
Sets

Create, edit, and delete agent policy
sets.

X

Export All Agent Policy
Sets

Export the agent policy sets list. X X

Reports
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Access Right Description Admin. Man. Op. Guest

Reports Administrator Generate reports regardless of access
rights for groups or endpoints.

X

View My Core Reports Generate core reports only for those
items this user has access to.

X X X X

View My LPR Reports Generate Patch and Remediation
reports only for those items this user
has access to.

X X X X

Export Reports Export the generated reports. X X X

Manage Server Modules

Installation Manager Access to the Installation Manager to
install, update, and uninstall server
components.

X

Subscriptions

View Subscription Access the subscription information. X X X X

Manage Subscription Edit or update subscription service
updates.

X

Export Subscription Export the subscription information. X X X

Email Notifications

View Email Notifications Access the email notifications. X X X X

Manage Email
Notifications

Create and edit email notifications and
settings.

X

Manage LPR Email
Notifications

Create and edit Patch and Remediation
email notifications and settings.

X

Export Email Notifications Export the email notifications. X X

Options

View Options Access to general, agent, and
deployment default server options.

X X X X

Manage Options Set and edit general, agent, and
deployment default server options.

X

Export Options Export the Options list. X

Technical Support
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Access Right Description Admin. Man. Op. Guest

View Technical Support Access the technical product support
information.

X X X X

Export Technical Support Export the technical product support
information.

X X X

Licenses

View Licenses Access the product licenses. X X X X

Manage Licenses Update product licenses. X

Export Licenses Export the product licenses. X X

Device Control Log Queries

View Device Event Logs Access to view Device event logs. X X X X

Manage Device Event Logs Access to manage Device event logs. X X

Export Device Event Logs Access to export Device event logs. X X X

Device Control Tools and Options

View Global Device
Control Options

Access to view global Device Control
options.

X X X X

Manage Global Device
Control Options

Access to manage Device Control
options.

X

Recover Password Access to recover a Device Control
password.

X

Grant Temporary
Permissions

Access to grant temporary Device
Control permissions.

X

Defining Accessible Groups
Accessible groups are specific groups of endpoints that a particular role can access and manage. Use this feature
for granularity when assigning roles to users.

Accessible groups are only applicable to custom user roles.

Note:  The Accessible Groups feature is disabled when working with a predefined system role. System roles
can access all groups and endpoints within the system.

This feature allows you to restrict a user to specified groups. For example, a user assigned the access right to
manage deployments can be limited to managing deployments for select groups.

The Accessible Groups feature is defined on the Groups tab in both the Create Role dialog and the Edit Role
dialog.
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The Groups tab contains the following lists, which are used to control what groups are associated with a
particular role:

Table 229: Groups Tab List Descriptions

List Description

Selected Groups Lists the groups assigned to the role.

Available Groups Lists the available groups that can be assigned to the role.

Figure 187: Roles Dialog Group Tab

Defining Accessible Endpoints
Accessible Endpoints are specific endpoints that a particular role can access and manage. This feature is similar
to the Accessible Groups feature; it allows for granularity when assigning roles to system users.

Accessible endpoints are only applicable to custom user roles.

Note:  The Accessible Endpoints feature is disabled when working with predefined system roles. System roles
can access all groups and endpoints within the system.

As mentioned, this feature lets you define specific endpoints that users associated with the role can access and
manage. For example, you can limit a user assigned the Manage Endpoints access right to management of a
single endpoint.

This feature is are defined on the Endpoints tab in both the Create Role dialog and the Edit Role dialog.

The Endpoints tab contains the following lists, which are used to control which endpoints are associated with a
role:

Table 230: Endpoint Tab List Descriptions

List Description

Selected Endpoints Lists the endpoints assigned to the role.
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List Description

Available Endpoints Lists the available endpoints that can be assigned to the role.

Figure 188: Roles Dialog Endpoints Tab

The Roles Tab Toolbar
This toolbar contains buttons that let you create and manage user roles.

The following table describes the function of each Roles tab toolbar button.

Table 231: Roles Tab Toolbar

Button Name Function

Enable Enables the selected disabled custom role. For additional information, refer to Enabling
User Roles on page 482.

Disable Disables the selected custom role. For additional information, refer to Disabling User Roles
on page 481.

Delete Deletes the selected custom role. For additional information, refer to Deleting User Roles
on page 482.

Create... Creates a new user role. For additional information, refer to Creating User Roles on page
478.

Export Exports the page data to a comma separated value (.csv) file. For additional information,
refer to Exporting Data on page 60.

Important:  The Enhanced Security Configuration feature for Internet Explorer
suppresses export functionality and must be disabled to export data successfully. Pop-
up blockers in Internet Explorer or other supported browsers may also suppress export
functionality and should be disabled.
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Button Name Function

Options

(menu)

Opens the Options menu. For additional information, refer to The Options Menu on page
53.

The Roles Tab List
This list displays all user roles that exist within Lumension Endpoint Management and Security Suite. Use the
action icons to manage roles. Additionally, this list can be filtered to display only specified roles.

The following table describes each Roles tab list column.

Table 232: Roles Tab List

Column Description

Action Contains Edit and Delete icons. Use these icons to edit or delete the associated role. For
addition information, refer to one of the following topics:

• Editing User Roles on page 479
• Deleting User Roles on page 482

Status Contains an icon that indicates the type of role. For additional information, refer to one
of the following topics:

• Predefined System Roles on page 469
• Custom Roles on page 469

Name The name of the user role.

Type The type of user role (System or Custom).

Access Rights The number of access rights assigned to the role.

Users The number of users assigned to the role.

Groups The number of accessible groups assigned to the role.

Endpoints The number of accessible endpoints assigned to the role.
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Working with Roles
To perform tasks associated with roles, click a toolbar button or a list icon. To perform some tasks, selecting one
or multiple roles from the list may be necessary.

• Creating User Roles on page 478
• Editing User Roles on page 479
• Disabling User Roles on page 481
• Enabling User Roles on page 482
• Deleting User Roles on page 482
• Exporting User Role Data on page 483

Creating User Roles
Custom roles let you select individual access rights, accessible groups, and accessible endpoints for that role.
Create a custom role when predefined system roles do not contain the access rights needed for a particular user.
Creating a custom role is also useful when you require a role that can only access specific groups or endpoints.

Create custom roles from the Roles tab.

1. Select Tools > Users and Roles.

2. Select the Roles tab.

3. Click Create.

Step Result: The Create Role dialog opens to the Information tab.

4. Type a name in the Name field.

5. Type a description in the Description field.

6. Select a role template from the Role Template list.

Any existing role can be used as a template. The selected role determines initial access rights. You can later
change which access rights are assigned to the role.

7. Select the Access Rights tab.

8. Select or clear the desired access rights.

For additional information, refer to Predefined System Roles on page 469.

Tip:  Select or clear the All check box to globally select or clear all access rights. Additionally, child access
rights are unavailable until their parent access rights are selected.

9. Select the Groups tab.
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10. Assign the desired accessible endpoint groups to the role.

Use one of the following methods to assign groups.

Method Steps

To assign individual groups: 1. From the Available Groups table, select the check box(es)
associated with the group(s) you want to assign.

2. Click Assign.

To assign all groups: Click Assign All.

Tip:  Remove groups using Remove and Remove All.

11. Select the Endpoints tab.

12. Assign the desired accessible endpoints to the role.

Use one of the following methods to assign endpoints.

Method Steps

To assign individual endpoints: 1. From the Available Endpoints table, select the check box(es)
associated with the endpoint(s) you want to assign.

2. Click Assign.

To assign all endpoints: Click Assign All.

Tip:  Remove endpoints using Remove and Remove All.

13. Click OK.

Result: Your new role is saved. It can now be assigned to users. Additionally, it can be edited from the Users
and Roles page Roles tab.

Editing User Roles
Edit a custom user role as the needs of users associated with the role change. You can only edit custom roles
(predefined system roles cannot be edited).

Edit roles from the Roles tab.

1. Select Tools > User and Roles.

2. Select the Roles tab.

3. Click the Edit icon associated with the role you want to edit.

Step Result: The Edit Role dialog opens to the Information tab.

4. [Optional] Edit the Description field.
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5. [Optional] Select a role template from the Role Template list.

Any existing role can be used as a template. The selected role determines initial access rights. You can later
change which access rights are assigned to the role.

6. Select the Access Rights tab.

7. [Optional] Select or clear the desired access rights.

Tip:  Select or clear the All check box to globally select or clear all access rights. Additionally, child access
rights are unavailable until their parent access rights are selected.

8. Select the Groups tab.

9. [Optional] Assign accessible endpoint groups to the role.

Use one of the following methods to assign groups.

Method Steps

To assign individual groups: 1. From the Available Groups table, select the check box(es)
associated with the group(s) you want to assign.

2. Click Assign.

To assign all groups: Click Assign All.

10. [Optional] Remove accessible endpoint groups from the role.

Use one of the following methods to remove groups.

Method Steps

To remove individual groups: 1. From the Selected Groups table, select the check box(es)
associated with the group(s) you want to remove.

2. Click Remove.

To remove all groups: Click Remove All.

11. Select the Endpoints tab.

12. [Optional] Assign accessible endpoints to the role.

Use one of the following methods to assign endpoints.

Method Steps

To assign individual endpoints: 1. From the Available Endpoints table, select the check box(es)
associated with the endpoint(s) you want to assign.

2. Click Assign.
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Method Steps

To assign all endpoints: Click Assign All.

13. [Optional] Remove accessible endpoints from the role.

Use one of the following methods to remove endpoints.

Method Steps

To remove individual
endpoints:

1. From the Selected Endpoints table, select the check box(es)
associated with the endpoint(s) you want to remove.

2. Click Remove.

To remove all endpoints: Click Remove All.

14. Click OK.

Result: Your edits are saved. The edited role is applied to all associated users.

Editing User Roles
Within Lumension Endpoint Management and Security Suite, you can edit custom user roles, which can be
assigned to users with unique access requirements.

Complete the dialog by defining the setting on each tab.

Disabling User Roles
You can disable any custom role, allowing you to maintain the role within Lumension Endpoint Management
and Security Suite without assigning it to users. You can enable, edit, and delete disabled roles. Disabled roles
appear unavailable.

Disable roles from the Roles tab.

Note:  You cannot disable system roles: Administrator, Manager, Operator, Guest.

1. Select Tools > Users and Roles.

2. Select the Roles tab.

3. Select the check box(es) associated with the enabled custom role(s) you want to disable.

4. Click Disable.

Result: The selected role(s) is disabled.

Caution:  If you disable a role currently assigned to a user, they can still log in to Lumension Endpoint
Management and Security Suite, but their access rights are heavily restricted.
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Enabling User Roles
Re-enable disabled user roles to assign them to users. You can enable disabled user roles at any time.

Re-enable roles from the Roles tab.

1. Select Tools > Users and Roles.

2. Select the Roles tab.

3. Select the check box(es) associated with the disabled role(s) you want to enable.

4. Click Enable.

Result: The selected user role(s) is re-enabled. You can now assign it to users.

Note:  Users already assigned the previously disabled role will again be able to access Lumension
Endpoint Management and Security Suite with their full access rights.

Deleting User Roles
Delete custom user roles when they are no longer needed. You can delete roles regardless of whether they are
enabled or disabled. You cannot delete predefined system roles.

Delete roles from the Roles tab.

1. Select Tools > Users and Roles.

2. Select the Roles tab.

3. Delete the desired roles.

Use one of the following methods.

Method Steps

To delete a single user role:
1. Click the Delete icon associated with the role you want to delete.
2. Click OK to acknowledge the deletion.
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Method Steps

To delete multiple user roles:
1. Select the check boxes associated with the user roles that you want

to delete.
2. From the toolbar, click the Delete button.
3. Click OK to acknowledge the deletion.

Note:  You cannot delete system roles: Administrator, Manager, Operator, Guest.

Result: The role is deleted.

Caution:  If you delete a role currently assigned to a user, they can still log in to Lumension Endpoint
Management and Security Suite, but their access rights are heavily restricted.

Exporting User Role Data
You can export the data displayed on the Roles tab list so that it can be used in other applications. This data is
exported to a comma separated value (.csv) file.

To export data, click the Export button. For additional information, refer to Exporting Data on page 60.
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Chapter

16
Using the Patch Agent

In this chapter:

• About the Patch Agent for Pre-
Windows Vista

• About Patch Agent for Windows
Vista and Later

• About the Agent for Mac

• About the Command Line Agent for
Linux/Unix/Mac

The Patch Agent is the module that executes Lumension Patch and
Remediation functions on an endpoint.

When added to the Lumension EMSS agent, the Patch Agent scans the
endpoint for vulnerabilities and uploads the scan results to Lumension
Endpoint Management and Security Suite. The results returned to
Lumension Endpoint Management and Security Suite server can be
viewed at any time, even if the workstation is disconnected from
your network. The scan results are used by Patch and Remediation
to determine a vulnerability’s applicability for each endpoint. If a
vulnerability is applicable, the Lumension Endpoint Management and
Security Suite Web console displays the endpoint as Not Patched.

After adding the Patch Agent, there is generally no additional user
interaction required at the endpoint.

About the Patch Agent for Pre-Windows Vista
The Patch Agent is responsible for retrieving endpoint inventory and vulnerability data, uploading that endpoint
data to Lumension Endpoint Management and Security Suite, and deploying content to the endpoint.

Viewing the Patch Agent
Viewing the Patch Agent shows information about the endpoint and Patch and Remediation deployments.

View the Patch Agent interface on a pre-Vista Windows endpoint after it is installed.

Open the Patch Agent.

You can perform this task two ways.

Method Steps

To open Patch Agent from
Windows:

1. Select Start > Setting > Control Panel.
2. Double-click Lumension Patch Agent.
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Method Steps

To open Patch Agent from the
Lumension EMSS Agent:

1. Select Start > Setting > Control Panel.
2. Double-click Lumension EMSS Agent.
3. Select the Patch and Remediation panel or the Proxy Server

panel.
4. Click Lumension Patch Agent.

Result: The Patch Agent Control Panel opens to the Deployment tab.

Note:  When opening the agent, Windows Control Panel must be displayed in the Windows Classic
View. Viewing Control Panel in Category View does not display the agent.

The Patch Agent Dialog (Pre-Windows Vista)
You can use the Patch Agent dialog to control behavior for the pre-Windows Vista version of the Patch Agent.
This dialog includes several tabs that either list agent information or modify agent behavior.

The Patch Agent dialog includes the following tabs:

• The Deployment Tab on page 486
• The Detection Tab on page 489
• Proxies Tab on page 492
• The About Tab on page 494

The Deployment Tab
The Deployment tab contains information about recent deployments to the Patch Agent.
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The Deployment tab includes the following sections:

• Server Information and Status on page 487
• Agent Information on page 487
• Log Operations on page 488
• Agent Operations on page 489

Figure 189: Agent Initial Screen

Server Information and Status
The Server Information and Status section contains information about the Lumension Endpoint Management
and Security Suite server that the Patch Agent is registered with and the agent's connection status.

The following table displays the Lumension Endpoint Management and Security Suite location and the
communication status.

Table 233: Server Information - Deployment Tab

Field Description

EMSS Server The URL of the Lumension Endpoint Management and Security Suite the
Patch Agent is registered with.

Deployment Agent Status Indicates the current status (Started, Stopped, Working, Waiting, or
Restarting) of the Lumension Patch and Remediation service on the
local endpoint.

Agent Information
The Agent Information area contains the Patch Agent's latest connection time, next connection time, logging
level, and listener port information.
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The following table describes the information in the Agent Information area of the Deployment tab.

Table 234: Agent Information

Field Description

Last Checked Time The time the Patch Agent last communicated with the Lumension Endpoint
Management and Security Suite server.

Next Checked Time The next scheduled time when the Patch Agent will contact the Lumension
Endpoint Management and Security Suite server.

Logging Level The Patch Agent’s current logging level.

Agent Listener Port The port on which the Patch Agent listens for communication. A setting of
0 disables agent listening.

Log Operations
The Log Operations section allows you to view and clear the Patch Agent activity log.

The following table describes the log operations.

Table 235: Log Operations

Use To

View Agent Log View the Patch Agent activity log.

Clear Agent Log Clear the contents of the Patch Agent activity log.

Viewing the Patch Agent Log
The Patch Agent log contains a record of recent activity.

Open the Patch Agent log from the Patch Agent console.

Click View Agent Log.

Step Result: The Patch Agent log (Lumension Update Agent.log) opens in a new window.

Figure 190: View Agent Log

Clearing the Patch Agent Log
Clearing the Patch Agent log removes all entries from it.
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Clear the Patch Agent log from the Deployments tab.

1. Click Clear Agent Log.

Step Result: A confirmation dialog opens, prompting you to confirm the clearance.

Figure 191: Clear Log Message

2. Click Yes.

Result: The system clears the agent log.

Agent Operations
You can use the Agent Operations section of Deployment tab to check for updates from the server or to restart
the server.

The following table describes the Agent Operations area.

Table 236: Agent Operations on the Deployment tab

Use To

Check Now Triggers the agent to contact the Lumension Endpoint Management and
Security Suite server. The Lumension Endpoint Management and Security
Suite server starts the process of deploying content to the Patch Agent if
deployments are scheduled.

Restart Agent Restarts the Lumension Patch and Remediation service.

The Detection Tab
The Detection tab lists server-to-agent connection information, log operations, and agent operations.
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The Detection tab includes the following sections:

• Server Information and Status on page 490
• Agent Information on page 490
• Log Operations on page 491
• Agent Operations on page 492

Figure 192: Detection Tab

Server Information and Status
The Server Information and Status section contains information about the connected Lumension Endpoint
Management and Security Suite and the status of the communication between the Patch Agent and the server.

The following table displays the Lumension Endpoint Management and Security Suite location and the
communication status.

Table 237: Server Information - Detection Tab

Field Description

EMSS Server The URL of the Lumension Endpoint Management and Security Suite the
Patch Agent is registered with.

Deployment Agent Status Indicates the current status of the Lumension Patch and Remediation
service on the local endpoint (Started, Stopped, Working, Waiting, or
Restarting).

Agent Information
The Agent Information section contains data about the last detection time and the Discover Applicable Updates
(DAU) task status.
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The following table describes the information in the Agent Information area of the Deployment tab.

Table 238: Agent Information - Detection Tab

Field Description

Last Detection Time The last time the DAU task ran.

Detection Status The status of the DAU task.

Log Operations
The Log Operations section allows you to view and clear the Patch Agent detection log.

The following table describes the Log Operations area.

Table 239: Log Operations - Detection Tab

Button Action

View Agent Log Opens the detection log.

Clear Agent Log Clears the detection log.

Viewing the Detection Log
The Patch Agent detection log records identification information about the Patch Agent and its Lumension
Endpoint Management and Security Suite server.

View the detection log from the Detection tab.

Click View Detection Log.

Step Result: The detection log (Lumension Detection Agent.log) opens.

Figure 193: Detection Log

Clearing the Detection Log
Clearing the detection log removes all entries from it.

Complete the following procedure to remove all the entries from the detection log.
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1. Click Clear Detection Log.

Step Result: The confirmation message dialog box opens.

Figure 194: Clear Agent Log Message

2. Click Yes.

Result: The system clears the detection log.

Agent Operations
The Agent Operations section of the Deployment tab allows you to perform the Discover Applicable Updates
(DAU) task.

The following table describes the Agent Operations area.

Table 240: Agent Operations

Use To

Detect ASAP Cause the agent to start a DAU task as soon as possible.

Proxies Tab
If you want to use a proxy server for communication between the Lumension Endpoint Management and
Security Suite and the endpoint, you can define the proxy information using the Proxies tab.



Using the Patch Agent

- 493 -

The Proxies tab is comprised of the following sections:

• Server Information and Status on page 493
• Configuring Proxy Settings on page 493

Figure 195: Proxies Tab

Note:  When installed, the Patch Agent controls all communication with a proxy server rather than the
Lumension EMSS Agent.

Server Information and Status
The Server Information and Status section contains information about the connected Lumension Endpoint
Management and Security Suite and the status of the communication between the Patch Agent and the server.

The following table displays the Lumension Endpoint Management and Security Suite location and the
communication status.

Table 241: Server Information - Proxies Tab

Field Description

EMSS Server The URL of the Lumension Endpoint Management and Security Suite the
Patch Agent is registered against.

Deployment Agent Status Indicates the current status of the Lumension Patch and Remediation
service on the local endpoint (Started, Stopped, Working, Waiting, or
Restarting).

Configuring Proxy Settings
Configure proxy settings so that the Patch Agent can connect to the server through a proxy.

Complete the following procedure from the Proxy tab.

1. Select Enable Proxy.

Step Result: The Server and Port fields become active.

2. Type the Lumension Endpoint Management and Security Suite server URL address in the Server field.
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3. In the Port field, type the port number that the proxy uses for communication.

4. If you are using a proxy that require authentication, select Authenticated.

a) In the Username field, type a username that authenticates with the proxy.
b) In the Password field, type the password associated with the username.

5. Click OK.

Step Result: The confirmation dialog opens.

Figure 196: Proxy Change Confirmation

6. Click Yes.

Result: The proxy information is saved and the agent restarts.

The About Tab
The About tab displays information regarding the Patch Agent and its associated Lumension Endpoint
Management and Security Suite server.



Using the Patch Agent

- 495 -

The About tab includes the following sections:

• Server Information and Status on page 495
• Version Information on page 495

Figure 197: About Tab

Server Information and Status
The Server Information and Status section contains information about the connected Lumension Endpoint
Management and Security Suite and the status of the communication between the Patch Agent and the server.

The following table displays the Lumension Endpoint Management and Security Suite location and the
communication status.

Table 242: Server Information - About Tab

Field Description

EMSS Server The URL of the Lumension Endpoint Management and Security Suite the
Patch Agent is registered against.

Deployment Agent Status Indicates the current status of the Lumension Patch and Remediation
service on the local endpoint (Started, Stopped, Working, Waiting, or
Restarting).

Version Information
The Version Information section contains information about the Lumension Endpoint Management and
Security Suite version, the agent version, and the version of other agent components.
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The following table describes the version information for the About tab.

Table 243: Version Information

Field Description

Client Agent Version number of the agent.

Detection Agent Version number of the detection agent.

EMSS Server Version number of the Lumension Endpoint Management and Security
Suite.

Control Panel Version number of the Control Panel.

Notification Manager Version number of the Notification Manager.

User Interaction During a Deployment
After you create a deployment within the Lumension Endpoint Management and Security Suite, the Patch Agent
can retrieve the deployment from the server.

When the Patch Agent receives a deployment, if a deployment notification was enabled and a user is logged into
the endpoint, a deployment notification displays on the endpoint.

An icon is also visible in the taskbar.

Figure 198: Install Icon

Beginning the Deployment
This procedure explains how to begin a deployment.

After you complete this procedure, the deployment will begin on the endpoint.

Click Install.

Step Result:

Figure 199: Deployment Dialog

Result: The Agent starts the deployment.
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Delaying a Deployment
This procedure explains how to delay a deployment.

Complete the following procedure to postpone a deployment.

1. Select a time frame from the Snooze for drop-down list.

2. Click Snooze.

Step Result: The deployment is delayed for the selected duration.

Canceling a Deployment
This procedure explains how to cancel a deployment.

Complete the following procedure to cancel a deployment.

1. Click Cancel (if Cancel is not available, your Administrator has disabled your ability to do so).

Step Result: A confirmation dialog opens, prompting you to confirm your choice.

2. Click Yes.

Step Result: The deployment is canceled.

Note:

If the deployment is part of a Mandatory Baseline, the Lumension Endpoint Management and
Security Suite will redeploy the patch until it is installed on the device.

User Interaction During a Reboot
If the agent must reboot the endpoint, a user is logged into the device, and reboot notification was enabled, the
reboot notification will displays on the endpoint desktop.
Rebooting Immediately
Rebooting immediately restarts the operating system on the endpoint.

You can reboot the endpoint immediately when prompted by the Patch Agent.
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Click Reboot.

Step Result:

Figure 200: Reboot Dialog

Result: The Agent reboots the endpoint.

Delaying a Reboot
Delaying a reboot temporarily prevents the operating system on the endpoint from restarting.

You can postpone a reboot when the Patch Agent notifies you that a reboot is pending.

1. Select a time frame from the Snooze for drop-down list.

2. Click Snooze.

Step Result: The reboot is delayed for the selected duration.

Canceling the Reboot
Cancel a reboot to prevent an endpoint from restarting. Canceling a reboot lets you select a more convenient to
restart, allowing you to continue work uninterrupted.

You can cancel a reboot when the Patch Agent prompts you to reboot your endpoint.

1. Click Cancel.

If Cancel is not available, the administrator has disabled your ability to cancel the reboot.

Step Result: A confirmation dialog displays, prompting you to confirm the cancellation.

2. Click Yes.

Step Result: The reboot is canceled.

About Patch Agent for Windows Vista and Later
The agent for Windows Vista and later communicates Patch and Remediation-related information about the
host endpoint to the Lumension Endpoint Management and Security Suite. The Patch Agent is responsible for
uploading endpoint data and downloading content.
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The Patch Agent for Windows Vista and later is managed through the Agent Control Panel. With this user
interface, you can launch Discover Applicable Update task, view server information, configure proxy servers,
and so on. You can install Patch Agent for Window Vista and later on the following endpoint operating systems:

• Windows Vista
• Windows 7
• Windows 8
• Windows Server 2008
• Windows Server 2012

Viewing the Agent
Viewing the Patch Agent provides access to agent functionality and connectivity data.

Open the Patch Agent dialog from the endpoint hosting it.

Note:  The following procedure describes viewing the agent in the Control Panel's Classic view. You can view
the agent in the Control Panel's Category view under the Security category.

1. Go to Start > Control Panel.

Step Result: The Control Panel opens.

2. Open Patch Agent.

Step Result: The Lumension Patch Agent Control Panel opens to the Home page.

Figure 201: Control Panel
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The Patch Agent (Windows Vista and Later)
You can use the Patch Agent dialog to configure agent behavior for the post-Vista Windows release versions of
the Patch Agent. You can also use it to view agent-server connectivity data.

The Patch Agent dialog includes the following pages:

• The Home Page on page 502
• The Tools and Settings Page on page 503
• Proxy Settings on page 505
• Configuring Proxy Settings on page 493
• The Log Files Page on page 508
• The Notification Manager Page on page 510
• The Server Settings Page on page 511

The Agent Control Panel Toolbar
On all Agent Control Panel pages, a toolbar is displayed. Use this toolbar to navigate within the Patch Agent or
perform agent actions.

The following table describes each Agent Control Panel toolbar button.

Table 244: Agent Control Panel Toolbar Buttons

Button Title Button Description

Backward Returns you to the previous Agent Control Panel page.

Forward Advances you to the page you viewed prior to clicking Backward.

Scan

(Split Button)

Launches a Discover Applicable Updates task on the endpoint. Click the
arrow to expand a menu. For additional information, refer to Manually
Performing Endpoint Scans (DAU Tasks) on page 501.

Scan

(Scan Menu List Item)

Launches a Discover Applicable Updates task on the endpoint. For
additional information, refer to Manually Performing Endpoint Scans
(DAU Tasks) on page 501.

Check for Deployments

(Scan Menu List Item)

Prompts to the Patch Agent to check the Lumension Endpoint
Management and Security Suite server for deployments targeted at
the agent. For additional information, refer to Manually Checking for
Deployments on page 501.

Agent Service...

(Scan Menu List Item)

Opens the Agent Service dialog. From this dialog, you can restart the
agent service. For additional information, refer to Restarting the Agent
Service on page 501.

Tools Opens the Tools and Settings page. For additional information, refer to
Viewing the Tools and Settings Page on page 504.
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Button Title Button Description

Question Mark

(Split Button)

Opens Help for the Agent Control Panel. Click the arrow to expand a
menu. For additional information, refer to The Agent Control Panel Help
Page on page 512.

Help...

(Question Mark Menu
Item)

Opens Help for the Agent Control Panel. For additional information,
refer to The Agent Control Panel Help Page on page 512.

Exit Agent Control
Panel

(Question Mark Menu
Item)

Closes the Agent Control Panel.

About

(Question Mark Menu
Item)

Opens the About dialog. This dialog list Patch Agent trademark
information. For additional information, refer to The About Dialog on
page 512.

Manually Performing Endpoint Scans (DAU Tasks)
You can manually initiate a DAU task for a endpoint hosting the Patch Agent.

Manually initiate DAU tasks from the Agent Control Panel.

From the toolbar, click Scan.

Result: The Patch Agent initiates a DAU task for the endpoint. Following the scan completion, results are
uploaded to the Lumension Endpoint Management and Security Suite server.

Manually Checking for Deployments
You can manually initiate a connection between the agent and the server. During this connection, the Patch
Agent checks the Lumension Endpoint Management and Security Suite for deployments, new agent policy sets,
or new policy changes.

You can manually check for deployments from the Agent Control Panel.

From the toolbar, select Scan > Check for Deployments.

Result: The Patch Agent checks the Lumension Endpoint Management and Security Suite for deployments and
policy updates. If a deployment is scheduled for the Patch Agent, the agent begins downloading the
deployment immediately.

Restarting the Agent Service
When necessary, you can restart the Patch Agent services.

Restart the Patch Agent services from the Agent Control Panel.

1. From the toolbar, select Scan > Agent Service.

Step Result: The Agent Service dialog opens.
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2. Click Restart.

Result: The Patch Agent service begin restarting. Wait for the restart to complete. After you confirm the restart
via the Agent Service dialog, dismiss the dialog by clicking Close.

The Home Page
The Patch Agent opens to the Home page. This page lists agent information and function.

The Home page include the following sections:

• Compliance Banner Statuses on page 502
• Active Scan Statistics on page 503
• Statuses on page 503

Figure 202: Home Page

Compliance Banner Statuses
Compliance Banner Statuses display whether the endpoint is compliant with corporate policies. View this banner
from the Patch Agent Home page.
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The following table describes each compliance status.

Table 245: Compliance Banner Statuses

Status Description Displays

Compliant Green (service is
running and the
agent is idle)

Determining
Compliance

Orange (service
is running and the
agent is busy)

Unable to
Determine
Compliance

Red (service is not
running)

Not Compliant Orange (service
is running and the
agent is busy)

Unable to
Contact Server

Blue (service is
running and the
agent is offline or
unknown)

Active Scan Statistics
Active Scan Statistics display only after clicking the Scan button. You can use the active scan statistics controls
to start a scan if one is not already active. This section also displays the scan type, start time, duration, and status.

Note:  The scan start time and duration values are only populated if you started the scan. If the scan was running
prior to you clicking the Scan button, the exact start time and duration are unknown.

Statuses
Statuses provide general agent status values.

Statuses include the Last Scan, the Update Schedule (as defined by the Communication Interval), the scan
Definition Date, and the Agent Version.

The Tools and Settings Page
The Tools and Settings page is comprised of links to agent utilities and configuration settings.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 504 -

This page is divided into two sections: Tools and Settings. These sections can be expanded or collapsed by
clicking the associated arrow icon. The following links appear on the Tools and Settings page.

Table 246: Tools and Setting Page Links

Link Description

Tools

Proxy Settings Opens the Proxy Settings page, allowing you to view of modify the agent's current
proxy configuration. For additional information, refer to Proxy Settings on page 505.

Logging Opens the Log Files page, allowing you to view or clear the agent log files. For
additional information, refer to The Log Files Page on page 508.

Notification
Manager

Opens th Notification Manager page, allowing you to define the notification manager
behavior. For additional information, refer to The Notification Manager Page on page
510.

Settings

Lumension EMSS
Server

Opens the Server Settings page. For additional information, refer to The Server Settings
Page on page 511.

Viewing the Tools and Settings Page
View the Tools and Settings page to access other pages related to agent management.

View the Tools and Settings page from the Agent Control Panel.

From the toolbar, click Tools.

Result: The Tools and Settings page opens.
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Proxy Settings
If you are using a proxy server for communication between the Lumension Endpoint Management and Security
Suite server and the endpoint, you can use the Proxy Settings page to define the proxy information.

Figure 203: Proxy Settings

This page is divided into two sections:

• Server Provided Proxy Settings on page 505
• Client Defined Proxy Settings on page 506

Note:  When installed, the Patch Agent controls all communication with a proxy server rather than the
Lumension EMSS Agent.

Viewing the Proxy Settings Page
View the Proxy Settings page to view settings for server- or local-defined proxy settings.

View the Proxy Settings page from the Agent Control Panel.

1. From the toolbar, click Tools.

2. Click Proxy Settings.

Result: The Proxy Settings page opens.

Server Provided Proxy Settings
This Proxy Setting page section lists server provided proxy settings. You can also use it to override server proxy
settings (if enabled by the Lumension Endpoint Management and Security Suite administrator).

You can expand or collapse this section by clicking its associated arrow icon.
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When the Server Provided Proxy Settings section is expanded, a table displays. The following table describes
each Server Provided Proxy Settings table column.

Table 247: Agent Server Provided Proxy Settings Table

Column Description

Server Lists the name of the server provided proxy server.

Port Lists the port used by the proxy server.

Authenticated Lists whether the proxy server require authentication (Yes or No).

Server Provided Proxy Settings also includes the Use a Proxy Server check box. Select this check box
to override server provided proxy settings with the local proxy settings you manually define. For additional
information, refer to Defining Client Proxy Settings  on page 507.

Client Defined Proxy Settings
This Proxy Setting page section lists client provided proxy settings. You can define these settings after selecting
the Use a Proxy Server checkbox in Server Provided Proxy Settings.

You can expand or collapse this section by clicking its associated arrow icon.

The following table describes each field you can define within Client Defined Proxy Settings.

Table 248: Client Defined Proxy Settings Field

Field Description

Proxy Server
Address

The name or IP address of the proxy server you want to use to relay communication
between the Lumension Endpoint Management and Security Suite server and the
endpoint.

Proxy Server Port The port number the proxy server uses for communication.

The Client Defined Proxy Settings section contains a sub-section, the Proxy Authentication section. When
defining client proxy settings, define these settings if the proxy require authentication.

To define these settings, select the Enter your proxy authentication credentials checkbox and type values into
the fields described in the following table. These fields become available after selecting the checkbox.

Table 249: Proxy Authentication Field Descriptions

Field Description

Username A username that authenticates with the defined client proxy.

Password The password associated with the username.

Password Retyped The password retyped.
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Defining Client Proxy Settings
If allowed by the Lumension Endpoint Management and Security Suite administrator, you can configure the
Patch Agent to use a proxy server of your choice rather than a proxy defined by the administrator.

Define proxy settings from the Agent Control panel Proxy Settings page.

1. Click Tools.

Step Result: The Tools and Settings page opens.

2. Click Proxy Settings.

Step Result: The Proxy Settings page opens.

3. Ensure Server Provided Proxy Settings is expanded.

4. Ensure the Use a proxy server checkbox is selected.

Note:  If this checkbox is unavailable, you cannot define a proxy server due to restricted access rights.
Contact your Lumension Endpoint Management and Security Suite administrator for further assistance.

5. Ensure Client Provided Proxy Settings is expanded.

6. Define the following fields by typing the applicable information in them.

The following table describes each field.

Field Description

Proxy Server Address The name or address of the proxy server you want to use.

Proxy Server Port The port number the proxy uses for server-to-agent communication.

7. If the defined proxy require authentication, ensure Proxy Authentication, select the Enter your proxy
authentication credentials, and type the applicable information in the following fields:

Field Description

Username A username that authenticates with the proxy.

Password The password associated with the username.

Retype Password The password retyped.

8. Click Save.
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The Log Files Page
The Log Files page contains buttons to open or clear the Patch Agent log files.

Figure 204: Log Files Page

The following table describes each Logging Files page column.

Table 250: Logging Files Page Column

Column Description

Name Lists the name of the log files.

Date Modified Lists the date and time the log files were last modified.

Size Lists the size of the log files in kilobytes.

Action Contains buttons for viewing and truncating log files. For additional information, refer to
the following topics:

• Opening Log Files on page 509
• Truncating Log Files on page 509

Viewing the Log Files Page
View the Log Files page to open or truncate logs.

View the Log Files page from the Agent Control Panel.

1. From the toolbar, click Tools.

Step Result: The Tools and Settings page opens.
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2. Click Logging.

Result: The Log Files page opens.

Opening Log Files
You can open Patch Agent logging files to review Patch Agent events.

Open log files from the Log Files page.

1. From the toolbar, click Tools.

Step Result: The Tools and Settings page opens.

2. Click Logging.

Step Result: The Log Files page opens.

3. Click the View button associated with the log you want to open.

Result: The log opens in the default text editor.

Truncating Log Files
When Patch Agent log files become excessively large, you can reduce their size by truncating them.

Truncate log files from the Log Files page.

1. Click Tools.

Step Result: The Tools and Settings page opens.

2. Click Logging.

Step Result: The Log Files page opens.

3. Click the Truncate button associated with the log you want truncate.

Result: The applicable log is truncated.
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The Notification Manager Page
Use the Notification Manager page to define how Patch Agent notifications display on the endpoint.

Figure 205: Notification Manager

The following table describes each Notification Manager setting.

Table 251: Notification Manager Settings

Setting Description

Notification Manager
Version

(Field)

Displays the version of the notification manager (for use by technical support).

Always Show Icon in
System Tray

(Check Box)

Forces the Lumension notification manager icons to displays in the Windows
system trays (when selected).

Viewing the Notification Manager Page
View the Notification Manager page to enable or disable the Patch Agent system tray icon.

View the Notification Manager page from the Agent Control Panel.

1. Select Tools.

Step Result: The Tools and Settings page opens.

2. Click Notification Manager.

Step Result: The Notification Manager page opens.

3. [Optional] Select or clear the Always show icon in system tray check box and click Save.
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The Server Settings Page
The Server Settings page contains information about the Lumension Endpoint Management and Security Suite
server that the Patch Agent is registered to.

The following table describes each Server Settings page field.

Table 252: Server Setting Field Descriptions

Field Description

Lumension EMSS
Server

(link)

Lists the name of the Lumension Endpoint Management and Security Suite server
the Patch Agent is registered to. Click the name open the Lumension Endpoint
Management and Security Suite server in a Web browser.

Lumension EMSS
Server Version

Lists the version of the Lumension Endpoint Management and Security Suite
server that the Patch Agent is registered to.

Agent Center Version Lists the associated Agent Center version (for use by Technical Support).

Figure 206: Server Settings

Viewing the Server Settings Page
View this page to review information about your Lumension Endpoint Management and Security Suite server.

View this page from the Agent Control Panel.

1. Click Tools.

Step Result: The Tools and Settings page opens.

2. Click Lumension EMSS Server.

Step Result: The Server Settings page opens.
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3. [Optional] Click Lumension EMSS to open the Lumension Endpoint Management and Security Suite in a
new browser window.

The Agent Control Panel Help Page
The Agent Control Panel contains a context-sensitive Help system. Help provides product feature explanations
and step-by-step procedures.

Access context-sensitive Help pages by selecting ? > Help... from the toolbar.

The About Dialog
The About dialog displays trademark information for the Lumension Patch Agent.

This dialog indicates if agent logging is turned on or off. Additionally, it indicates the agent listener port. Click
OK to dismiss the dialog.

User Interaction During a Deployment
After you create a deployment within Lumension Endpoint Management and Security Suite, the Patch Agent can
retrieve the deployment from the server. When the agent receives a deployment, if a deployment notification was
enabled and a user is logged into the endpoint, a deployment notification will display.

Beginning the Deployment
When a deployment is configured to notify an endpoint's user of the deployment, a user can initiate the
deployment manually from the endpoint.

Begin an endpoint deployment when prompted by the Patch Agent.

Click Install Now.

Result: The Patch Agent starts the deployment.

Delaying a Deployment
You can deplay an endpoint deployment when the Lumension Endpoint Management and Security Suite
administrator has granted you this control.

You can delay deployments when prompted to begin a deployment.

Select a time frame from the Remind me in drop-down list.

Result: The deployment is delayed for the selected duration.

Canceling a Deployment
This procedure explains how to cancel a deployment.

Complete the following procedure to cancel a deployment.

1. Click Cancel (if Cancel is not available, your Administrator has disabled your ability to do so).

Step Result: A confirmation dialog opens, prompting you to confirm your choice.
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2. Click Yes.

Step Result: The deployment is canceled.

Note:

If the deployment is part of a Mandatory Baseline, the Lumension Endpoint Management and
Security Suite will redeploy the patch until it is installed on the device.

User Interaction During a Reboot
If the Patch Agent must reboot the endpoint, a user is logged into the endpoint, and reboot notification was
enabled, a reboot notification displays.

Rebooting an Endpoint
Performing the Patch Agent's reboot function reboots the endpoint immediately.

You can reboot the agent when prompted by the Patch Agent.

Click Restart now.

Result: The Patch Agent reboots the endpoint.

Delaying a Reboot
You can delay an endpoint reboot manually when the Lumension Endpoint Management and Security Suite
administrator has configured the deployment for this control.

You can delay reboots when prompted to reboot the endpoint.

Select a time frame from the Remind me in drop-down list.

Result: The reboot is delayed for the selected duration.

Canceling a Reboot
You can cancel an endpoint reboot manually when the Lumension Endpoint Management and Security Suite
administrator has configured the deployment for this control.

You can cancel a reboot when prompted.

1. Click Cancel (if Cancel is not available, your administrator has disabled your ability to do so).

Step Result: A confirmation dialog displays, prompting you to confirm your choice.

2. Click Yes.

Result: The reboot is canceled.
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About the Agent for Mac
The Patch Agent for Mac is a graphical user interface application for Apple OS X. The agent is responsible for
uploading endpoint data to the Lumension Endpoint Management and Security Suite server and downloading
content.

Viewing the Patch Agent
Viewing the Patch Agent allows you to perform agent operations and view connectivity data.

View the Patch Agent from your Mac endpoint.

1. Click System Preferences.

2. Click Patch Agent.

Step Result: The Lumension Patch Agent Control Panel opens. The Deployment tab is the default.

Patch Agent Components
The Patch Agent components are located on the Deployment tab and the Detection tab, which allow you to view
information and define how the agent contacts the Lumension Endpoint Management and Security Suite server
and receives deployments.

Deployment Tab
The Deployment tab contains data related to Patch Agent deployments.
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The Deployment tab includes the following sections:

• Server Information on page 515
• Diagnostics Information on page 516
• Results on page 516

Figure 207: Agent Initial Screen

Server Information
The Server Information section contains information about the Lumension Endpoint Management and Security
Suite server, proxy information, the Patch Agent version, location and status, and connectivity data.

The following table displays server information.

Table 253: Server Information Displayed in the Mac Agent

Field Description

Server The URL of the Lumension Endpoint Management and Security Suite the
Patch Agent is registered with.

Proxy Server The URL of the proxy server, if a proxy server is configured.

Proxy Port The port used by the proxy server, if a proxy server is configured.

Agent Version The version number of the agent.

Agent Status Indicates the current status of the Patch Agent service on the local endpoint
(Started, Stopped, Working, Waiting, or Restarting).

Install Directory The directory in which the Patch Agent is installed.
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Field Description

Last Checked The time at which the Patch Agent last communicated with the Lumension
Endpoint Management and Security Suite.

Next Checked The next scheduled time when the Patch Agent will contact the Lumension
Endpoint Management and Security Suite.

Diagnostics Information
The Diagnostics Information section contains Patch Agent logging information.

The following table displays the agent diagnostics information and log operations.

Table 254: Diagnostics Information

Field Description

Logging Level The logging level performed by the Patch Agent. Values for this field
include None, Basic Info, Detailed, and Debug.

Agent Listener Port The port that the Pathc Agent uses to connect to the Lumension Endpoint
Management and Security Suite.

Trim Logs Reduces the size of the error, agent, and detect log files. Oldest entries are
deleted and the file is truncated at 100,000 lines.

Archive Logs Archives log files. The location of the archive appears in the Results field.

View Agent Log Opens a text file containing the Patch Agent activity log.

Clear Agent Log Clears the Patch Agent activity log.

View Error Log Opens a text file containing the Patch Agent error log.

Clear Error Log Clears the Patch Agent error log.

More Information Displays Patch Agent configuration information, usage information, and
excerpts of the agent activity and error logs in the Results field.

Results
The Results field shows the results of the agent activities performed on the Deployment tab.

Detection Tab
The Detection tab allows you to perform detection operations and view the detection log.
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The Detection tab is comprised of two areas.

• Status on page 517
• Results on page 516

Figure 208: Detection Tab

The following functions are available on the Detection tab.

Table 255: Detection Tab Functions

Status Description

Detect Now Causes the Patch Agent to start a Discoverable
Applicable Updates (DAU) task as soon as possible.

View Detect Log Displays the Patch Agent detection log.

Clear Detect Log Clears the Patch Agent detection log.

Status
The Status field shows a text description of the agent activities performed on the Detection tab.
Results
The Results field shows the results of the agent activities performed on the Detection tab.

Refreshing the Agent Information
Refreshing the agent information updates the information that appears on the Patch Agent Deployment tab.

Refresh agent information from the Deployment tab.

1. Click System Preferences.
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2. Click Patch Agent.

Step Result: The Lumension Patch Agent Control Panel opens to the Deployment tab.

3. Click Refresh.

Result: The agent information is refreshed.

Starting the Agent
Starting the agent activates the Patch Agent and initiates a connection attempt between the agent and the
Lumension Endpoint Management and Security Suite server.

Start the Patch Agent from the Deployment tab.

1. Click System Preferences.

2. Click Patch Agent.

Step Result: The Lumension Patch Agent Control Panel open to the Deployment tab.

3. Click Start Agent.

Result: The Patch Agent starts.

Stopping the Agent
Stopping the agent deactivates the Patch Agent and terminates any connection between the agent and Lumension
Endpoint Management and Security Suite server. The Patch Agent restarts automatically after a reboot.

Stop the Patch Agent from the Deployment tab.

1. Click System Preferences.

2. Click Patch Agent.

Step Result: The Lumension Patch Agent Control Panel opens to the Deployment tab.

3. Click Stop Agent.

Result: The Patch Agent is stopped.

Restarting the Agent
Restarting the Patch Agent stops and then restarts the agent. A connection attempt is initiated between the Patch
Agent and Lumension Endpoint Management and Security Suite server.

Restart the Patch Agent from the Deployment tab.

1. Click System Preferences.

2. Click Patch Agent.

Step Result: The Lumension Patch Agent Control Panel opens to the Deployment tab.
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3. Click Restart Agent.

Result: The Patch Agent restarts.

User Interaction During a Deployment
After you create a deployment within Lumension Endpoint Management and Security Suite, the Patch Agent can
retrieve the deployment from the server. When the agent receives a deployment, if a deployment notification was
enabled and a user is logged into the endpoint, the deployment notification displays on the endpoint screen.

Beginning the Deployment
When a deployment has been configured to notify the user of the deployment, the user can initiate the
deployment manually from the endpoint.

You can begin a deployment when prompted.

Click Install.

Result: The Patch Agent starts the deployment.

Delaying a Deployment
You can delay the deployment manually when the Lumension Endpoint Management and Security Suite
administrator has configured the deployment to permit this control.

You can delay deployments when prompted to begin a deployment.

1. Select a time frame from the drop-down list.

2. Click Snooze.

Step Result: The deployment is delayed for the selected duration.

Canceling a Deployment
You can cancel the deployment manually from the endpoint when a deployment has been configured to allow
this type of control.

You can cancel deployments when prompted to begin a deployment.

1. Click Cancel.

If Cancel is not available, your administrator has disabled your ability to cancel the deployment.

Step Result: A confirmation dialog opens, prompting you to confirm the cancellation.

2. Click Yes.

Result: The deployment is canceled.

Note:  If the deployment is part of a Mandatory Baseline, the Lumension Endpoint Management and
Security Suite will redeploy the patch until it is installed on the endpoint.
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User Interaction During a Reboot
If the Patch Agent must reboot the endpoint, a user is logged into the endpoint, and reboot notification was
enabled, the reboot notification displays on the endpoint screen.

Rebooting Immediately
Using the Patch Agent's reboot function reboots the endpoint immediately.

You can reboot the endpoint when prompted.

Click Reboot.

Result: The Patch Agent reboots the endpoint.

Delaying a Reboot
You can delay a reboot manually when the deployment has been configured to allow this type of control on the
endpoint.

You can delay a reboot when prompted to reboot the endpoint.

1. Select a time frame from the drop-down list.

2. Click Snooze.

Result: The reboot is delayed for the selected duration.

Canceling the Reboot
You can cancel a reboot manually when the deployment has been configured to allow this type of control on the
endpoint.

You can cancel reboots when prompted to reboot the endpoint.

1. Click Reject.

If Reject is not available, your administrator has disabled your ability to cancel the reboot.

Step Result: A confirmation dialog opens, prompting you to confirm the cancellation.

2. Click Yes.

Step Result: The reboot is canceled.

About the Command Line Agent for Linux/Unix/Mac
The Patch Agent for Linux/Unix/Mac is a command line based application that does not have a user interface.

While you are in the root directory, inside the Patch Service program, type the following command:

user/local/patchagent/patchservice
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Refer to the following commands to complete tasks within these agents.

Table 256: LUMN Agent Commands

Command Description

info Indicates general information about the agent.

status Indicates the status of the agent process.

daustatus Indicates the status of the Discover Applicable Updates (DAU) task.

detect Starts the detection task.

stop Stops the agent process.

restart Stops and starts the agent process.

patchdirectory Sets the directory where patches will be temporarily downloaded.

setmacro Specifies the macro definitions that should be used by the agent.

archivelogs Archives the agent logs so that they can be sent to Lumension.

proxysetup Configures your proxy server.

clearAgentLog Clears the agent error log file.

clearErrLog Clears the agent error log file.

clearDetectLog Clears the agent detection log file.

trimlogs Reduces the size of the error, agent, and detect log files. Oldest entries are
deleted and the file is truncated at 100,000 lines.

setagentnice Sets the agent's prioritization value.

help Displays the patch server script usage information.
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Appendix

A
Server Reference

In this appendix:

• Server Security

• Server Error Pages

• WinInet Error Codes

• HTTP Status Codes

• Agent Module Status Icons

• Defining Targets Using Wildcards

• Defining Targets Within an Imported
File

• Setting Up Lumension Endpoint
Management and Security Suite

• Restarting the STATEngine Service

• Specifying Content Mirrors for
CentOS

Within Lumension Endpoint Management and Security Suite, certain
pages or code messages notify you of errors or events.

Refer to this appendix for a thorough definition of these pages and
codes messages. This appendix also contains reference information
regarding endpoint statuses, how to define scan targets using imported
files, and how to restart the STATEngine Service.

Server Security
Lumension Endpoint Management and Security Suite limits access to only authorized users. Referring to the
definitions in this topic will help you understand how security operates within Windows and the product.

There are multiple layers of security for Lumension Endpoint Management and Security Suite (Lumension
EMSS). These layers include:

Web Site Authentication Internet Information Services (IIS) controls authentication for access to the
Lumension EMSS Web site, which means the operating system itself is
validating credentials.

Web Site Encryption via SSL SSL provides an encrypted wrapper around all Web communication to
and from the product. Therefore, installing Lumension EMSS with SSL
provides an additional level of protection.
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User (Security) Roles Every feature, page, and action throughout Lumension EMSS is assigned
to a series of access rights. These access rights combine to form a user
role. Roles also contain a list of accessible endpoints and endpoint groups.
Regardless of how a user is authenticated, the access and permissions are
defined solely by the Lumension EMSS administrator.

Server Error Pages
When an error occurs within Lumension Endpoint Management and Security Suite, a special page opens that
explains the error. Understanding these pages and what they mean will help you resume operations.

The Lumension Endpoint Management and Security Suite (Lumension EMSS) server provides several distinct
error pages. These pages are:

Access Denied Displays when a user fails to provide valid credentials during log in to the
Lumension EMSS server. Also display when a user attempts to access a
page or feature they do not have access to.

Internal Server Error Displays when an unspecified internal error occurs. In most cases, closing
the browser window and restarting your task will resolve the issue.

Refresh User Data Displays when the current session expires. Usually displays following an
extended period of inactivity.

Requested Page Not Found Displays when a user attempts to navigate to a nonexistent server address.
This page features links to other pages. Users can navigate from these links
back to the desired page.

System Component Version
Conflict

Displays when a system component version conflict is detected. To ensure
optimal behavior, the system components of Lumension EMSS are checked
every time a user logs in. If a conflict is detected, this page identifies the
component(s) that caused the conflict.

Note:  Lumension EMSS also sends a notification email to the Lumension
EMSS administrator when a conflict occurs.

Cache Expired Displays when the user session expires. Usually displays following an
extended period of inactivity.

Unsupported Browser Version Displays when a user attempts to open the Lumension EMSS server with an
unsupported browser.

WinInet Error Codes
Lumension Endpoint Management and Security Suite uses Microsoft Window Internet application programming
interface (WinInet API) for communication between the server and agents. When agent-server communication
fails, a WinInet error code displays. Understanding these codes can help you resolve the communication errors.
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The following table defines the most common error codes.

Note:  Refer to Microsoft Knowledgebase article #193625 (http://support.microsoft.com/default.aspx?scid=kb;EN-
US;193625) for additional WinInet error code descriptions.

Table 257: WinInet Error Code Descriptions

Agent Error Description WinInet Error Code Description

Head failed: Head request
failed. Error is 12002. .
Host=1116 HTTP Error=0

12002 The Internet connection timed out.

Head failed: Head request
failed. Error is 12031. .
Host=1109 HTTP Error=0

12031 The connection with the server has been
reset.

Head failed: Head request
failed. Error is 12007. .
Host=1109 HTTP Error=0

12007 The server name could not be resolved.

HTTP Status Codes
As a Web-based application that uses Internet Information Services (IIS), Lumension Endpoint Management
and Security Suite subsequently uses HTTP status codes. These codes appear when an HTTP error occurs while
using the product. Understanding these codes will help you solve any issue that may arise.

While many of the status codes are informational only, the following table defines a few of the common error
codes.

Table 258: HTTP Status Codes

Code Description

HTTP 401.1 - Login
failed

Log in attempt was unsuccessful (typically due to invalid user name or
password).

Note:  Lumension Endpoint Management and Security Suite
(Lumension EMSS) will display a custom error page (as defined under
Server Error Pages on page 524) instead of the default HTTP 401.1 -
Logon failed error page.

HTTP 403.4 - SSL
required

You must use HTTPS instead of HTTP when accessing this page.

HTTP 403.9 - Too many
users

The number of connected users exceeds the defined connection limit.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;193625
http://support.microsoft.com/default.aspx?scid=kb;EN-US;193625
http://support.microsoft.com/default.aspx?scid=kb;EN-US;193625
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Code Description

HTTP 404 - Not found The requested file cannot be found.

Note:  Lumension EMSS will display a custom error page (as defined
under Server Error Pages on page 524) instead of the default HTTP
404 - Not Found error page.

Agent Module Status Icons
Within Lumension Endpoint Management and Security Suite, icons are used to indicate agent statuses regarding
agent activity. These icons appear on various pages. By understanding these icons, you can understand what
activity is occurring on any specified patch endpoint.

The following table defines agent (endpoint) status and associated icons.

Table 259: Endpoint Status Icons

Active Pending Description

 

 

N/A The agent is currently working on a deployment (animated icon). Patch and
Remediation only.

 

 

 

 

The agent is idle, and has pending deployments. Patch and Remediation only.

 

 

 

 

The agent is offline.

 

 

 

 

The agent is sleeping due to its hours of operation settings.

 

 

 

 

This agent is disabled.

 

 

 

 

The agent is offline and is in a chain status (can accept chained deployments until
only after reboot). Patch and Remediation only.
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Active Pending Description

 

 

 

 

The agent is offline and is in a reboot status (can accept no more deployments until
after it reboots). Patch and Remediation only.

 

 

 

 

The agent is in a chain status (the agent can accept chained deployments only until
after a reboot). Patch and Remediation only.

 

 

 

 

The agent is in a reboot status (the agent can accept no more deployments until after
it reboots). Patch and Remediation only.

 

 

 

 

The agent is in a chain status (the agent can accept chained deployments only until
after a reboot) and is sleeping due to its hours of operation settings. Patch and
Remediation only.

 

 

 

 

The agent is in a reboot status (the agent can accept no more deployments until
after it reboots) and is sleeping due to its hours of operation settings. Patch and
Remediation only.

 

 

Unable to identify the agent status.

For more information about reboot and chained endpoint status, refer to Reboot and Chained State on page 215.

Defining Targets Using Wildcards
When configuring a discovery scan job or agent management job, you can define scan targets using wildcard IP
addresses. Wildcards are characters can be used to substitute for any other character or characters in a string. In
otherwords, you can use wildcards to scan for numerous IP address instead of just one. Use wildcards to scan
specific IP address ranges.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 528 -

The following table lists examples of how to define targets using wildcards.

Table 260: Wildcard Examples

Discovery Method Step Example Targets Defined

To define wildcard IP addresses: Type a wildcard
IP address using
commas (,).

Type a wildcard IP
address using dashes
(-).

Type a wildcard
IP address using
asterisks (*).

Type a wildcard
IP address using
Classless Inter-
Domain Routing
(CIDR).

10.1.1.2,9

10.1.1.2-5

10.1.1.*

10.1.1.0/24

10.1.1.2 and 10.1.1.9

10.1.1.2, 10.1.1.3,
10.1.1.4, and 10.1.1.5

10.1.1.0 through
10.1.1.255

10.1.1.0 through
10.1.1.255

To define IP ranges: Type two IP
addresses separated
by a greater-than sign
(>).

Type two IP
addresses separated
by a dash (-).

Note:  Dashes and
greater-than signs are
interchangeable.

10.1.1.2 > 10.1.1.9

10.1.1.2 - 10.1.1.9

10.1.1.2 through
10.1.1.9

10.1.1.2 through
10.1.1.9

To define wildcard IP addresses
using dashes in various octets:

Type a wildcard IP
address using dashes,
placing the dashes
where applicable.
You can use dashes
in any octet.

10.2-4.5.9

10.5.2-4.9

10.2.5.9, 10.3.5.9,
10.4.5.9

10.5.2.9, 10.5.3.9,
10.5.4.9

To define wildcard IP addresses
using asterisks in various octets:

Type a wildcard
IP address using
asterisks, placing
the asterisks where
applicable. You can
use asterisks in any
octet.

*.6.65.92

10.25.*.*

1.6.65.92 through
255.6.65.92

10.25.0.0 through
10.25.255.255
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Discovery Method Step Example Targets Defined

To define wildcard IP addresses
using commas in various octets:

Type a wildcard
IP address using
commas, placing
the commas where
applicable. You can
use commas in any
octet.

10.2.5,9,12.9

10,12,19.2.5.9

10.2.5.9, 10.2.9.9,
10.2.12.9

10.2.5.9, 12.2.5.9,
19.2.5.9

To define wildcard IP addresses
using a combination of wildcard
characters:

Type a wildcard
IP address using
dashes, commas, and
asterisks.

10-13.*.12.2,4,7

10.2-4.5,23.*

10, 11, 12,
13.0-255.12.2, 4, 7

10.2, 3, 4.5, 23.0-255

Defining Targets Within an Imported File
Using imported files, you can define job targets using a combination of single IP addresses, wildcard IP
addresses, IP ranges, DNS names, NetBIOS names, and so on. To create a file containing targets, open a text
editor that allows you to create .txt or .csv (like Notepad). This topic also explains how to use wildcards for
any job type.

The following table lists the methods you can use to define discovery methods within an importable file type, and
then follows those methods with examples. Use one method per line.

Table 261: Basic Use

Discovery
Method

Step Example Targets Defined

To define
single IP
addresses:

Type a single address. 10.1.1.2 10.1.1.2

To define
wildcard IP
addresses:

Type a wildcard IP address using
commas (,).

Type a wildcard IP address using dashes
(-).

Type a wildcard IP address using
asterisks (*).

Type a wildcard IP address using
Classless Inter-Domain Routing (CIDR).

10.1.1.2,9

10.1.1.2-5

10.1.1.*

10.1.1.0/24

10.1.1.2 and 10.1.1.9

10.1.1.2, 10.1.1.3,
10.1.1.4, and 10.1.1.5

10.1.1.0 through
10.1.1.255

10.1.1.0 through
10.1.1.255
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Discovery
Method

Step Example Targets Defined

To define IP
ranges:

Type two IP addresses separated by a
greater-than sign (>).

Type two IP addresses separated by a
dash (-).

Note:  Dashes and greater-than signs
are interchangeable.

10.1.1.2 > 10.1.1.9

10.1.1.2 - 10.1.1.9

10.1.1.2 through
10.1.1.9

10.1.1.2 through
10.1.1.9

To define DNS
names:

Type a DNS host name for an endpoint. DNS.dom.com The defined DNS name.

To define
NetBIOS
names:

Type a NetBIOS name for an endpoint. NetBIOSname The defined NetBIOS
name.

Table 262: Advanced Use

Discovery Method Steps Examples Targets Defined

To define wildcard IP
addresses using dashes in
various octets:

Type a wildcard IP
address using dashes,
placing the dashes where
applicable. You can use
dashes in any octet.

10.2-4.5.9

10.5.2-4.9

10.2.5.9, 10.3.5.9,
10.4.5.9

10.5.2.9, 10.5.3.9,
10.5.4.9

To define wildcard IP
addresses using asterisks
in various octets:

Type a wildcard IP
address using asterisks,
placing the asterisks
where applicable. You can
use asterisks in any octet.

*.6.65.92

10.25.*.*

1.6.65.92 through
255.6.65.92

10.35.0.0 through
10.35.255.255

To define wildcard IP
addresses using commas
in various octets:

Type a wildcard IP
address using commas,
placing the commas
where applicable. You can
use commas in any octet.

10.2.5,9,12.9

10,12,19.2.5.9

10.2.5.9, 10.2.9.9,
10.2.12.9

10.2.5.9, 12.2.5.9,
19.2.5.9

To define wildcard
IP addresses using a
combination of wildcard
characters:

Type a wildcard IP
address using dashes,
commas, and asterisks.

10-13.*.12.2,4,7

10.2-4.5,23.*

10, 11, 12, 13.0-255.12.2,
4, 7

10.2, 3, 4.5, 23.0-255
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Setting Up Lumension Endpoint Management and Security Suite
Following installation and initial log in, the Application Setup Manager dialog opens. This dialog appears
only once, the first time you log in to Lumension Endpoint Management and Security Suite and you use it to
configure basic options within the system.

Prerequisites:

Complete Lumension EMSS installation and open the Web console in your browser.

You cannot reopen this dialog following its completion. However, you can access these settings from various
Lumension EMSS pages.

1. Log in to Lumension EMSS. For additional information, refer to Logging In to Lumension Endpoint
Management and Security Suite on page 50.

Step Result: Lumension EMSS opens and the Application Setup Manager displays. This dialog only
appears the first time Lumension EMSS is opened.

2. Ensure the Customer Info tab is selected.

3. Type the applicable information in the following fields.

Field Description

First name Your first name.

Last name Your last name.

Company name Your company name. The company name specified during installation
appears by default but can be edited.

4. Click Apply.

5. Select the Languages tab.

6. Select the check boxes associated with the languages you want to receive content in.

Each content item available in Lumension EMSS may be available in multiple versions for different
languages.

Tip:  For information on how to select content languages outside of the Application Setup Manager, refer to
Configuring the Languages Tab on page 104.

7. Click Apply.

8. Select the Uninstall Password* tab.
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9. Define the global agent uninstall password.

This password can be used to manually uninstall Lumension EMSS agents and should be kept confidential.

Tip:  For information on how to edit this password outside of the Application Setup Manager, refer to
Defining the Global Uninstall Password on page 358.

10. Click Apply.

11. Select the Email Notifications tab.

12. Define the email information used for email notifications.

Email notifications are alerts sent by Lumension EMSS when certain system events occur.

Type the applicable information in the following fields.

Field Description

SMTP Host The local SMTP mail host name. Lumension EMSS uses your
corporate Internet (SMTP) mail server.

‘From’ email address The email address used when the system sends email notifications.

‘To’ email address An email address you use to receive system notifications.

Important:  When upgrading Lumension EMSS via a fresh installation, you must reconfigure your
email notifications after installing your licensed server modules. For additional details regarding Email
Notifications, refer to The Email Notifications Page section within the Lumension Endpoint Management and
Security Suite User Guide (http://portal.lumension.com).

13. Click Apply.

14. Select the Install an Agent tab.

15. [Optional] Select the Automatically install an agent on the server check box to install an agent on the
server.

a) Select the check boxes the applicable modules.

Selecting these modules activates agent functionality associated with the module.

Tip:  For additional information about installing an agent on the server outside of the Application Setup
Manager, refer to Downloading the Agent Installer on page 166.

16. Click Apply.

Step Result: You initial settings are applied.

17. Click Close.

Result: Initial configuration is complete. You are now ready to begin monitoring your network with Lumension
EMSS.

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com
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Restarting the STATEngine Service
If the STATEngine service is disabled on the Lumension Endpoint Management and Security Suite, you will
need to restart it before you can successfully complete discovery scan jobs and agent management jobs.

You can restart the STATEngine service from your server's command prompt.

Note:  If you try to configure a discovery scan job or agent management job while the STATEngine service is
stopped, a dialog will open, notifying you that the engine is stopped.

1. Select Start > Run.

2. Type net start statengine.

3. Click OK.

Result: The STATEngine is restarted. You can now configure discovery scan jobs and agent management jobs.

Specifying Content Mirrors for CentOS
In environments containing CentOS endpoints, Lumension recommends defining a Mirror site that your
Lumension Endpoint Management and Security Suite server can use to download CentOS Patch and
Remediation content. Using a mirror site increases content download speeds and reduces download traffic from
the CentOS community locations.

Prerequisites:

Complete Replicating on page 100.

Define a content mirror using your Web browser and the Lumension Endpoint Management and Security Suite
server Computer dialog.

Note:  Mirror site definition requires use of the Specify Site Mirror Tool. The Lumension Endpoint Management
and Security Suite server downloads this tool during its first replication with the Global Subscription Server.

1. Navigate to your regional CentOS mirror site.

Open your Web browser and enter the URI for your Region.

Region URI

North America (Countries and
States A-M)

http://www.centos.org/modules/tinycontent/index.php?id=30

North America (Countries and
States N-Z)

http://www.centos.org/modules/tinycontent/index.php?id=35

Europe (Countries and A-M) http://www.centos.org/modules/tinycontent/index.php?id=31

http://www.centos.org/modules/tinycontent/index.php?id=30
http://www.centos.org/modules/tinycontent/index.php?id=35
http://www.centos.org/modules/tinycontent/index.php?id=31
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Region URI

Europe (Countries N-Z) http://www.centos.org/modules/tinycontent/index.php?id=34

Other Regions http://www.centos.org/modules/tinycontent/index.php?id=32

2. From the Lumension Endpoint Management and Security Suite server, open a command prompt.

Context Description

To open a command prompt in
Windows 2003:

• Select Start.
• In the Start Search field, enter cmd.

To open a command prompt in
Windows 2008:

• Select Start > Run.
• In the Opencmd field, enter cmd.

3. From the command prompt, enter Program Files\Lumension\EMSS\Replication Services.

4. Enter SpecifyMirrorSite.exe /name:"MirrorServerName" /uri:"MirrorServerURI".

Note:

• This command only validates that the URI resolves. It does not validate CentOS data.
• Your Lumension Endpoint Management and Security Suite must allow outbound access though ports 80

and 443 to the chosen mirror.

5. [Optional] Validate the CentOS mirror locations.

Enter SpecifyMirrorSite.exe/validate.

http://www.centos.org/modules/tinycontent/index.php?id=34
http://www.centos.org/modules/tinycontent/index.php?id=32
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Appendix

B
Securing Your Server

In this appendix:

• Secure Your Server With SSL

• Use Secure Passwords

• Disabling File and Printer Sharing

• Placing Your Server Behind a
Firewall

• Disable Non-Critical Services

• Lock Down Unused TCP and UDP
Ports

• Apply All Security Patches

Lumension Endpoint Management and Security Suite protects your
network endpoints. Server operation is critical to your network's
overall security. To ensure your server is secure as possible,
Lumension suggests implementing several security practices.

These practices include:

• Securing your server with SSL
• Using secure passwords
• Disabling file and printer sharing
• Placing your sever behind a firewall
• Disabling non-critical services
• Disabling unused TCP and UDP ports
• Applying all security patches

Secure Your Server With SSL
Implement Secure Sockets Layer (SSL) to secure all Lumension Endpoint Management and Security Suite
communication.

SSL is a protocol used to secure data transmitted over the Internet. SSL support is included in Web browsers,
Web servers, and operating systems so that any type of agent and server can use authenticated and encrypted
communications over private and public networks. Lumension Endpoint Management and Security Suite
(Lumension EMSS) uses SSL when downloading vulnerability data and packages from the Global Subscription
Server. SSL is used for transmitting data between the Lumension EMSS Server and Lumension EMSS Agents
by enabling SSL during the installation of Lumension EMSS. The installation process requires obtaining a
SSL certificate (.CER). For details regarding installing with SSL enabled, refer to the Lumension Endpoint
Management and Security Suite: Server Installation Guide (http://portal.lumension.com).

Use Secure Passwords
When setting passwords for Lumension Endpoint Management and Security Suite, using secure passwords
significantly lowers the probability that your server can be compromised.

http://portal.lumension.com
http://portal.lumension.com
http://portal.lumension.com


Lumension Endpoint Management and Security Suite: Patch and Remediation

- 536 -

Worm attacks, which attempt to install malicious software on a target endpoint, frequently test log ins with weak
and commonly used passwords. For secure passwords, Lumension recommends a 12 character password that
combines mixed-case alpha characters, numeric characters, and punctuation characters.

Disabling File and Printer Sharing
When installing Lumension Endpoint Management and Security Suite, you should disable the File and Printer
Sharing for Microsoft Networks protocol on the target server. If this protocol is left active, it creates a security
risk that intruders can exploit: a Windows networking share. Therefore, File and Printer Sharing for Microsoft
Networks should be disabled.

Disabling File and Printer Sharing in Windows Server 2003
Disable File and Printer Sharing for Microsoft Networks on the Lumension Endpoint Management and Security
Suite server, as this protocol is an unnecessary security liability. This protocol is not necessary for your server to
function properly.

Disable this protocol from Windows Control Panel.

1. Select Start > Control Panel.

Step Result: Control Panel opens.

2. Double-click Network Connections.

3. Double-click the applicable Local Area Connection.

Step Result: The Local Area Connection Status dialog opens.
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4. Click Properties.

Step Result: The Local Area Connection Properties dialog opens.

Figure 209: Local Area Connection Properties

5. Clear the check box associated with File and Printer Sharing for Microsoft Networks.

Caution:  Do not disable Client for Microsoft Networks. It is required by both Microsoft SQL Server and
Internet Information Server.

6. Click OK.

Result: File and Printer Sharing for Microsoft Networks is disabled.

Disabling File and Printer Sharing in Windows Server 2008
Disable File Sharing and Printer Sharing on the Lumension Endpoint Management and Security Suite server, as
this protocol is an unnecessary security liability. These protocols are not necessary for your server to function
properly.

Disable these protocols from Control Panel.

1. Select Start > Control Panel.

Step Result: Control Panel opens.

2. Double-click Network and Sharing Center.

Step Result: The Network and Sharing Center opens.

3. Ensure File Sharing is set to Off.
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4. Ensure Printer Sharing is set to Off.

5. Close Network and Sharing Center.

Result: File Sharing and Printer Sharing are disabled.

Placing Your Server Behind a Firewall
Lumension recommends placing your Lumension Endpoint Management and Security Suite server behind a
firewall. This measurement is considered best-practice.

Since the Lumension Endpoint Management and Security Suite server receives content updates from the Global
Subscription Server (GSS), allowing the Lumension Endpoint Management and Security Suite server Internet
access is unnecessary. However, access to the GSS must be specified in your firewall configuration.

Disable Non-Critical Services
Lumension Endpoint Management and Security Suite only requires several essential services to operate.
Disabling services that are not critical to its operation reduces security risks.

The default installation of Microsoft Windows sets most features and services to active. Therefore, there are
a number of services that can be disabled (e.g.: RPC, Remote Registry, etc.) to reduce security compromises.
Although Lumension does not encourage this type of lock down, it can be an effective method to reduce the risk
of hacker attacks. The following services are required to run Lumension Endpoint Management and Security
Suite:

• World Wide Web Publishing Service
• IIS Admin Service
• SQL Server
• Replication Service
• STATEngine

Lock Down Unused TCP and UDP Ports
Unused ports pose a security risk to Lumension Endpoint Management and Security Suite servers that operate on
the Windows Server 2003 platform. Therefore, these ports should be closed.

Use a firewall to prevent network traffic on various unused and vulnerable TCP and UDP ports. However, if a
firewall is not available or additional server-level disablement is desired, TCP and UDP ports can be disabled as
a function of the network connection.

Note:  Ports cannot be closed from the Local Area Connection Properties dialog within Windows Server 2008.
Therefore, Lumension does not recommend disabling the firewall when using Lumension Endpoint Management
and Security Suite in a Windows Server 2008 environment.
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Disabling Unused Ports in Windows Server 2003
Lock down unused ports when a firewall is not in place on the server.

1. Select Start > Control Panel.

Step Result: Control Panel opens.

2. Double-click Network Connections.

3. Double-click the applicable Local Area Connection.

4. Ensure the General tab is selected.

5. Click Properties.

Step Result: The Local Area Connection Properties dialog opens.

Figure 210: Local Area Connection Properties Dialog

6. Select the Internet Protocol (TCP/IP) protocol.
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7. Click Properties.

Step Result: The Internet Protocol (TCP/IP) Properties window opens.

Figure 211: Internet Protocol (TCP/IP) Properties

8. In the General tab, click Advanced.

Step Result: The Advanced TCP/IP Settings window opens.

9. Select the Options tab.

10. Select TCP/IP Filtering.
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11. Click Properties.

Step Result: The TCP/IP Filtering window opens.

Figure 212: TCP/IP Filtering

12. Enable the Enable TCP/IP Filtering (All Adapters) option.

13. Select the Permit Only TCP Ports option.

14. Add TCP ports 443 and 80 to the listing of permitted ports.

a) Click Add.

Step Result: The Add Filter window opens.

b) Type 443 in the TCP Port field.
c) Click OK.

Step Result: The Add Filter window closes.

d) Repeat steps a, b, and c to add port 80.

Note:  No other ports are required, although you may want to enable additional ports to allow DNS, TS,
or VNC.

15. Select the Permit Only UDP Ports option, leaving the UDP Ports window blank since no UDP ports are
required.

16. Click OK.

17. Close the open windows.

After Completing This Task:

Since all ports are disabled (except for ports 80 and 443), it will be necessary to add entries to your proxy or
HOSTS file for the necessary Lumension Web sites and the Global Subscription Server.
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Apply All Security Patches
The Lumension Endpoint Management and Security Suite server should have the most recent security patches
installed.

Apply all applicable Microsoft Security Patches to ensure that the server remains protected against all known
security threats. Be sure to apply the most recent patches for Internet Information Services, SQL Server, and the
version of Windows server in use.
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Appendix

C
Configuring the Server and Endpoints for Agent
Management Jobs

In this appendix:

• Configuring the Lumension EMSS
Server for Discovery Scanning

• Port and ICMP Requirements for
Agent Management Jobs

• Configuring Windows XP and
Windows Server 2003 Endpoints for
Discovery

• Configuring Windows XP and
Windows Server 2003 Endpoints for
Agent Management Jobs

• Configuring Vista or Later Endpoints
for Discovery

• Configuring Vista or Later Endpoints
for Agent Management Jobs

• Troubleshooting Agent Management
Jobs

• Installing Agents by Agent
Management Job

• Uninstalling Agents by Agent
Management Job

• Defining Targets Using Wildcards

After installing Lumension Endpoint Management and Security
Suite on a server, you must perform additional configuration on the
endpoints that you want to manage so that agent management jobs will
complete successfully.

Agent Management jobs consist of two parts: endpoint discovery and
agent management itself. During discovery, the Lumension Endpoint
Management and Security Suite server locates the endpoint you want
to install an agent on. During agent management, the agent is installed
(or uninstalled). Discovery jobs run only the discovery process. Agent
management jobs run the discovery process and the agent management
process.

To configure a Windows XP or Windows Server 2003 endpoint for
discovery or agent management, complete one of the following tasks:

1. Configuring Windows XP and Windows Server 2003 Endpoints for
Discovery on page 545

2. Configuring Windows XP and Windows Server 2003 Endpoints for
Agent Management Jobs on page 553

To configure a Windows Vista or later endpoint for discovery or agent
management, complete one of the following tasks:

1. Configuring Vista or Later Endpoints for Discovery on page 564
2. Configuring Vista or Later Endpoints for Agent Management Jobs

on page 573

Tip:  In environments where you want to prohibit agent management
jobs for security purposes, you can still discover endpoints with
minimal security risk. To activate discovery functions (but not agent
management) complete only the listed discovery procedures.
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Configuring the Lumension EMSS Server for Discovery Scanning
The Lumension Endpoint Management and Security Suite server must be configured in the following manner so
that you can run agent management jobs on your managed endpoints.

1. Click Start > Run.

2. Enter regedit in the Open field.

3. Click OK.

Step Result: The registry editor displays.

4. In the registry editor, navigate to HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\Control\Lsa.

5. Verify that the value for the lmcompatibilitylevel registry key is set to 3.

Note:  Under most network conditions, a setting of 3 is sufficient. However, in some networks, this key may
require a different value. To determine which value to use, refer to How to Enable NTLM 2 Authentication
(http://support.microsoft.com/kb/239869).

Result: The Lumension Endpoint Management and Security Suite Server is configured for discovery scanning.

After Completing This Task:

If you are configuring the Lumension Endpoint Management and Security Suite server for scanning in
preparation for agent management jobs, continue to endpoint configuration. For additional information about
endpoint configuration for agent management jobs, refer to one of the following topics:

• Configuring Windows XP and Windows Server 2003 Endpoints for Agent Management Jobs on page 553
• Configuring Vista or Later Endpoints for Agent Management Jobs on page 573

Port and ICMP Requirements for Agent Management Jobs
In environments that use third-party firewalls to protect endpoints, you must first create firewall exceptions for
successfull completion of agent management jobs. These exceptions will also allow discovery scan jobs to return
more detailed information about endpoints.

http://support.microsoft.com/kb/239869
http://support.microsoft.com/kb/239869
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Within your firewall application, open the ports listed in the following table.

Table 263: Required Ports

Required Ports Description

• 445/TCP
• 139/UDP
• 135/UDP
• 137/UDP

Lumension EMSS uses these ports to access the endpoint during the installation
process of the agent management job. Discovery scan jobs also use this ports
to discovery information about the endpoint. After the agent management job
completes, you can reclose these ports.

• 443/TCP
• 80/TCP

Following agent installation, the Lumension EMSS Agent uses these ports to
register and communicate with the Lumension EMSS Server. After the agent
management job completes, you should leave these ports open.

Additionally, both discovery scan jobs and agent managements jobs require the endpoint to accept pings from the
Lumension EMSSserver. Therefore, you should also create an exception for inbound ICMP echo requests within
your third-party firewall.

Configuring Windows XP and Windows Server 2003 Endpoints for
Discovery

Configuring Windows XP and Windows Server 2003 endpoints for discovery will make them available for
scanning during discovery scan jobs.

Note:  If your organization uses a third-party firewall:

• Do not complete the steps in this procedure for creating Windows Firewall exceptions. Your third-party
firewall makes them unnecessary.

• You must create exceptions for Lumension EMSS within you third-party firewall. For additional information,
refer to Port and ICMP Requirements for Agent Management Jobs on page 544.

You can perform this procedure on endpoints that have Windows XP or Windows 2003 installed. When starting
this procedure, first ensure that the services necessary for successful discovery scanning are started.

1. Select Start > Control Panel.

Step Result: Control Panel opens.
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2. Double-click Administrative Tools.

Step Result: The Administrative Tools dialog opens.

Figure 213: Administrative Tools Dialog

3. Double-click Services.

Step Result: The Services dialog opens.

Figure 214: Services Dialog
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4. Ensure the necessary services are started.

The following list itemizes the services that must be started for job completion.

Note:  In environments that use a third-party firewall, ensure the Windows Firewall/Internet Connection
Sharing service is instead disabled.

• DCOM Server Process Launcher
• Remote Procedure Call (RPC)
• Server
• Windows Firewall/Internet Connection Sharing (ICS)
• Windows Management Instrumentation

If all of the listed services required for your configuration purposes have a Server status of Started, continue
to the next step. If any of the listed services for your configuration purposes are not started, complete the
following substeps to start them.

a) Right-click the applicable service and select Properties.

Step Result: The properties dialog for the service opens.

b) Ensure the Startup type list is set to Automatic. If edits are necessary, click Apply after selecting
Automatic from the list.

c) Click Start.

Step Result: The service starts.

d) Click OK

Step Result: The properties dialog for the service closes.

e) If necessary, repeat the substeps for each unstarted service.

5. Close the Services dialog and the Administrative Tools dialog.

Next, ensure that File and Printer Sharing is enabled. Enabling this setting returns more detailed results for the
endpoint name during discovery scanning.

Tip:  Enabling File and Printer Sharing is optional. However, if you do enable it, you must create a firewall
exception for it.

6. [Optional] Select Start > Control Panel.

Step Result: Control Panel opens.

7. [Optional] Double-click Network Connections.

Step Result: The Network Connections dialog opens.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 548 -

8. [Optional] Right-click your local area connection and select Properties.

Step Result: The Local Area Connection Properties dialog opens.

Figure 215: Local Area Connection Properties Dialog

9. [Optional] Ensure the File and Printer Sharing for Microsoft Networks check box is selected.

10. [Optional] Click OK.

Step Result: The Local Areaa Connection Properties dialog closes.

11. [Optional] Close the Local Area Connections Status dialog and the Network Connections dialogs.

Next, ensure the Windows Firewall is configured to allow exceptions for discovery scans. A Windows
Firewall that does not allow exceptions will blocks pings and other discovery scan processes. Ensure that
firewall exceptions are in place for successful discovery scanning.



Configuring the Server and Endpoints for Agent Management Jobs

- 549 -

Create the firewall exceptions using the Local Group Policy Editor. Create exceptions for both the standard
and domain profiles.

Note:  In environments using a third-party firewall, do not complete the steps to create Windows Firewall
exceptions. Instead, complete create exceptions in your third-party firewall. For additional information, refer
to Port and ICMP Requirements for Agent Management Jobs on page 544.

12. Select Start > Run.

Step Result: The Run prompt opens.

13. Type gpedit.msc in the Open field and press ENTER.

Step Result: The Group Policy dialog opens.

Figure 216: Group Policy Dialog

Once you have selected the domain profile, you must configure the following firewall exception settings (and
their subsettings) for discovery purposes.

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exceptions
• Windows Firewall: Allow ICMP exceptions

The following steps fully explain how to configure eash setting.

14. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Domain Profiles. Ensure the Domain Profiles
folder is selected.

15. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Properties.

Step Result: The exception dialog opens.

b) Ensure the Disabled option is selected.
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c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured.

16. [Optional] Configure the Windows Firewall: Allow file and printer sharing exceptions setting.

Tip:  Enable this setting if you turned on File and Printer Sharing earlier in the procedure.

a) From the main pane, right-click Windows Firewall: Allow file and printer sharing exceptions and
select Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow file and printer sharing exceptions setting is configured for
discovery scanning.

17. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Ensure the Allow inbound echo request check box is selected.
d) Ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured.

After configuring firewall exceptions for the domain profile, you must also complete identical steps to
configure firewall exceptions for your standard profile.

Configure the following settings for discovery purposes:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exception
• Windows Firewall: Allow ICMP exceptions
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The following steps fully explain how to configure each setting.

18. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Standard Profiles. Ensure the Standard Profiles
folder is selected.

19. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Properties.

Step Result: The exception dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured.

20. [Optional] Configure the Windows Firewall: Allow file and printer sharing exceptions setting.

Tip:  Enable this setting if you turned on File and Printer Sharing earlier in the procedure.

a) From the main pane, right-click Windows Firewall: Allow file and printer sharing exceptions and
select Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow file and printer sharing exceptions setting is configured for
discovery scanning.

21. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Ensure the Allow inbound echo request check box is selected.
d) Ensure all other check boxes are cleared.
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e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured.

22. Close the Group Policy dialog.

Step Result:
Note:  The creation of Windows Firewall exceptions opens the following ports, which are
required for job completion:

• 445/TCP
• 139/UDP
• 135/UDP
• 137/UDP

Finally, complete configuration of your endpoint by ensuring the C$ and ADMIN$ network shares are shared.
Enabling these shares lets the Lumension EMSS server access your endpoint.

23. Select Start > Run.

Step Result: The Run prompt opens.

24. In the Open field, type cmd and press ENTER.

Step Result: The Command Prompt opens.

25. From the Command Prompt, type net share and press ENTER.

Step Result: The endpoint network shares are listed.

26. Ensure that the following shares are listed in the Share name column.

• C$

• ADMIN$

If they are already listed, proceed to the next step. If these shares are not listed, complete the following
substeps to enable them. If one of the necessary shares is enabled but not the other, only enable the share that
needs to be enabled.

a) From the Command Prompt, type the necessary command(s) to enable any required network shares.

• To enable the C$ share, type NET SHARE C$=C and press ENTER.
• To enable the ADMIN$ share, type NET SHARE ADMIN$ and press ENTER.

Step Result: You have enabled the required share(s). All enabled shares remain active until the system
reboots.
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27. Close the Command Prompt.

Step Result: The Command Prompt closes.

Result: The endpoint can now be discovered during discovery scan jobs.

Configuring Windows XP and Windows Server 2003 Endpoints for
Agent Management Jobs

Before you can remotely install agents on your Windows XP and Windows Server 2003 endpoints, you must first
configure your endpoints for agent management jobs. Endpoint configuration for agent management includes
starting the required services; enabling file and print sharing; creating firewall exceptions, configuring your
NTLM settings, and enabling network shares.

Complete these instructions from the Windows 2003 or Windows XP endpoint you want to configure for agent
management.

Note:  If your organization uses a third-party firewall:

• Do not complete the steps in this procedure for creating Windows Firewall exceptions. Your third-party
firewall makes them unnecessary.

• You must create exceptions for Lumension EMSS within you third-party firewall. For additional information,
refer to Port and ICMP Requirements for Agent Management Jobs on page 544.

First, ensure that the services necessary for successful agent management are started.

1. Select Start > Control Panel.

Step Result: Control Panel opens.
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2. Double-click Administrative Tools.

Step Result: The Administrative Tools dialog opens.

Figure 217: Administrative Tools Dialog

3. Double-click Services.

Step Result: The Services dialog opens.

Figure 218: Services Dialog
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4. Ensure the necessary services are started.

The following list itemizes the services that must be started for job completion.

Note:  In environments that use a third-party firewall, ensure the Windows Firewall/Internet Connection
Sharing service is instead disabled.

• DCOM Server Process Launcher
• Remote Procedure Call (RPC)
• Server
• Windows Firewall/Internet Connection Sharing (ICS)
• Windows Management Instrumentation

If all of the listed services required for your configuration purposes have a Server status of Started, continue
to the next step. If any of the listed services for your configuration purposes are not started, complete the
following substeps to start them.

a) Right-click the applicable service and select Properties.

Step Result: The properties dialog for the service opens.

b) Ensure the Startup type list is set to Automatic. If edits are necessary, click Apply after selecting
Automatic from the list.

c) Click Start.

Step Result: The service starts.

d) Click OK

Step Result: The properties dialog for the service closes.

e) If necessary, repeat the substeps for each unstarted service.

5. Close the Services dialog and the Administrative Tools dialog.

Next, ensure Simple File Sharing is disabled on the endpoint. You must have this setting disabled so that the
Lumension EMSS can access the neccessary files during agent installation; Simple File Sharing can prevent
this process.

6. Select Start > My Computer.

Step Result: The My Computer dialog opens.

7. From the dialog toobar, select Tools > Folder Options.

Step Result: The Folder Options dialog opens.

8. Select the View tab.

Step Result: The View tab opens.

9. Ensure the Use simple file sharing (Recommended) check box is clear. You may have to scroll to find this
setting.
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10. Click OK.

11. Close the My Computer dialog.

Next, ensure File and Printer sharing is enabled. To install an agent on you endpoint, Lumension EMSS needs
access to certain endpoint folders. Enabling File and Printer sharing grants this access.

12. Select Start > Control Panel.

Step Result: Control Panel opens.

13. Double-click Network Connections.

Step Result: The Network Connections dialog opens.

14. Right-click your local area connection and select Properties.

Step Result: The Local Area Connection Properties dialog opens.

Figure 219: Local Area Connection Properties Dialog

15. Ensure the File and Printer Sharing for Microsoft Networks check box is selected.

16. Click OK.

Step Result: The Local Areaa Connection Properties dialog closes.

17. Close the Local Area Connections Status dialog and the Network Connections dialogs.
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Next, ensure Windows Firewall is configured to allow exceptions for agent management jobs. A Windows
Firewall that does not allow exceptions will block pings and other agent management processes. Ensure that
firewall exceptions are in place for successfull agent management.

Create the firewall exceptions using the Local Group Policy Editor. Create exceptions for both the standard
and domain profiles.

Note:  In environments using a third-party firewall, do not complete the steps to create Windows Firewall
exceptions. Instead, complete create exceptions in your third-party firewall. For additional information, refer
to Port and ICMP Requirements for Agent Management Jobs on page 544.

18. Select Start > Run.

Step Result: The Run prompt opens.

19. Type gpedit.msc in the Open field and press ENTER.

Step Result: The Group Policy dialog opens.

Figure 220: Group Policy Dialog

Next, ensure firewall exceptions are created for the domain profile. These settings allow the Lumension EMSS
to access the endpoint through the firewall.

While in this dialog, ensure the settings (and their subsettings) are configured for agent management jobs:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow remote administration exceptions
• Windows Firewall: Allow file and printer sharing exceptions
• Windows Firewall: Allow ICMP exceptions

Configure the following settings (and their subsettings) for agent management purposes:

20. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Domain Profiles. Ensure the Domain Profiles
folder is selected.
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21. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Properties.

Step Result: The exception dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured.

22. Configure the Windows Firewall: Allow remote administration exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow remote administration exceptions and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow remote administration exceptions setting is configured for
agent management.

23. Configure the Windows Firewall: Allow file and printer sharing exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow file and printer sharing exceptions and
select Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow file and printer sharing exceptions setting is configured for
agent management.
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24. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Ensure the Allow inbound echo request check box is selected.
d) Ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured.

After configuring firewall exceptions for the domain profile, you must also complete identical steps to
configure firewall exceptions for your standard profile.

Configure the following settings (and their subsettings) for agent management purposes:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow remote administration exception
• Windows Firewall: Allow file and printer sharing exception
• Windows Firewall: Allow ICMP exceptions

The following steps fully explain how to configure each setting.

25. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Standard Profiles. Ensure the Standard Profiles
folder is selected.

26. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Properties.

Step Result: The exception dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured.

27. Configure the Windows Firewall: Allow remote administration exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow remote administration exceptions and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
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c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension
recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow remote administration exceptions setting is configured for
agent management.

28. Configure the Windows Firewall: Allow file and printer sharing exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow file and printer sharing exceptions and
select Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow file and printer sharing exceptions setting is configured for
agent management.

29. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select
Properties.

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Ensure the Allow inbound echo request check box is selected.
d) Ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured.
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30. Close the Group Policy dialog.

Step Result:
Note:  The creation of Windows Firewall exceptions opens the following ports, which are
required for job completion:

• 445/TCP
• 139/UDP
• 135/UDP
• 137/UDP

Next, ensure your endpoint has an NTLM setting that is compatible with the Lumension EMSS server. You
can define this setting for your endpoint within the Registry Editor.

31. Select Start > Run.

Step Result: The Run prompt opens.

32. In the Open field, type regedit and press ENTER.

Step Result: The Registry Editor opens.

Figure 221: Registry Editor

33. In the tree panel, expand the registry to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
\Lsa. Ensure the Lsa folder is selected.

Step Result: The Lsa folder keys open in the main panel.

34. In the main panel, double-click lmcompatibilitylevel.

Step Result: The Edit DWORD Value dialog for the lmcompatibilitylevel key opens.
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35. Ensure that the Value data field is set to one of the following values:

• 3
• 5

If the field is not set correctly, complete the following substeps.

Note:  Under most network conditions, a setting of 3 or 5 is sufficient. However, in some networks, this key
may require a different value. To determine which value to use, refer to How to enable NTLM 2 authentication
(http://support.microsoft.com/kb/239869).

a) In the Value data field, type 3 or 5 (unless another value is required).
b) Click OK.

36. Close the Registry Editor.

Next, complete configuration of your endpoint by ensuring that the C$ and ADMIN$ network shares are
enabled. These shares are required for agent management job completion.

37. Select Start > Run.

Step Result: The Run prompt opens.

38. In the Open field, type cmd and press ENTER.

Step Result: The Command Prompt opens.

39. From the Command Prompt, type net share and press ENTER.

Step Result: The endpoint network shares are listed.

40. Ensure that the following shares are listed in the Share name column.

• C$

• ADMIN$

If they are already listed, proceed to the next step. If these shares are not listed, complete the following
substeps to enable them. If one of the necessary shares is enabled but not the other, only enable the share that
needs to be enabled.

a) From the Command Prompt, type the necessary command(s) to enable any required network shares.

• To enable the C$ share, type NET SHARE C$=C and press ENTER.
• To enable the ADMIN$ share, type NET SHARE ADMIN$ and press ENTER.

Step Result: You have enabled the required share(s). All enabled shares remain active until the system
reboots.

41. Close the Command Prompt.

Step Result: The Command Prompt closes.

http://support.microsoft.com/kb/239869
http://support.microsoft.com/kb/239869
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For Windows Server 2003 and Windows XP 64-bit endpoints, ensure WMI Windows Installer Provider is
installed. This Management and Monitoring Tool is used to complete agent management uninstall jobs. The
tool is not installed by default on these operating systems. Windows XP 32-bit endpoints come with this tool
installed by default.

Note:  These steps apply only to Windows Server 2003 and Windows XP 64-bit endpoints. You do not have
to complete these steps for Windows XP 32-bit endpoints.

42. Select Start > Control Panel.

Step Result: Control Panel opens.

43. Double-click Add or Remove Programs.

Step Result: The Add or Remove Programs dialog opens.

44. Click Add/Remove Windows Components.

Step Result: The Windows Components Wizard opens.

45. Select Management and Monitoring Tools and ensure the check box is selected.

46. Click Details.

Step Result: The Management and Monitoring Tools dialog opens.

47. Ensure the WMI Windows Installer Provider check box is selected and click OK.

Tip:  If Management and Monitoring Tools and WMI Windows Installer Provider are already installed, you
do not need to complete the remaining steps. Continue to the end of the procedure.

48. Click Next.

Step Result: Installation of WMI Windows Installer Provider begins.

49. When prompted, insert your Windows installation disc and continue the install. Repeat this step as needed.

Step Result: Installation continues.

50. Click Finish and restart the endpoint.

Result: The endpoint is configured for agent management.
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Configuring Vista or Later Endpoints for Discovery
For Lumension Endpoint Management and Security Suite to discover Windows Vista or later endpoints, they
must have both network discovery and file sharing enabled. Target endpoints without these features enabled will
not be discovered.

Note:  If your organization uses a third-party firewall:

• Do not complete the steps in this procedure for creating Windows Firewall exceptions. Your third-party
firewall makes them unnecessary.

• You must create exceptions for Lumension EMSS within you third-party firewall. For additional information,
refer to Port and ICMP Requirements for Agent Management Jobs on page 544.

You can perform this procedure on endpoints with the following operating systems:

• Windows Vista
• Windows 7
• Windows 8
• Windows Server 2008
• Windows Server 2012

First, ensure that the servcies necessary for successful discovery scanning are started.

1. Open Control Panel.

Operating System Steps

Windows Vista, Windows 7, or
Windows Server 2008

Select Start > Control Panel.

Windows 8 or Windows Server
2012

1. Press the Windows Logo key.
2. Type Control Panel and press ENTER.

Step Result: Control Panel opens.

2. Ensure Control Panel is set to the Control Panel Home or Category view.

If Control Panel is already in this view, procede to the next step. If it is not set to this view, complete the step
applicable to your operating system.

Operating System Step

Windows Vista or Windows
Server 2008

Click Control Panel Home.
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Operating System Step

Windows 7, Windows 8, or
Windows Server 2012

From the View by list, select Category.

3. Open your system settings.

Operating System Step

Windows Vista or Windows
Server 2008

Click System and Maintenance.

Windows 7, Windows 8, or
Windows Server 2012

Click System and Security.

Step Result: Control Panel opens to the system options.

4. Click Administrative Tools.

Step Result: The Administrative Tools dialog opens.

5. Double-click Services.

Step Result: The Services dialog opens.

Figure 222: Services Dialog
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6. Ensure the necessary services are started.

The following list itemizes the services that must be started for job completion.

Note:  In environments that use a third-party firewall, ensure the Windows Firewall service is instead
disabled.

• DCOM Server Process Launcher
• Remote Procedure Call (RPC)
• Server
• Windows Firewall
• Windows Management Instrumentation

If all of the listed services required for your configuration purposes have a Server status of Started, continue
to the next step. If any of the listed services for your configuration purposes are not started, complete the
following substeps to start them.

a) Right-click the applicable service and select Properties.

Step Result: The properties dialog for the service opens.

b) Ensure the Startup type list is set to Automatic. If edits are necessary, click Apply after selecting
Automatic from the list.

c) Click Start.

Step Result: The service starts.

d) Click OK

Step Result: The properties dialog for the service closes.

e) If necessary, repeat the substeps for each unstarted service.

7. Close the Services dialog and the Administrative Tools dialog.

Tip:  Leave Control Panel open.

Next, ensure your Network and Discovery settings are configured to allow discovery. The discovery setting
allows the endpoint to be seen by the Lumension EMSS server during discovery scanning.

8. From Control Panel, click Network and Internet.

Step Result: Control Panel opens to the Network and Internet options.

9. Click Network and Sharing Center.

Step Result: Control Panel opens to the Network and Sharing Center.
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10. Ensure Network discovery is enabled. Enabling this setting makes the endpoint publically known within
network. Lumension EMSS uses the information shared by this setting to return more detailed information
about the endpoint during discovery scanning.

Based on the endpoint operating system, complete the applicable substeps that follow.

Operating System Substep

Windows Vista or Windows
Server 2008:

1. Click the arrow icon adjacent to Network discovery.
2. Ensure the Turn on network discovery option is selected.
3. If necessary, click Apply.

Windows 7: 1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Home or Work
• Public
• Domain

3. Scroll to Network discovery.
4. Ensure the Turn on network discovery option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.

Windows 8 or Windows Server
2012:

1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Private
• Guest or Public
• Domain

3. Scroll to Network discovery.
4. Ensure the Turn on network discovery option is selected.
5. Ensure the Turn on automatic setup of network connected

devices option is cleared.
6. If necessary, click Save Changes.
7. Repeat these substeps for each profile section.

11. [Optional] Ensure File sharing is enabled.

Tip:  Completion of this step is optional. However, if you enable File Sharing, you must also create a firewall
exception for it.



Lumension Endpoint Management and Security Suite: Patch and Remediation

- 568 -

Based on the endpoint operating system, complete the applicable substeps that follow.

Operating System Steps

Windows Vista and Windows
Server 2008:

1. Click the arrow icon adjacent to File Sharing.
2. Ensure the Turn on file sharing option is selected.
3. If necessary, click Apply.

Windows 7: 1. Ensure you have clicked Advanced sharing settings.
2. Expand one of the following sections:

• Home or Work
• Public
• Domain

3. Scroll to File and printer sharing.
4. Ensure the Turn on file and printer sharing option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.

Windows 8 or Windows Server
2012:

1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Private
• Guest or Public
• Domain

3. Scroll to File and printer.
4. Ensure the Turn on file and printer sharing option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.

12. Close Network and Sharing Center.

Step Result: Network and Sharing Center closes.

13. Close Network and Sharing Center.

Step Result: Network and Sharing Center closes.

Next, ensure the Windows Firewall is configured to allow exceptions for discovery scans. A Windows
Firewall that does not allow exceptions will blocks pings and other discovery scan processes. Ensure that
firewall exceptions are in place for successful discovery scanning.
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Create the firewall exceptions using the Local Group Policy Editor. Create exceptions for both the standard
and domain profiles.

Note:  In environments using a third-party firewall, do not complete the steps to create Windows Firewall
exceptions. Instead, complete create exceptions in your third-party firewall. For additional information, refer
to Port and ICMP Requirements for Agent Management Jobs on page 544.

14. Open a run prompt.

Operating System Steps

Windows Vista, Windows 7,
and Windows Server 2008:

1. Select the Start menu.
2. Type run in the Search field and press ENTER.

Windows 8 or Windows Server
2012:

1. Press the Windows Logo key.
2. Type run and press ENTER.

Step Result: The Run prompt opens.

15. Type gpedit.msc in the Open field and press ENTER.

Step Result: The Local Group Policy Editor opens.

Note:  In Windows Vista, this dialog is called the Group Policy Object Editor.

Figure 223: Local Group Policy Editor

Once you have selected the domain profile, you must configure the following firewall exception settings (and
their subsettings) for discovery purposes.

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exceptions
• Windows Firewall: Allow ICMP exceptions
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The following steps fully explain how to configure eash setting.

16. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Domain Profiles. Ensure the Domain Profiles
folder is selected.

17. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured for agent
management.

18. [Optional] Configure the Windows Firewall: Allow inbound file and printer sharing exceptions setting.

Tip:  Enable this setting if you turned on File and Printer Sharing earlier in the procedure.

a) From the main pane, right-click Windows Firewall: Allow inbound file and printer sharing exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow inbound file and printer sharing exceptions setting is
configured for discovery scanning.

19. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Within Options, ensure the Allow inbound echo request check box is selected.
d) Within Options, ensure all other check boxes are cleared.
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e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured for agent
management.

After configuring firewall exceptions for the domain profile, you must also complete identical steps to
configure firewall exceptions for your standard profile.

Configure the following settings for discovery purposes:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exception
• Windows Firewall: Allow ICMP exceptions

The following steps fully explain how to configure each setting.

20. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Standard Profiles. Ensure the Standard Profiles
folder is selected.

21. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured for agent
management.

22. [Optional] Configure the Windows Firewall: Allow inbound file and printer sharing exceptions setting.

Tip:  Enable this setting if you turned on File and Printer Sharing earlier in the procedure.

a) From the main pane, right-click Windows Firewall: Allow inbound file and printer sharing exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)
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d) Click OK.

Step Result: The Windows Firewall: Allow inbound file and printer sharing exceptions setting is
configured for discovery scanning.

23. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Within Options, ensure the Allow inbound echo request check box is selected.
d) Within Options, ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured for agent
management.

24. Close the Local Group Policy Editior (or the Group Policy Object Editor).

Step Result:
Note:  The creation of Windows Firewall exceptions opens the following ports, which are
required for job completion:

• 445/TCP
• 139/UDP
• 135/UDP
• 137/UDP

Finally, complete configuration of your endpoint by ensuring the C$ and ADMIN$ network shares are shared.
Enabling these shares lets the Lumension EMSS server access your endpoint.

25. Open the Command Prompt.

Operating System Steps

Windows Vista, Windows 7,
and Windows Server 2008:

1. Select the Start menu.
2. Type cmd in the Search field and press ENTER.

Windows 8 or Windows Server
2012:

1. Press the Windows Logo key.
2. Type cmd and press ENTER.

26. From the Command Prompt, type net share and press ENTER.

Step Result: The endpoint network shares are listed.
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27. Ensure that the following shares are listed in the Share name column.

• C$

• ADMIN$

If they are already listed, proceed to the next step. If these shares are not listed, complete the following
substeps to enable them. If one of the necessary shares is enabled but not the other, only enable the share that
needs to be enabled.

a) From the Command Prompt, type the necessary command(s) to enable any required network shares.

• To enable the C$ share, type NET SHARE C$=C and press ENTER.
• To enable the ADMIN$ share, type NET SHARE ADMIN$ and press ENTER.

Step Result: You have enabled the required share(s). All enabled shares remain active until the system
reboots.

28. Close the Command Prompt.

Step Result: The Command Prompt closes.

Result: The endpoint is configured for discovery.

Configuring Vista or Later Endpoints for Agent Management Jobs
Before you can remotely install agents on your Windows Vista or later endpoints, you must first configure
your endpoints for agent management jobs. Endpoint configuration for agent management includes starting the
required services; editing your sharing and discovery settings; creating firewall exceptions; and enabling network
shares.

Note:  If your organization uses a third-party firewall:

• Do not complete the steps in this procedure for creating Windows Firewall exceptions. Your third-party
firewall makes them unnecessary.

• You must create exceptions for Lumension EMSS within you third-party firewall. For additional information,
refer to Port and ICMP Requirements for Agent Management Jobs on page 544.

You can perform these steps on endpoints with the following operating systems:

• Windows Vista
• Windows 7
• Windows 8
• Windows Server 2008
• Windows Server 2012

First, ensure that the services necessary for successful agent management are started.
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1. Open Control Panel.

Operating System Steps

Windows Vista, Windows 7, or
Windows Server 2008

Select Start > Control Panel.

Windows 8 or Windows Server
2012

1. Press the Windows Logo key.
2. Type Control Panel and press ENTER.

Step Result: Control Panel opens.

2. Ensure Control Panel is set to the Control Panel Home or Category view.

If Control Panel is already in this view, procede to the next step. If it is not set to this view, complete the step
applicable to your operating system.

Operating System Step

Windows Vista or Windows
Server 2008

Click Control Panel Home.

Windows 7, Windows 8, or
Windows Server 2012

From the View by list, select Category.

3. Open your system settings.

Operating System Step

Windows Vista or Windows
Server 2008

Click System and Maintenance.

Windows 7, Windows 8, or
Windows Server 2012

Click System and Security.

Step Result: Control Panel opens to the system options.

4. Click Administrative Tools.

Step Result: The Administrative Tools dialog opens.
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5. Double-click Services.

Step Result: The Services dialog opens.

Figure 224: Services Dialog

6. Ensure the necessary services are started.

The following list itemizes the services that must be started for job completion.

Note:  In environments that use a third-party firewall, ensure the Windows Firewall service is instead
disabled.

• DCOM Server Process Launcher
• Remote Procedure Call (RPC)
• Server
• Windows Firewall
• Windows Management Instrumentation

If all of the listed services required for your configuration purposes have a Server status of Started, continue
to the next step. If any of the listed services for your configuration purposes are not started, complete the
following substeps to start them.

a) Right-click the applicable service and select Properties.

Step Result: The properties dialog for the service opens.

b) Ensure the Startup type list is set to Automatic. If edits are necessary, click Apply after selecting
Automatic from the list.

c) Click Start.

Step Result: The service starts.

d) Click OK

Step Result: The properties dialog for the service closes.

e) If necessary, repeat the substeps for each unstarted service.
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7. Close the Services dialog and the Administrative Tools dialog.

Tip:  Leave Control Panel open.

Next, ensure your Sharing and Discovery settings are configured to allow network discovery and file sharing.
The discovery setting allows the endpoint to be seen by the Lumension EMSS server, while the file sharing
setting allows the Lumension EMSS server access to install the agent during agent management.

8. From Control Panel, click Network and Internet.

Step Result: Control Panel opens to the Network and Internet options.

9. Click Network and Sharing Center.

Step Result: Control Panel opens to the Network and Sharing Center.

10. Ensure Network discovery is enabled. Enabling this setting makes the endpoint publically known within
network. Lumension EMSS uses the information shared by this setting to return more detailed information
about the endpoint during discovery scanning.

Based on the endpoint operating system, complete the applicable substeps that follow.

Operating System Substep

Windows Vista or Windows
Server 2008:

1. Click the arrow icon adjacent to Network discovery.
2. Ensure the Turn on network discovery option is selected.
3. If necessary, click Apply.

Windows 7: 1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Home or Work
• Public
• Domain

3. Scroll to Network discovery.
4. Ensure the Turn on network discovery option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.
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Operating System Substep

Windows 8 or Windows Server
2012:

1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Private
• Guest or Public
• Domain

3. Scroll to Network discovery.
4. Ensure the Turn on network discovery option is selected.
5. Ensure the Turn on automatic setup of network connected

devices option is cleared.
6. If necessary, click Save Changes.
7. Repeat these substeps for each profile section.

11. Ensure File sharing is enabled.

Based on the endpoint operating system, complete the applicable substeps that follow.

Operating System Steps

Windows Vista and Windows
Server 2008:

1. Click the arrow icon adjacent to File Sharing.
2. Ensure the Turn on file sharing option is selected.
3. If necessary, click Apply.

Windows 7: 1. Ensure you have clicked Advanced sharing settings.
2. Expand one of the following sections:

• Home or Work
• Public
• Domain

3. Scroll to File and printer sharing.
4. Ensure the Turn on file and printer sharing option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.
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Operating System Steps

Windows 8 or Windows Server
2012:

1. Click Change advanced sharing settings.
2. Expand one of the following sections:

• Private
• Guest or Public
• Domain

3. Scroll to File and printer.
4. Ensure the Turn on file and printer sharing option is selected.
5. If necessary, click Save Changes.
6. Repeat these substeps for each profile section.

12. Close Network and Sharing Center.

Step Result: Network and Sharing Center closes.

Next, ensure Windows Firewall is configured to allow exceptions for agent management jobs. A Windows
Firewall that does not allow exceptions will block pings and other agent management processes. Ensure that
firewall exceptions are in place for successfull agent management.

Create the firewall exceptions using the Local Group Policy Editor. Create exceptions for both the standard
and domain profiles.

Note:  In environments using a third-party firewall, do not complete the steps to create Windows Firewall
exceptions. Instead, complete create exceptions in your third-party firewall. For additional information, refer
to Port and ICMP Requirements for Agent Management Jobs on page 544.

13. Open a run prompt.

Operating System Steps

Windows Vista, Windows 7,
and Windows Server 2008:

1. Select the Start menu.
2. Type run in the Search field and press ENTER.

Windows 8 or Windows Server
2012:

1. Press the Windows Logo key.
2. Type run and press ENTER.

Step Result: The Run prompt opens.
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14. Type gpedit.msc in the Open field and press ENTER.

Step Result: The Local Group Policy Editor opens.

Note:  In Windows Vista, this dialog is called the Group Policy Object Editor.

Figure 225: Local Group Policy Editor

Next, ensure firewall exceptions are created for the domain profile. These settings allow the Lumension EMSS
server to access the endpoint through the firewall.

Ensure the following settings (and their subsettings) are configured for agent management jobs:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exception
• Windows Firewall: Allow ICMP exceptions
• Windows Firewall: Allow inbound remote administration exception

Configure the following settings (and their subsettings) for agent management purposes:

15. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Domain Profiles. Ensure the Domain Profiles
folder is selected.

16. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured for agent
management.
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17. Configure the Windows Firewall: Allow inbound file and printer sharing exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow inbound file and printer sharing exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow inbound file and printer sharing exceptions setting is
configured for agent management.

18. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Within Options, ensure the Allow inbound echo request check box is selected.
d) Within Options, ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured for agent
management.

19. Configure the Windows Firewall: Allow inbound remote administration exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow inbound remote administration exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)



Configuring the Server and Endpoints for Agent Management Jobs

- 581 -

d) Click OK.

Step Result: The Windows Firewall: Allow inbound remote administration exceptions setting is
configured for agent management.

As with the domain profile Window Firewall settings, you must enable or disable identical settings (and
subsettings) within the standard profile.

Configure the following settings (and their subsettings) for agent management jobs:

• Windows Firewall: Do not allow exceptions
• Windows Firewall: Allow inbound file and printer sharing exception
• Windows Firewall: Allow ICMP exceptions
• Windows Firewall: Allow inbound remote administration exception

The following steps fully explain how to configure each setting.

20. Expand the local computer policy tree to Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Standard Profiles. Ensure the Standard Profiles
folder is selected.

21. Disable the Windows Firewall: Do not allow exceptions setting.

a) From the main pane, right-click Windows Firewall: Do not all exceptions and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Disabled option is selected.
c) Click OK.

Step Result: The Windows Firewall: Do not allow exceptions setting is configured for agent
management.

22. Configure the Windows Firewall: Allow inbound file and printer sharing exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow inbound file and printer sharing exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)
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d) Click OK.

Step Result: The Windows Firewall: Allow inbound file and printer sharing exceptions setting is
configured for agent management.

23. Configure the Windows Firewall: Allow ICMP exception setting.

a) From the main pane, right-click Windows Firewall: Allow ICMP exceptions setting and select Edit (or
Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) Within Options, ensure the Allow inbound echo request check box is selected.
d) Within Options, ensure all other check boxes are cleared.
e) Click OK.

Step Result: The Windows Firewall: Allow ICMP exceptions setting is configured for agent
management.

24. Configure the Windows Firewall: Allow inbound remote administration exceptions setting.

a) From the main pane, right-click Windows Firewall: Allow inbound remote administration exceptions
and select Edit (or Properties).

Step Result: The setting dialog opens.

b) Ensure the Enabled option is selected.
c) [Optional] Define an IP range in the Allow unsolicited incoming messages from field. Lumension

recommends defining this field using your Lumension EMSS Server IP address.

To define a range, you may use the following syntax. This input is not validated.

• * (any IP address)
• 10.3.2.0/24 (specific Class C subnet)
• localsubnet (for local subnetwork access only)

d) Click OK.

Step Result: The Windows Firewall: Allow inbound remote administration exceptions setting is
configured for agent management.
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25. Close the Local Group Policy Editior (or the Group Policy Object Editor).

Step Result:
Note:  The creation of Windows Firewall exceptions opens the following ports, which are
required for job completion:

• 445/TCP
• 139/UDP
• 135/UDP
• 137/UDP

Finally, complete configuration of your endpoint for agent management by verifying that the C$ and ADMIN$
network shares are enabled. These shares are required for agent management job completion.

26. Open the Command Prompt.

Operating System Steps

Windows Vista, Windows 7,
and Windows Server 2008:

1. Select the Start menu.
2. Type cmd in the Search field and press ENTER.

Windows 8 or Windows Server
2012:

1. Press the Windows Logo key.
2. Type cmd and press ENTER.

27. From the Command Prompt, type net share and press ENTER.

Step Result: The endpoint network shares are listed.

28. Ensure that the following shares are listed in the Share name column.

• C$

• ADMIN$

If they are already listed, proceed to the next step. If these shares are not listed, complete the following
substeps to enable them. If one of the necessary shares is enabled but not the other, only enable the share that
needs to be enabled.

a) From the Command Prompt, type the necessary command(s) to enable any required network shares.

• To enable the C$ share, type NET SHARE C$=C and press ENTER.
• To enable the ADMIN$ share, type NET SHARE ADMIN$ and press ENTER.

Step Result: You have enabled the required share(s). All enabled shares remain active until the system
reboots.
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29. Close the Command Prompt.

Step Result: The Command Prompt closes.

Result: The endpoint is configured for agent managment jobs.

Troubleshooting Agent Management Jobs
If agent managements are not completing successfully, additional configuration may be required.

If the Lumension Endpoint Management and Security Suite server or an applicable network endpoint has lost its
trust relationship with the domain, agent management jobs will fail with an error of access denied.

To verify if this issue is causing agent management job failure, ensure that the Lumension EMSS server can
connect to the applicable endpoints C$, and that the applicable endpoints can connect to the server's C$.
To verify these connections, type the following command from the applicable endpoint or server prompt: \
\EndpointIPAddress\C$.

If the following system output results from the command, your endpoint or server has lost its trust relationship
with the domain: The trust relationship between this workstation and the primary domain
failed.

To resolve this issue, remove the applicable server or endpoint from the domain, and then add it back. This
process forces the domain to refresh the endpoint password. The endpoint password prompts users for resetting at
scheduled intervals according to its security settings.

To disable password changes, complete Disabling Password Changes on page 585.

Resolving Endpoint UAC Issues
On endpoints running Windows Vista or later operating systems, UAC security features are set to highly
restrictive levels by default. These settings must be configured properly to ensure agent management job success.

When a post-Windows Vista endpoint is in this default UAC configuration, agent management jobs fail with an
access denied error.

Use one of two methods to resolve this issue:

Add a domain account Adding a domain account to the applicable endpoint's local administrator's
group will typically resolve the issue. To use this method, add the endpoint
to a domain (provided it isn't already added), and then add a domain user
to the endpoint's local administrator group. Running an agent management
job configured to use this domain account's credentials will allow the job to
complete successfully.

Note:  The domain account added to the local administrator's group must
be an individual domain account; you cannot add a domain group.
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Set a Registry Value If the user of a local administrative account is desired or required, you can
set a registry value to resolve this issue.

Create a DWORD registry value named LocalAccountTokenFilterPolicy in the
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies

\System\ registry hive. Set its value to 1.

No reboot is required. This method allows a local administrative account to
successfully run agent management jobs.

Note:  Refer to How to change the Remote UAC
LocalAccountTokenFilterPolicy registry setting (http://support.microsoft.com/
kb/942817) for additional information about this method.

Disabling Password Changes
Do disable password changes, create a registry key for the applicable endpoint.

Perform this task from the applicable endpoint.

1. Select Start > Run.

Step Result: The Run dialog opens.

2. Type regedit in the Open field.

3. Click OK.

Step Result: The Registry Editor opens.

4. Expand the directory tree structure to My Computer\HKEY_LOCAL_MACHINE\SYSTEM
\CurrentControlSet\Services\Netlogon\Parameters.

5. Right-click DisablePasswordChange.

6. Select Modify.

Step Result: The Edit DWORD Value dialog opens.

7. In the Value data field, type 1.

8. Click OK.

Result: The key value is updated. User profile passwords can no longer be edited on the applicable endpoint.

http://support.microsoft.com/kb/942817
http://support.microsoft.com/kb/942817
http://support.microsoft.com/kb/942817
http://support.microsoft.com/kb/942817
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Installing Agents by Agent Management Job
You can install agents upon network endpoints remotely by using agent management jobs. Installing agents
remotely substantially eases an administrator's workload, since they do not have to install agents locally.

Prerequisites:

• Verify that the endpoints you are installing agents on are Windows endpoints. Linux, UNIX, and Mac
endpoints cannot have agents installed using agent management jobs.

• Gather the built-in Administrator credentials for endpoints you are installing agents on. Successful job
outcome is contingent upon authenticated credentials for this account.

• Configure your server to allow agent management. For additional information, refer to Configuring the
Lumension EMSS Server for Discovery Scanning on page 544.

• Configure your targets to allow agent management. For additional information, refer to one of the following
procedures:

• Configuring Windows XP and Windows Server 2003 Endpoints for Agent Management Jobs on page
553

• Configuring Vista or Later Endpoints for Agent Management Jobs on page 573

While configuring Windows Vista or later endpoints, ensure network discovery and file sharing are turned
on.

Configuration of agent management jobs is similar to configuration of discovery scan jobs. Configuration occurs
in the Install Agents Wizard.

1. Begin configuration of the Install Agent Wizard.

Complete one of the following substep sets to being configuration.

Context Steps

To open the Wizard without
targets predefined:

Select Discover > Assets and Install Agents.
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Context Steps

To open the Wizard with target
predefined:

1. Select Manage > Endpoints.
2. Select the endpoints you want to install agents on.
3. From the toolbar, select Manage Agents > Install Agents.

Step Result: The wizard opens to the Job Name and Scheduling page.

Figure 226: Job Name and Scheduling Page

2. [Optional] Type a new name in the Scan job name field.

Note:  By default, new agent management jobs for installation are named New Agent Install
Management Job, followed by the server's date and time.

3. Schedule the job.

Use one of the following methods.

Tip:  During job scheduling, you can use the following shortcuts:

• Click the Calender icon to select a Start date. Selecting a date automatically fills the Start date field.
• Click the Clock icon to select a Start time. Selecting a time automatically fills the Start time field.

Method Steps

To schedule an immediate job: Select the Immediate option.
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Method Steps

To schedule a one-time job: 1. Ensure the Once option is selected.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

Note:  Scheduling a one-time job for a past date and time will
launch the job immediately.

To schedule a recurring weekly
job:

1. Select the Weekly option.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

4. Define the day of the week the job runs by selecting a day from the
Run every week on the following day list.

To schedule a recurring
monthly job:

1. Select the Monthly option.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

4. Define the day of the month the job runs by typing a day in the Run
every month on the following day field.

Note:  One-time and recurring jobs scheduled for the last day of a 31-day month are automatically
rescheduled for the last day of shorter months.
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4. Click Next.

Step Result: The Targets page opens.

Figure 227: Targets Page

5. If necessary, define targets (endpoints) for the job to locate.

Use one or more of the following discovery methods.

Method Steps

To define targets using a single
IP address:

1. From the Scan for list, select Single IP Address.
2. Type an IP address in the empty field. Wildcards are supported. For

additional information, refer to Defining Targets Using Wildcards on
page 613.

3. If necessary, edit the Timeout list. The Timeout list defines
the number of seconds before a scan fails due to inactivity for a
particular target. Under most network conditions, the Timeout field
does not require editing.

4. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a scan retries on that target
if the scan times out.
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Method Steps

To define targets using an IP
range:

1. From the Scan for list, select IP Range.
2. In the first empty field, type the beginning of IP range. Wildcards

are supported. For additional information, refer to Defining Targets
Using Wildcards on page 613.

3. In the second empty field, type the ending of the IP range.
4. If necessary, edit the Timeout list. The Timeout list defines the

number of seconds before a scan fails due to inactivity for that
particular target. Under most network conditions, the Timeout field
does not require editing.

5. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a scan retries on that target
if the scan times out.

To define targets using a
computer name:

1. From the Scan for list, select Computer name.
2. In the empty field, type an endpoint name in one of the following

formats: endpointname or domain\endpointname.

To define targets using
network neighborhood:

1. From the Scan for list, select Network Neighborhood.
2. From the second list, select the desired network neighborhood.

To define targets using active
directory:

1. From the Scan for list, select Active Directory.
2. In the Fully-qualified domain name field, type the DNS domain

name of the domain controller you want to scan. For example, if
your domain controller DNS name is box.domain.company.local,
you would type domain.company.local in this field.

3. Optionally, in the Organizational Unit field, type the active
directory organizational unit string from specific to broad,
separating each string with front slashes (such as Techpubs/
Engineering/Corporate). The omission of this field returns
job results containing the full contents of all the active directory
organizational units. View the following figure for an example of
how to enter data using Active Directory.

4. In the Domain controller field, type the domain controller IP
address.

5. In the Username field, type a user name that authenticates with
the domain controller. Type the user name in one of the following
format: domainname\username or username.

6. In the Password field, type the password associated with the user
name.
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Method Steps

To define targets using an
imported file:

1. From the Scan for list, select Import file.
2. Click Browse.
3. Browse to the file you want to use for target discovery. The

following file types are supported: .txt and .csv.
4. Click Open.

Note:  For additional information about how to define targets within
an imported file, refer to Defining Targets Within an Imported File on
page 529.

Figure 228: Active Directory Input Example

6. Add targets to the wizard list. This list indicates whether defined targets are included in or excluded from the
job.

Use one of the following methods.

Method Steps

To include defined targets in
the job:

Click Add to Scan.

To exclude defined targets
from the job:

Click Exclude from Scan.

Note:  You must include at least one target for Next to become available. You can also delete targets from
the list by selecting the applicable check boxes and clicking Remove.
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7. [Optional] Define additional targets and add them to the list.

Tip:  You can edit targets added to the list. For more information, see Editing Targets on page 610.

8. Click Next.

Step Result: The Scan Options page opens.

Figure 229: Scan Options Page

9. Select or clear the desired Scan Options.

The following table defines each Scan Option.

Option Description

Verify With Ping Jobs using this option send ping requests to all network endpoints
targeted for discovery. Endpoints that respond to the request are
flagged for scanning; unresponsive endpoints are skipped. Endpoints
unresponsive to Verify With Ping are not scanned by other selected
discovery options.

Note:  Anti-virus software and host firewalls may block Verify With
Ping. If necessary, adjust antivirus and firewall configurations to
permit ping requests.
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Option Description

ICMP Discovery Jobs using this option request a series of echoes, information, and
address masks from endpoints. Endpoint responses are then compared
to a list of known ICMP fingerprints to identify endpoint operating
systems.

Note:  ICMP Discovery is ineffective on endpoints configured to
ignore ICMP requests. For best results identifying Windows operating
systems, use this option in conjunction with Windows Version
Discovery.

Port Scan Discovery Jobs using this option perform a limited scan on endpoint FTP, Telnet,
SSH, SMTP, and HTTP ports. Based on the application banners found
in these ports, endpoint operating systems are generically identified.

Note:  For best results in identifying Windows operating systems, use
this option in conjunction with Windows Version Discovery.

SNMP Discovery Jobs using this option request system properties for SNMP devices
(routers, printers, and so on) from the management information base.
Following credential authentication, SNMP devices are identified.

Note:  Without authenticated credentials, SNMP devices ignore
SNMP Discovery requests. In this event, one of two outcomes occur:
the SNMP device is misidentified as a UNIX endpoint or the SNMP
device is not detected. Jobs with no SNMP credentials use the public
credential by default.

Windows Version Discovery Jobs using this option identify an endpoint's specific version of
Windows following generic operating system identification during
ICMP or Port Scan Discovery.

Note:  Correct operating system identification is contingent upon
authenticated credentials. This option must be used in conjunction with
either ICMP or Port Scan Discovery.

Resolve DNS Names Jobs using this option acquire the endpoint DNS name through a local
DNS server query. These names are displayed in job results for easy
endpoint identification.

Resolve MAC Addresses Jobs using this option acquire endpoint MAC addresses through
endpoint queries. These addresses are displayed in job results for easy
endpoint identification.

Note:  Monitor network inventory reports to prevent MAC address
spoofing that may alter the Resolve MAC Addresses results.
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Option Description

Resolve NetBIOS Names Jobs using this option acquire endpoint NetBIOS names through WINS
NetBIOS mapping. These names are displayed in job results for easy
endpoint identification.

Note:  Security-hardened networks running Windows 2003 or
Windows XP may require enabling of NetBIOS over TCP/IP for
Resolve NetBIOS Names to acquire NetBIOS names. Additionally,
firewalls protecting endpoints using Windows XP Professional SP2
may require adjustment to permit NetBIOS communication.

10. Click Next.

Step Result: The Agent Options page opens.

11. Select the desired Agent Options.

These options control which version of the agent is installed on Windows-based endpoints.

a) Select an agent version from the Agent version list.

Note:  The agent versions available for selection are defined by the Agent Version Options, which you
can edit from the Options page Agents tab. For additional information, refer to Agent Versions on page
126.

b) Select the modules you want to install with the agent.

Select the check boxes associated with the modules you want to install.
c) [Optional] Select the Overwrite existing agents check box.

This option controls whether the agent management job skips targets that already have agents installed.

Attention:  Selecting this option will cause data loss when an endpoint's Lumension Endpoint
Management and Security Suite Agent is overwritten.

Following initial agent installation, if the Patch and Remediation module is installed, the agent version will
change if the applicable endpoint is subject to a conflicting agent version policy. (Patch and Remediation
only).
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12. Click Next.

Note:  If a dialog opens that notifies you that an endpoint reboot is required following agent installation,
click Continue to dismiss the dialog.

Step Result: The Credentials page opens.

Figure 230: Credentials Page

13. Define Windows credentials for the target.

Type the applicable information in the following fields.

Note:  When configuring an agent management job, you must define valid Windows credentials.

Field Description

Username A user name that authenticates with Windows-based endpoints. Type
the user name in a local format (UserName) or a domain format
(DOMAIN\UserName).

Note:  When configuring agent management jobs, Lumension
recommends using the built-in Administrator account.

Password The password associated with the Username.

Confirm password The Password retyped.
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14. Click Next.

Step Result: The Agent Settings page opens.

Figure 231: Agent Settings Page

15. Define the Distribution options.

The following table describes each list their available values.

List Description

Timeout

(list)

Defines the number of minutes before the agent management job
terminates due to a non-responsive agent installation or removal (0-30).

Number of retries

(list)

Defines the number of attempts an agent installation or removal will
retry if the initial attempt fails (1-10).

Number of simultaneous
installs

(list)

Defines the maximum number of agents that can installed or removed
simultaneously during the job (1-25). A value of 1 indicates that serial
installs or removals should occur.

16. Define the Lumension Endpoint Management and Security Suite server that the agent will report to using the
Server Identity field.

Define the Server identity using one of the following formats. The wizard fills this field with the server
computername by default.

• endpointname.domainname.com

• computername

• 10.10.10.10
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17. If the target endpoints will communicate with the Lumension EMSS server through a proxy server following
initial agent installation, select the Use a proxy server check box and define the following fields.

Note:  In many network environments, although a proxy is used for Internet access, a proxy bypass is used to
access within the corporate network. Therefore, only enter proxy information if your agents will be required
to use a proxy to access your Lumension Endpoint Management and Security Suite server. A Squid proxy
server will only properly resolve using a fully qualified domain name.

Refer to Lumension KnowledgeBase Article 1625 (http://www.lumension.com/kb/1625) for additional
information on a Squid proxy server configuration.

Field Description

Server address The applicable proxy IP address.

Port The applicable proxy port number used to communicate.

18. If the target endpoints will use a proxy for agent to server communication, and that proxy requires
authentication, select the Authentication required check box and define the following fields.

Field Description

Username A user name that authenticates with the proxy.

Password The password associated with the Username.

Confirm password The Password retyped.

19. Click Finish.

Result: The Install Agents Wizard closes. Depending on how you configured the job, it moves to either the
Scheduled tab or Active tab on the Job Results page. The job will run at the applicable time, installing
agents on the defined targets, and move to Completed tab when finished.

After Completing This Task:

• If you installed an endpoint module that requires a reboot, reboot the endpoint(s) when the agent management
job complete.

• After the agent management job completes, install agent modules if necessary. For additional information,
refer to Managing Module Endpoint Components on page 171.

Editing Targets
While configuring agent management jobs that uninstall agents, you can edit items included in the Targets list.

Edit Target list items from the Targets page.

1. From the Targets list, select the check box associated with the item you want to edit.

http://www.lumension.com/kb/1625
http://www.lumension.com/kb/1625
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2. Click Edit.

Step Result: The Edit Targets dialog opens.

Figure 232: Edit Targets Dialog

3. Based on the type of discovery method, edit the item.

Discovery Method Steps

Single IP Address
1. Type a new IP address in the field. Wildcards are supported. For

additional information, refer to Defining Targets Within an Imported
File on page 529.

2. If necessary, edit the Timeout list. The Timeout list defines the
number of seconds before a scan fails due to inactivity. Under most
network conditions, the Timeout field does not require editing.

3. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a discover assets scan retries
if the scan times out.

IP Range
1. In the field, type the beginning of IP range. Wildcards are

supported. For additional information, refer to Defining Targets
Within an Imported File on page 529.

2. In the field, type the ending of the IP range.
3. If necessary, edit the Timeout list. The Timeout list defines the

number of seconds before a scan fails due to inactivity. Under most
network conditions, the Timeout field does not require editing.

4. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a discover assets scan retries
if the scan times out.
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Discovery Method Steps

Computer Name In the empty field, type a new endpoint name in one of the following
formats: endpointname or domain\endpointname.

Network Neighborhood From list, select the desired network neighborhood.

Active Directory
1. In the Fully-qualified domain name field, type the DNS

domain name of the domain controller you want to scan.
For example, if your domain controller's DNS name was
box.domain.company.local, you would type domain.company.local
in this field.

2. Optionally, in the Organizational Unit field, type the active
directory organizational unit string from specific to broad,
separating each string with front slashes (such as Techpubs/
Engineering/Corporate). The omission of this field returns
job results containing the full contents of all the active directory
organizational units. View the following figure for an example of
how to enter data using Active Directory.

3. In the Domain controller field, type the domain controller's IP
address.

4. In the Username field, type user name that will authenticate with
the domain controller. Type the user name in one of the following
format: domainname\username or username.

5. In the Password field, type the password associated with the user
name.

Figure 233: Active Directory Input Example
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4. Include or exclude the target(s) from the scan.

• To include the target(s), click Include Targets.
• To exclude the target(s), click Exclude Targets.

Result: The Targets list reflects your changes.

Uninstalling Agents by Agent Management Job
You can remotely uninstall agents from endpoints in your network using an agent management job. These jobs
prevent administrators from having to uninstall agents locally.

Prerequisites:

• Verify that the endpoints you are installing agents on are Windows endpoints. Linux, UNIX, and Mac
endpoints cannot have agents installed using agent management jobs.

• Gather the built-in Administrator credentials for endpoints you are installing agents on. Successful job
outcome is contingent upon authenticated credentials for this account.

• Configure your server to allow agent management. For additional information, refer to Configuring the
Lumension EMSS Server for Discovery Scanning on page 544.

• Configure your targets to allow agent management. For additional information, refer to one of the following
procedures:

• Configuring Windows XP and Windows Server 2003 Endpoints for Agent Management Jobs on page
553

• Configuring Vista or Later Endpoints for Agent Management Jobs on page 573

While configuring Windows Vista or later endpoints, ensure network discovery and file sharing are turned
on.

Configuration of agent management is similar to a discover scan job. Configuration occurs in the Uninstall
Agents Wizard.

1. Begin configuration of the Uninstall Agent Wizard.

Complete one of the follow substep sets to being configuration.

Context Steps

To open the Wizard without
targets predefined:

Select Discover > Assets and Uninstall Agents.
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Context Steps

To open the Wizard with target
predefined:

1. Select Manage > Endpoints.
2. Select the endpoints you want to uninstall agents from.
3. From the toolbar, select Manage Agents > Uninstall Agents.

Step Result: The wizard opens to the Job Name and Scheduling page.

Figure 234: Job Name and Scheduling Page

2. [Optional] Type a new name in the Scan job name field.

Note:  By default, new agent management jobs for uninstallation are named New Agent Uninstall
Management Job, followed by the server date and time.

3. Schedule the job.

Use one of the following methods.

Tip:  During job scheduling, you can use the following shortcuts:

• Click the Calender icon to select a Start date. Selecting a date automatically fills the Start date field.
• Click the Clock icon to select a Start time. Selecting a time automatically fills the Start time field.

Method Steps

To schedule an immediate job: Select the Immediate option.
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Method Steps

To schedule a one-time job: 1. Ensure the Once option is selected.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

Note:  Scheduling a one-time job for a past date and time will
launch the job immediately.

To schedule a recurring weekly
job:

1. Select the Weekly option.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

4. Define the day of the week the job runs by selecting a day from the
Run every week on the following day list.

To schedule a recurring
monthly job:

1. Select the Monthly option.
2. Define a start date by typing a date in the Start date field. Type the

date in a mm/dd/yyyy format.
3. Define a start time by typing a time in the Start time field. Type

the time in hh:mm format followed by AM or PM. This field supports
both 12- and 24-hour time.

4. Define the day of the month the job runs by typing a day in the Run
every month on the following day field.

Note:  One-time and recurring jobs scheduled for the last day of a 31-day month are automatically
rescheduled for the last day of shorter months.
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4. Click Next.

Step Result: The Targets page opens.

Figure 235: Targets Page

5. If necessary, define targets (endpoints) for the job to locate.

Use one or more of the following discovery methods.

Method Steps

To define targets using a single
IP address:

1. From the Scan for list, select Single IP Address.
2. Type an IP address in the empty field. Wildcards are supported. For

additional information, refer to Defining Targets Using Wildcards on
page 613.

3. If necessary, edit the Timeout list. The Timeout list defines
the number of seconds before a scan fails due to inactivity for a
particular target. Under most network conditions, the Timeout field
does not require editing.

4. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a scan retries on that target
if the scan times out.
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Method Steps

To define targets using an IP
range:

1. From the Scan for list, select IP Range.
2. In the first empty field, type the beginning of IP range. Wildcards

are supported. For additional information, refer to Defining Targets
Using Wildcards on page 613.

3. In the second empty field, type the ending of the IP range.
4. If necessary, edit the Timeout list. The Timeout list defines the

number of seconds before a scan fails due to inactivity for that
particular target. Under most network conditions, the Timeout field
does not require editing.

5. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a scan retries on that target
if the scan times out.

To define targets using a
computer name:

1. From the Scan for list, select Computer name.
2. In the empty field, type an endpoint name in one of the following

formats: endpointname or domain\endpointname.

To define targets using
network neighborhood:

1. From the Scan for list, select Network Neighborhood.
2. From the second list, select the desired network neighborhood.

To define targets using active
directory:

1. From the Scan for list, select Active Directory.
2. In the Fully-qualified domain name field, type the DNS domain

name of the domain controller you want to scan. For example, if
your domain controller DNS name is box.domain.company.local,
you would type domain.company.local in this field.

3. Optionally, in the Organizational Unit field, type the active
directory organizational unit string from specific to broad,
separating each string with front slashes (such as Techpubs/
Engineering/Corporate). The omission of this field returns
job results containing the full contents of all the active directory
organizational units. View the following figure for an example of
how to enter data using Active Directory.

4. In the Domain controller field, type the domain controller IP
address.

5. In the Username field, type a user name that authenticates with
the domain controller. Type the user name in one of the following
format: domainname\username or username.

6. In the Password field, type the password associated with the user
name.
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Method Steps

To define targets using an
imported file:

1. From the Scan for list, select Import file.
2. Click Browse.
3. Browse to the file you want to use for target discovery. The

following file types are supported: .txt and .csv.
4. Click Open.

Note:  For additional information about how to define targets within
an imported file, refer to Defining Targets Within an Imported File on
page 529.

Figure 236: Active Directory Input Example

6. Add targets to the wizard list. This list indicates whether defined targets are included in or excluded from the
job.

Use one of the following methods.

Method Steps

To include defined targets in
the job:

Click Add to Scan.

To exclude defined targets
from the job:

Click Exclude from Scan.

Note:  You must include at least one target for Next to become available. You can also delete targets from
the list by selecting the applicable check boxes and clicking Remove.
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7. [Optional] Define additional targets and add them to the list. For more information, see Editing Targets on
page 610.

8. Click Next.

Step Result: The Options page opens.

Figure 237: Options Page

9. Select or clear the desired Scan Options.

The following table defines each Scan Option.

Option Description

Verify With Ping Jobs using this option send ping requests to all network endpoints
targeted for discovery. Endpoints that respond to the request are
flagged for scanning; unresponsive endpoints are skipped. Endpoints
unresponsive to Verify With Ping are not scanned by other selected
discovery options.

Note:  Anti-virus software and host firewalls may block Verify With
Ping. If necessary, adjust antivirus and firewall configurations to
permit ping requests.
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Option Description

ICMP Discovery Jobs using this option request a series of echoes, information, and
address masks from endpoints. Endpoint responses are then compared
to a list of known ICMP fingerprints to identify endpoint operating
systems.

Note:  ICMP Discovery is ineffective on endpoints configured to
ignore ICMP requests. For best results identifying Windows operating
systems, use this option in conjunction with Windows Version
Discovery.

Port Scan Discovery Jobs using this option perform a limited scan on endpoint FTP, Telnet,
SSH, SMTP, and HTTP ports. Based on the application banners found
in these ports, endpoint operating systems are generically identified.

Note:  For best results in identifying Windows operating systems, use
this option in conjunction with Windows Version Discovery.

SNMP Discovery Jobs using this option request system properties for SNMP devices
(routers, printers, and so on) from the management information base.
Following credential authentication, SNMP devices are identified.

Note:  Without authenticated credentials, SNMP devices ignore
SNMP Discovery requests. In this event, one of two outcomes occur:
the SNMP device is misidentified as a UNIX endpoint or the SNMP
device is not detected. Jobs with no SNMP credentials use the public
credential by default.

Windows Version Discovery Jobs using this option identify an endpoint's specific version of
Windows following generic operating system identification during
ICMP or Port Scan Discovery.

Note:  Correct operating system identification is contingent upon
authenticated credentials. This option must be used in conjunction with
either ICMP or Port Scan Discovery.

Resolve DNS Names Jobs using this option acquire the endpoint DNS name through a local
DNS server query. These names are displayed in job results for easy
endpoint identification.

Resolve MAC Addresses Jobs using this option acquire endpoint MAC addresses through
endpoint queries. These addresses are displayed in job results for easy
endpoint identification.

Note:  Monitor network inventory reports to prevent MAC address
spoofing that may alter the Resolve MAC Addresses results.
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Option Description

Resolve NetBIOS Names Jobs using this option acquire endpoint NetBIOS names through WINS
NetBIOS mapping. These names are displayed in job results for easy
endpoint identification.

Note:  Security-hardened networks running Windows 2003 or
Windows XP may require enabling of NetBIOS over TCP/IP for
Resolve NetBIOS Names to acquire NetBIOS names. Additionally,
firewalls protecting endpoints using Windows XP Professional SP2
may require adjustment to permit NetBIOS communication.

10. Click Next.

Step Result: The Credentials page opens.

Figure 238: Credentials Page

11. Define Windows credentials for the target.

Type the applicable information in the following fields.

Note:  When configuring an agent management job, you must define valid Windows credentials.

Field Description

Username A user name that authenticates with Windows-based endpoints. Type
the user name in a local format (UserName) or a domain format
(DOMAIN\UserName).

Note:  When configuring agent management jobs, Lumension
recommends using the built-in Administrator account.
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Field Description

Password The password associated with the Username.

Confirm password The Password retyped.

12. Click Next.

Step Result: The Agent Settings page opens.

Figure 239: Agent Settings Page

13. Define the Distribution options.

The following table describes each list their available values.

List Description

Timeout

(list)

Defines the number of minutes before the agent management job
terminates due to a non-responsive agent installation or removal (0-30).

Number of retries

(list)

Defines the number of attempts an agent installation or removal will
retry if the initial attempt fails (1-10).

Number of simultaneous
installs

(list)

Defines the maximum number of agents that can installed or removed
simultaneously during the job (1-25). A value of 1 indicates that serial
installs or removals should occur.
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14. Define the Reboot option.

Select one of the following options:

• Suppress the reboot
• Force a reboot (does not prompt the user)

Note:  If the agent being uninstalled is installed on the Lumension Endpoint Management and Security
Suite server, the reboot is automatically suppressed regardless of this setting.

15. Click Finish.

Result: The Uninstall Agents Wizard closes. Depending on how you configured the job, it moves to either
the Scheduled tab or Active tab on the Job Results page. The job will run at the applicable time,
uninstalling agents on the defined targets, and move to the Completed tab when finished.

Editing Targets
While configuring jobs, you can edit items included in the Targets list.

Edit Target list items from the Targets page.

1. From the Targets list, select the check box associated with the item you want to edit.

2. Click Edit.

Step Result: The Edit Targets dialog opens.

Figure 240: Edit Targets Dialog
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3. Based on the type of discovery method, edit the item.

Discovery Method Steps

Single IP Address
1. Type a new IP address in the field. Wildcards are supported. For

additional information, refer to Defining Targets Within an Imported
File on page 529.

2. If necessary, edit the Timeout list. The Timeout list defines the
number of seconds before a scan fails due to inactivity. Under most
network conditions, the Timeout field does not require editing.

3. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a discover assets scan retries
if the scan times out.

IP Range
1. In the field, type the beginning of IP range. Wildcards are

supported. For additional information, refer to Defining Targets
Within an Imported File on page 529.

2. In the field, type the ending of the IP range.
3. If necessary, edit the Timeout list. The Timeout list defines the

number of seconds before a scan fails due to inactivity. Under most
network conditions, the Timeout field does not require editing.

4. If necessary, edit the Number of retries list. The Number of
retries list defines the number of times a discover assets scan retries
if the scan times out.

Computer Name In the empty field, type a new endpoint name in one of the following
formats: endpointname or domain\endpointname.

Network Neighborhood From list, select the desired network neighborhood.
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Discovery Method Steps

Active Directory
1. In the Fully-qualified domain name field, type the DNS

domain name of the domain controller you want to scan.
For example, if your domain controller's DNS name was
box.domain.company.local, you would type domain.company.local
in this field.

2. Optionally, in the Organizational Unit field, type the active
directory organizational unit string from specific to broad,
separating each string with front slashes (such as Techpubs/
Engineering/Corporate). The omission of this field returns
job results containing the full contents of all the active directory
organizational units. View the following figure for an example of
how to enter data using Active Directory.

3. In the Domain controller field, type the domain controller's IP
address.

4. In the Username field, type user name that will authenticate with
the domain controller. Type the user name in one of the following
format: domainname\username or username.

5. In the Password field, type the password associated with the user
name.

Figure 241: Active Directory Input Example
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4. Include or exclude the target(s) from the scan.

• To include the target(s), click Include Targets.
• To exclude the target(s), click Exclude Targets.

Result: The Targets list reflects your changes.

Defining Targets Using Wildcards
When configuring a discovery scan job or agent management job, you can define scan targets using wildcard IP
addresses. Wildcards are characters can be used to substitute for any other character or characters in a string. In
other words, you can use wildcards to scan for numerous IP address instead of just one. Use wildcards to scan
specific IP address ranges.

The following table lists examples of how to define targets using wildcards.

Table 264: Wildcard Examples

Discovery Method Step Example Targets Defined

To define wildcard IP addresses: Type a wildcard
IP address using
commas (,).

Type a wildcard IP
address using dashes
(-).

Type a wildcard
IP address using
asterisks (*).

Type a wildcard
IP address using
Classless Inter-
Domain Routing
(CIDR).

10.1.1.2,9

10.1.1.2-5

10.1.1.*

10.1.1.0/24

10.1.1.2 and 10.1.1.9

10.1.1.2, 10.1.1.3,
10.1.1.4, and 10.1.1.5

10.1.1.0 through
10.1.1.255

10.1.1.0 through
10.1.1.255

To define IP ranges: Type two IP
addresses separated
by a greater-than sign
(>).

Type two IP
addresses separated
by a dash (-).

Note:  Dashes and
greater-than signs are
interchangeable.

10.1.1.2 > 10.1.1.9

10.1.1.2 - 10.1.1.9

10.1.1.2 through
10.1.1.9

10.1.1.2 through
10.1.1.9
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Discovery Method Step Example Targets Defined

To define wildcard IP addresses
using dashes in various octets:

Type a wildcard IP
address using dashes,
placing the dashes
where applicable.
You can use dashes
in any octet.

10.2-4.5.9

10.5.2-4.9

10.2.5.9, 10.3.5.9,
10.4.5.9

10.5.2.9, 10.5.3.9,
10.5.4.9

To define wildcard IP addresses
using asterisks in various octets:

Type a wildcard
IP address using
asterisks, placing
the asterisks where
applicable. You can
use asterisks in any
octet.

*.6.65.92

10.25.*.*

1.6.65.92 through
255.6.65.92

10.25.0.0 through
10.25.255.255

To define wildcard IP addresses
using commas in various octets:

Type a wildcard
IP address using
commas, placing
the commas where
applicable. You can
use commas in any
octet.

10.2.5,9,12.9

10,12,19.2.5.9

10.2.5.9, 10.2.9.9,
10.2.12.9

10.2.5.9, 12.2.5.9,
19.2.5.9

To define wildcard IP addresses
using a combination of wildcard
characters:

Type a wildcard
IP address using
dashes, commas, and
asterisks.

10-13.*.12.2,4,7

10.2-4.5,23.*

10, 11, 12,
13.0-255.12.2, 4, 7

10.2, 3, 4.5, 23.0-255
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Appendix

D
Creating a Disaster Recovery Solution

In this appendix:

• Preparing Your Database

• Creating a Manual Solution

• Creating an Automated Solution

Lumension Endpoint Management and Security Suite uses Microsoft
SQL Server to store data values; therefore, you should prepare your
instance of Microsoft SQL Server for a disaster.

The most important part of an effective disaster recovery solution
is having a current and valid backup. You can create backups either
manually or as part of a Database Maintenance Plan.

Note:  This appendix applies to Microsoft SQL Server 2008
and requires the Microsoft SQL Server Management Studio. The
Management Studio is available by upgrading to SQL Server 2008
Standard or Enterprise. For further information, see Microsoft
SQL Server 2008 (http://www.microsoft.com/sqlserver/2008/en/us/
default.aspx).

Preparing Your Database
In the event of a disaster, detailed transaction logs are useful when restoring your database. You can control the
level of detail that your logs record.

The installation of Lumension Endpoint Management and Security Suite sets your database to a recovery model
of Simple. To use Transaction Logs, and thus increase the quality of your disaster recovery solution, you should
change the recovery model to Full.

Changing the Database Recovery Model
Modify the database recovery model to record more robust details about the events leading to a disaster.

Database recovery model edits take place in the SQL Server Management Studio.

1. Open the Microsoft SQL Server Management Studio (Start > All Programs > Microsoft SQL Server 2008
> SQL Server Management Studio).

2. Log into your database server.

3. In the directory tree, expand Server Name\SQL Instance > Databases.

4. Right-click the PLUS database.

http://www.microsoft.com/sqlserver/2008/en/us/default.aspx
http://www.microsoft.com/sqlserver/2008/en/us/default.aspx
http://www.microsoft.com/sqlserver/2008/en/us/default.aspx
http://www.microsoft.com/sqlserver/2008/en/us/default.aspx
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5. Select Properties.

Step Result: The Database Properties window opens.

Figure 242: Database Properties

6. In the Select a Page pane, click Options.

Step Result: The Options page opens.

7. In the Recovery model list, select Full.

Note:  A full database backup backs up the whole database. This includes part of the transaction log so that
full database backup can be recovered.

8. Click OK.

Step Result: The changes are saved and the Database Properties window closes.

9. Repeat the recovery model modification process for the following databases:

Table 265: Database Names

Database Name Product

STAT_Guardian Lumension Endpoint Management and Security Suite

UPCCommon Lumension Endpoint Management and Security Suite

UPCExtended Lumension Endpoint Management and Security Suite
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Database Name Product

PLUS_Reports Lumension Enterprise Reporting Client

SCM Lumension Security Configuration Management

ERS Lumension Enterprise Reporting

ERS_Staging Lumension Enterprise Reporting

ReportServer(1) Microsoft SQL Server Reporting Services

ReportServerTempDB(1) Microsoft SQL Server Reporting Services

SafeGuard(2) Lumension Disk Encryption powered by Sophos®

(1) Subscription features available in Microsoft SQL Server Reporting Services can be implemented
in Lumension Enterprise Reporting. By default, the database names are ReportServer and
ReportServerTempDB.

(2) Data protection capabilities in Lumension Disk Encryption is enhanced with a full disk encryption add-
on from Sophos. The installation of Lumension Disk Encryption results in a Safeguard database.

After Completing This Task:

You must create a backup of each database before any Transaction logs will be created. Refer to Creating a
Database Backup on page 617 to create a one-time backup of your database.

Creating a Manual Solution
To prevent data loss, create a database solution, and implement it in the event of a disaster.

While a Maintenance Plan will allow you to automate the backup of your databases and transaction logs, you can
also create and restore individual backups using the SQL Server Management Studio.

Creating a Database Backup
The most important part of an effective disaster recovery technique is having a current and valid backup. Create
a backup for the SQL Server instance associated with Lumension Endpoint Management and Security Suite to
assure minimal system data is lost if a disaster occurs.

Backups are created within SQL Server Management Studio.

1. Open the Microsoft SQL Server Management Studio (Start > Programs > Microsoft SQL Server 2008 >
SQL Server Management Studio).

2. Log into your database server.

3. In the directory tree, expand to Databases (Server Name > SQL Instance > Databases).

4. Right-click the PLUS database.
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5. Select Tasks > Backup.

Step Result: The Back Up Database window opens.

Figure 243: Back Up Database

6. Ensure that the Source values are set as follows:

• Database: PLUS
• Recovery model: Full

Note:  If the Recovery model is not set to Full, refer to Changing the Database Recovery Model on page
615.

• Backup Type: Full
• Backup Component: Database

7. Define the Backup set identification fields.

The following table describes each field.

Field Description

Name The name of the backup set.

Description The description of the backup set.
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8. Define the backup set expiration date.

Use one of the following methods.

Method Steps

To define an expiration date
based on a set number of days:

1. Select the After option.
2. Type the desired number in the After field.

To define an expiration date
based on a set date:

1. Select the On option.
2. Select the desired date frm the On list.

9. Define your backup Destination settings.

a) Select either the Disk or Tape option.
b) Define the destination Folder.

Note:  For performance reasons, it is recommended that you create your database backup in a directory
that is not on the same physical drive as your database.

10. Select Options within the Select a page pane.

Step Result: The Options page displays.

Figure 244: Back Up Database - Options

11. Select whether to Backup up to the existing media set or Back up to a new media set, and erase all
existing backup sets as is appropriate for your organization.
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12. Select the Verify backup when finished option to ensure a valid backup.

13. Click OK.

14. Repeat for the following databases:

Table 266: Database Names

Database Name Product

STAT_Guardian Lumension Endpoint Management and Security Suite

UPCCommon Lumension Endpoint Management and Security Suite

UPCExtended Lumension Endpoint Management and Security Suite

PLUS_Reports Lumension Enterprise Reporting Client

SCM Lumension Security Configuration Management

ERS Lumension Enterprise Reporting

ERS_Staging Lumension Enterprise Reporting

ReportServer(1) Microsoft SQL Server Reporting Services

ReportServerTempDB(1) Microsoft SQL Server Reporting Services

SafeGuard(2) Lumension Disk Encryption powered by Sophos®

(1) Subscription features available in Microsoft SQL Server Reporting Services can be implemented
in Lumension Enterprise Reporting. By default, the database names are ReportServer and
ReportServerTempDB.

(2) Data protection capabilities in Lumension Disk Encryption is enhanced with a full disk encryption add-
on from Sophos. The installation of Lumension Disk Encryption results in a Safeguard database.

After Completing This Task:

You must also backup the Lumension EMSS content directory.

Tip:  The default location of the content directory is <Installation Directory>\Lumension\EMSS
\Content. However, if this directory was modified during installation, you can verify its location by viewing
the \HKEY_LOCAL_MACHINE\SOFTWARE\Patchlink.com\Update\ISAPI\Storage registry key.
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Restoring a Database Backup
Another important part of an effective Disaster Recovery Solution is having a process defined in which to restore
your database backup.

Prerequisites:

Prior to restoring the database backup you must install the Lumension Endpoint Management and Security Suite
server using the same serial number that was used previously.

Important:  After installing the Lumension Endpoint Management and Security Suite server do not open the
user interface until after you have restored the databases.

1. Open the Services Management Console (Start > Settings > Control Panel > Administrative Tools >
Services).

2. Right-click the World Wide Web Publishing service.

3. Select Stop to stop the World Wide Web Publishing (IIS) service.

4. Repeat steps 2 and 3 for the following services:

• EDS LanPortal

• EDS MessageBroker

• EDS Server

• Replication Service

• STATEngine

5. Restore the backup you made of the content directory, over the new content directory (<Installation
Directory>\Lumension\EMSS\Content by default). However, if this directory was modified
during installation, you can verify its location by viewing the \HKEY_LOCAL_MACHINE\SOFTWARE
\Patchlink.com\Update\ISAPI\Storage registry key.

6. Open the Microsoft SQL Server Management Studio (Start > Programs > Microsoft SQL Server 2008 >
SQL Server Management Studio).

7. Using an user account that has sysadmin rights, log into your database server.

8. In the directory tree, expand Server Name\SQL Instance > Databases.

9. Right-click on the Databases folder.
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10. Select Restore Database

Step Result: The Restore Database window opens.

Figure 245: Restore Database

11. In the To database field, type or select the PLUSdatabase.

12. Select From device and click the Ellipses button (...).

Step Result: The Specify Backup dialog opens.

13. Click Add.

Step Result: The Locate Backup File dialog opens.

14. Locate and select your backup (.bak) file.

15. Click OK.

16. Click OK to return to the Restore Database window.

17. Select the check-box associated with your backup within the Select the backup sets to restore table.
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18. Click Options within the Select a page pane.

Step Result: The Options page displays.

Figure 246: Restore Database - Options

19. Ensure the Overwrite the existing database option is selected.

20. Verify, and correct if necessary, the directory path within the Restore the database files as table.

21. Ensure the Leave the database ready to use option is selected.

22. Click OK to begin the database restoration.

23. After the restore is complete run the following SQL command against the database.

  exec sp_changedbowner 'sa'
     

24. Repeat steps 9 through 23, restoring each of the following databases:

Table 267: Database Names

Database Name Product

STAT_Guardian Lumension Endpoint Management and Security Suite

UPCCommon Lumension Endpoint Management and Security Suite

UPCExtended Lumension Endpoint Management and Security Suite

PLUS_Reports Lumension Enterprise Reporting Client

SCM Lumension Security Configuration Management
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Database Name Product

ERS Lumension Enterprise Reporting

ERS_Staging Lumension Enterprise Reporting

ReportServer(1) Microsoft SQL Server Reporting Services

ReportServerTempDB(1) Microsoft SQL Server Reporting Services

SafeGuard(2) Lumension Disk Encryption powered by Sophos®

(1) Subscription features available in Microsoft SQL Server Reporting Services can be implemented
in Lumension Enterprise Reporting. By default, the database names are ReportServer and
ReportServerTempDB.

(2) Data protection capabilities in Lumension Disk Encryption is enhanced with a full disk encryption add-
on from Sophos. The installation of Lumension Disk Encryption results in a Safeguard database.

25. Against the master database run the following SQL command.

  exec sp_dboption N'STAT_Guardian', N'DB CHAINING', N'true'
  exec sp_dboption N'UPCCommon', N'DB CHAINING', N'true'
  exec sp_dboption N'UPCExtended', N'DB CHAINING', N'true' 
  exec sp_dboption N'PLUS', N'DB CHAINING', N'true'
  exec sp_dboption N'PLUS_Reports', N'DB CHAINING', N'true' 
  exec sp_dboption N'SCM', N'DB CHAINING', N'true'
  exec sp_dboption N'ERS', N'DB CHAINING', N'true'
  exec sp_dboption N'ERS_Staging', N'DB CHAINING', N'true'
  exec sp_dboption N'ReportServer', N'DB CHAINING', N'true'
  exec sp_dboption N'ReportServerTempDB', N'DB CHAINING', N'true'
  exec sp_dboption N'SafeGuard', N'DB CHAINING', N'true' 
    
     

26. If you changed the computer name, Service account name, or Client account name, then you must perform
the following steps.

a) Delete the previous Service account and Client account users from each database.
b) Add the new Service and Client account users to the following roles for each database.

• PLUS - EMSS Server and aspnet_ChangeNotification_ReceiveNotificationsOnlyAcccess
• PLUS_Reports - EMSS Server
• SCM - EMSS Server
• STAT_Guardian - Guardian_Admin
• UPCCommon - EMSS Server and aspnet_ChangeNotification_ReceiveNotificationsOnlyAcccess
• UPCExtended - EMSS Server and aspnet_ChangeNotification_ReceiveNotificationsOnlyAcccess
• ERS - EMSS Server
• ERS_Staging - EMSS Server

27. If you re-installed the Lumension EMSS server with a different user name than was used when originally
installed, run the following SQL command.

  UPDATE AccountContacts SET UserName = 'NewUserName' WHERE UserName = 'OldUserName'
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28. If you re-installed the Lumension EMSS server with the content directory in a different location than the
original installation, run the following SQL command.

  UPDATE SystemConfig SET SystemConfig_Value = 'NewStorageSystemPath' WHERE SystemConfig_Name =
 'Storage'
     

29. If you re-installed the Lumension EMSS server with a different installation directory than the original
installation, run the following SQL command.

  UPDATE SystemConfig SET SystemConfig_Value = 'NewWebInstallPath' WHERE SystemConfig_Name =
 'InstallPath'
     

30. Restart the World Wide Web Publishing Service, EDS LanPortal, EDS MessageBroker, EDS
Server, Replication Service, and STATEngine services.

31. Install the Lumension EMSS Agent from the Download Agent Installers page.

Creating an Automated Solution
A Maintenance Plan allows you to create an automated backup and schedule the backup to occur as frequently as
your organizational needs dictate. Maintenance Plans allow you to define your back up options as well as which
databases and transaction logs to include.

Note:  If you have not already done so, you should change your Database Recovery Model to FULL before
continuing. For additional information, refer to Changing the Database Recovery Model on page 615.

Creating a Maintenance Plan
You can automate a database maintenance plan for the SQL Server instances associated with Lumension
Endpoint Management and Security Suite.

Prerequisites:

Prior to creating a Maintenance Plan you must upgrade your database server to Microsoft SQL Server 2008
Standard or Microsoft SQL Server 2008 Enterprise, install SSIS (SQL Server Integration Services), and set the
SQL Server Agent startup type to Automatic.

1. Open the Microsoft SQL Server Management Studio (Start > Programs > Microsoft SQL Server 2008 >
SQL Server Management Studio).

2. Log into your database server.

3. In the directory tree, expand Server Name\SQL Instance > Databases.

4. Right-click on the Maintenance Plans folder.
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5. Select Maintenance Plan Wizard.

Step Result: The SQL Server Maintenance Plan Wizard opens.

Figure 247: SQL Server Maintenance Plan Wizard

6. Click Next.

Step Result: The Select a Target Server page opens.

7. Define the maintenance plan Name, Description [optional], target Server, and Authentication method.

8. Click Next.

Step Result: The Select Maintenance Tasks page opens.

9. Select the following maintenance tasks:

• Check Database Integrity
• Clean Up History [optional]
• Back Up Database (Full)
• Back Up Database (Transaction Log)

10. Click Next.

Step Result: The Select Maintenance Task Order page opens.

11. Set the tasks to execute in the following order:

• Check Database Integrity
• Back Up Database (Full)
• Back Up Database (Transaction Log)
• Clean Up History [optional]
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12. Click Next.

Step Result: The Define Database Check Integrity Task page opens.

13. Click the Database drop-down.

a) Select the These databases option.
b) Select the PLUS, PLUS_Reports, UPCCommon, UPCExtended, SCM, and STAT_Guardian databases.
c) Click OK.

14. Ensure that the Include indexes option is selected.

15. Click Next.

Step Result: The Define Back Up Database (Full) Task page opens.

Figure 248: Define Back Up Database (Full) Task

16. Click the Database drop-down.

a) Select the These databases option.
b) Select the PLUS, PLUS_Reports, UPCCommon, UPCExtended, SCM, and STAT_Guardian databases.
c) Click OK.

17. Define your Back up Destination settings.

a) Select either the Disk or Tape option.
b) Select to Create a backup file for every database.
c) Select to Create a sub-directory for each database.
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d) Define your destination Folder.

Note:  For performance reasons, it is recommended that you create your database backup in a directory
that is not on the same physical drive as your database.

e) Ensure the Backup file extension is set as bak.
f) Select Verify backup integrity.

18. Click Next.

Step Result: The Define Back Up Database (Transaction Log) Task page opens.

19. Click the Database drop-down.

a) Select the These databases option.
b) Select the PLUS, PLUS_Reports, UPCCommon, UPCExtended, SCM, and STAT_Guardian databases.
c) Click OK.

20. Define your Back up Destination settings.

a) Select either the Disk or Tape option.
b) Select to Create a backup file for every database.
c) Select to Create a sub-directory for each database.
d) Define your destination Folder.

Note:  For performance reasons, it is recommended that you create your database backup in a directory
that is not on the same physical drive as your database.

e) Ensure the Backup file extension is set as trn.
f) Select Verify backup integrity.
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21. Click Next.

Step Result: If the Clean Up History option was selected, the Define Cleanup History Task page opens.
Otherwise the Select Plan Properties page will open.

Figure 249: Define Cleanup History Task

22. If the Clean Up History option was selected, define the Cleanup History Task options.

a) Ensure that Backup and restore history is selected.
b) Ensure that SQL Server Agent job history is selected.
c) Ensure that Maintenance plan history is selected.
d) Define the Remove historical data older than setting as appropriate for your organization.
e) Click Next.

Step Result: The Select Plan Properties page will open.
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23. [Optional] Click Change to open the New Job Schedule page and define the maintenance plan schedule.

Figure 250: New Job Schedule

a) Enter a Name for the schedule.
b) Select a Schedule type.
c) Ensure that Enabled is selected.
d) Define the Occurrence frequency (Daily, Weekly, or Monthly) and options.
e) Define the Daily frequency.
f) Define the Duration.
g) Click OK.

Step Result: The changes are saved and the New Job Schedule page closes.

24. Click Next.

Step Result: The Select Report Options page opens.

25. Set your desired reporting options.

26. Click Next.

Step Result: The Complete the Wizard page opens.

27. Click Finish to complete the wizard.

After Completing This Task:

You must now establish a backup procedure which will archive all of your backup files and the contents of the
UpdateStorage directory on a regular basis. This can be done through the use of any file backup utility.



- 631 -

Appendix

E
Glossary

In this appendix:

• Glossary

This glossary defines terms related to Lumension Endpoint
Management and Security Suite. Some terms apply to information
technology in general, while others are specific to Lumension
Endpoint Management and Security Suite.

Glossary
This glossary contains list of terms related to Lumension Endpoint Management and Security Suite, as well as
their definitions.

A

AAA Architecture In client/server networking, an architecture that combines three necessary
elements of security, to make them available on one server and able to work
with each other in a coordinated manner.

access control list (ACL) A database file that stores information regarding entities that may request
access to a network, as well as the rights and privileges to be granted upon
request.

accessible endpoints A feature that associates an individual endpoint with a particular role. This
feature allows you to limit a user’s permissions to specific endpoints. For
example, you can limit a user with administrative rights to administration of
a single endpoint.

accessible endpoint groups A feature that associates an individual group with a particular role. This
feature allows you to limit a user's permissions to specific groups. For
example, you can limit a user with administrative rights to administration of
a single group.

access rights System privileges that determine whether or not a user can access an
individual feature or page. There is an access right for each system page
and function. Access rights for a user are determined by selecting rights for
a user role, and then assigning that user role to the applicable user.
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accounting In network security architectures, records what users do once they are
granted access to a network, or in the case of denied access, it can report
how many failed attempts, and even details of the attempts.

Active Directory Microsoft’s trademarked system that centralizes the management of
networked resources by making each item on a network, including
most applications, objects in a relational database and then enabling the
administrator to manage those objects through one management center.

active directory synchronization The process by which the Application Control module synchronizes with a
network active directory. This process crawls targeted active directories for
users, user groups, endpoints, endpoint containers, and other data stored in
the active directory.

Active Server Page An HTML page that contains embedded server side scripting that is
processed on a Microsoft Web Server before the page is sent to the user.

ActiveX A technology, built on Microsoft’s Component Object Model (COM), that
enables software components, regardless of the language used to create
them, to interact with one another in a networked environment.

Active Template Library A Microsoft program library for use when creating ASP code and other
ActiveX program components to run in a browser window.

Address Resolution Protocol An OSI layer-3 protocol used to find an endpoint’s MAC address using its
IP address.

agent A software routine that resides in background memory on a computer or
other device and waits to perform an action when a specified event occurs.

Agent Management Job Jobs that let you install agents upon endpoints within your network
remotely. The first function of this job is to discover the targeted endpoints
as in a discovery scan job. The second function of this job is to install
agents upon endpoints discovered during the first function. These jobs
access the targeted endpoints by providing credentials specified during job
configuration.

Agent Policies The agent rules for communicating with the server. These rules include:
communication interval, deployment notification options, discovery agent
mode, hours of operation, logging level, and reboot notification options.
Agent policies are assigned to groups, but any group that has not been
explicitly assigned an agent policy will use the default system policy, as
defined within the Lumension Endpoint Management and Security Suite
server.

agent policy conflict resolution A series of protocols that determine which setting takes priority when a
group or endpoint is assigned two or more agent policy sets with policies
that conflict.
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Agent Policy Sets The combined selected agent policies as defined by the user. After their
definition, these sets are then assigned to groups.

asset An endpoint, along with all the hardware and software that is installed on
that endpoint. Each endpoint, individual hardware device, and individual
software application is considered an asset.

authentication The process of identifying a user, typically through the use of credentials
such as a user name and password, as the originator of a message or as the
end point of a channel. High level authentication can use such other tokens
as the originating IP address, or an encryption key, providing evidence of
the authenticity of the request.

Authenticode A technology based on information technology security industry standards
that provides a method for developers to digitally sign their code. When
code is signed, the company signing the code takes responsibility for the
code and guarantees that the code is safe and free from viruses.

authorization vs. authentication Whereas authentication is the process of verifying that a user is who they
say they are, like having two forms of ID from different places, or dating
paint and frame wood to verify authenticity of a painting, authorization is
verifying the level of access available to that user, such as aisle and row
seating stamped on a concert ticket, or possessing a back-stage pass.

authorization The process of determining what level of access to grant a user to a system
or software application function based upon their log in credentials.

Automatic Caching System
(ACS)

A system that automatically writes packages marked critical to a memory
queue, allowing administrators to have the critical and security-related
patches available for rapid deployment.

B

baseline In information technology, it is the base set of files that comprises a system,
or the backup state available for reversions in the case of viral infection or
other loss of data, such as when a system is restored from a backup.

behavior A specific desired outcome for any patch or package deployment,
configurable by the use of deployment flags and options.

browser Software that allows the user to find, view, hear, and interact with material
on a corporate Intranet or the World Wide Web.

C

chained deployment The deployment of multiple packages in sequence, flagged to prevent
reboot until the last of the chain has been deployed. Chained deployments
are a Patch and Remediation module function
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child hierarchy The entire group hierarchy belows a specific group within the group
hierarchy. Child groups have only one parent. Nesting child groups within
parent groups creates an inheritance, which lets you apply one agent policy
set to a parent and its children.

client In computer networks, a client is any user, computer, node, server, or
system that is requesting files from or access to some other system,
regardless of whether it also acts as a server.

code signing The process of digitally signing programs for verification purposes.

Common Vulnerabilities and
Exposures (CVE)

A list of standardized names for vulnerabilities and other information
exposures. CVE aims to standardize the names for all publicly known
vulnerabilities and exposures.

communication interval Determines how much time the Lumension Endpoint Management
and Security Suite agent will sleep between communication with the
Lumension Endpoint Management and Security Suite server. When the
agent communicates with the server, it is checking for agent policy updates
and deployments. This interval is critical since if the interval is too long,
the agents will not get their tasks in a reasonable amount of time. If the
interval is too short, the server may constantly be busy and other agents
may not be able to get their tasks. Interval rates typically vary between 15
and 60 minutes depending on the number of nodes, network architecture
and bandwidth.

components The components that form Lumension Endpoint Management and Security
Suite. components come in two types: platform components and module
components. Platform components form a basis for module components to
operate. Module components are the individual security solutions used to
prevent network security breaches.

Component Object Model
(COM)

Microsoft’s programming architecture in the Windows family of operating
systems that enables software components to communicate between
processes and fit easily into object-oriented program design. The family
of COM technology includes COM+, Distributed COM (DCOM) and
ActiveX.

compliance An expression of whether the node being evaluated meets the Mandatory
Baseline of content to make it safe for admission to the network in a
quarantine arrangement. Usually expressed by the boolean true or false,
a station can either be compliant or non-compliant. If non-compliant, it
is set up for remediation and under quarantine until fully patched. This
expression applies to environments with the Patch and Remediation module
installed.
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concurrent deployment limit Defines the maximum number of Lumension Endpoint Management and
Security Suite agents that can receive active deployments at the same
time. The purpose of the limit is to control the number of deployments to
agents across the entire network and to reduce the chance of overloading
your Lumension Endpoint Management and Security Suite server. If an
agent takes longer than 60 minutes to finish its deployment, it is no longer
counted against this limit. This is the only value that cannot be overridden
by a group’s agent policy set, as it limits deployments for all agents.
This option is available in environments with the Patch and Remediation
installed.

content Any type of content that the Lumension Endpoint Management and
Security Suite server can deploy to agents. Types of content include
vulnerabilities, software, patches, hotfixes, and so on. Security content
items contain pre-requisites, fingerprints, and signatures (all of which
determine whether content is applicable to an endpoint) in addition to the
package that contains the software to be installed. Content is available in
environments with the Patch and Remediation module installed.

context Pertaining to Microsoft Active Directory, context refers to the exact
container position in the directory tree, thus allowing for the location of
resources in a tree, by use of relative rather than fully qualified identifiers.

Control Panel applet An application designed to be run within Microsoft Windows Control
Panel. Lumension’s Control Panel applet allows easy interaction with the
Lumension Endpoint Management and Security Suite agent.

Coordinated Universal Time
(UTC)

An international standard that allows for synchronization of events across
many geographic zones. On a Lumension Endpoint Management and
Security Suite server, UTC might be chosen instead of local time if a
scheduled event is desired to run at the same time at all sites, dependent
also upon deployment constraints.

credentials An object or objects presented along with a request for admission to a
network or server that is used to validate the authorization of the presenter.
Usually a credential is a combined user name and password, but can also
consist of IP address, MAC address or an encryption key to verify that the
request comes form an authorization location.

cross-platform Portable or applicable to more than one operating system.

D

decryption The process of converting ciphered text back to plain text after it travels
across a public access medium. A previously determined key is used once
the text arrives at its destination to convert the ciphered message back to
clear text.
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decryption key A string of seemingly random bits of data used with cryptographic
algorithms to create or verify digital signatures and unscramble cipher text
back to its original clear text. Keys can be public or private and keeping at
least one key private provides high security. Keys at least 128 bits long are
considered more secure by modern standards, as many shorter ones have
been cracked by modern computing technology.

deadline When deploying patches or packages, it is the date and time by which
a package or patch absolutely must deploy, and until which, a user may
snooze a deployment if inconvenient. This term applies to environments
with the Patch and Remediation module installed.

deployment flag When preparing a package or patch deployment, the administrator has
many options and flags that can be set to fine tune how and when the
deployment occurs and what events accompany and follow the deployment.
This function is available in environments with the Patch and Remediation
module installed.

deployment The planned delivery of content to any or all nodes determined to be non-
compliant. Deployments are available in environments with the Patch and
Remediation module installed.

dirty C state Indicates that the Lumension Endpoint Management and Security Suite
agent received a chained deployment and the reboot is currently suppressed.
While in the C state, the agent will only accept other chained deployments
or a reboot deployment. Only a reboot deployment or manual reboot will
clear this state. This term applies to environments with the Patch and
Remediation module installed.

dirty R state Indicates that the Lumension Endpoint Management and Security Suite
agent received a deployment that required a reboot and the reboot was
suppressed. While in the R state, the agent will only accept a reboot
deployment. Only a reboot deployment or manual reboot will clear this
state. This term applies to environments with the Patch and Remediation
module installed.

dirty state The term used to describe an agent that displays a C or R on the Endpoints
page of the Lumension Endpoint Management and Security Suite server.
Agents that are in a clean state display no such lettering. This term applies
to environments with the Patch and Remediation module installed.

Discover Applicable Updates
(DAU)

A predefined system task that launches the Lumension Endpoint
Management and Security Suite agent on a client endpoint. The DAU runs
following subscription replication, five minutes after the application of a
patch, after a reboot and when an agent checks in after the ScanNow button
has been clicked in the Lumension Endpoint Management and Security
Suite server interface.
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discovery methods The methods used to designate targets (endpoints and devices) during
discovery scan jobs. Endpoints and devices can be discovered using a
single IP address, an IP address range, a single computer name, network
neighborhood, or active directory.

discovery options A series of queries and scans that collect information about targets
defined for detection during discovery scan jobs. These options (which
include Verify with PING, ICMP Discovery, Port Scan Discovery, SNMP
Discovery, Windows Version Discovery, Resolve DNS Names, Resolve
MAC Addresses, and Resolve NetBIOS Names) identify whether an
endpoint is present, and, if one is, what its address and operating system
information are.

Discovery Scan Job A network-based scan run from the Lumension Endpoint Management
and Security Suite server that discovers assets in your network (endpoints,
routers, switches, printers, and so on) by using user-specified IP addresses
or asset names and/or domains. These jobs also discover additional
information about assets (operating system, address information, and so on)
through port scans, information queries, and address mask requests.

Distributed Component Object
Model (DCOM)

An extension of the Component Object Model (COM) that extends COM’s
capabilities across network boundaries, allowing objects to communicate
across a network. COM, unlike DCOM, is designed for interprocess
communication on the same node or computer.

domain On a local or wide area network, a domain is a set of network resources and
services available to a group of users. Domains act as containers that can be
identified by a name and address, which can then provide authorized users
access to any elements they contain. Domains can also share resources with
each other as trust is extended by administrators to those other domains.

Domain Name System (DNS) The system used to name computers and especially servers for easier
location. A domain name is a meaningful and human-readable name
associated with an IP address. Domain names most often take on the format
of domainname.com and the most common ones are associated with WWW
locations.

Dynamic Host Configuration
Protocol (DHCP)

A protocol that lets network administrators centrally manage and automate
the assignment of IP addresses in an organization’s network by establishing
a range of IP addresses to be assigned automatically and indexed. Without
DHCP, managers would have to manually assign and keep track of each
host IP address on the network.

dynamic-link library file (DLL
file)

A file that has linked and compiled one or more functions used by a
separate process, which can be loaded into the memory space of that
process when the program is started or running.
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E

encryption The process of converting clear, readable text to ciphered text before
it travels on network media, so that it can only be read or understood
by a recipient with the proper decryption key. Some of the most secure
encryption methods include RSA, AES, IKE, MDS, SSL, and SHA-1.

encryption key A string of ciphered bits used with cryptographic algorithms to create or
verify digital signatures and scramble clear text to protect it from being
intercepted and read while traveling across public networking media. Keys
can be public or private, and keeping at least one key private provides
high security. Keys at least 128-bits long are considered more secure
by modern standards, as many shorter ones have been compromised by
modern computing technology.

endpoint In a client/server network architecture, an endpoint is any node that is a
destination of two-way communication, whether requesting or responding.
Additionally, in regard to the Lumension Endpoint Management and
Security Suite, the term endpoint is synonymous with any computer in your
network that can have an agent installed.

F

File Transfer Protocol (FTP) A protocol that uses simple, clear text. Thus, it is a non-secure protocol
used to exchange files between computers on a network or the internet.

fingerprint A group of unique identifiers used to determine the presence of a patch,
and/or vulnerability, and/or content item. Fingerprints can include unique
files, file attributes, directories, registry keys or data values. This term
applies to environments with the Patch and Remediation module installed.

firewall A firewall is a set of related programs located at a network gateway server
that protects the resources of a private network from unauthorized access.

fully qualified domain name
(FQDN)

The domain name is a unique identifier for any resource located within a
domain or network. A FQDN is the full name of any network entity starting
with its hostname and ending with the exact domain name in which it
resides. Example: johnq.accounting.acme.com

G

Global Subscription Server
(GSS )

The central repository where security content is stored for retrieval by the
Lumension Endpoint Management and Security Suite server. The GSS
also serves as the Lumension Endpoint Management and Security Suite
licensing server.
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globally unique identifier (GUI) A 128-bit number generated by Windows operating systems or one of its
applications, which is assigned to any object in a two-way communication,
be it user, application, or component. The algorithm used to generate
GUIDs combines a few unique settings, such as IP Address, MAC Address,
and clock date and time to create an even more unique identifier.

group A targeted collection of computers created and named for the purpose of
deploying distribution packages, defining agent policies, setting Mandatory
Baselines, or reporting. Groups provide a simple way to manage computers
that have similar requirements rather than managing each computer
separately.

H

hostname The name given to identify each node of a network. The hostname usually
describes either the user that operates the node, its position in a building, or
its function. Hostname is intended to be more human friendly than numeric
IP Addresses.

hours of operation (HOP) When enabled, this value determines when the agents start and stop
communicating with the Lumension Endpoint Management and Security
Suite server. If the agent is in the middle of a deployment and the agent’s
hours of operation expire (exceed the designated stop time) it will finish
what it is currently working on and continue the rest of the deployment at
the next hours of operation interval. This term applies to environments with
the Patch and Remediation module installed.

HTML The accepted publishing language of the World Wide Web. It is a
universally accepted standard for displaying links, images, and text in a
format that computers around the world can read. There are currently many
advantages in HTML that allow for an increasing number of different types
of objects to be added to and displayed in a browser page.

HTTP The set of rules for exchanging files (text, graphic images, sound, video,
and other multimedia files) on the World Wide Web.

HTTPS A Web protocol built into most browsers that encrypts and decrypts user
page requests as well as the pages that are returned via HTTP over SSL by
the Web server.

hyperlink Generally a different color from the surrounding text, a hyperlink is a coded
reference to another location in the document, or to a URL or network
address, usually written in a form of HTML code or JAVA, and is most
prevalent on Web pages.
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I

Internet Assigned Numbers
Authority (IANA)

An administrative organization that assigns internet host addresses and
other numeric constants used in Internet protocols.

Internet Information Services
(IIS)

Microsoft’s Web server that provides an infrastructure for all Internet
services (HTTP, FTP, Telnet, and Gopher for some examples) and
other capabilities for Microsoft’s NT, XP, 2000, 2003, 2008, and Vista
operating systems. The IIS Manager allows for central control of all related
information services.

inventory The hardware, software, services, and operating systems that operate on
an endpoint. During scanning, the Lumension Endpoint Management
and Security Suite agent compiles a listing for each item in an endpoint's
inventory. Some unclassifiable items, such as serial numbers, are also
included in an endpoint's inventory. This term applies to environments with
the Patch and Remediation module installed.

IP (Internet Protocol) The best known and main protocol in a suite of protocols known as TCP/
IP that carry all traffic on the internet currently. IP is a connectionless
protocol, meaning it does not wait for confirmation that it was received
before sending the next packet. It is designed for long distance carriage of
packets of data, as was originally the plan with Arpanet, which later became
the internet.

IP address The 32-bit (4 dotted divisions of eight binary digits) numeric identifier for
any device on a network that distinguishes it from other devices and allows
for routers and switches to group devices and their communication packets.
The 32-bit dotted format is soon to be replaced by IPv6, which will expand
the number of available IP addresses to keep pace with the enormous
growth of the internet in recent years. Example: IP address 192.168.0.1
would be read by a router as 11000000.10101000.00000000.00000001.

J

JAVA A programming language invented by Sun Microsystems. It can be used
as a general purpose application programming language with built-in
networking libraries. It can also be used to write small applications called
applets.

JAVA Runtime Environment
(JRE)

Created by Sun Microsystems, it is the core set of files necessary to execute
JAVA written programs in any OS environment. JAVA is used because it
is cross-platform, which is increasingly necessary in the current Web-based
world.
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L

library A collection of precompiled routines, sometimes called modules, that are
stored in object format for reuse by a program.

Lightweight Directory Access
Protocol (LDAP)

A software protocol that enables the use of Directory Services to locate
organizations, individuals, and other resources such as files and devices in a
network, whether on the Internet or on a corporate intranet.

localhost The default name describing the computer address also known as the
loopback address of the computer. On Web servers, this loopback can be
used to test the default Web page. To access this page, type http://127.0.0.1
or http://localhost.

localprofile.txt An XML file found in the C:\ProgramFiles\Lumension\Patch Agent, this
file is maintained by the Lumension Endpoint Management and Security
Suite agent and contains information on computer’s name, services,
software, hardware, operating system, and support pack level. The refresh
inventory data system task uses the information in this file to populate
computer inventory data on the Lumension Endpoint Management and
Security Suite server.

Lumension Content Wizard Lumension Content Wizard (LCW). An addition to Lumension Endpoint
Management and Security Suite that provides the ability to define custom
detection reports, deployment packages, signatures, and fingerprints.
It has an easy-to-use graphical interface that illustrates all associated
subcomponents of the patch in a single view.

Lumension Endpoint
Management and Security Suite

An application that serves as a platform for other applications that protect
your network from security risks. These applications, called modules,
use different approaches to protect your endpoint. Lumension EMSS is
composed of a server component and an agent component. The server
component is installed on a server within your network. The agent
component is installed on network endpoints you want to protect from
security risks. Lumension EMSS is accessed via a Web UI.

Lumension Endpoint
Management and Security Suite
administrator

Any user who is assigned any of the access rights that control the
functionality of the Lumension Endpoint Management and Security Suite
server or its deployments is considered a Lumension Endpoint Management
and Security Suite administrator.

Lumension Endpoint
Management and Security Suite
Agent

The Lumension Endpoint Management and Security Suite agent is a service
that runs on each node and queries the Lumension Endpoint Management
and Security Suite server to receive any deployments that become ready.
The behavior of the agent is defined by the agent’s policies, whether it is
using the default agent policies of the Lumension Endpoint Management
and Security Suite server or the group’s agent policies.
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Lumension Endpoint
Management and Security Suite
Server

The central system in Lumension Endpoint Management and Security
Suite that manages content retrieval, vulnerability detection, and package
deployment to all registered computers on the network. As a sophisticated,
automated central repository of the most current security content available
for a network, it maintains communication with the Lumension Endpoint
Management and Security Suite agent on nodes, across many key
networking platforms, on the network, and detects any vulnerabilities with
the help of the agent on each node.

Lumension Endpoint
Management and Security Suite
user

Any user who has access to authenticate in to the Lumension Endpoint
Management and Security Suite server is considered a Lumension Endpoint
Management and Security Suite user.

M

MAC address A 12-digit hexadecimal address that is burned into network cards and
networking devices to allow for unique reference.

macro Within Lumension Endpoint Management and Security Suite, a macro is
an environment variable that represents a filename, directory path, or a
series of commands, actions, or keystrokes that can only be executed by the
Lumension Endpoint Management and Security Suite agent.

Mandatory Baseline The absolute minimum set of content or locally-created distribution
packages that must be installed on the group’s computer members. In terms
of content reports, a Mandatory Baseline will continually verify that the
content is actually installed, and, if it is not, it will deploy the necessary
distribution packages to bring the computer into compliance. This feature
is available in environments with the Patch and Remediation module
installed.

Microsoft SQL Desktop Edition
(MSDE)

An enabling technology that provides local data storage and is completely
compatible with the SQL Server version 7.0 code base. This technology
transforms Microsoft Access from a simple file-server database application
into an extremely powerful and highly scalable client-server solution for
any size organization.

Module Components Individual security solutions used to prevent various types of security
breaches within your network. Each module plugs in to the Lumension
EMSS platform and can be purchased individually. Some module
components come installed with the Lumension EMSS platform and require
no additional licensing.

Module Sub Components The two parts that form a module component. Each module component
consists of a server sub component and an endpoint subcomponent. These
subcomponents work together to form a module's functionality.
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MSI installer Designed for Windows networks that use the Windows software installer
mechanism. The MSI installer can be edited to include the Lumension
Endpoint Management and Security Suite server name and serial number.
In this way, the agent can be deployed through the use of group policy
agents.

N

NetWare Networking OS that has played a major role in the development of Local
Area Networking over the past few decades, being an early Network OS to
use the Directory Services concept.

Novell Directory Services (NDS) The relational database that contains all the resources on a Novell network,
and provides security, and access for all resources.

O

Open Software Description
(OSD)

Creates a standard way to describe software components, their versions,
underlying structure and relationships to other components. OSD is the
standard language used when performing automatic software distributions
and updates over the Internet.

Operating System Pack (OSP) Contains all vulnerability detection information needed by an agent for a
given operating system. It is generated by the DS and is passed to the agent
during the DAU task. When a vulnerability replication executes, it checks
to see if any operating systems received new data and it will automatically
schedule the DS to regenerate the OS Packs for those operating systems.

P

package A package contains all the actual patch software and executable code
for deployment. A package can run tasks or scripts, install software
applications, place files (or directories of files) in a specified location,
change the configuration of applications or services, or perform various
other tasks that can be done in an unattended manner. The majority of
packages contain the patches for vulnerabilities, defects, or bugs. This term
applies to environments with the Patch and Remediation module installed.

package script The script that performs the functions required to start package installation.
Can be written using Microsoft VBScript, Microsoft JScript, or command
line script. This term applies to environments with the Patch and
Remediation module installed. Documentation regarding these languages
can be found at MSDN Library: Scripting (http://msdn2.microsoft.com/en-us/
library/ms950396).

http://msdn2.microsoft.com/en-us/library/ms950396
http://msdn2.microsoft.com/en-us/library/ms950396
http://msdn2.microsoft.com/en-us/library/ms950396
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parent hierarchy Refers to the entire group hierarchy above a specific group within the group
hierarchy.

Patch and Remediation A Lumension Endpoint Management and Security Suite module you can
use to apply hotfixes, patches, service packs, and other content to agent-
managed endpoints. Content is first deployed from the Lumension Endpoint
Management and Security Suite Server, and is then installed on endpoints
by the Lumension Endpoint Management and Security Suite Agent.

patch management The systematic deployment, installation, and auditing of applicable
hotfixes, patches, and service packs to operating systems and software
applications. This process must incorporate the organization or people
needed to administer the patches, the processes needed to ensure the proper
testing, the inventorying of existing patch levels, the identification of
needed patches, and the technology to deploy and apply the appropriate
patches.

platform components The essential components needed for Lumension Endpoint Management
and Security Suite operation. These components include the Lumension
EMSS Web console, the Lumension EMSS database, and the Lumension
Installation Manager.

policy server In a network designed with protections against unauthorized admission, it
is where the rules and policies are stored that are the standards by which
admission decisions are made. Rules can then be enforced by routers or
some other form of firewall protection.

port number The port number is carried in internet transport protocols to identify which
service or program is to receive an incoming packet. Certain port numbers
are permanently assigned to particular protocols by the IANA. For example,
e-mail uses port 25 and Web services use port 80.

posture A term used by Cisco to refer to the state of readiness of a node requesting
admission to a network, which will determine, when compared to the rules
on the policy server, what degree of access if any, the node may be granted
to the network. No access is usually termed as quarantine.

prerequisite A requirement, such as the existence of a software package, file, and/or
registry entry, that must be met prior to the deployment or installation of a
patch.

proxy server In an enterprise that uses one of the Internet protocols, a proxy server is a
server that acts as an intermediary between a client and an Internet server.
The proxy server allows an enterprise to ensure security and administrative
control.
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Q

Q-chain (QChain.exe) The utility Microsoft provides to chain hotfixes on Microsoft Windows NT,
2000, 2003, 2008, XP, or Vista.

quiet mode When set to quiet mode, a deployment package will suppress all user
interfaces during installation.

R

Reflective Memory Injection A technique for excuting external code within an authorized process,
bypassing an endpoint’s whitelist enforcement mechanism. This is
sometimes (though not always) the result of a malware attack.

Refresh Inventory Data (RID) Prevents certain log files from getting too large. RID is handled differently
on the various platforms; some delete the files when they reach a certain
size, while others will trim the file, leaving the most recent data but
shrinking the file size.

registry The registry serves as a central data repository for system and application-
specific configuration data on a Windows machine. A registry contains
keys, which are like directories in a Windows file system. Each key can
contain values (the registry equivalent of a data file) or nested subkeys (the
registry equivalent of a nested folder). Just as with files or folders, you can
identify a registry key by building a full path to it.

remediation Installing a countermeasure to reduce or neutralize the risks associated
with a vulnerability. This term applies to environments with the Patch and
Remediation module installed.

replication The process whereby the Lumension Endpoint Management and Security
Suite server receives daily scheduled updates of patches from the GSS.
The schedule replication time of day can be manually overridden daily by
clicking Update Now.

report Records that document activity and information pertaining to your network
environment. Within the Lumension Endpoint Management and Security
Suite server, you can generate reports for virtually every function that the
server and agent performs: endpoint inventory, the results of discovery scan
jobs, the status of a deployment, and so on.

Reverse Address Resolution
Protocol (RARP)

Literally, the reverse of Address Resolution Protocol, RARP resolves an IP
address from a given hardware, or MAC address.

rules Statements of conditions that must be met or parameters that will determine
an action to be taken. Rules can be positive or negative, but usually are
stated simply and clearly such as “if member of group ADMIN, run
superuser.bat.”
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S

Secure File Transfer Protocol
(SFTP)

A secure version of FTP, SFTP is designed to provide some encryption
capabilities for file transfer over a network. Functionally similar to FTP,
SFTP instead uses SSH to transfer files, so it cannot be used with a standard
FTP client.

Secure Sockets Layer (SSL) A security protocol that provides data encryption, message integrity, and
client/server authentication for the transmission of private information and
documents over the internet. SSL is available with either 40-bit or 128-bit
encryption. However, 40-bit has been compromised in recent years, making
128-bit the lowest level anyone should go for secure encryption.

server A server is a computer or software application that provides data to client
computers or software applications. A single computer running multiple
software applications can simultaneously perform the function of multiple
servers, multiple clients, or any combination thereof.

signature Used to recognize a specific combination of installed software applications,
services, and operating systems. A signature typically contains multiple
fingerprints.

source group Groups that automatically assigned managed endpoints to associated
custom groups.

SQL Server A trademark for a Microsoft database server that uses SQL. SQL Server is a
popular database management system for Windows NT environments.

structured query language
(SQL)

A database language used by administrators of relational databases to
query, update, and mange data. It enables the administrator to use clear
syntax that is descriptive of whatever action is wanted.

SSL Certificate An electronic certificate consisting of a set of keys, one public, one private,
exchanged between a Web server and a requesting client. A session is
created, and a unique session key ensures a high level of encryption of any
sensitive data passed between the client and server, preventing interception
or unauthorized use of that data by any other entity.

standard deployment The deployment of a standard, non-chainable package, or the deployment of
a chainable package in a non-chainable state. This function is available in
environments with the Patch and Remediation module installed.

T

TCP/IP (Transmission Control
Protocol/Internet Protocol)

The main suite of communications protocols used to connect hosts on the
Internet, and now the prevalent LAN protocol even when other protocols
are available.
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transaction log A Web server file that records a history of actions such as data changes.
This log is used to roll the Web server back to a stable condition should the
database be found in an inconsistent state.

trust In domains, a trust relationship will allow members of one domain, when
properly logged in and authenticated, to access services available on
another domain.

U

URL (Universal Resource
Locater)

The address that is the formal access name for a network or Internet
resource. It usually begins with the protocol identifier, such as http or ftp.
Thus, http://www.yahoo.com is a URL for the domain yahoo.com.

user A profile used to access the Lumension Endpoint Management and Security
Suite server. These profiles include credentials (a user name and password)
and an assigned role that determines the user's access rights within the
system.

User Datagram Protocol (UDP) A communications protocol that offers a limited amount of service when
messages are exchanged between computers in a network that uses Internet
Protocol. It is one of the most common connection based protocols in use
on the internet, the other being TCP.

user name The unique name used to gain access to a computer and/or network. User
names and passwords are required in multi-user systems.

V

VeriSign certificate A VeriSign certificate is issued by VeriSign, Inc. to verify a company’s
identity and enables the company to digitally sign programs and prove the
authenticity of a Web site address.

vulnerability A weakness in a system that would allow an attacker to compromise
system confidentiality, integrity, or availability. Alternatively, it can
also be a breach from the original design, concept, or intended behavior
of a computer’s hardware or software that leaves the computer, or any
piece of it, in an exposed state. Malicious users can use this to force other
unintended actions to be performed. Vulnerabilities are often caused
by defects or bugs, though this is not always the case. Many times the
very configuration may result in unexpected exposures. Even out of date
documentation may be labeled as a vulnerability, as not informing a user
of how to perform actions in the preferred manner may result in systems
being widely exposed. This term applies to environments with the Patch
and Remediation module installed.
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vulnerability report A series of signatures and fingerprints designed to determine if a computer
is a susceptible to a vulnerability and if the computer has been patched.

W - Z

Web server A program that publishes content using the HTTP protocol so that it can
be viewed using any type of compliant browser from any location on the
connected Intranet or Internet.

widget A graph or chart displayed on the Lumension Endpoint Management and
Security Suite Home page that depicts Lumension Endpoint Management
and Security Suite and Lumension Endpoint Management and Security
Suite module activities.

World Wide Web (WWW) A commonly used name for the Internet, the WWW is a Web of connected
Domains of local computers, which can share information with authorized
users whom connect from anywhere else on the Web. Due to the
exponential growth in recent years, a good way to check on current
standards is to visit the World Wide Web Consortium (http://www.w3.org).

XML (extensible markup
language)

A flexible way to create common information formats and share both the
format and the data on the World Wide Web, Intranets, and elsewhere.

http://www.w3.org
http://www.w3.org

	Table of Contents
	About This Document
	Typographical Conventions
	Contacting Lumension

	Lumension Patch and Remediation Overview
	Installing Patch and Remediation on the Lumension EMSS Server
	The Patch and Remediation Process
	Recommended Configuration
	Recommended Server Configuration
	Recommended Server Configuration (Components on Separate Servers)
	Recommended Agent Configuration
	Recommended Server Configuration Information

	Supported Endpoint Operating Systems
	Agent Supported Internationalizations and Locales

	Installing the Module
	Explaining Module Subcomponents
	Installing the Patch and Remediation Module Server Component
	Installing the Patch and Remediation Module Endpoint Component
	Uninstalling the Patch and Remediation Module Server Component

	Getting Started with Patch and Remediation
	Patch and Remediation at a Glance
	Help and support while you work
	The Lumension Patch and Remediation Workflow
	Logging In to Lumension Endpoint Management and Security Suite
	Installing the Patch and Remediation Module Server Component
	Installing the Patch and Remediation Module Endpoint Component
	Creating New Groups
	Creating Agent Policy Sets
	Viewing and Remediating Vulnerabilities
	Adding Content to a Mandatory Baseline
	Defining Default Deployment Options
	Editing Email Notifications
	Editing Custom Roles


	Using Lumension Endpoint Management and Security Suite
	Supported Browsers
	Logging In to Lumension Endpoint Management and Security Suite
	Logging Out of Lumension Endpoint Management and Security Suite

	Common Functions within Lumension Endpoint Management and Security Suite
	Common Conventions
	Toolbars
	List Pages
	The Page Banner
	The Options Menu
	Filters
	Supported Wildcards
	Using Filters
	Using Filter Rows

	Group By
	Expanding and Collapsing Structures
	Advancing Through Pages
	Help
	Exporting Data

	The Home Page
	The Lumension Endpoint Management and Security Suite Header
	The Navigation Menu
	The Dashboard
	Dashboard Setting and Behavior Icons
	Previewing and Printing the Dashboard
	Editing the Dashboard
	The System Alert Pane
	License Expiration


	Configuring Default Behavior
	The Subscription Updates Page
	Viewing the Subscription Updates Page
	Subscription Updates Page Toolbar
	Subscription Service Information
	Subscription Service History
	The Subscription Service Configuration Dialog
	Viewing the Subscription Service Configuration Dialog
	The Service Tab
	Status
	Package Caching
	Proxy
	Communication

	The Languages Tab
	The Content Tab


	Working with Subscription Updates
	Replicating
	Resetting the Replication Status
	Editing the Communication Interval
	Configuring the Service Tab
	Restarting the Subscription Service
	Configuring the Languages Tab
	Exporting Content Data
	Exporting Subscription Update Data

	The Email Notifications Page
	Viewing the Email Notifications Page
	Email Notification Page Buttons
	The Email Notifications Table
	Alert Settings
	RSS Feed

	Working with Email Notifications
	Defining Alert Settings
	Creating Email Notification Addresses
	Editing Email Notification Addresses
	Deleting Email Notification Addresses
	Exporting Email Notification Data
	Testing Email Notifications

	The Options Page
	The Options Page Buttons
	Viewing the Options Page
	The General Tab
	UI Options
	Password Options
	Discovery and Agent Management Job Logging
	Report and Display Options

	The Agents Tab
	Agent Installation
	Communication
	Discover Applicable Updates (DAU) Options
	Absentee Agent Deletion
	ISAPI Communication
	Agent Versions
	The Agent Version Detail Dialog


	The Deployments Tab
	Deployment Defaults
	Notification Defaults
	User Interface


	Working with Options
	Configuring the General Tab
	Configuring the Agents Tab
	Configuring the Deployments Tab
	Exporting Option Data


	Licensing and Support
	The Technical Support Page
	Viewing the Technical Support Page
	Technical Support Page Buttons
	Technical Support Options
	Server Information
	Viewing the MDAC File Version Information Dialog
	MDAC File Version Information

	Suite Version Information
	Regenerating OS Packs
	Exporting Technical Support Data

	The Product Licensing Page
	Viewing the Product Licensing Page
	The Product Licensing Page Buttons
	The Product Licensing Page List
	Initiating Subscription License Replication Jobs
	Exporting Product Information

	Supporting Linux and UNIX Endpoints
	Content Credentials Manager
	Red Hat Enterprise Linux Content Support
	Configuring Red Hat Network Credentials

	Oracle Solaris Content Support
	Configuring My Oracle Credentials

	Oracle Linux Content Support
	Configuring Oracle Unbreakable Linux Network Credentials

	Novell SUSE Linux Support
	Enabling Enhanced Content for Novell SUSE Linux

	HP-UX Content Support
	Configuring HP IT Resource Center Credentials



	Using Endpoints
	About Endpoints
	Viewing the Endpoints Page

	The Endpoints Page
	The All Tab
	The All Tab Toolbar
	The All Tab List

	The Patch and Remediation Tab
	The Patch and Remediation Tab Toolbar
	The Patch and Remediation Tab List


	Working with the Endpoints Page
	Deploying Content to Endpoints (Patch and Remediation Tab)
	Installing an Agent
	Installing Agents by Agent Management Job
	Uninstalling Agents by Agent Management Job
	Defining the Endpoint Agent Version
	Downloading the Agent Installer
	Deleting an Endpoint
	Enabling Modules on an Endpoint
	Enabling an Endpoint
	Disabling Modules on an Endpoint
	Disabling an Endpoint
	The Add/Remove Modules Dialog
	Managing Module Endpoint Components

	Using Scan Now to Scan Inventory (Patch and Remediation Tab)
	Rebooting Endpoints
	Exporting Endpoint Information

	The Endpoint Details Page
	Viewing the Endpoint Details Page
	The Information Tab
	The Information Tab Toolbar
	Endpoint Information
	Agent Information
	Status Information
	Component Information
	Group Information
	Policy Information

	The Vulnerabilities Tab
	The Vulnerabilities Tab Toolbar
	The Vulnerabilities Tab List

	The Inventory Tab
	The Inventory Tab Toolbar
	The Inventory Tab List

	The Deployments and Tasks Tab
	The Deployments and Tasks Tab Toolbar
	The Deployments and Tasks Tab List
	Viewing Deployment and Task Results


	Working with the Endpoint Details Page
	Viewing the Agent Uninstall Password
	The Agent Uninstall Password Dialog

	Defining the Endpoint Agent Version (Endpoint Details)
	Enabling Content
	Disabling Content
	Updating the Cache
	Deploying Content (Endpoint Details Page)
	Enabling an Endpoint
	Disabling an Endpoint
	Enabling Deployments
	Disabling Deployments
	Aborting Deployments
	Deleting Deployments
	Managing Endpoint Modules
	Using Scan Now to Scan Inventory (Endpoint Details Page)
	Rebooting the Endpoint
	Exporting Endpoint Information


	Using Inventory
	About Inventory
	Viewing Inventory

	The Inventory Page
	The Inventory Page Toolbar
	The Inventory Page List (Filtered for Operating Systems)
	The Inventory Page List (Filtered for Software)
	The Inventory Page List (Filtered for Hardware)
	The Inventory Page List (Filtered for Services)
	About Scan Now (Scanning Inventory)
	Using Scan Now to Scan Inventory (Inventory Page)


	The Endpoints with Inventory Page
	Using Custom Inventory
	Guidelines for Linux/Unix/Mac-based Operating Systems
	Guidelines for Microsoft Windows-based Operating Systems


	Managing Deployments and Tasks
	About Deployments
	Explaining Deployment Distribution Order
	Deployment Types
	Standard and Chained Deployments
	Reboot and Chained State


	The Deployments and Tasks Page
	Viewing Deployments and Tasks
	Viewing All Deployments and Tasks
	Viewing Deployments and Tasks within Endpoints
	Viewing Deployments and Tasks within Groups

	Deployment Type
	The Deployments and Tasks Page Toolbar
	The Deployments and Tasks Page List

	Working With Deployments and Tasks
	Aborting Deployments and Tasks
	Disabling Deployments
	Enabling Deployments
	Editing Package Deployment Options
	Deleting Deployments
	Deploying Content (Deployments and Tasks Page)
	Explaining Deployment Deadlines

	Using the Deployment Wizard
	Introduction Page
	Available Endpoints/Groups Page
	Creating an Endpoint Deployment
	Creating a Group Deployment

	Available Packages Page
	Selecting Deployment Packages
	Associated Vulnerability Analysis Page

	Licenses Page
	Accepting License Agreements

	Deployment Information Page
	Defining Deployment Information
	Schedule Configuration Page
	Scheduling a One Time Deployment
	Scheduling a Recurring Deployment
	Configuring a Daily Recurring Deployment
	Configuring a Weekly Recurring Deployment
	Configuring a Monthly Recurring Deployment
	Selecting the Deployment Start and End Functions



	Package Deployment Behavior Options Page
	Behavior Icon Definitions
	Reboot Icon Definitions
	Setting Package Deployment Order
	Package Deployment Behavior Options Page
	Package Flag Descriptions
	Package Display Options
	Selecting Deployment Behavior Options


	Notification Options Page
	Setting Notification Options
	About the Show on Top Option

	Deployment Confirmation Page
	Deployment Summary Page

	The Deployment Details Page
	Viewing the Deployment Details
	The Deployment Details Page Toolbar
	The Deployment Details Page List


	Using Groups
	About Groups
	The Groups Page
	The Group Browser Directory Tree
	Parent and Child Groups
	Defining Groups

	Viewing Groups
	Searching for a Group

	The Information View
	Group Information
	Email Notification Addresses
	Child Groups
	Mandatory Baseline Items
	Agent Policy Sets
	Resultant Agent Policy Set Information
	Roles
	Exporting Information View Data

	The Group Membership View
	The Group Membership View Toolbar
	The Group Membership View List
	Creating a Group
	Editing Groups
	Deleting Groups
	Moving a Group
	Deploying Content to Groups (Group Membership View)
	Using Scan Now to Scan Group Inventory
	Rebooting Groups
	Exporting Group Membership View Data

	The Endpoint Membership View
	The All Tab (Groups Page)
	The All Tab Toolbar (Groups Page)
	The All Tab List (Groups Page)

	The Patch and Remediation Tab (Groups Page)
	The Patch and Remediation Toolbar (Groups Page)
	The Patch and Remediation Tab List (Groups Page)

	Adding Endpoint Members
	Removing Endpoint Members
	Deploying Content to Endpoints (Endpoint Membership View)
	Installing Agents by Agent Management Job
	Uninstalling Agents by Agent Management Job
	Downloading the Agent Installer
	Defining the Endpoint Agent Version (Groups Page)
	Deleting Endpoint (Groups Page)
	Enabling or Disabling Endpoints within a Group
	Enabling or Disabling Endpoints Modules within a Group
	Managing Endpoint Modules (Groups Page)
	Using Scan Now to Scan Group Endpoint Inventory
	Rebooting Group Endpoints
	Exporting Endpoint Membership View Data

	The Mandatory Baseline View
	About Mandatory Baselines
	About Mandatory Baseline Import/Export
	The Mandatory Baseline Process
	Viewing a Group Mandatory Baseline
	The Mandatory Baseline View Toolbar
	The Mandatory Baseline View List
	Mandatory Baseline Item Compliance Icons

	Adding Content to Mandatory Baselines
	Using the Filter Functions to Select Content
	Showing Only the Required Vulnerabilities

	Removing Content from Mandatory Baselines
	Setting Mandatory Baseline Deployment Options
	Removing Deployments Created by Mandatory Baselines
	Removing a Mandatory Baseline Deployment from a Group
	Stopping a Deployment for Specific Endpoints

	Updating the Mandatory Baseline Cache
	Importing Mandatory Baseline Templates
	Exporting Mandatory Baselines Templates
	Exporting Mandatory Baseline View Data

	The Vulnerabilities View
	The Vulnerabilities View Toolbar
	The Vulnerabilities View List
	Disabling Content within a Group
	Enabling Content within a Group
	Updating the Groups Cache
	Deploying Selected Content (Vulnerabilities View)
	Exporting Vulnerability View Data

	The Inventory View
	The Inventory View Toolbar
	Exporting Inventory View Data

	The Deployments and Tasks View
	The Deployments and Tasks View Toolbar
	The Deployments and Tasks View List
	Enabling Group Deployments
	Disabling Group Deployments
	Aborting Group Deployments
	Deleting Group Deployments
	Deploying Content (Deployments and Tasks View)
	Exporting Deployments View Data

	The Agent Policy Sets View
	The Agent Policy Sets View Toolbar
	The Agent Policy Sets View List
	Assigning an Agent Policy Set to a Group
	Unassigning an Agent Policy Set from a Group
	Creating an Agent Policy Set (Groups Page)
	Exporting Agent Policy Set View Data

	The Roles View
	The Roles View Toolbar
	The Roles View List
	Adding a Role to a Group
	Removing a Role from a Group
	Creating User Roles (Roles View)
	Exporting Roles View Data

	The Dashboard View
	Group Dashboard Widgets
	Widget Setting and Behavior Icons
	Previewing and Printing the Dashboard
	Editing the Dashboard

	The Settings View
	Editing Group Settings
	Defining Source Groups
	Assigning a Source Group to a Custom Group

	Exporting Settings View Data


	Managing Agent Policy Sets
	The Agent Policy Sets Page
	About Agent Policies and Agent Policy Sets
	Viewing the Agent Policy Sets Page
	The Agent Policy Sets Page Toolbar
	The Agent Policy Sets Page List

	Working with Agent Policy Sets
	Creating an Agent Policy Set
	Editing an Agent Policy Set
	Deleting an Agent Policy Set
	Defining the Global Uninstall Password
	Defining Agent Policy Logging Levels
	Defining Inventory Collection Options
	Defining Agent Hours of Operation
	The Edit FastPath Servers Dialog
	Adding/Editing FastPath Servers
	Deleting FastPath Servers

	Defining Agent Policy Inheritance Rules
	Defining Agent Policy Conflict Resolution
	Exporting Agent Policy Set Data
	Assigning an Agent Policy Set to a Group
	Unassigning an Agent Policy Set from a Group


	Using Content
	About Content
	Defining Content Structure
	Content Item
	Signatures
	Fingerprints
	Pre-requisites
	Packages

	Vulnerabilities
	Software Content
	Other Content

	The Content Pages
	To Access the Content Pages
	The Content Type Filter
	The Content Pages Toolbar
	The Content Pages List
	Content Status and Type
	Content Cache Status and Type
	Content Icons and Descriptions
	Content Name


	Working With Content
	Deploying Selected Content (Content Pages)
	Disabling And Enabling Content
	Disabling Content
	Enabling Content

	Using Scan Now to Scan Inventory (Content Pages)
	Updating the Cache
	Exporting Content Data

	The Patch Status Page
	Viewing Content Patch Statuses
	The Patch Status Page Toolbar
	The Patch Status Page List
	Endpoint Status

	The Information Tab
	The Information Tab Buttons (Package Details Page)
	Vulnerability Information
	CVE Information


	Working with Content Items
	View Packages
	Deploying Content
	Exporting Content Item Data


	Managing Packages
	About Packages
	The Packages Page
	Viewing Packages
	The Packages Page Toolbar
	The Packages Page List
	Content Package Icons and Descriptions

	Working with Packages
	Deploying Selected Packages
	Deleting a Package
	Updating the Package Cache
	Creating a Package
	Editing a Package

	The Package Details Page
	Viewing the Package Details Page
	Package Deployments Tab
	The Deployments Tab Toolbar (Package Details Page)
	The Deployments Tab List (Package Details Page)

	The Information Tab (Package Details Page)
	The Information Tab Buttons (Package Details Page)
	Package Information


	Using the Package Editor
	Including Deployment Options in a Package
	Package Flag Descriptions
	Adding File and Directories to a Package
	Adding a Directory to a Package
	Creating a Drive for a Package
	Adding a New Macro to a Package
	Creating a Folder for a Package
	Adding a File to a Package
	Deleting a File from a Package
	Renaming a File within a Package
	Folder Properties for a Package
	Creating Scripts for a Package


	Patch and Remediation Reporting
	About Patch and Remediation Reports
	The Patch and Remediation Report Pages
	Viewing the Patch and Remediation Report Pages
	Generating a Report


	Managing Lumension EMSS Users and Roles
	The Users and Roles Page
	Viewing the Users and Roles Page
	Defining User Access

	The Users Tab
	Defining Users
	The Users Tab Toolbar
	The Users Tab List

	Working with Users
	Creating New Lumension EMSS Users
	Adding Existing Windows Users to Lumension EMSS
	Editing Lumension EMSS Users
	Removing Lumension EMSS Users
	Deleting Lumension EMSS Users
	Changing a User Password
	Changing Your Password
	Exporting User Data

	The Roles Tab
	Defining Roles
	Predefined System Roles
	Custom Roles

	Defining Access Rights
	Defining Accessible Groups
	Defining Accessible Endpoints
	The Roles Tab Toolbar
	The Roles Tab List

	Working with Roles
	Creating User Roles
	Editing User Roles
	Editing User Roles

	Disabling User Roles
	Enabling User Roles
	Deleting User Roles
	Exporting User Role Data


	Using the Patch Agent
	About the Patch Agent for Pre-Windows Vista
	Viewing the Patch Agent
	The Patch Agent Dialog (Pre-Windows Vista)
	The Deployment Tab
	Server Information and Status
	Agent Information
	Log Operations
	Viewing the Patch Agent Log
	Clearing the Patch Agent Log
	Agent Operations

	The Detection Tab
	Server Information and Status
	Agent Information
	Log Operations
	Viewing the Detection Log
	Clearing the Detection Log
	Agent Operations

	Proxies Tab
	Server Information and Status
	Configuring Proxy Settings

	The About Tab
	Server Information and Status
	Version Information

	User Interaction During a Deployment
	Beginning the Deployment
	Delaying a Deployment
	Canceling a Deployment

	User Interaction During a Reboot
	Rebooting Immediately
	Delaying a Reboot
	Canceling the Reboot



	About Patch Agent for Windows Vista and Later
	Viewing the Agent
	The Patch Agent (Windows Vista and Later)
	The Agent Control Panel Toolbar
	Manually Performing Scan Functions
	Manually Checking for Deployments
	Restarting the Agent Service

	The Home Page
	Compliance Banner Statuses
	Active Scan Statistics
	Statuses

	The Tools and Settings Page
	Viewing the Tools and Settings Page
	Proxy Settings
	Viewing the Proxy Settings Page
	Server Provided Proxy Settings
	Client Defined Proxy Settings
	Defining Client Proxy Settings

	The Log Files Page
	Viewing the Log Files Page
	Opening Log Files
	Truncating Log Files

	The Notification Manager Page
	Viewing the Notification Manager Page

	EMSS Server
	Viewing the Server Settings Page


	The Agent Control Panel Help Page
	The About Dialog

	User Interaction During a Deployment
	Beginning the Deployment
	Delaying a Deployment
	Canceling a Deployment

	User Interaction During a Reboot
	Rebooting an Endpoint
	Delaying a Reboot
	Canceling a Reboot


	About the Agent for Mac
	Viewing the Patch Agent
	Patch Agent Components
	Deployment Tab
	Server Information
	Diagnostics Information
	Results

	Detection Tab
	Status
	Results


	Refreshing the Agent Information
	Starting the Agent
	Stopping the Agent
	Restarting the Agent
	User Interaction During a Deployment
	Beginning the Deployment
	Delaying a Deployment
	Canceling a Deployment

	User Interaction During a Reboot
	Rebooting Immediately
	Delaying a Reboot
	Canceling the Reboot


	About the Command Line Agent for Linux/Unix/Mac

	Server Reference
	Server Security
	Server Error Pages
	WinInet Error Codes
	HTTP Status Codes
	Agent Module Status Icons
	Defining Targets Using Wildcards
	Defining Targets Within an Imported File
	Setting Up Lumension Endpoint Management and Security Suite
	Restarting the STATEngine Service
	Specifying Content Mirrors for CentOS

	Securing Your Server
	Secure Your Server With SSL
	Use Secure Passwords
	Disabling File and Printer Sharing
	Disabling File and Printer Sharing in Windows Server 2003
	Disabling File and Printer Sharing in Windows Server 2008

	Placing Your Server Behind a Firewall
	Disable Non-Critical Services
	Lock Down Unused TCP and UDP Ports
	Disabling Unused Ports in Windows Server 2003

	Apply All Security Patches

	Configuring the Server and Endpoints for Agent Management Jobs
	Configuring the Lumension EMSS Server for Discovery Scanning
	Port and ICMP Requirements for Agent Management Jobs
	Configuring Windows XP and Windows Server 2003 Endpoints for Discovery
	Configuring Windows XP and Windows Server 2003 Endpoints for Agent Management Jobs
	Configuring Vista or Later Endpoints for Discovery
	Configuring Vista or Later Endpoints for Agent Management Jobs
	Troubleshooting Agent Management Jobs
	Resolving Endpoint UAC Issues
	Disabling Password Changes

	Installing Agents by Agent Management Job
	Editing Targets

	Uninstalling Agents by Agent Management Job
	Editing Targets

	Defining Targets Using Wildcards

	Creating a Disaster Recovery Solution
	Preparing Your Database
	Changing the Database Recovery Model

	Creating a Manual Solution
	Creating a Database Backup
	Restoring a Database Backup

	Creating an Automated Solution
	Creating a Maintenance Plan


	Glossary
	Glossary




